- Update to 2.09.2 and unbreak this port

- Add WWW while I'm here

Changes:	http://search.cpan.org/dist/Apache-Scoreboard/Changes
PR:		ports/153759
Submitted by:	Jarrod Sayers <jarrod@downtools.com.au>
Feature safe:	yes
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2011-01-15 17:16:55 +00:00
parent 01cd106ee1
commit 3b981f7463
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=267846
4 changed files with 28 additions and 46 deletions

View file

@ -6,29 +6,29 @@
#
PORTNAME= Apache2-Scoreboard
PORTVERSION= 2.08
PORTVERSION= 2.09.2
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITES= CPAN/../../authors/id/M/MJ/MJH
PKGNAMEPREFIX= p5-
DISTNAME= Apache-Scoreboard-${PORTVERSION}
DISTNAME= ${PORTNAME:C/2//}-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to the Apache scoreboard structure
BUILD_DEPENDS= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
BUILD_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_perl2>=2.0.0:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS= ${BUILD_DEPENDS}
BROKEN= does not compile
PERL_CONFIGURE= yes
USE_APACHE= 2.0+
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME:R}
PERL_CONFIGURE= 5.8.0+
MAN3= Apache::Scoreboard.3 Apache::DummyScoreboard.3
USE_LDCONFIG= YES
MAN3= Apache::DummyScoreboard.3 Apache::Scoreboard.3
post-patch:
@${RM} -f ${WRKSRC}/lib/Apache/*.orig
${SED} -i.bak 's@%%LOCALBASE%%@${LOCALBASE}@g' ${WRKSRC}/Makefile.PL
${SED} -i.bak 's@%%LOCALBASE%%@${LOCALBASE}@g' ${WRKSRC}/Dummy/Makefile.PL
@${REINPLACE_CMD} \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%APACHEINCLUDEDIR%%|${APACHEINCLUDEDIR}|g' \
${WRKSRC}/Makefile.PL ${WRKSRC}/Dummy/Makefile.PL
.include <bsd.port.mk>

View file

@ -1,3 +1,2 @@
MD5 (Apache-Scoreboard-2.08.tar.gz) = f66b6e222cfc4b41c9b327af2478b44b
SHA256 (Apache-Scoreboard-2.08.tar.gz) = c089aeb59d329ad1f9cbac2a631b1ee06e95c7dd31ae49a985e75642d798caba
SIZE (Apache-Scoreboard-2.08.tar.gz) = 18572
SHA256 (Apache-Scoreboard-2.09.2.tar.gz) = 671252a383aabc5c7906dd54e7dce92b65d944a56782f7233ca5a83c6299cc34
SIZE (Apache-Scoreboard-2.09.2.tar.gz) = 18728

View file

@ -1,37 +1,21 @@
--- Makefile.PL.orig Mon Apr 17 17:08:56 2006
+++ Makefile.PL Mon Apr 17 17:10:29 2006
@@ -30,13 +30,18 @@
Apache::TestMM::filter_args();
Apache::TestMM::generate_script('t/TEST');
+# XXX: this is a hack!
+my $extra_inc = "-I%%LOCALBASE%%/include/apache2/modules/perl/";
+
ModPerl::MM::WriteMakefile(
NAME => 'Apache::Scoreboard',
VERSION_FROM => 'lib/Apache/Scoreboard.pm',
PREREQ_PM => \%require,
--- Makefile.PL.orig 2008-01-22 03:17:41.000000000 +0800
+++ Makefile.PL 2011-01-16 01:12:53.000000000 +0800
@@ -45,7 +45,7 @@
clean => {
FILES => "@{ clean_files() }",
- }
+ },
+ # XXX: this is a hack!
+ INC => join " ", $extra_inc, ModPerl::MM::get_def_opt('INC')
},
- INC => join " ", $extra_inc, ModPerl::MM::get_def_opt('INC'),
+ INC => join " ", "-I%%LOCALBASE%%/%%APACHEINCLUDEDIR%%/modules/perl/", $extra_inc, ModPerl::MM::get_def_opt('INC'),
);
sub clean_files {
--- Dummy/Makefile.PL.orig Mon Apr 17 17:12:37 2006
+++ Dummy/Makefile.PL Mon Apr 17 17:13:12 2006
@@ -18,7 +18,12 @@
genxs();
+# XXX: this is a hack!
+my $extra_inc = "-I%%LOCALBASE%%/include/apache2/modules/perl/";
+
--- Dummy/Makefile.PL.orig 2008-01-22 03:17:31.000000000 +0800
+++ Dummy/Makefile.PL 2011-01-16 01:13:41.000000000 +0800
@@ -29,6 +29,6 @@
ModPerl::MM::WriteMakefile(
NAME => 'Apache::DummyScoreboard',
VERSION_FROM => 'DummyScoreboard.pm',
+ # XXX: this is a hack!
+ INC => join " ", $extra_inc, ModPerl::MM::get_def_opt('INC')
- INC => join " ", $extra_inc, ModPerl::MM::get_def_opt('INC'),
+ INC => join " ", "-I%%LOCALBASE%%/%%APACHEINCLUDEDIR%%/modules/perl/", $extra_inc, ModPerl::MM::get_def_opt('INC'),
);

View file

@ -1,4 +1,3 @@
Perl interface to the Apache scoreboard structure
- Trevor Cornpropst
tcornpropst@cox.net
WWW: http://search.cpan.org/dist/Apache-Scoreboard/