- Add a patch to fix a memory leak [1]

- Bump PORTREVISION [1]
- Add LICENSE (Artistic 1 & GPL 2)

PR:		ports/166198 [1]
Submitted by:	Zane C.B-H. <vvelox@vvelox.net>
Feature safe:	yes
This commit is contained in:
Frederic Culot 2012-04-06 13:34:23 +00:00
parent b5876a0d5b
commit 3be13e4d84
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=294289
2 changed files with 17 additions and 0 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= Text-Template
PORTVERSION= 1.45
PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= http://perl.plover.com/Template/ \
CPAN
@ -15,8 +16,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Expand template text with embedded Perl
LICENSE= ART10 GPLv2
LICENSE_COMB= dual
PERL_CONFIGURE= YES
MAN3= Text::Template.3 Text::Template::Preprocess.3
post-patch:
@${FIND} ${WRKSRC} -name "*.orig" -delete
.include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
--- lib/Text/Template.pm.orig 2008-04-16 18:38:08.000000000 -0500
+++ lib/Text/Template.pm 2012-03-17 06:44:14.882739137 -0500
@@ -428,6 +428,8 @@
foreach my $key (keys %$hash) {
undef $hash->{$key};
}
+ %$hash = ();
+ delete $Text::Template::{$s."::"};
}
}