sysutils/daggy: Update 1.1.3 -> 2.0.1
This commit is contained in:
parent
5f8e2567c7
commit
3bfe58bf1b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=531330
5 changed files with 51 additions and 10 deletions
|
@ -1,27 +1,30 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= daggy
|
||||
DISTVERSION= 1.1.3
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 2.0.1
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Data Aggregation Utility: runs commands on remote hosts simultaneously
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= mustache>0:devel/mustache
|
||||
LIB_DEPENDS= libbotan-2.so:security/botan2 \
|
||||
libssh2.so:security/libssh2 \
|
||||
libyaml-cpp.so:devel/yaml-cpp
|
||||
|
||||
USES= compiler:c++17-lang gl pkgconfig qmake qt:5
|
||||
USES= compiler:c++17-lang gl localbase:ldflags pkgconfig cmake qt:5
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= synacker
|
||||
USE_QT= core gui network buildtools_build
|
||||
USE_QT= core gui network buildtools_build qmake_build
|
||||
USE_GL= gl
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
QMAKE_ARGS= VERSION="${PORTVERSION}" BUILD_NUMBER="0"
|
||||
CMAKE_OFF= CONAN_BUILD
|
||||
|
||||
PLIST_FILES= bin/daggy
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|VERSION_STR|"${DISTVERSION}"|' ${WRKSRC}/src/Daggy/CConsoleDaggy.cpp
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1564207441
|
||||
SHA256 (synacker-daggy-1.1.3_GH0.tar.gz) = 559a9d7916988edf67be50625d89b38c311edaa322c3238e0107883dc315f0c6
|
||||
SIZE (synacker-daggy-1.1.3_GH0.tar.gz) = 2727913
|
||||
TIMESTAMP = 1586488793
|
||||
SHA256 (synacker-daggy-2.0.1_GH0.tar.gz) = 3322409062cc4dae1f6570cb3452773af8efa1ca522fed259902380153f7f98c
|
||||
SIZE (synacker-daggy-2.0.1_GH0.tar.gz) = 329940
|
||||
|
|
13
sysutils/daggy/files/patch-CMakeLists.txt
Normal file
13
sysutils/daggy/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- CMakeLists.txt.orig 2020-04-10 04:02:12 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -4,8 +4,8 @@ project(daggy)
|
||||
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
|
||||
set(CMAKE_PREFIX_PATH ${CONAN_QT_ROOT})
|
||||
|
||||
-include(conan)
|
||||
+#include(conan)
|
||||
|
||||
-set(CONAN_BUILD ON)
|
||||
+#set(CONAN_BUILD ON)
|
||||
|
||||
add_subdirectory(src)
|
11
sysutils/daggy/files/patch-src_CMakeLists.txt
Normal file
11
sysutils/daggy/files/patch-src_CMakeLists.txt
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/CMakeLists.txt.orig 2020-04-10 04:30:55 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -27,7 +27,7 @@ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CUR
|
||||
include_directories(${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_BINARY_DIR}/exports)
|
||||
|
||||
include(compiler)
|
||||
-include(version)
|
||||
+#include(version)
|
||||
|
||||
add_subdirectory(DaggyCore)
|
||||
if(DAGGY_CONSOLE)
|
14
sysutils/daggy/pkg-plist
Normal file
14
sysutils/daggy/pkg-plist
Normal file
|
@ -0,0 +1,14 @@
|
|||
bin/daggy
|
||||
include/DaggyCore/CJsonDataSourcesConvertor.h
|
||||
include/DaggyCore/CLocalDataProvider.h
|
||||
include/DaggyCore/CSsh2DataProviderFabric.h
|
||||
include/DaggyCore/CYamlDataSourcesConvertor.h
|
||||
include/DaggyCore/Command.h
|
||||
include/DaggyCore/Common.h
|
||||
include/DaggyCore/DaggyCore.h
|
||||
include/DaggyCore/IDataAggregator.h
|
||||
include/DaggyCore/IDataProviderFabric.h
|
||||
include/DaggyCore/IDataSourceConvertor.h
|
||||
include/DaggyCore/Result.h
|
||||
include/DaggyCore/daggycore_export.h
|
||||
lib/libDaggyCore.so
|
Loading…
Reference in a new issue