security/cardpeek: unbreak against enforced ccache, move the manpage

If `devel/ccache' is packaged with compiler symlinks, `gcc' would be
detected and used via $(OBJCLD), switch to the $(CCLD)-based linking
command to avoid that.  Now that we're here, convert the `post-patch'
target to a regular patch file.
This commit is contained in:
Alexey Dokuchaev 2024-01-23 00:16:32 +00:00
parent 898ae858e7
commit 3c01a249d2
2 changed files with 22 additions and 5 deletions

View File

@ -17,8 +17,9 @@ RUN_DEPENDS= pcscd:devel/pcsc-lite
USES= gnome iconv localbase lua:52 pkgconfig
USE_GNOME= gtk30
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
PLIST_FILES= bin/cardpeek man/man1/cardpeek.1.gz \
PLIST_FILES= bin/cardpeek share/man/man1/cardpeek.1.gz \
share/appdata/cardpeek.appdata.xml \
share/applications/cardpeek.desktop \
share/icons/hicolor/48x48/apps/cardpeek-logo.png
@ -26,8 +27,4 @@ PORTDOCS= AUTHORS README cardpeek_ref.en.pdf
OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's,^doc_DATA =,& AUTHORS README,' \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>

View File

@ -0,0 +1,20 @@
--- Makefile.in.orig 2015-02-27 14:24:48 UTC
+++ Makefile.in
@@ -435,7 +435,7 @@ cardpeek_SOURCES = asn1.c asn1.h bytestring.c bytestri
cardpeek_public_key.h win32/config.h $(am__append_1) \
$(am__append_3)
EXTRA_cardpeek_SOURCES = cardpeek.c osx/cardpeek-osx.m
-doc_DATA = doc/cardpeek_ref.en.pdf
+doc_DATA = AUTHORS README doc/cardpeek_ref.en.pdf
cardpeek_LDADD = cardpeek_resources.$(OBJEXT) @LUA_LIBS@ @PCSC_LIBS@ @GLIB_LIBS@ @GTK_LIBS@ @CURL_LIBS@ @ICONV_LIBS@
cardpeek_LDFLAGS = -g $(am__append_2)
dist_man_MANS = cardpeek.1
@@ -595,7 +595,7 @@ osx/cardpeek-osx.$(OBJEXT): osx/$(am__dirstamp) \
cardpeek$(EXEEXT): $(cardpeek_OBJECTS) $(cardpeek_DEPENDENCIES) $(EXTRA_cardpeek_DEPENDENCIES)
@rm -f cardpeek$(EXEEXT)
- $(AM_V_OBJCLD)$(cardpeek_LINK) $(cardpeek_OBJECTS) $(cardpeek_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(LINK) $(cardpeek_OBJECTS) $(cardpeek_LDADD) $(LIBS)
mostlyclean-compile:
-rm -f *.$(OBJEXT)