Update mastersites.
Make compliant with CC/CFLAGS/X11BASE. Add WWW link. PR: ports/96221 Submitted by: Ports Fury
This commit is contained in:
parent
fcf8e4e204
commit
3c1eb6397b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=162324
4 changed files with 25 additions and 17 deletions
|
@ -7,14 +7,14 @@
|
|||
|
||||
PORTNAME= xmangekyou
|
||||
PORTVERSION= 2.0.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= http://www.seki.ee.kagu.tus.ac.jp/~sakai/myfreesoft/
|
||||
MASTER_SITES= http://hp.vector.co.jp/authors/VA014157/myfreesoft/ \
|
||||
ftp://ftp.vector.co.jp/pack/unix/art/anime/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A kaleidoscope on X
|
||||
|
||||
BROKEN= does not fetch
|
||||
|
||||
ALL_TARGET= xmangekyou
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
|
@ -22,5 +22,25 @@ USE_XPM= yes
|
|||
|
||||
MAN1= xmangekyou.1
|
||||
MANCOMPRESSED= yes
|
||||
PORTDOCS= COPYRIGHT.euc HISTORY.euc README.euc
|
||||
PLIST_FILES= bin/xmangekyou lib/X11/XMangekyou/animation.dat
|
||||
PLIST_DIRS= lib/X11/XMangekyou
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|= /usr/X11R6|= $${PREFIX}|g ; \
|
||||
s|gcc |$${CC} |g ; \
|
||||
s|-O |$${CFLAGS} |g ; \
|
||||
s|-I/usr/X11R6/|-I$${X11BASE}/|g ; \
|
||||
s|-L/usr/X11R6/|-L$${X11BASE}/|g' ${WRKSRC}/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/xmangekyou ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/xmangekyou.1.gz ${MANPREFIX}/man/man1
|
||||
@${MKDIR} ${PREFIX}/lib/X11/XMangekyou
|
||||
${INSTALL_DATA} ${WRKSRC}/animation.dat ${PREFIX}/lib/X11/XMangekyou
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/*.euc ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
--- Makefile~ Fri Nov 3 05:13:33 2000
|
||||
+++ Makefile Fri Nov 3 05:14:52 2000
|
||||
@@ -1,4 +1,4 @@
|
||||
-XMANGEKYOU_PREFIX = /usr/X11R6
|
||||
+XMANGEKYOU_PREFIX = ${PREFIX}
|
||||
XMANGEKYOU_BIN = ${XMANGEKYOU_PREFIX}/bin
|
||||
XMANGEKYOU_LIB = ${XMANGEKYOU_PREFIX}/lib/X11/XMangekyou
|
||||
XMANGEKYOU_MAN = ${XMANGEKYOU_PREFIX}/man/man1
|
|
@ -1,2 +1,4 @@
|
|||
XMangekyou is a kaleidoscope on X. You can see many, many, many kaleidoscope
|
||||
patterns.
|
||||
|
||||
WWW: http://hp.vector.co.jp/authors/VA014157/myfreesoft/
|
||||
|
|
|
@ -1,6 +0,0 @@
|
|||
bin/xmangekyou
|
||||
lib/X11/XMangekyou/animation.dat
|
||||
lib/X11/XMangekyou/README.euc
|
||||
lib/X11/XMangekyou/Makefile
|
||||
lib/X11/XMangekyou/COPYRIGHT.euc
|
||||
@dirrm lib/X11/XMangekyou
|
Loading…
Reference in a new issue