audio/drumstick: Update 1.1.2 -> 1.1.3
Reported by: portscout
This commit is contained in:
parent
d69a6c2700
commit
3c222d15af
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=514413
5 changed files with 27 additions and 53 deletions
|
@ -1,8 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= drumstick
|
||||
DISTVERSION= 1.1.2
|
||||
PORTREVISION= 6
|
||||
DISTVERSION= 1.1.3
|
||||
CATEGORIES= audio multimedia
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
|
||||
|
||||
|
@ -33,7 +32,7 @@ PLIST_SUB= SHL3=${PORTVERSION} SHL1=${PORTVERSION:R:R}
|
|||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|"default.sf2"|"${LOCALBASE}/share/sounds/sf2/FluidR3_GM.sf2"|' \
|
||||
${WRKSRC}/utils/vpiano/fluidsettingsdialog.cpp \
|
||||
${WRKSRC}/library/rt-backends/synth/synthengine.cpp
|
||||
${WRKSRC}/library/rt-backends/fluidsynth/synthengine.cpp
|
||||
@${REINPLACE_CMD} -e 's|"$${CMAKE_INSTALL_DATAROOTDIR}/man/man1"|"${PREFIX}/man/man1"|' \
|
||||
${WRKSRC}/cmake_admin/CreateManpages.cmake
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1543211012
|
||||
SHA256 (drumstick-1.1.2.tar.bz2) = 7791b439aab9a5c24a53cbf5ce9ab1dcaf40a33a9d8828ca1731e823b1c7924e
|
||||
SIZE (drumstick-1.1.2.tar.bz2) = 1012371
|
||||
TIMESTAMP = 1567656913
|
||||
SHA256 (drumstick-1.1.3.tar.bz2) = 75aca4281da25fe0186b44c07772c5f0b4d1f2bba875c4667e7e6e9fcedb3cd9
|
||||
SIZE (drumstick-1.1.3.tar.bz2) = 1037699
|
||||
|
|
|
@ -1,15 +1,6 @@
|
|||
--- CMakeLists.txt.orig 2018-11-25 16:14:19 UTC
|
||||
--- CMakeLists.txt.orig 2019-09-01 13:59:42 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -25,7 +25,7 @@ endif()
|
||||
project(DRUMSTICK)
|
||||
|
||||
if(CMAKE_SIZEOF_VOID_P MATCHES "8")
|
||||
- set(_INIT_LIB_SUFFIX "64")
|
||||
+ set(_INIT_LIB_SUFFIX "")
|
||||
else()
|
||||
set(_INIT_LIB_SUFFIX "")
|
||||
endif()
|
||||
@@ -72,7 +72,7 @@ set(_DBUS_INIT OFF)
|
||||
@@ -54,7 +54,7 @@ set(_DBUS_INIT OFF)
|
||||
|
||||
# User options
|
||||
option(STATIC_DRUMSTICK "Build static libraries instead of dynamic" OFF)
|
||||
|
@ -18,8 +9,8 @@
|
|||
|
||||
message(STATUS "Build configuration: ${CMAKE_BUILD_TYPE}")
|
||||
|
||||
@@ -100,8 +100,8 @@ else()
|
||||
message(FATAL_ERROR "Program pkg-config not found")
|
||||
@@ -84,8 +84,8 @@ if(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Windows")
|
||||
endif()
|
||||
endif()
|
||||
|
||||
-if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
|
@ -29,18 +20,18 @@
|
|||
if(ALSA_FOUND)
|
||||
set(ALSA_LIBS ${ALSA_LIBRARIES})
|
||||
list(APPEND ALSA_LIB_DIR ${ALSA_LIBRARY_DIRS} ${ALSA_LIBDIR})
|
||||
@@ -111,7 +111,9 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
endif()
|
||||
@@ -96,7 +96,9 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
endif()
|
||||
|
||||
-pkg_check_modules(PULSE libpulse-simple)
|
||||
+if (USE_PULSEAUDIO)
|
||||
+ pkg_check_modules(PULSE libpulse-simple)
|
||||
+endif()
|
||||
if(NOT PULSE_FOUND)
|
||||
message(STATUS "Warning: PulseAudio library not found.")
|
||||
endif()
|
||||
@@ -134,7 +136,7 @@ if(BUILD_TESTING)
|
||||
if(PKG_CONFIG_FOUND)
|
||||
- pkg_check_modules(PULSE libpulse-simple)
|
||||
+ if (USE_PULSEAUDIO)
|
||||
+ pkg_check_modules(PULSE libpulse-simple)
|
||||
+ endif()
|
||||
if(NOT PULSE_FOUND)
|
||||
message(STATUS "Warning: PulseAudio library not found.")
|
||||
endif()
|
||||
@@ -117,7 +119,7 @@ if(BUILD_TESTING)
|
||||
add_subdirectory(tests)
|
||||
endif()
|
||||
|
||||
|
@ -49,7 +40,7 @@
|
|||
find_package(Doxygen)
|
||||
if(DOXYGEN_FOUND)
|
||||
configure_file(
|
||||
@@ -145,12 +147,14 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
@@ -128,12 +130,14 @@ if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
${DOXYGEN} Doxyfile
|
||||
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})
|
||||
endif()
|
||||
|
@ -62,19 +53,10 @@
|
|||
configure_file(drumstick.spec.in drumstick.spec IMMEDIATE @ONLY)
|
||||
- install(FILES
|
||||
- ${CMAKE_CURRENT_BINARY_DIR}/drumstick-alsa.pc
|
||||
- DESTINATION lib${LIB_SUFFIX}/pkgconfig )
|
||||
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig )
|
||||
+ #install(FILES
|
||||
+ # ${CMAKE_CURRENT_BINARY_DIR}/drumstick-alsa.pc
|
||||
+ # DESTINATION lib${LIB_SUFFIX}/pkgconfig )
|
||||
+# ${CMAKE_CURRENT_BINARY_DIR}/drumstick-alsa.pc
|
||||
+# DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig )
|
||||
# XML mime types
|
||||
set( SHARED_MIME_INFO_MINIMUM_VERSION "0.30" )
|
||||
set( XDG_MIME_INSTALL_DIR "${CMAKE_INSTALL_DATAROOTDIR}/mime/packages" )
|
||||
@@ -180,7 +184,7 @@ configure_file(
|
||||
add_custom_target( uninstall
|
||||
"${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
|
||||
|
||||
-if(${CMAKE_SYSTEM} MATCHES "Linux")
|
||||
+if(${CMAKE_SYSTEM} MATCHES "Linux|FreeBSD")
|
||||
# tarball target
|
||||
add_custom_target( tarball
|
||||
COMMAND mkdir -p drumstick-${VERSION}
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- library/rt-backends/CMakeLists.txt.orig 2018-02-26 17:05:42 UTC
|
||||
+++ library/rt-backends/CMakeLists.txt
|
||||
@@ -17,7 +17,7 @@
|
||||
#add_subdirectory(dummy-in)
|
||||
#add_subdirectory(dummy-out)
|
||||
|
||||
-if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
+if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD")
|
||||
if(ALSA_FOUND)
|
||||
add_subdirectory(alsa-in)
|
||||
add_subdirectory(alsa-out)
|
|
@ -28,6 +28,10 @@ share/icons/hicolor/32x32/apps/drumstick.png
|
|||
share/icons/hicolor/48x48/apps/drumstick.png
|
||||
share/icons/hicolor/64x64/apps/drumstick.png
|
||||
share/icons/hicolor/scalable/apps/drumstick.svgz
|
||||
%%DATADIR%%/cmake/drumstick-file-config-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
%%DATADIR%%/cmake/drumstick-file-config.cmake
|
||||
%%DATADIR%%/cmake/drumstick-rt-config-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
%%DATADIR%%/cmake/drumstick-rt-config.cmake
|
||||
%%MANPAGES%%man/man1/drumstick-drumgrid.1.gz
|
||||
%%MANPAGES%%man/man1/drumstick-dumpmid.1.gz
|
||||
%%MANPAGES%%man/man1/drumstick-dumpove.1.gz
|
||||
|
|
Loading…
Reference in a new issue