math/qwtplot3d:

- Readd math/qwtplot3d as Qt 5 reincarnation. math/qwtplot3d-qt4 can be merged
  with this port, if anybody still cares for Qt 4.
- Take maintainership
This commit is contained in:
Max Brazhnikov 2018-11-28 13:07:18 +00:00
parent 4911ac707f
commit 3c2e8c5326
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=486088
9 changed files with 136 additions and 1 deletions

1
MOVED
View file

@ -4547,7 +4547,6 @@ math/fung-calc||2013-07-26|Has expired: Depends on Qt 3.x
math/koctave||2013-07-26|Has expired: Depends on Qt 3.x
math/kseg||2013-07-26|Has expired: Depends on Qt 3.x
math/pgcalc||2013-07-26|Has expired: Depends on Qt 3.x
math/qwtplot3d||2013-07-26|Has expired: Depends on Qt 3.x
math/rkward||2013-07-26|Has expired: Depends on Qt 3.x
math/xgfe||2013-07-26|Has expired: Depends on Qt 3.x
misc/gwenview-i18n||2013-07-26|Has expired: Depends on Qt 3.x

View file

@ -789,6 +789,7 @@
SUBDIR += qtiplot
SUBDIR += qtiplot-doc
SUBDIR += qtoctave
SUBDIR += qwtplot3d
SUBDIR += qwtplot3d-qt4
SUBDIR += randlib
SUBDIR += rapid

19
math/qwtplot3d/Makefile Normal file
View file

@ -0,0 +1,19 @@
# $FreeBSD$
PORTNAME= qwtplot3d
PORTVERSION= 0.2.7
CATEGORIES= math
MASTER_SITES= SF
PKGNAMESUFFIX= -qt5
MAINTAINER= makc@FreeBSD.org
COMMENT= 3D plotting widgets for Qt
USES= dos2unix gl qmake qt:5 tar:tgz
USE_QT= core gui opengl widgets buildtools_build
USE_GL= gl glu
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.mk>

3
math/qwtplot3d/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1543181657
SHA256 (qwtplot3d-0.2.7.tgz) = 1208336b15e82e7a9d22cbc743e46f27e2fad716094a9c133138f259fa299a42
SIZE (qwtplot3d-0.2.7.tgz) = 183836

View file

@ -0,0 +1,10 @@
--- include/qwt3d_openglhelper.h.orig 2018-11-26 20:04:53 UTC
+++ include/qwt3d_openglhelper.h
@@ -6,6 +6,7 @@
#include <qgl.h>
#else
#include <QtOpenGL/qgl.h>
+#include <GL/glu.h>
#endif
namespace Qwt3D

View file

@ -0,0 +1,56 @@
--- qwtplot3d.pro.orig 2018-11-26 20:18:41 UTC
+++ qwtplot3d.pro
@@ -1,9 +1,9 @@
# pro file for building the makefile for qwtplot3d
#
-TARGET = qwtplot3d
+TARGET = qwtplot3d-qt5
TEMPLATE = lib
-CONFIG += qt warn_on opengl thread zlib debug
+CONFIG += qt warn_on opengl thread zlib
MOC_DIR = tmp
OBJECTS_DIR = tmp
INCLUDEPATH = include
@@ -11,6 +11,7 @@ DEPENDPATH = include src
DESTDIR = lib
#DESTDIR = ../../../lib
QT += opengl
+unix:LIBS += -lGLU
win32:TEMPLATE = vclib
win32:CONFIG += dll exceptions
@@ -21,7 +22,7 @@ win32:QMAKE_CXXFLAGS += $$QMAKE_CFLA
win32:CONFIG -= zlib
linux-g++:TMAKE_CXXFLAGS += -fno-exceptions
-unix:VERSION = 0.2.6
+unix:VERSION = 0.2.7
# Input
SOURCES += src/qwt3d_axis.cpp \
@@ -81,8 +82,8 @@ HEADERS += include/qwt3d_surfaceplot.h \
include/qwt3d_multiplot.h
# gl2ps support
-HEADERS+=3rdparty/gl2ps/gl2ps.h \
- include/qwt3d_io_gl2ps.h
+# HEADERS+=3rdparty/gl2ps/gl2ps.h \
+HEADERS+= include/qwt3d_io_gl2ps.h
SOURCES+=src/qwt3d_io_gl2ps.cpp \
3rdparty/gl2ps/gl2ps.c
@@ -92,4 +93,11 @@ zlib {
DEFINES += GL2PS_HAVE_ZLIB
win32:LIBS += zlib.lib
unix:LIBS += -lz
-}
\ No newline at end of file
+}
+
+target.path = $$[QT_INSTALL_LIBS]
+
+headers.files = $$HEADERS
+headers.path = $$[QT_INSTALL_HEADERS]/qwtplot3d-qt5
+
+INSTALLS += target headers

View file

@ -0,0 +1,11 @@
--- src/qwt3d_lighting.cpp.orig 2018-11-26 20:04:53 UTC
+++ src/qwt3d_lighting.cpp
@@ -175,7 +175,7 @@ void Plot3D::applyLight(unsigned light)
glRotatef( lights_[light].rot.x-90, 1.0, 0.0, 0.0 );
glRotatef( lights_[light].rot.y , 0.0, 1.0, 0.0 );
glRotatef( lights_[light].rot.z , 0.0, 0.0, 1.0 );
- GLfloat lightPos[4] = { lights_[light].shift.x, lights_[light].shift.y, lights_[light].shift.z, 1.0};
+ GLfloat lightPos[4] = { static_cast<GLfloat>(lights_[light].shift.x), static_cast<GLfloat>(lights_[light].shift.y), static_cast<GLfloat>(lights_[light].shift.z), 1.0};
GLenum le = lightEnum(light);
glLightfv(le, GL_POSITION, lightPos);
}

4
math/qwtplot3d/pkg-descr Normal file
View file

@ -0,0 +1,4 @@
QwtPlot3d is a feature-rich Qt/OpenGL-based C++ library. It provides
Qt widgets for 3D plotting.
WWW: http://qwtplot3d.sourceforge.net

32
math/qwtplot3d/pkg-plist Normal file
View file

@ -0,0 +1,32 @@
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_autoptr.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_autoscaler.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_axis.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_color.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_colorlegend.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_coordsys.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_drawable.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_enrichment.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_enrichment_std.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_function.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_global.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_graphplot.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_gridmapping.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_helper.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_io.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_io_gl2ps.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_io_reader.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_label.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_mapping.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_multiplot.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_openglhelper.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_parametricsurface.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_plot.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_portability.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_scale.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_surfaceplot.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_types.h
%%QT_INCDIR%%/qwtplot3d-qt5/qwt3d_volumeplot.h
%%QT_LIBDIR%%/libqwtplot3d-qt5.so
%%QT_LIBDIR%%/libqwtplot3d-qt5.so.0
%%QT_LIBDIR%%/libqwtplot3d-qt5.so.0.2
%%QT_LIBDIR%%/libqwtplot3d-qt5.so.0.2.7