Unbreak
PR: 197175
This commit is contained in:
parent
a6f0da5887
commit
3c36249046
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=378654
2 changed files with 24 additions and 31 deletions
|
@ -1,11 +1,10 @@
|
|||
# Created by: clive
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= BitchX
|
||||
PORTREVISION= 8
|
||||
PORTNAME= bitchx
|
||||
CATEGORIES= chinese
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= chris@bsdjunk.com
|
||||
COMMENT= Zh-tw cursor movement friendly, wrapping clean BitchX
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../irc/bitchx
|
||||
|
@ -13,10 +12,6 @@ EXTRA_PATCHES= ${.CURDIR}/files/patch-source__input.c \
|
|||
${.CURDIR}/files/patch-include__config.h \
|
||||
${.CURDIR}/files/patch-source__screen.c
|
||||
|
||||
WITH_LATIN= YES
|
||||
# Cursor movement and words wrapping aren't hacked if compiled with gnome.
|
||||
WITHOUT_GNOME= YES
|
||||
# If without gnome, esound support isn't needed.
|
||||
WITHOUT_ESOUND= YES
|
||||
OPTIONS_SLAVE= LATIN
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
|
|
@ -1,19 +1,17 @@
|
|||
--- include/config.h.orig2 2012-11-05 22:31:31.000000000 -0500
|
||||
+++ include/config.h 2012-11-05 22:31:12.000000000 -0500
|
||||
@@ -99,7 +99,11 @@
|
||||
"pinky.slashnet.org "\
|
||||
"blago.slashnet.org "\
|
||||
"moo.slashnet.org "\
|
||||
- "coruscant.slashnet.org "
|
||||
+ "coruscant.slashnet.org "\
|
||||
+ "[ircnet] "\
|
||||
+ "irc.seed.net.tw "\
|
||||
+ "irc.tw.freebsd.org "\
|
||||
+ "irc.csie.nctu.edu.tw "
|
||||
#endif
|
||||
|
||||
/*
|
||||
@@ -152,7 +156,7 @@
|
||||
--- include/config.h.bak 2015-01-29 06:24:13.523281651 -0800
|
||||
+++ include/config.h 2015-01-29 06:33:51.148252017 -0800
|
||||
@@ -63,6 +63,10 @@
|
||||
"ircnet.eversible.com "\
|
||||
"ircnet.blacklotus.net "\
|
||||
"irc.ca.ircnet.net "\
|
||||
+ "[ircnet tw]"\
|
||||
+ "irc.seed.net.tw"\
|
||||
+ "irc.tw.freebsd.org"\
|
||||
+ "irc.csie.nctu.edu.tw"\
|
||||
"[ircnet EU] "\
|
||||
"irc.dotsrc.org "\
|
||||
"irc.belwue.de "\
|
||||
@@ -150,7 +154,7 @@
|
||||
* we define the default network type for server groups. Do not just
|
||||
* undefine this.
|
||||
*/
|
||||
|
@ -22,7 +20,7 @@
|
|||
|
||||
/*
|
||||
* Below are the IRCII variable defaults. For boolean variables, use 1 for
|
||||
@@ -299,7 +303,7 @@
|
||||
@@ -297,7 +301,7 @@
|
||||
* when you've defined LATIN1. The problem is that ansi graphics will look
|
||||
* ugly if you use the scroll up feature (PageUp/PageDown)
|
||||
*/
|
||||
|
@ -31,7 +29,7 @@
|
|||
|
||||
/* If you define REVERSE_WHITE_BLACK, then the format codes for black and
|
||||
* white color are revepsed. (%W, %w is bold black and black, %K, %k is bold
|
||||
@@ -332,7 +336,7 @@
|
||||
@@ -330,7 +334,7 @@
|
||||
|
||||
#define DEFAULT_PING_TYPE 1
|
||||
#define DEFAULT_MSGLOG ON
|
||||
|
@ -40,7 +38,7 @@
|
|||
#define DEFAULT_ALT_CHARSET ON
|
||||
#define DEFAULT_FLOOD_KICK ON
|
||||
#define DEFAULT_FLOOD_PROTECTION ON
|
||||
@@ -341,9 +345,9 @@
|
||||
@@ -339,9 +343,9 @@
|
||||
#define DEFAULT_LLOOK_DELAY 120
|
||||
#define DEFAULT_ALWAYS_SPLIT_BIGGEST ON
|
||||
#define DEFAULT_AUTO_UNMARK_AWAY OFF
|
||||
|
@ -52,7 +50,7 @@
|
|||
#define DEFAULT_BEEP_MAX 3
|
||||
#define DEFAULT_BEEP_WHEN_AWAY OFF
|
||||
#define DEFAULT_BOLD_VIDEO ON
|
||||
@@ -427,7 +431,7 @@
|
||||
@@ -425,7 +429,7 @@
|
||||
#define DEFAULT_NOTIFY ON
|
||||
#define DEFAULT_QUEUE_SENDS 0
|
||||
#define DEFAULT_MAX_SERVER_RECONNECT 2
|
||||
|
@ -61,7 +59,7 @@
|
|||
#define DEFAULT_WINDOW_DESTROY_PART OFF
|
||||
#define DEFAULT_WINDOW_DESTROY_QUERY OFF
|
||||
#define DEFAULT_SUPPRESS_SERVER_MOTD ON
|
||||
@@ -560,7 +564,7 @@
|
||||
@@ -558,7 +562,7 @@
|
||||
#define DEFAULT_SHELL "/bin/sh"
|
||||
#define DEFAULT_SHELL_FLAGS "-c"
|
||||
#define DEFAULT_USERINFO ""
|
||||
|
@ -70,13 +68,13 @@
|
|||
#define DEFAULT_XTERM_OPTIONS "-bg black -fg white"
|
||||
#define DEFAULT_DCC_DLDIR "~"
|
||||
|
||||
@@ -695,6 +699,24 @@
|
||||
@@ -692,6 +696,24 @@
|
||||
|
||||
#define WANT_CORE
|
||||
|
||||
+
|
||||
+#define WANT_BIG5
|
||||
+
|
||||
+
|
||||
+/* XXX I hope this could be integrated into BX.
|
||||
+ * XXX Well, this should be done via libc,
|
||||
+ * but FreeBSD libc support is quite LAME.
|
||||
|
|
Loading…
Reference in a new issue