Fix build on 7.x

PR:		ports/150666
Submitted by:	KATO Tsuguru <tkato432 at yahoo.com>
This commit is contained in:
Max Brazhnikov 2010-09-18 15:57:39 +00:00
parent 70f5c7d1b3
commit 3c777c96b1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=261393
6 changed files with 221 additions and 28 deletions

View file

@ -15,27 +15,21 @@ COMMENT= A GNOME-based ACL editor, with integration into Nautilus
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
LICENSE= GPLv2
USE_BZIP2= yes
USE_GNOME= gnomehack gnomeprefix intlhack nautilus2 libgnomeui
USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:22
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-nautilus-extensions-dir=${PREFIX}/lib/nautilus/extensions-2.0
MAKE_JOBS_SAFE= yes
MAN1= eiciel.1
LICENSE= GPLv2
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800000
BROKEN= does not compile
.endif
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,93 @@
--- src/acl_manager.cpp.orig 2010-06-03 05:38:27.000000000 +0900
+++ src/acl_manager.cpp 2010-06-19 22:52:10.000000000 +0900
@@ -111,7 +111,7 @@
{
// A user|group entry
// Gather the permissions
- acl_entry new_acl;
+ acl_manager_entry new_acl;
new_acl.reading = ACL_GET_PERM(permission_set, ACL_READ);
new_acl.writing = ACL_GET_PERM(permission_set, ACL_WRITE);
new_acl.execution = ACL_GET_PERM(permission_set, ACL_EXECUTE);
@@ -225,7 +225,7 @@
{
// An entry of type user/group
// get all permissions
- acl_entry new_acl;
+ acl_manager_entry new_acl;
new_acl.reading = ACL_GET_PERM(permission_set, ACL_READ);
new_acl.writing = ACL_GET_PERM(permission_set, ACL_WRITE);
new_acl.execution = ACL_GET_PERM(permission_set, ACL_EXECUTE);
@@ -317,14 +317,14 @@
_text_acl_access.clear();
_text_acl_access += "u::" + permission_to_str(_owner_perms) + "\n";
- for (vector<acl_entry>::iterator i = _user_acl.begin();
+ for (vector<acl_manager_entry>::iterator i = _user_acl.begin();
i != _user_acl.end(); i++)
{
_text_acl_access += "u:" + write_name(*i) + ":" + permission_to_str(*i) + "\n";
}
_text_acl_access += "g::" + permission_to_str(_group_perms) + "\n";
- for (vector<acl_entry>::iterator i = _group_acl.begin();
+ for (vector<acl_manager_entry>::iterator i = _group_acl.begin();
i != _group_acl.end(); i++)
{
_text_acl_access += "g:" + write_name(*i) + ":" + permission_to_str(*i) + "\n";
@@ -352,12 +352,12 @@
_text_acl_default += "o::" + permission_to_str(_default_others) + "\n";
}
- for (vector<acl_entry>::iterator i = _default_user_acl.begin();
+ for (vector<acl_manager_entry>::iterator i = _default_user_acl.begin();
i != _default_user_acl.end(); i++)
{
_text_acl_default += "u:" + write_name(*i) + ":" + permission_to_str(*i) + "\n";
}
- for (vector<acl_entry>::iterator i = _default_group_acl.begin();
+ for (vector<acl_manager_entry>::iterator i = _default_group_acl.begin();
i != _default_group_acl.end(); i++)
{
_text_acl_default += "g:" + write_name(*i) + ":" + permission_to_str(*i) + "\n";
@@ -370,7 +370,7 @@
}
}
-string ACLManager::write_name(acl_entry& eacl)
+string ACLManager::write_name(acl_manager_entry& eacl)
{
if (eacl.valid_name)
{
@@ -477,11 +477,11 @@
}
}
-void ACLManager::set_acl_generic(const string& name, vector<acl_entry>& acl_list,
+void ACLManager::set_acl_generic(const string& name, vector<acl_manager_entry>& acl_list,
const permissions_t& perms)
{
ACLEquivalence equiv_acl(name);
- vector<acl_entry>::iterator i = find_if(acl_list.begin(), acl_list.end(), equiv_acl);
+ vector<acl_manager_entry>::iterator i = find_if(acl_list.begin(), acl_list.end(), equiv_acl);
if (i != acl_list.end()) // If already there, update
{
i->reading = perms.reading;
@@ -490,7 +490,7 @@
}
else // If not there, create
{
- acl_entry eacl;
+ acl_manager_entry eacl;
eacl.valid_name = true;
eacl.name = name;
eacl.reading = perms.reading;
@@ -524,7 +524,7 @@
update_changes_acl_default();
}
-void ACLManager::remove_acl_generic(const string& name, vector<acl_entry>& acl_list)
+void ACLManager::remove_acl_generic(const string& name, vector<acl_manager_entry>& acl_list)
{
ACLEquivalence equiv_acl(name);
acl_list.erase(remove_if(acl_list.begin(), acl_list.end(), equiv_acl), acl_list.end());

View file

@ -0,0 +1,63 @@
--- src/acl_manager.hpp.orig 2010-06-03 05:38:27.000000000 +0900
+++ src/acl_manager.hpp 2010-06-19 22:48:42.000000000 +0900
@@ -93,7 +93,7 @@
};
-struct acl_entry : permissions_t
+struct acl_manager_entry : permissions_t
{
int qualifier; // Group or user
string name; // Symbolic name of the qualifier
@@ -118,10 +118,10 @@
bool _there_is_mask;
permissions_t _mask_acl;
- vector<acl_entry> _user_acl;
- vector<acl_entry> _group_acl;
- vector<acl_entry> _default_user_acl;
- vector<acl_entry> _default_group_acl;
+ vector<acl_manager_entry> _user_acl;
+ vector<acl_manager_entry> _group_acl;
+ vector<acl_manager_entry> _default_user_acl;
+ vector<acl_manager_entry> _default_group_acl;
permissions_t _default_user;
bool _there_is_default_user;
@@ -143,9 +143,9 @@
void get_acl_entries_default();
void create_textual_representation();
string permission_to_str(permissions_t& p);
- string write_name(acl_entry& eacl);
- void set_acl_generic(const string& nom, vector<acl_entry>& llistACL, const permissions_t& perms);
- void remove_acl_generic(const string& nom, vector<acl_entry>& llistaACL);
+ string write_name(acl_manager_entry& eacl);
+ void set_acl_generic(const string& nom, vector<acl_manager_entry>& llistACL, const permissions_t& perms);
+ void remove_acl_generic(const string& nom, vector<acl_manager_entry>& llistaACL);
void commit_changes_to_file();
void calculate_access_mask();
@@ -160,7 +160,7 @@
public:
ACLEquivalence(const string& qualif)
: _qualifier(qualif) {}
- bool operator ()(acl_entry& a)
+ bool operator ()(acl_manager_entry& a)
{
return (a.valid_name && (a.name == _qualifier));
}
@@ -203,10 +203,10 @@
void create_default_acl();
- vector<acl_entry> get_acl_user() const { return _user_acl; }
- vector<acl_entry> get_acl_group() const { return _group_acl; }
- vector<acl_entry> get_acl_user_default() const { return _default_user_acl; }
- vector<acl_entry> get_acl_group_default() const { return _default_group_acl; }
+ vector<acl_manager_entry> get_acl_user() const { return _user_acl; }
+ vector<acl_manager_entry> get_acl_group() const { return _group_acl; }
+ vector<acl_manager_entry> get_acl_user_default() const { return _default_user_acl; }
+ vector<acl_manager_entry> get_acl_group_default() const { return _default_group_acl; }
permissions_t get_mask() { return _mask_acl; }
permissions_t get_user() { return _owner_perms; }

View file

@ -0,0 +1,43 @@
--- src/eiciel_main_controller.cpp.orig 2010-06-03 05:38:27.000000000 +0900
+++ src/eiciel_main_controller.cpp 2010-06-19 22:56:56.000000000 +0900
@@ -125,11 +125,11 @@
effective_permissions = _ACL_manager->get_mask();
}
- vector<acl_entry> vACL;
+ vector<acl_manager_entry> vACL;
_window->add_non_selectable(Glib::locale_to_utf8(_ACL_manager->get_owner_name()), perms.reading,
perms.writing, perms.execution, EK_USER);
vACL = _ACL_manager->get_acl_user();
- for (vector<acl_entry>::iterator i = vACL.begin();
+ for (vector<acl_manager_entry>::iterator i = vACL.begin();
i != vACL.end(); i++)
{
_window->add_selectable(Glib::locale_to_utf8(i->name), i->reading,
@@ -153,7 +153,7 @@
(!effective_permissions.execution && perms.execution);
vACL = _ACL_manager->get_acl_group();
- for (vector<acl_entry>::iterator i = vACL.begin();
+ for (vector<acl_manager_entry>::iterator i = vACL.begin();
i != vACL.end(); i++)
{
_window->add_selectable(Glib::locale_to_utf8(i->name), i->reading,
@@ -200,7 +200,7 @@
vACL = _ACL_manager->get_acl_user_default();
there_is_default_acl |= (vACL.size() > 0);
- for (vector<acl_entry>::iterator i = vACL.begin();
+ for (vector<acl_manager_entry>::iterator i = vACL.begin();
i != vACL.end(); i++)
{
_window->add_selectable(Glib::locale_to_utf8(i->name), i->reading,
@@ -231,7 +231,7 @@
vACL = _ACL_manager->get_acl_group_default();
there_is_default_acl |= (vACL.size() > 0);
- for (vector<acl_entry>::iterator i = vACL.begin();
+ for (vector<acl_manager_entry>::iterator i = vACL.begin();
i != vACL.end(); i++)
{
_window->add_selectable(Glib::locale_to_utf8(i->name), i->reading,

View file

@ -2,4 +2,4 @@ Eiciel allows you to visually edit file ACL entries. You can add and remove
users and groups who will be granted permissions through the graphical
interface.
WWW: http://rofi.pinchito.com/eiciel/
WWW: http://rofi.roger-ferrer.org/eiciel/

View file

@ -3,39 +3,39 @@ lib/nautilus/extensions-2.0/libeiciel-nautilus.a
lib/nautilus/extensions-2.0/libeiciel-nautilus.la
lib/nautilus/extensions-2.0/libeiciel-nautilus.so
share/applications/eiciel.desktop
%%DATADIR%%/img/others-default.png
%%DATADIR%%/img/others.png
%%DATADIR%%/img/group-acl-default.png
%%DATADIR%%/img/group-acl.png
%%DATADIR%%/img/group-default.png
%%DATADIR%%/img/group.png
%%DATADIR%%/img/mask-default.png
%%DATADIR%%/img/mask.png
%%DATADIR%%/img/user-acl-default.png
%%DATADIR%%/img/user-acl.png
%%DATADIR%%/img/user-default.png
%%DATADIR%%/img/user.png
%%DATADIR%%/img/icon_eiciel_16.png
%%DATADIR%%/img/icon_eiciel_24.png
%%DATADIR%%/img/icon_eiciel_32.png
%%DATADIR%%/img/icon_eiciel_48.png
%%DATADIR%%/img/icon_eiciel_64.png
%%DATADIR%%/img/mask-default.png
%%DATADIR%%/img/mask.png
%%DATADIR%%/img/others-default.png
%%DATADIR%%/img/others.png
%%DATADIR%%/img/user-acl-default.png
%%DATADIR%%/img/user-acl.png
%%DATADIR%%/img/user-default.png
%%DATADIR%%/img/user.png
share/gnome/help/eiciel/C/eiciel.xml
share/gnome/help/eiciel/C/figures/entrada_acl.png
share/gnome/help/eiciel/C/figures/obrir_fitxer_nautilus.png
share/gnome/help/eiciel/C/figures/obrir_fitxer.png
share/gnome/help/eiciel/C/figures/permisos_acl.png
share/gnome/help/eiciel/C/figures/permisos_ugo.png
share/gnome/help/eiciel/C/figures/detall_mascara.png
share/gnome/help/eiciel/C/figures/pantalla_ea.png
share/gnome/help/eiciel/C/figures/others-default.png
share/gnome/help/eiciel/C/figures/others.png
share/gnome/help/eiciel/C/figures/entrada_acl.png
share/gnome/help/eiciel/C/figures/group-acl-default.png
share/gnome/help/eiciel/C/figures/group-acl.png
share/gnome/help/eiciel/C/figures/group-default.png
share/gnome/help/eiciel/C/figures/group.png
share/gnome/help/eiciel/C/figures/mask-default.png
share/gnome/help/eiciel/C/figures/mask.png
share/gnome/help/eiciel/C/figures/obrir_fitxer.png
share/gnome/help/eiciel/C/figures/obrir_fitxer_nautilus.png
share/gnome/help/eiciel/C/figures/others-default.png
share/gnome/help/eiciel/C/figures/others.png
share/gnome/help/eiciel/C/figures/pantalla_ea.png
share/gnome/help/eiciel/C/figures/permisos_acl.png
share/gnome/help/eiciel/C/figures/permisos_ugo.png
share/gnome/help/eiciel/C/figures/user-acl-default.png
share/gnome/help/eiciel/C/figures/user-acl.png
share/gnome/help/eiciel/C/figures/user-default.png
@ -44,9 +44,9 @@ share/locale/ca/LC_MESSAGES/eiciel.mo
share/locale/de/LC_MESSAGES/eiciel.mo
share/locale/es/LC_MESSAGES/eiciel.mo
share/locale/sv/LC_MESSAGES/eiciel.mo
@dirrm %%DATADIR%%/img
@dirrm %%DATADIR%%
@dirrm share/gnome/help/eiciel/C/figures
@dirrm share/gnome/help/eiciel/C
@dirrm share/gnome/help/eiciel
@dirrm %%DATADIR%%/img
@dirrm %%DATADIR%%
@dirrmtry share/applications