- write new rc script [1]

- install config with @sample macro
- bump PORTREVISION

MFH:		2016Q1
This commit is contained in:
Olli Hauer 2016-01-11 19:36:32 +00:00
parent eb10e89aa3
commit 3c7cd574b3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=405804
5 changed files with 40 additions and 31 deletions

View file

@ -3,7 +3,7 @@
PORTNAME= bandwidthd
PORTVERSION= 2.0.1
PORTREVISION= 7
PORTREVISION= 8
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
@ -14,6 +14,8 @@ LICENSE= GPLv2
LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
SUB_FILES= bandwidthd
USE_CSTD= gnu89
GNU_CONFIGURE= YES
@ -21,7 +23,9 @@ CONFIGURE_ARGS= ac_cv_lib_iconv_libiconv_open=no
USES= gmake tar:tgz
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/bandwidthd.sh \
${STAGEDIR}${PREFIX}/etc/rc.d/bandwidthd.sh.sample
${INSTALL_SCRIPT} ${WRKDIR}/bandwidthd \
${STAGEDIR}${PREFIX}/etc/rc.d
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View file

@ -0,0 +1,26 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: bandwidthd
# REQUIRE: NETWORKING SERVERS
# BEFORE: DAEMON
# KEYWORD: shutdown
# Add the following lines to /etc/rc.conf to enable bandwidthd:
# bandwidthd_enable (bool): Set it to "YES" to enable bandwidthd.
# Default is "NO".
bandwidthd_enable=${bandwidthd_enable:="NO"}
. /etc/rc.subr
name="bandwidthd"
rcvar="bandwidthd_enable"
command="%%PREFIX%%/bandwidthd/bandwidthd"
required_files="%%PREFIX%%/bandwidthd/etc/bandwidthd.conf"
pidfile="/var/run/bandwidthd.pid"
load_rc_config $name
run_rc_command "$1"

View file

@ -1,22 +0,0 @@
#!/bin/sh
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
echo "$0: Cannot determine the PREFIX" >&2
exit 1
fi
case "$1" in
start)
[ -x ${PREFIX}/bandwidthd ] && \
[ -r ${PREFIX}/bandwidthd/etc/bandwidthd.conf ] && \
cd ${PREFIX}/bandwidthd && ./bandwidthd &&\
echo -n ' bandwidthd'
;;
stop)
killall bandwidthd && echo -n ' bandwidthd'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
;;
esac

View file

@ -1,11 +1,11 @@
--- Makefile.in.orig Sun Jan 16 17:02:04 2005
+++ Makefile.in Sun Jan 16 17:02:38 2005
@@ -41,7 +41,7 @@
--- Makefile.in.orig 2005-01-11 21:15:49 UTC
+++ Makefile.in
@@ -41,7 +41,7 @@ install: all
@INSTALL@ -d $(DESTDIR)$(exec_prefix)/bandwidthd/etc
@INSTALL@ -d $(DESTDIR)$(exec_prefix)/bandwidthd/htdocs
@INSTALL@ -m755 -s bandwidthd $(DESTDIR)$(exec_prefix)/bandwidthd
- if [ ! -f $(DESTDIR)$(exec_prefix)/bandwidthd/etc/bandwidthd.conf ] ; then @INSTALL@ -m644 etc/bandwidthd.conf $(DESTDIR)$(exec_prefix)/bandwidthd/etc/ ; fi
+ @INSTALL@ -m644 etc/bandwidthd.conf $(DESTDIR)$(exec_prefix)/bandwidthd/etc/bandwidthd.conf-dist
+ @INSTALL@ -m644 etc/bandwidthd.conf $(DESTDIR)$(exec_prefix)/bandwidthd/etc/bandwidthd.conf.sample
@INSTALL@ -m644 htdocs/legend.gif $(DESTDIR)$(exec_prefix)/bandwidthd/htdocs
@INSTALL@ -m644 htdocs/logo.gif $(DESTDIR)$(exec_prefix)/bandwidthd/htdocs

View file

@ -1,5 +1,6 @@
bandwidthd/etc/bandwidthd.conf-dist
bandwidthd/bandwidthd
@sample bandwidthd/etc/bandwidthd.conf.sample
bandwidthd/htdocs/legend.gif
bandwidthd/htdocs/logo.gif
etc/rc.d/bandwidthd.sh.sample
etc/rc.d/bandwidthd
%%PORTDOCS%%%%DOCSDIR%%/README