Update to v4.1
This commit is contained in:
parent
48fc012063
commit
3c862c5130
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=453176
3 changed files with 29 additions and 4 deletions
|
@ -1,7 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pdfpc
|
||||
DISTVERSION= 4.0.8-2
|
||||
DISTVERSION= 4.1
|
||||
CATEGORIES= graphics
|
||||
DISTVERSIONPREFIX= v
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1506414416
|
||||
SHA256 (pdfpc-pdfpc-v4.0.8-2_GH0.tar.gz) = 5dcd87da548fd1994f97a6b980209c096de0952b375b61524aeb48d2fd3c19a6
|
||||
SIZE (pdfpc-pdfpc-v4.0.8-2_GH0.tar.gz) = 91138
|
||||
TIMESTAMP = 1509370570
|
||||
SHA256 (pdfpc-pdfpc-v4.1_GH0.tar.gz) = aee684cc4b6cd8f2f83196ebd42608b9917104c9b1572985797daf1ae68e5454
|
||||
SIZE (pdfpc-pdfpc-v4.1_GH0.tar.gz) = 95802
|
||||
|
|
25
graphics/pdfpc/files/patch-src_CMakeLists.txt
Normal file
25
graphics/pdfpc/files/patch-src_CMakeLists.txt
Normal file
|
@ -0,0 +1,25 @@
|
|||
--- src/CMakeLists.txt.orig 2017-10-30 08:51:03 UTC
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -50,8 +50,22 @@ include_directories(
|
||||
${CMAKE_CURRENT_SOURCE_DIR}
|
||||
)
|
||||
|
||||
+link_directories(
|
||||
+ ${GOBJECT_LIBRARY_DIRS}
|
||||
+ ${GIO_LIBRARY_DIRS}
|
||||
+ ${GEE_LIBRARY_DIRS}
|
||||
+ ${POPPLER_LIBRARY_DIRS}
|
||||
+ ${GTK_LIBRARY_DIRS}
|
||||
+ ${GTHREAD_LIBRARY_DIRS}
|
||||
+ ${PANGOCAIRO_LIBRARY_DIRS}
|
||||
+ ${GSTREAMER_LIBRARY_DIRS}
|
||||
+ ${GSTINTERFACES_LIBRARY_DIRS}
|
||||
+ ${GSTVIDEO_LIBRARY_DIRS}
|
||||
+)
|
||||
+
|
||||
if(${WITH_X11})
|
||||
include_directories(${X11_INCLUDE_DIRS})
|
||||
+ link_directories(${X11_LIBRARY_DIRS})
|
||||
set(ADDITIONAL_LIBS ${X11_LIBRARIES})
|
||||
endif()
|
||||
|
Loading…
Reference in a new issue