- In www/serf move libssl and libcrypto from Requires.private to

Libs.private in serf-1.pc such that subversion-static can use
  "pkg-config --static" instead of requiring a .la file
- Remove an old libtool patch from devel/subversion

Approved by:	ohauer
This commit is contained in:
Tijl Coosemans 2014-08-28 21:37:54 +00:00
parent 009d225dd5
commit 3c880db83d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=366457
5 changed files with 7 additions and 60 deletions

View file

@ -50,10 +50,10 @@ SASL_CONFIGURE_ON= --with-sasl=${LOCALBASE}
SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
SERF_CONFIGURE_OFF= --without-serf
SERF_CONFIGURE_ON= --with-serf=${LOCALBASE}
SERF_CONFIGURE_ON= --with-serf
SERF_LIB_DEPENDS= libserf-1.so:${PORTSDIR}/www/serf
STATIC_CONFIGURE_ON= --enable-all-static
STATIC_CONFIGURE_ON= --enable-all-static PKG_CONFIG="${LOCALBASE}/bin/pkg-config --static"
# ===============================================================
.include <bsd.port.options.mk>

View file

@ -1,11 +0,0 @@
--- build/ltmain.sh.orig 2011-08-26 19:01:42.000000000 +0400
+++ build/ltmain.sh 2011-09-08 00:11:05.000000000 +0400
@@ -5597,7 +5597,7 @@
# These systems don't actually have a C library (as such)
test "X$arg" = "X-lc" && continue
;;
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly*)
+ *-*-openbsd* | *-*-freebsd4* | *-*-dragonfly*)
# Do not include libc due to us having libc/libc_r.
test "X$arg" = "X-lc" && continue
;;

View file

@ -3,6 +3,7 @@
PORTNAME= serf
PORTVERSION= 1.3.7
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://serf.googlecode.com/svn/src_releases/
@ -17,9 +18,6 @@ USES= scons tar:bzip2
USE_OPENSSL= yes
USE_LDCONFIG= yes
# support for subversion-static,
SUB_FILES= libserf-1.la
OPTIONS_DEFINE= DOCS GSSAPI
SCONS_ARGS= APR=${LOCALBASE}/bin/apr-1-config
@ -43,12 +41,14 @@ do-install:
@(cd ${WRKSRC} && ${SENTENV} ${MAKE_CMD} ${SCONS_ARGS} ${INSTALL_TARGET})
post-patch:
@${REINPLACE_CMD} -e '/^Requires.private/d' ${WRKSRC}/build/serf.pc.in
@${REINPLACE_CMD} -E \
-e '/^Requires.private/s/(libssl|libcrypto)//g' \
-e '/^Libs.private/s|$$| -L${OPENSSLLIB} -lssl -lcrypto|' \
${WRKSRC}/build/serf.pc.in
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/design-guide.txt ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${SUB_FILES:S|^|${WRKDIR}/|} ${STAGEDIR}${PREFIX}/lib
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libserf-1.so
regression-test check: build

View file

@ -1,41 +0,0 @@
# libserf-1.la - a libtool library file
# Generated by libtool (GNU libtool) 2.4.2
#
# Please DO NOT delete this file!
# It is necessary for linking the library.
# The name that we can dlopen(3).
dlname='libserf-1.so'
# Names of this library.
library_names='libserf-1.so'
# The name of the static archive.
old_library='libserf-1.a'
# Linker flags that can not go in dependency_libs.
inherited_linker_flags=' -pthread'
# Libraries that this one depends upon.
dependency_libs=' -R%%LOCALBASE%%/lib -L/usr/lib -L%%LOCALBASE%%/lib %%LOCALBASE%%/lib/libaprutil-1.la %%LOCALBASE%%/lib/libapr-1.la -lcrypt -lz -lssl -lcrypto'
# Names of additional weak libraries provided by this library
weak_library_names=''
# Version information for libserf-1.
current=0
age=0
revision=0
# Is this an already installed library?
installed=yes
# Should we warn about portability when linking against -modules?
shouldnotlink=no
# Files to dlopen/dlpreopen
dlopen=''
dlpreopen=''
# Directory that this library needs to be installed in:
libdir='%%LOCALBASE%%/lib'

View file

@ -2,7 +2,6 @@ include/serf-1/serf.h
include/serf-1/serf_bucket_types.h
include/serf-1/serf_bucket_util.h
lib/libserf-1.a
lib/libserf-1.la
lib/libserf-1.so
lib/libserf-1.so.1
lib/libserf-1.so.1.3.0