Moved gyrosscope from www to x11.

This commit is contained in:
Jim Mock 1999-08-18 08:42:03 +00:00
parent 5d8cffbdba
commit 3cba145a61
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=20772
6 changed files with 56 additions and 0 deletions

25
x11/gyroscope/Makefile Normal file
View file

@ -0,0 +1,25 @@
# New ports collection makefile for: gyroscope
# Version required: 1.0
# Date created: 31 July 1999
# Whom: Jim Mock <jim@FreeBSD.org>
#
# $Id: Makefile,v 1.1.1.1 1999/08/16 09:06:25 jim Exp $
#
DISTNAME= gyroscope-1.0
CATEGORIES= x11
MASTER_SITES= http://www.millar.u-net.com/
MAINTAINER= jim@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
WRKSRC= ${WRKDIR}/gyroscope
USE_X_PREFIX= yes
do-build:
@(cd ${WRKSRC} && ${MAKE})
.include <bsd.port.mk>

1
x11/gyroscope/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (gyroscope-1.0.tar.gz) = d2f51c415fb3e10be8a43043e2c818ad

View file

@ -0,0 +1,21 @@
--- Makefile.orig Sun Jan 31 03:30:22 1999
+++ Makefile Sat Jul 31 16:27:41 1999
@@ -1,8 +1,8 @@
-CC = gcc
+CC ?= gcc
BINARYNAME = gyroscope
-BIN_DIR = /usr/local/bin/
-GTKINC = `gtk-config --cflags` -Wall -O2
-GTKLIB = `gtk-config --libs`
+BIN_DIR = ${X11BASE}/bin
+GTKINC = `gtk12-config --cflags` -Wall -O2
+GTKLIB = `gtk12-config --libs`
$(BINARYNAME): main.o gtkcolorsel.o
$(CC) -o $(BINARYNAME) main.o gtkcolorsel.o $(GTKLIB)
@@ -17,4 +17,4 @@
-@ rm core -f *.o ./$(BINARYNAME)
install:
- cp ./$(BINARYNAME) $(BIN_DIR)$(BINARYNAME)
+ @/usr/bin/install -c -o 0 -g 0 -s -m 1755 ${BINARYNAME} ${BIN_DIR}/${BINARYNAME}

View file

@ -0,0 +1 @@
Gyroscope is an HTML color picker written using GTK

7
x11/gyroscope/pkg-descr Normal file
View file

@ -0,0 +1,7 @@
Gyroscope is an HTML color picker written using GTK. You slide the
sliders and click in the appropriate places to choose a color and
it displays the #123456 type format for it.
WWW: http://www.millar.u-net.com/gyroscope.html
- Jim <jim@FreeBSD.org>

1
x11/gyroscope/pkg-plist Normal file
View file

@ -0,0 +1 @@
bin/gyroscope