x11-wm/i3-gaps: Unbreak build when both DOCS and MANPAGES are selected
Upstream PR: https://github.com/i3/i3/pull/4264
This commit is contained in:
parent
1a0be3d9eb
commit
3cbe234525
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=555963
2 changed files with 35 additions and 1 deletions
|
@ -29,7 +29,7 @@ RUN_DEPENDS= p5-AnyEvent-I3>=0:devel/p5-AnyEvent-I3 \
|
|||
p5-JSON-XS>=0:converters/p5-JSON-XS \
|
||||
p5-Try-Tiny>=0:lang/p5-Try-Tiny
|
||||
|
||||
USES= compiler:c11 gettext-runtime gmake gnome iconv localbase:ldflags \
|
||||
USES= compiler:c11 gettext-runtime gnome iconv localbase:ldflags \
|
||||
meson perl5 pkgconfig xorg
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= Airblader
|
||||
|
|
34
x11-wm/i3-gaps/files/patch-meson.build
Normal file
34
x11-wm/i3-gaps/files/patch-meson.build
Normal file
|
@ -0,0 +1,34 @@
|
|||
Upstream PR: https://github.com/i3/i3/pull/4264
|
||||
--- meson.build.orig 2020-11-15 18:11:08 UTC
|
||||
+++ meson.build
|
||||
@@ -428,7 +428,9 @@ command_parser = custom_target(
|
||||
command: [perl, parser_gen, '--input=@INPUT@', '--prefix=command'],
|
||||
)
|
||||
|
||||
-i3srcs += command_parser
|
||||
+command_parser_dep = declare_dependency(
|
||||
+ sources : [command_parser]
|
||||
+)
|
||||
|
||||
config_parser = custom_target(
|
||||
'config_parser',
|
||||
@@ -441,7 +443,9 @@ config_parser = custom_target(
|
||||
command: [parser_gen, '--input=@INPUT@', '--prefix=config'],
|
||||
)
|
||||
|
||||
-i3srcs += config_parser
|
||||
+config_parser_dep = declare_dependency(
|
||||
+ sources : [config_parser]
|
||||
+)
|
||||
|
||||
# src/log.c uses threading primitives for synchronization
|
||||
thread_dep = dependency('threads')
|
||||
@@ -472,6 +476,8 @@ common_deps = [
|
||||
gobject_dep,
|
||||
ev_dep,
|
||||
config_h,
|
||||
+ command_parser_dep,
|
||||
+ config_parser_dep
|
||||
]
|
||||
|
||||
executable(
|
Loading…
Reference in a new issue