- Update shishi to 1.0.0
- Update MASTER_SITE (GNU) - Remove custom patch (fixed upstream) - Note: shlib version bumped
This commit is contained in:
parent
7d0a0bb58e
commit
3cd8db92cd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=254965
5 changed files with 10 additions and 28 deletions
|
@ -7,11 +7,9 @@
|
|||
#
|
||||
|
||||
PORTNAME= shishi
|
||||
PORTVERSION= 0.0.43
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.0.0
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_GNU_ALPHA}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
MASTER_SITES= GNU
|
||||
|
||||
MAINTAINER= johans@FreeBSD.org
|
||||
COMMENT= A free implementation of the Kerberos 5 network security system
|
||||
|
@ -64,7 +62,4 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e 's:\.\./gl/libgnu.la:../db/gl/libgnu.la &:' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (shishi-0.0.43.tar.gz) = ee2e4d122d27c312c07d8ab6ec65da6e
|
||||
SHA256 (shishi-0.0.43.tar.gz) = a0768907475867a9f7c6ec9152b6467f0de907895bc155b2d13cdf4d2725129e
|
||||
SIZE (shishi-0.0.43.tar.gz) = 4250074
|
||||
MD5 (shishi-1.0.0.tar.gz) = e6536784d7181e6bcb848ee259dd56c7
|
||||
SHA256 (shishi-1.0.0.tar.gz) = 2f1e996649776514b63e46a069051d51b53dcd22fea191ce7618f3dbb45b12c9
|
||||
SIZE (shishi-1.0.0.tar.gz) = 4976544
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
--- lib/netio.c.orig 2010-04-01 23:36:30.000000000 +0200
|
||||
+++ lib/netio.c 2010-04-01 23:36:37.000000000 +0200
|
||||
@@ -241,9 +241,11 @@ sendrecv_host (Shishi * handle,
|
||||
{
|
||||
if (transport == TCP)
|
||||
rc = sendrecv_tcp (handle, ai, indata, inlen, outdata, outlen);
|
||||
+#ifdef USE_STARTTLS
|
||||
else if (transport == TLS)
|
||||
rc = _shishi_sendrecv_tls (handle, ai, indata, inlen,
|
||||
outdata, outlen);
|
||||
+#endif
|
||||
else
|
||||
rc = sendrecv_udp (handle, ai, indata, inlen, outdata, outlen);
|
||||
|
|
@ -1,7 +1,6 @@
|
|||
=================================================================
|
||||
NOTE: To finish installing this port, you need to execute the
|
||||
following commands:
|
||||
following command:
|
||||
|
||||
# mkdir -m 0700 -p /var/shishi
|
||||
# %%PREFIX%%/bin/shisa -a > %%PREFIX%%/etc/shishi/shishi.keys
|
||||
=================================================================
|
||||
|
|
|
@ -13,11 +13,11 @@ include/shishi.h
|
|||
lib/libshisa.a
|
||||
lib/libshisa.la
|
||||
lib/libshisa.so
|
||||
lib/libshisa.so.0
|
||||
lib/libshisa.so.1
|
||||
lib/libshishi.a
|
||||
lib/libshishi.la
|
||||
lib/libshishi.so
|
||||
lib/libshishi.so.0
|
||||
lib/libshishi.so.1
|
||||
lib/security/pam_shishi.so
|
||||
lib/security/pam_shishi.la
|
||||
lib/security/pam_shishi.a
|
||||
|
@ -33,3 +33,5 @@ libdata/pkgconfig/shishi.pc
|
|||
%%NLS%%@dirrmtry share/locale/en@quot
|
||||
@dirrmtry etc/shishi
|
||||
@dirrmtry lib/security
|
||||
@exec mkdir -m 0700 -p /var/shishi
|
||||
@dirrmtry /var/shishi
|
||||
|
|
Loading…
Reference in a new issue