biology/bcftools: Upgrade to 1.10.2
Numerous bug fixes and enhancements since 1.9: https://github.com/samtools/bcftools/tags Take maintainership per ports/248089. PR: ports/248089
This commit is contained in:
parent
115e5a0bb5
commit
3d154d8bbc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=544096
6 changed files with 69 additions and 78 deletions
|
@ -2,33 +2,30 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bcftools
|
||||
PORTVERSION= 1.9
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.10.2
|
||||
CATEGORIES= biology
|
||||
|
||||
MAINTAINER= cartwright@asu.edu
|
||||
MAINTAINER= jwb@FreeBSD.org
|
||||
COMMENT= Tools for manipulating next-generation sequencing data
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= htslib>=1.6:biology/htslib
|
||||
LIB_DEPENDS= libhts.so:biology/htslib
|
||||
LIB_DEPENDS= libhts.so.3:biology/htslib
|
||||
TEST_DEPENDS= bash:shells/bash
|
||||
|
||||
USES= autoreconf gmake localbase \
|
||||
perl5 python:env shebangfix
|
||||
USES= autoreconf gmake localbase perl5 python:env shebangfix
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= samtools
|
||||
|
||||
USE_LDCONFIG= ${PREFIX}/libexec/${PORTNAME}
|
||||
USE_PERL5= test
|
||||
|
||||
GH_ACCOUNT= samtools
|
||||
GNU_CONFIGURE= yes
|
||||
SHEBANG_FILES= misc/* test/test.pl
|
||||
|
||||
OPTIONS_DEFINE= GPL
|
||||
GPL_DESC= Enable modules that rely on GPL code
|
||||
OPTIONS_DEFINE= GPL
|
||||
GPL_DESC= Enable modules that rely on GPL code
|
||||
OPTIONS_DEFAULT= GPL
|
||||
|
||||
GPL_LIB_DEPENDS= libgsl.so:math/gsl
|
||||
|
@ -43,22 +40,22 @@ LICENSE_COMB= multi
|
|||
|
||||
TEST_TARGET= test
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|@PORTVERSION@|${PORTVERSION}|g' ${WRKSRC}/configure.ac
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} -e 's|@PORTVERSION@|${PORTVERSION}|g' \
|
||||
${WRKSRC}/configure.ac
|
||||
|
||||
post-install:
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/samtools_misc/color-chrs.pl \
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/color-chrs.pl \
|
||||
${STAGEDIR}${PREFIX}/bin/color-chrs
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/samtools_misc/guess-ploidy.py\
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/guess-ploidy.py\
|
||||
${STAGEDIR}${PREFIX}/bin/guess-ploidy
|
||||
${MV} /${STAGEDIR}${PREFIX}/bin/samtools_misc/plot-roh.py \
|
||||
${MV} /${STAGEDIR}${PREFIX}/bin/plot-roh.py \
|
||||
${STAGEDIR}${PREFIX}/bin/plot-roh
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/samtools_misc/run-roh.pl \
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/run-roh.pl \
|
||||
${STAGEDIR}${PREFIX}/bin/run-roh
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/samtools_misc/vcfutils.pl \
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/vcfutils.pl \
|
||||
${STAGEDIR}${PREFIX}/bin/vcfutils
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/samtools_misc/plot-vcfstats \
|
||||
${MV} ${STAGEDIR}${PREFIX}/bin/plot-vcfstats \
|
||||
${STAGEDIR}${PREFIX}/bin/
|
||||
${RMDIR} ${STAGEDIR}${PREFIX}/bin/samtools_misc/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1532903716
|
||||
SHA256 (samtools-bcftools-1.9_GH0.tar.gz) = 223b90c9a9b11576174384de70abe8e8394aef1b45c7324e4bf875d0f344e96e
|
||||
SIZE (samtools-bcftools-1.9_GH0.tar.gz) = 2394968
|
||||
TIMESTAMP = 1595166811
|
||||
SHA256 (samtools-bcftools-1.10.2_GH0.tar.gz) = 13277c17047152951e0bfe4467adc7768571b18e26610d206cab5560de5a395a
|
||||
SIZE (samtools-bcftools-1.10.2_GH0.tar.gz) = 2880994
|
||||
|
|
|
@ -1,40 +1,40 @@
|
|||
--- Makefile.orig 2018-07-18 08:34:29 UTC
|
||||
--- Makefile.orig 2019-12-19 09:57:32 UTC
|
||||
+++ Makefile
|
||||
@@ -22,10 +22,10 @@
|
||||
@@ -22,13 +22,12 @@
|
||||
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
|
||||
# DEALINGS IN THE SOFTWARE.
|
||||
|
||||
-CC = gcc
|
||||
-AR = ar
|
||||
-RANLIB = ranlib
|
||||
-CPPFLAGS =
|
||||
-CFLAGS = -g -Wall -Wc++-compat -O2
|
||||
-CFLAGS = -g -Wall -O2
|
||||
-LDFLAGS =
|
||||
+CC ?= cc
|
||||
+CPPFLAGS +=
|
||||
+CFLAGS += -Wall
|
||||
+LDFLAGS +=
|
||||
LIBS =
|
||||
-LIBS =
|
||||
+CC ?= gcc
|
||||
+AR ?= ar
|
||||
+RANLIB ?= ranlib
|
||||
+CPPFLAGS ?=
|
||||
+CFLAGS ?= -g -Wall -O2
|
||||
+LDFLAGS ?=
|
||||
|
||||
DYNAMIC_FLAGS = -rdynamic
|
||||
@@ -42,26 +42,25 @@ OBJS = main.o vcfindex.o tabix.o \
|
||||
vcfsort.o \
|
||||
PLUGINS_ENABLED = yes
|
||||
@@ -45,7 +44,8 @@ OBJS = main.o vcfindex.o tabix.o \
|
||||
ccall.o em.o prob1.o kmin.o # the original samtools calling
|
||||
PLUGIN_OBJS = vcfplugin.o
|
||||
|
||||
-prefix = /usr/local
|
||||
+prefix = ${PREFIX}
|
||||
+PREFIX ?= /usr/local
|
||||
+prefix = $(PREFIX)
|
||||
exec_prefix = $(prefix)
|
||||
bindir = $(exec_prefix)/bin
|
||||
libdir = $(exec_prefix)/lib
|
||||
libexecdir = $(exec_prefix)/libexec
|
||||
-mandir = $(prefix)/share/man
|
||||
+mandir = $(prefix)/man
|
||||
man1dir = $(mandir)/man1
|
||||
# Installation location for $(PLUGINS)
|
||||
plugindir = $(libexecdir)/bcftools
|
||||
pluginpath = $(plugindir)
|
||||
@@ -58,13 +58,13 @@ pluginpath = $(plugindir)
|
||||
# Installation location for $(MISC_PROGRAMS) and $(MISC_SCRIPTS)
|
||||
-misc_bindir = $(bindir)
|
||||
+misc_bindir = $(bindir)/samtools_misc
|
||||
misc_bindir = $(bindir)
|
||||
|
||||
+# Use BSD_INSTALL_PROGRAM to strip when WITH_DEBUG not set
|
||||
MKDIR_P = mkdir -p
|
||||
-INSTALL = install -p
|
||||
-INSTALL_DATA = $(INSTALL) -m 644
|
||||
|
@ -50,25 +50,16 @@
|
|||
|
||||
PROGRAMS = bcftools
|
||||
MISC_SCRIPTS = \
|
||||
@@ -77,7 +76,7 @@ all: $(PROGRAMS) $(TEST_PROGRAMS) plugin
|
||||
|
||||
ALL_CPPFLAGS = -I. $(HTSLIB_CPPFLAGS) $(CPPFLAGS)
|
||||
ALL_LDFLAGS = $(HTSLIB_LDFLAGS) $(LDFLAGS)
|
||||
-ALL_LIBS = -lz -ldl $(LIBS)
|
||||
+ALL_LIBS = -lz $(LIBS)
|
||||
|
||||
# Usually config.mk and config.h are generated by running configure
|
||||
# or config.status, but if those aren't used create defaults here.
|
||||
@@ -131,7 +130,7 @@ print-version:
|
||||
@@ -141,7 +141,7 @@ print-version:
|
||||
ifdef USE_GPL
|
||||
main.o : EXTRA_CPPFLAGS += -DUSE_GPL
|
||||
OBJS += polysomy.o peakfit.o
|
||||
- GSL_LIBS ?= -lgsl -lcblas
|
||||
+ GSL_LIBS ?= -lgsl -lgslcblas
|
||||
+ GSL_LIBS ?= -lgslcblas
|
||||
endif
|
||||
|
||||
bcftools: $(OBJS) $(HTSLIB)
|
||||
@@ -278,7 +277,7 @@ docs: doc/bcftools.1 doc/bcftools.html
|
||||
print-%:
|
||||
@@ -320,7 +320,7 @@ docs: doc/bcftools.1 doc/bcftools.html
|
||||
# Since there is no make dependency, bcftools.1 can be out-of-date and
|
||||
# make docs can be run to update if asciidoc is available
|
||||
install: $(PROGRAMS) $(PLUGINS)
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
--- prob1.c.orig 2017-09-28 11:22:48 UTC
|
||||
+++ prob1.c
|
||||
@@ -33,6 +33,12 @@ THE SOFTWARE. */
|
||||
#include <zlib.h>
|
||||
#include "prob1.h"
|
||||
|
||||
+#include <sys/param.h>
|
||||
+#if defined(__FreeBSD__) && (__FreeBSD_version < 1000034)
|
||||
+# define logl(x) log(x)
|
||||
+# define expl(x) exp(x)
|
||||
+#endif
|
||||
+
|
||||
// #include "kstring.h"
|
||||
// #include "kseq.h"
|
||||
// KSTREAM_INIT(gzFile, gzread, 16384)
|
|
@ -1,29 +1,38 @@
|
|||
--- test/test.pl.orig 2017-10-18 09:33:24 UTC
|
||||
--- test/test.pl.orig 2020-07-21 20:49:56 UTC
|
||||
+++ test/test.pl
|
||||
@@ -381,7 +381,7 @@ sub _cmd
|
||||
@@ -610,7 +610,7 @@ sub _cmd
|
||||
else
|
||||
{
|
||||
# child
|
||||
- exec('/bin/bash', '-o','pipefail','-c', $cmd) or error("Cannot execute the command [/bin/sh -o pipefail -c $cmd]: $!");
|
||||
+ exec('/usr/local/bin/bash', '-o','pipefail','-c', $cmd) or error("Cannot execute the command [/usr/local/bin/sh -o pipefail -c $cmd]: $!");
|
||||
+ exec('bash', '-o','pipefail','-c', $cmd) or error("Cannot execute the command [/usr/local/bin/sh -o pipefail -c $cmd]: $!");
|
||||
}
|
||||
return ($? >> 8, join('',@out));
|
||||
}
|
||||
@@ -782,7 +782,7 @@ sub test_usage
|
||||
@@ -622,7 +622,7 @@ sub _cmd3
|
||||
my $pid = fork();
|
||||
if ( !$pid )
|
||||
{
|
||||
- exec('/bin/bash', '-o','pipefail','-c', "($cmd) 2>$tmp.e >$tmp.o");
|
||||
+ exec('bash', '-o','pipefail','-c', "($cmd) 2>$tmp.e >$tmp.o");
|
||||
}
|
||||
waitpid($pid,0);
|
||||
|
||||
@@ -1063,7 +1063,7 @@ sub test_usage
|
||||
my $command = $args{cmd};
|
||||
my $commandpath = $$opts{bin}."/".$command;
|
||||
my ($ret,$out) = _cmd("$commandpath $args{redirection} 2>&1");
|
||||
- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
|
||||
+ if ( $out =~ m/\/usr\/local\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
|
||||
+ if ( $out =~ m/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath: $out"); return; }
|
||||
|
||||
my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
|
||||
|
||||
@@ -833,7 +833,7 @@ sub test_usage_subcommand
|
||||
@@ -1118,7 +1118,7 @@ sub test_usage_subcommand
|
||||
my $subcommand = $args{subcmd};
|
||||
my $commandpath = $$opts{bin}."/".$command;
|
||||
my ($ret,$out) = _cmd("$commandpath $subcommand $args{redirection} 2>&1");
|
||||
- if ( $out =~ m/\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
|
||||
+ if ( $out =~ m/\/usr\/local\/bin\/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
|
||||
+ if ( $out =~ m/bash.*no.*such/i ) { failed($opts,$test,"could not run $commandpath $subcommand: $out"); return; }
|
||||
|
||||
my @sections = ($out =~ m/(^[A-Za-z]+.*?)(?:(?=^[A-Za-z]+:)|\z)/msg);
|
||||
|
||||
|
|
|
@ -8,7 +8,9 @@ bin/vcfutils
|
|||
libexec/bcftools/GTisec.so
|
||||
libexec/bcftools/GTsubset.so
|
||||
libexec/bcftools/ad-bias.so
|
||||
libexec/bcftools/add-variantkey.so
|
||||
libexec/bcftools/af-dist.so
|
||||
libexec/bcftools/allele-length.so
|
||||
libexec/bcftools/check-ploidy.so
|
||||
libexec/bcftools/check-sparsity.so
|
||||
libexec/bcftools/color-chrs.so
|
||||
|
@ -22,15 +24,22 @@ libexec/bcftools/fixploidy.so
|
|||
libexec/bcftools/fixref.so
|
||||
libexec/bcftools/frameshifts.so
|
||||
libexec/bcftools/guess-ploidy.so
|
||||
libexec/bcftools/gvcfz.so
|
||||
libexec/bcftools/impute-info.so
|
||||
libexec/bcftools/indel-stats.so
|
||||
libexec/bcftools/isecGT.so
|
||||
libexec/bcftools/mendelian.so
|
||||
libexec/bcftools/missing2ref.so
|
||||
libexec/bcftools/parental-origin.so
|
||||
libexec/bcftools/prune.so
|
||||
libexec/bcftools/remove-overlaps.so
|
||||
libexec/bcftools/setGT.so
|
||||
libexec/bcftools/smpl-stats.so
|
||||
libexec/bcftools/split-vep.so
|
||||
libexec/bcftools/split.so
|
||||
libexec/bcftools/tag2tag.so
|
||||
libexec/bcftools/trio-dnm.so
|
||||
libexec/bcftools/trio-stats.so
|
||||
libexec/bcftools/trio-switch-rate.so
|
||||
libexec/bcftools/variantkey-hex.so
|
||||
man/man1/bcftools.1.gz
|
||||
|
|
Loading…
Reference in a new issue