- Update to 1.1.4
- Add mandir to INSTALL_TARGET PR: ports/107907 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
This commit is contained in:
parent
40df539255
commit
3d45221cc4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=182435
5 changed files with 167 additions and 7 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= bogofilter
|
||||
PORTVERSION= 1.0.3
|
||||
PORTVERSION= 1.1.4
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES?= mail
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
|
@ -33,7 +33,7 @@ PATCH_STRIP= -p1
|
|||
|
||||
BF_LIBS?= -ldb-4.3
|
||||
BF_CPPFLAGS?= -I${LOCALBASE}/include/db43 -I${LOCALBASE}/include
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc --mandir=${PREFIX}/man
|
||||
.if !defined(WITHOUT_UNICODE)
|
||||
CONFIGURE_ARGS+= --enable-unicode
|
||||
USE_ICONV= yes
|
||||
|
@ -47,7 +47,7 @@ CONFIGURE_ARGS+= --with-included-gsl
|
|||
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib" LIBS="${BF_LIBS}" \
|
||||
PERL="${PERL}" CPPFLAGS="${BF_CPPFLAGS}"
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
INSTALL_TARGET= install-strip prefix=${PREFIX}
|
||||
INSTALL_TARGET= install-strip prefix=${PREFIX} mandir=${MANPREFIX}/man
|
||||
|
||||
MAN1= bogofilter.1 bogoutil.1 bogoupgrade.1 bogolexer.1 bogotune.1 \
|
||||
bf_copy.1 bf_compact.1 bf_tar.1
|
||||
|
@ -67,7 +67,7 @@ PLIST_SUB= CONTRIB=""
|
|||
.endif
|
||||
|
||||
post-build::
|
||||
cd ${WRKSRC} && make check SHELL=${SH}
|
||||
cd ${WRKSRC}/src && make check SHELL=${SH}
|
||||
|
||||
post-install::
|
||||
@${MKDIR} ${DOCSDIR}/contrib
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (bogofilter-1.0.3.tar.bz2) = f3ccde59a29c1d3519e31fe7e6a9fd29
|
||||
SHA256 (bogofilter-1.0.3.tar.bz2) = 71d9f184ceba98233543a7f620eed6fdd447c38541f7e46a99e2c991f38c5e95
|
||||
SIZE (bogofilter-1.0.3.tar.bz2) = 778983
|
||||
MD5 (bogofilter-1.1.4.tar.bz2) = 6c72a2e482908cf78288c3bc6b11f57b
|
||||
SHA256 (bogofilter-1.1.4.tar.bz2) = 2cd09fac0c1e425d54028415c238627847543a5c03adf7a79d71158129d2b419
|
||||
SIZE (bogofilter-1.1.4.tar.bz2) = 797924
|
||||
|
|
29
mail/bogofilter/files/patch-aa-fix-deptracking
Normal file
29
mail/bogofilter/files/patch-aa-fix-deptracking
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- ./src/Makefile.am.orig Sat Dec 9 14:53:57 2006
|
||||
+++ ./src/Makefile.am Sun Jan 14 17:51:18 2007
|
||||
@@ -27,4 +27,6 @@
|
||||
endif
|
||||
|
||||
+BUILT_SOURCES= version.c directories.c
|
||||
+
|
||||
# what to build
|
||||
bin_PROGRAMS = bogofilter bogoutil bogolexer bogotune
|
||||
@@ -44,5 +46,4 @@
|
||||
bogoutil_LDADD = $(LDADD) $(LIBDB)
|
||||
configtest_LDADD = $(LDADD) $(LIBDB)
|
||||
-bogofilter_DEPENDENCIES = $(LDADD)
|
||||
|
||||
if NEED_GSL
|
||||
@@ -60,5 +61,5 @@
|
||||
noinst_LIBRARIES += libbf_gsl.a
|
||||
libbf_gsl_a_CPPFLAGS= -I$(top_srcdir)
|
||||
-bogofilter_DEPENDENCIES += libbf_gsl.a
|
||||
+BUILT_SOURCES += libbf_gsl.a
|
||||
endif
|
||||
|
||||
@@ -152,6 +153,4 @@
|
||||
datastore_db.h \
|
||||
mysetvbuf.c mysetvbuf.h
|
||||
-
|
||||
-BUILT_SOURCES= version.c directories.c
|
||||
|
||||
libbogofilter_a_SOURCES = \
|
70
mail/bogofilter/files/patch-ab-fix-deptracking
Normal file
70
mail/bogofilter/files/patch-ab-fix-deptracking
Normal file
|
@ -0,0 +1,70 @@
|
|||
--- ./src/Makefile.in.orig Sun Jan 14 17:51:53 2007
|
||||
+++ ./src/Makefile.in Sun Jan 14 17:52:38 2007
|
||||
@@ -233,4 +233,6 @@
|
||||
am_bogofilter_OBJECTS = bogofilter.$(OBJEXT) main.$(OBJEXT)
|
||||
bogofilter_OBJECTS = $(am_bogofilter_OBJECTS)
|
||||
+bogofilter_DEPENDENCIES = $(am__DEPENDENCIES_4) $(am__DEPENDENCIES_2) \
|
||||
+ $(am__DEPENDENCIES_2)
|
||||
am__objects_5 = bogofilter.$(OBJEXT) main.$(OBJEXT)
|
||||
am_bogofilter_static_OBJECTS = $(am__objects_5)
|
||||
@@ -384,5 +386,4 @@
|
||||
EXEEXT = @EXEEXT@
|
||||
EXE_EXT = @EXE_EXT@
|
||||
-GREP = @GREP@
|
||||
GSL_CFLAGS = @GSL_CFLAGS@
|
||||
GSL_CONFIG = @GSL_CONFIG@
|
||||
@@ -443,5 +444,8 @@
|
||||
USE_UNICODE = @USE_UNICODE@
|
||||
VERSION = @VERSION@
|
||||
+ac_ct_AR = @ac_ct_AR@
|
||||
ac_ct_CC = @ac_ct_CC@
|
||||
+ac_ct_RANLIB = @ac_ct_RANLIB@
|
||||
+ac_ct_STRIP = @ac_ct_STRIP@
|
||||
ac_cv_enable_xmlto = @ac_cv_enable_xmlto@
|
||||
am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
|
||||
@@ -459,7 +463,4 @@
|
||||
build_vendor = @build_vendor@
|
||||
datadir = @datadir@
|
||||
-datarootdir = @datarootdir@
|
||||
-docdir = @docdir@
|
||||
-dvidir = @dvidir@
|
||||
exec_prefix = @exec_prefix@
|
||||
host = @host@
|
||||
@@ -468,5 +469,4 @@
|
||||
host_os = @host_os@
|
||||
host_vendor = @host_vendor@
|
||||
-htmldir = @htmldir@
|
||||
includedir = @includedir@
|
||||
infodir = @infodir@
|
||||
@@ -474,13 +474,10 @@
|
||||
libdir = @libdir@
|
||||
libexecdir = @libexecdir@
|
||||
-localedir = @localedir@
|
||||
localstatedir = @localstatedir@
|
||||
mandir = @mandir@
|
||||
mkdir_p = @mkdir_p@
|
||||
oldincludedir = @oldincludedir@
|
||||
-pdfdir = @pdfdir@
|
||||
prefix = @prefix@
|
||||
program_transform_name = @program_transform_name@
|
||||
-psdir = @psdir@
|
||||
sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
@@ -503,4 +500,5 @@
|
||||
|
||||
AM_CFLAGS = -DBOGOFILTER $(am__append_1)
|
||||
+BUILT_SOURCES = version.c directories.c $(am__append_4)
|
||||
bin_SCRIPTS = bogoupgrade
|
||||
dist_bin_SCRIPTS = bf_copy bf_compact bf_tar
|
||||
@@ -514,5 +512,4 @@
|
||||
bogoutil_LDADD = $(LDADD) $(LIBDB)
|
||||
configtest_LDADD = $(LDADD) $(LIBDB)
|
||||
-bogofilter_DEPENDENCIES = $(LDADD) $(am__append_4)
|
||||
@NEED_GSL_TRUE@libbf_gsl_a_CFLAGS = $(AM_CFLAGS) -DRENAMEFILES
|
||||
@NEED_GSL_TRUE@libbf_gsl_a_SOURCES = \
|
||||
@@ -600,5 +597,4 @@
|
||||
mysetvbuf.c mysetvbuf.h
|
||||
|
||||
-BUILT_SOURCES = version.c directories.c
|
||||
libbogofilter_a_SOURCES = version.c $(version_sources) \
|
||||
$(datastore_SOURCE)
|
61
mail/bogofilter/files/patch-ba-fix-subnet-tokens
Normal file
61
mail/bogofilter/files/patch-ba-fix-subnet-tokens
Normal file
|
@ -0,0 +1,61 @@
|
|||
diff -u -r1.153 -r1.155
|
||||
--- ./src/token.c 26 Nov 2006 16:34:30 -0000 1.153
|
||||
+++ ./src/token.c 12 Jan 2007 00:20:16 -0000 1.155
|
||||
@@ -1,4 +1,4 @@
|
||||
-/* $Id: token.c,v 1.153 2006/11/26 16:34:30 relson Exp $ */
|
||||
+/* $Id: token.c,v 1.155 2007/01/12 00:20:16 relson Exp $ */
|
||||
|
||||
/*****************************************************************************
|
||||
|
||||
@@ -121,22 +121,17 @@
|
||||
token_set(dst, src->text, src->leng);
|
||||
}
|
||||
|
||||
-static void build_prefixed_token( word_t *token, word_t *prefix,
|
||||
+static void build_prefixed_token( word_t *prefix, word_t *token,
|
||||
word_t *temp, uint32_t temp_size )
|
||||
{
|
||||
- uint pfx_len = (prefix == NULL) ? 0 : prefix->leng;
|
||||
- uint len = token->leng + pfx_len;
|
||||
+ uint len = token->leng + prefix->leng;
|
||||
|
||||
if (len >= temp_size)
|
||||
- len = temp_size - pfx_len - 1;
|
||||
+ len = temp_size - prefix->leng - 1;
|
||||
|
||||
temp->leng = len;
|
||||
-
|
||||
- /* copy prefix, if there is one */
|
||||
- if (prefix != NULL)
|
||||
- memcpy(temp->text, prefix->text, pfx_len);
|
||||
-
|
||||
- memcpy(temp->text + pfx_len, token->text, len-pfx_len);
|
||||
+ memmove(temp->text+prefix->leng, token->text, len-prefix->leng);
|
||||
+ memcpy(temp->text, prefix->text, prefix->leng);
|
||||
Z(temp->text[temp->leng]);
|
||||
|
||||
token->leng = temp->leng;
|
||||
@@ -167,12 +162,11 @@
|
||||
if (token_prefix != NULL) {
|
||||
/* IP addresses get special prefix */
|
||||
if (save_class != IPADDR) {
|
||||
- build_prefixed_token(token, token_prefix, &yylval, yylval_text_size);
|
||||
+ build_prefixed_token(token_prefix, token, &yylval, yylval_text_size);
|
||||
}
|
||||
else {
|
||||
-
|
||||
word_t *prefix = (wordlist_version >= IP_PREFIX) ? w_ip : w_url;
|
||||
- build_prefixed_token(token, prefix, ipsave, max_token_len);
|
||||
+ build_prefixed_token(prefix, token, &yylval, yylval_text_size);
|
||||
}
|
||||
|
||||
/* if excessive length caused by prefix, get another token */
|
||||
@@ -198,7 +192,7 @@
|
||||
else
|
||||
{
|
||||
ipsave->leng = (uint) (t - ipsave->text);
|
||||
- token_set( &yylval, ipsave->text, ipsave->leng);
|
||||
+ token_set( token, ipsave->text, ipsave->leng);
|
||||
cls = save_class;
|
||||
done = true;
|
||||
}
|
Loading…
Reference in a new issue