Add some patches to make this port build with clang.
Feature safe: yes
This commit is contained in:
parent
9f4f1a933f
commit
3d82b066a6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286640
3 changed files with 31 additions and 7 deletions
|
@ -23,10 +23,4 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS= --with-rexx=regina
|
||||
DATADIR= ${PREFIX}/share/rexx${PORTNAME}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${CC} == "clang"
|
||||
BROKEN= Does not configure with clang
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
lang/rexx-wrapper/files/patch-configur
Normal file
11
lang/rexx-wrapper/files/patch-configur
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configur.orig 2003-06-30 09:39:59.000000000 +0200
|
||||
+++ configur 2011-11-29 13:21:17.000000000 +0100
|
||||
@@ -1476,7 +1476,7 @@
|
||||
|
||||
|
||||
|
||||
-CC_LIST="gcc cc c89 acc"
|
||||
+CC_LIST="gcc clang cc c89 acc"
|
||||
|
||||
mh_sysv_incdir=""
|
||||
mh_sysv_libdir=""
|
19
lang/rexx-wrapper/files/patch-rexxwrap.cmd
Normal file
19
lang/rexx-wrapper/files/patch-rexxwrap.cmd
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- rexxwrap.cmd.orig 2006-09-22 01:16:29.000000000 +0200
|
||||
+++ rexxwrap.cmd 2011-11-29 13:21:17.000000000 +0100
|
||||
@@ -84,7 +84,7 @@
|
||||
implib.unirexx = 'rxx'
|
||||
|
||||
compiler.win32 = 'cygwin ming vc wcc borland lcc'
|
||||
-compiler.unix = 'gcc cc c89 egcs xlc'
|
||||
+compiler.unix = 'gcc clang cc c89 egcs xlc'
|
||||
compiler.qnx = 'cc'
|
||||
compiler.os2 = 'gcc emxos2 emxdos wcc'
|
||||
compiler.dos = 'djgpp'
|
||||
@@ -718,6 +718,7 @@
|
||||
If _debug > 0 Then opt = '-g -DREXXWRAPPER_DEBUG='_debug
|
||||
Else opt = '-O'
|
||||
cc.gcc = 'gcc'
|
||||
+ cc.clang='clang'
|
||||
cc.egcs = 'egcs'
|
||||
cc.cc = 'cc'
|
||||
cc.xlc = 'xlc'
|
Loading…
Reference in a new issue