devel/py-awscli: Update to 1.27.9
- Update to 1.27.9 - Rename to comply with Python naming policy and flavorize - Assume MAINTAINER
This commit is contained in:
parent
a93de65b65
commit
3d8e46a27f
9 changed files with 22 additions and 32 deletions
1
MOVED
1
MOVED
|
@ -17609,3 +17609,4 @@ devel/py-types-termcolor||2022-11-11|No longer needed, type annotations are now
|
|||
x11-toolkits/wlroots-devel|x11-toolkits/wlroots|2022-11-11|Out of date: use x11-toolkits/wlroots for now
|
||||
multimedia/mpv034||2022-11-14|No longer needed
|
||||
devel/py-types-xxhash||2022-11-15|No longer needed, type annotations are now available in xxhash module
|
||||
devel/awscli|devel/py-awscli|2022-11-15|Renamed comply with Python Ports Policy and flavored
|
||||
|
|
|
@ -248,7 +248,6 @@
|
|||
SUBDIR += aws-crt-cpp
|
||||
SUBDIR += aws-sdk-cpp
|
||||
SUBDIR += aws-sdk-php
|
||||
SUBDIR += awscli
|
||||
SUBDIR += axmldec
|
||||
SUBDIR += ayatana-ido
|
||||
SUBDIR += b2
|
||||
|
@ -4194,6 +4193,7 @@
|
|||
SUBDIR += py-aws-requests-auth
|
||||
SUBDIR += py-aws-sam-translator
|
||||
SUBDIR += py-aws-xray-sdk
|
||||
SUBDIR += py-awscli
|
||||
SUBDIR += py-awscrt
|
||||
SUBDIR += py-azure-appconfiguration
|
||||
SUBDIR += py-azure-batch
|
||||
|
|
|
@ -1,3 +0,0 @@
|
|||
TIMESTAMP = 1634205488
|
||||
SHA256 (awscli-1.20.61.tar.gz) = 30f4cfd871af16c27659ea3c42bb4308f25769423e9171046fc0cf5804f8c842
|
||||
SIZE (awscli-1.20.61.tar.gz) = 1526330
|
|
@ -1,23 +0,0 @@
|
|||
--- awscli/help.py.orig 2019-08-27 18:05:04 UTC
|
||||
+++ awscli/help.py
|
||||
@@ -107,13 +107,16 @@ class PosixHelpRenderer(PagingHelpRenderer):
|
||||
|
||||
def _convert_doc_content(self, contents):
|
||||
man_contents = publish_string(contents, writer=manpage.Writer())
|
||||
- if not self._exists_on_path('groff'):
|
||||
+ if self._exists_on_path('groff'):
|
||||
+ cmdline = ['groff', '-m', 'man', '-T', 'ascii']
|
||||
+ elif self._exists_on_path('mandoc'):
|
||||
+ cmdline = ['mandoc', '-man', '-T', 'ascii']
|
||||
+ else:
|
||||
raise ExecutableNotFoundError('groff')
|
||||
- cmdline = ['groff', '-m', 'man', '-T', 'ascii']
|
||||
LOG.debug("Running command: %s", cmdline)
|
||||
p3 = self._popen(cmdline, stdin=PIPE, stdout=PIPE, stderr=PIPE)
|
||||
- groff_output = p3.communicate(input=man_contents)[0]
|
||||
- return groff_output
|
||||
+ man_output = p3.communicate(input=man_contents)[0]
|
||||
+ return man_output
|
||||
|
||||
def _send_output_to_pager(self, output):
|
||||
cmdline = self.get_pager_cmdline()
|
|
@ -1,9 +1,10 @@
|
|||
PORTNAME= awscli
|
||||
PORTVERSION= 1.20.61
|
||||
CATEGORIES= devel
|
||||
PORTVERSION= 1.27.9
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= otis@FreeBSD.org
|
||||
COMMENT= Universal Command Line Interface for Amazon Web Services
|
||||
WWW= https://aws.amazon.com/cli/
|
||||
|
||||
|
@ -12,13 +13,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
|||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.21.61:devel/py-botocore@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}colorama>=0.2.5:devel/py-colorama@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}s3transfer>=0.5.0:net/py-s3transfer@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}docutils>=0.10:textproc/py-docutils@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}rsa>=3.1.2:security/py-rsa@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}s3transfer>=0.5.0:net/py-s3transfer@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}yaml>=3.10:devel/py-yaml@${PY_FLAVOR}
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils concurrent noflavors
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
SUB_FILES= pkg-message
|
3
devel/py-awscli/distinfo
Normal file
3
devel/py-awscli/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1668536463
|
||||
SHA256 (awscli-1.27.9.tar.gz) = d8ba5b1121b2ce66cc6851335f8087e29a9e506969da62b56e2daba350a7b39e
|
||||
SIZE (awscli-1.27.9.tar.gz) = 1607886
|
11
devel/py-awscli/files/patch-awscli_help.py
Normal file
11
devel/py-awscli/files/patch-awscli_help.py
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- awscli/help.py.orig 2022-11-14 19:07:18 UTC
|
||||
+++ awscli/help.py
|
||||
@@ -109,7 +109,7 @@ class PosixHelpRenderer(PagingHelpRenderer):
|
||||
if self._exists_on_path('groff'):
|
||||
cmdline = ['groff', '-m', 'man', '-T', 'ascii']
|
||||
elif self._exists_on_path('mandoc'):
|
||||
- cmdline = ['mandoc', '-T', 'ascii']
|
||||
+ cmdline = ['mandoc', '-man', '-T', 'ascii']
|
||||
else:
|
||||
raise ExecutableNotFoundError('groff or mandoc')
|
||||
LOG.debug("Running command: %s", cmdline)
|
Loading…
Reference in a new issue