[1]:
- Update to 0.95.3 - Pass maintainership to submitter Moreover: - Respect ${CC} - Respect ${LOCALBASE} - Do not let the port use its own optimization cflags - Polish the Makefile [1]: PR: ports/82860 Submitted by: Jonas Sonntag <jonas@schiebtsich.net> (new maintainer) Approved by: former maintainer
This commit is contained in:
parent
55ae0aaee3
commit
3d949c29fa
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138325
8 changed files with 24 additions and 186 deletions
|
@ -8,7 +8,7 @@
|
|||
#
|
||||
# A quick note on configurable make symbols:
|
||||
#
|
||||
# INTERACTIVE_CONFIGURE: Launches Configure in it's default mode,
|
||||
# INTERACTIVE_CONFIGURE: Launches Configure in its default mode,
|
||||
# which is *very* interactive. Disabled here by default to conform to
|
||||
# FreeBSD guidelines, this mode is useful if you have problems with the
|
||||
# default Configure.
|
||||
|
@ -22,20 +22,16 @@
|
|||
# WITH_DEBUG: Compile with debugging symbols. Useful if you intend to make
|
||||
# a bug report.
|
||||
#
|
||||
# WITHOUT_ICU: Don't compile with unicode support via the ICU library.
|
||||
# Note that ICU versions previous to 2.6 may not work correctly.
|
||||
#
|
||||
|
||||
PORTNAME= gtk-gnutella
|
||||
PORTVERSION= 0.95
|
||||
PORTVERSION= 0.95.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://gtk-gnutella.sourceforge.net/download/ \
|
||||
ftp://gtk-gnutella.sourceforge.net/pub/gtk-gnutella/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= crollins666@hotmail.com
|
||||
MAINTAINER= jonas@schiebtsich.net
|
||||
COMMENT= GTK based Gnutella client
|
||||
|
||||
USE_PERL5= yes
|
||||
|
@ -43,18 +39,19 @@ USE_X_PREFIX= yes
|
|||
USE_BZIP2= yes
|
||||
USE_BISON= yes
|
||||
USE_GNOME= libxml2
|
||||
INSTALL_TARGET= install install.man
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= Configure
|
||||
CONFIGURE_ARGS= -Dyacc='bison -y' -Dofficial='true' -Dprefix=${PREFIX}
|
||||
CONFIGURE_ARGS+= -Dbindir=${PREFIX}/bin -Dprivlib=${PREFIX}/share/gtk-gnutella
|
||||
CONFIGURE_ARGS+= -Dsysman=${PREFIX}/man/man1 -Dlocale=${PREFIX}/share/locale
|
||||
CONFIGURE_ARGS+= -Dccflags='${CFLAGS} -I${LOCALBASE}/include/'
|
||||
CONFIGURE_ARGS= -Dyacc='bison -y' -Dofficial='true' -Dprefix=${PREFIX} \
|
||||
-Dprivlib=${PREFIX}/share/gtk-gnutella \
|
||||
-Dsysman=${PREFIX}/man/man1 -Dlocale=${PREFIX}/share/locale \
|
||||
-Dcc='${CC}' -Dccflags='${CFLAGS} -I${LOCALBASE}/include' \
|
||||
-Doptimize='undef' -Dlibpth='/usr/lib ${LOCALBASE}/lib'
|
||||
|
||||
MAN1= gtk-gnutella.1
|
||||
|
||||
OPTIONS= DEBUG "Build with debugging symbols" off \
|
||||
GTK2 "Build with gtk2 frontend" off \
|
||||
ICU "Enable non-roman charset support" on \
|
||||
GTK2 "Build with gtk2 frontend" on \
|
||||
PORTABILITY "Use the PATH variable at run-time" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -75,22 +72,8 @@ CONFIGURE_ARGS+= -Dgtkversion=1
|
|||
USE_GNOME+= gtk12
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_ICU)
|
||||
LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu2
|
||||
|
||||
# Add threading to the ld flags; icuuc requires these by default
|
||||
CONFIGURE_ARGS+= -Dldflags=${PTHREAD_LIBS}
|
||||
.else
|
||||
CONFIGURE_ARGS+= -Dd_icu=false
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PORTABILITY)
|
||||
CONFIGURE_ARGS+= -Dd_portable=true
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${ECHO} 'Installing compressed man page in man/man1/'
|
||||
@${CP} ${WRKSRC}/src/gtk-gnutella.man ${WRKSRC}/src/gtk-gnutella.1
|
||||
@${INSTALL_MAN} ${WRKSRC}/src/gtk-gnutella.1 ${PREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gtk-gnutella-0.95.tar.bz2) = de2ff4973c975ee16cdd69ca72c06bcd
|
||||
SIZE (gtk-gnutella-0.95.tar.bz2) = 2191028
|
||||
MD5 (gtk-gnutella-0.95.3.tar.bz2) = bde94b95622f895294bffac8cecbe67a
|
||||
SIZE (gtk-gnutella-0.95.3.tar.bz2) = 2306819
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
diff -ur gtk-gnutella-0.95-old/src/ui/gtk/gtk2/pbarcellrenderer.c gtk-gnutella-0.95/src/ui/gtk/gtk2/pbarcellrenderer.c
|
||||
--- src/ui/gtk/gtk2/pbarcellrenderer.c 2005-01-25 01:24:15.291080696 -0500
|
||||
+++ src/ui/gtk/gtk2/pbarcellrenderer.c 2005-01-25 01:37:07.614669664 -0500
|
||||
@@ -51,6 +51,9 @@
|
||||
* Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
+/* If we're using GTK 2.6, this is obsolete - Tim Hentenaar */
|
||||
+#if GTK_MAJOR_VERSION == 2 && GTK_MINOR_VERSION < 6
|
||||
+
|
||||
#include "gtk/gui.h"
|
||||
|
||||
RCSID("$Id: 0.95-gtk2.6.patch,v 1.1 2005/01/30 20:46:05 squinky86 Exp $");
|
||||
@@ -426,5 +429,5 @@
|
||||
G_FREE_NULL(cellprogress->priv);
|
||||
(*G_OBJECT_CLASS(parent_class)->finalize)(object);
|
||||
}
|
||||
-
|
||||
+#endif /* GTK < 2.6 */
|
||||
/* vi: set ts=4: */
|
||||
diff -ur gtk-gnutella-0.95-old/src/ui/gtk/gtk2/pbarcellrenderer.h gtk-gnutella-0.95/src/ui/gtk/gtk2/pbarcellrenderer.h
|
||||
--- src/ui/gtk/gtk2/pbarcellrenderer.h 2005-01-25 01:24:15.291080696 -0500
|
||||
+++ src/ui/gtk/gtk2/pbarcellrenderer.h 2005-01-25 01:35:55.844580376 -0500
|
||||
@@ -49,6 +49,9 @@
|
||||
#ifndef _gtk2_pbarcellrenderer_h_
|
||||
#define _gtk2_pbarcellrenderer_h_
|
||||
|
||||
+/* If we're using GTK 2.6, this is obsolete - Tim Hentenaar */
|
||||
+#if GTK_MAJOR_VERSION == 2 && GTK_MINOR_VERSION < 6
|
||||
+
|
||||
#include <gtk/gtkcellrenderer.h>
|
||||
#include "gtk/gui.h"
|
||||
|
||||
@@ -76,5 +79,5 @@
|
||||
GtkCellRenderer* gtk_cell_renderer_progress_new(void);
|
||||
|
||||
G_END_DECLS
|
||||
-
|
||||
+#endif /* GTK < 2.6 */
|
||||
#endif /* _gtk2_pbarcellrenderer_h_ */
|
|
@ -1,24 +0,0 @@
|
|||
--- Configure.orig Wed Jun 9 01:49:22 2004
|
||||
+++ Configure Sat Jun 12 16:48:17 2004
|
||||
@@ -3874,8 +3874,8 @@
|
||||
$rm -f t.c
|
||||
|
||||
: see if ucnv_open_2_6 exists
|
||||
-set ucnv_open_2_6 d_ucnv_open_2_6
|
||||
-eval $inlibc
|
||||
+: set ucnv_open_2_6 d_ucnv_open_2_6
|
||||
+: eval $inlibc
|
||||
|
||||
: check whether we have a working ICU library
|
||||
echo " "
|
||||
@@ -3883,8 +3883,8 @@
|
||||
case " $libs " in
|
||||
*" -licuuc "*)
|
||||
has_icu=y
|
||||
- case "$i_uni_putil$d_ucnv_open_2_6" in
|
||||
- "$define$define")
|
||||
+ case "$i_uni_putil" in
|
||||
+ "$define")
|
||||
echo "Your ICU library is workable." >&4
|
||||
val="$define"
|
||||
;;
|
|
@ -8,7 +8,7 @@
|
|||
#
|
||||
# A quick note on configurable make symbols:
|
||||
#
|
||||
# INTERACTIVE_CONFIGURE: Launches Configure in it's default mode,
|
||||
# INTERACTIVE_CONFIGURE: Launches Configure in its default mode,
|
||||
# which is *very* interactive. Disabled here by default to conform to
|
||||
# FreeBSD guidelines, this mode is useful if you have problems with the
|
||||
# default Configure.
|
||||
|
@ -22,20 +22,16 @@
|
|||
# WITH_DEBUG: Compile with debugging symbols. Useful if you intend to make
|
||||
# a bug report.
|
||||
#
|
||||
# WITHOUT_ICU: Don't compile with unicode support via the ICU library.
|
||||
# Note that ICU versions previous to 2.6 may not work correctly.
|
||||
#
|
||||
|
||||
PORTNAME= gtk-gnutella
|
||||
PORTVERSION= 0.95
|
||||
PORTVERSION= 0.95.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
http://gtk-gnutella.sourceforge.net/download/ \
|
||||
ftp://gtk-gnutella.sourceforge.net/pub/gtk-gnutella/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= crollins666@hotmail.com
|
||||
MAINTAINER= jonas@schiebtsich.net
|
||||
COMMENT= GTK based Gnutella client
|
||||
|
||||
USE_PERL5= yes
|
||||
|
@ -43,18 +39,19 @@ USE_X_PREFIX= yes
|
|||
USE_BZIP2= yes
|
||||
USE_BISON= yes
|
||||
USE_GNOME= libxml2
|
||||
INSTALL_TARGET= install install.man
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_SCRIPT= Configure
|
||||
CONFIGURE_ARGS= -Dyacc='bison -y' -Dofficial='true' -Dprefix=${PREFIX}
|
||||
CONFIGURE_ARGS+= -Dbindir=${PREFIX}/bin -Dprivlib=${PREFIX}/share/gtk-gnutella
|
||||
CONFIGURE_ARGS+= -Dsysman=${PREFIX}/man/man1 -Dlocale=${PREFIX}/share/locale
|
||||
CONFIGURE_ARGS+= -Dccflags='${CFLAGS} -I${LOCALBASE}/include/'
|
||||
CONFIGURE_ARGS= -Dyacc='bison -y' -Dofficial='true' -Dprefix=${PREFIX} \
|
||||
-Dprivlib=${PREFIX}/share/gtk-gnutella \
|
||||
-Dsysman=${PREFIX}/man/man1 -Dlocale=${PREFIX}/share/locale \
|
||||
-Dcc='${CC}' -Dccflags='${CFLAGS} -I${LOCALBASE}/include' \
|
||||
-Doptimize='undef' -Dlibpth='/usr/lib ${LOCALBASE}/lib'
|
||||
|
||||
MAN1= gtk-gnutella.1
|
||||
|
||||
OPTIONS= DEBUG "Build with debugging symbols" off \
|
||||
GTK2 "Build with gtk2 frontend" off \
|
||||
ICU "Enable non-roman charset support" on \
|
||||
GTK2 "Build with gtk2 frontend" on \
|
||||
PORTABILITY "Use the PATH variable at run-time" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -75,22 +72,8 @@ CONFIGURE_ARGS+= -Dgtkversion=1
|
|||
USE_GNOME+= gtk12
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_ICU)
|
||||
LIB_DEPENDS+= icuuc:${PORTSDIR}/devel/icu2
|
||||
|
||||
# Add threading to the ld flags; icuuc requires these by default
|
||||
CONFIGURE_ARGS+= -Dldflags=${PTHREAD_LIBS}
|
||||
.else
|
||||
CONFIGURE_ARGS+= -Dd_icu=false
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PORTABILITY)
|
||||
CONFIGURE_ARGS+= -Dd_portable=true
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${ECHO} 'Installing compressed man page in man/man1/'
|
||||
@${CP} ${WRKSRC}/src/gtk-gnutella.man ${WRKSRC}/src/gtk-gnutella.1
|
||||
@${INSTALL_MAN} ${WRKSRC}/src/gtk-gnutella.1 ${PREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (gtk-gnutella-0.95.tar.bz2) = de2ff4973c975ee16cdd69ca72c06bcd
|
||||
SIZE (gtk-gnutella-0.95.tar.bz2) = 2191028
|
||||
MD5 (gtk-gnutella-0.95.3.tar.bz2) = bde94b95622f895294bffac8cecbe67a
|
||||
SIZE (gtk-gnutella-0.95.3.tar.bz2) = 2306819
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
diff -ur gtk-gnutella-0.95-old/src/ui/gtk/gtk2/pbarcellrenderer.c gtk-gnutella-0.95/src/ui/gtk/gtk2/pbarcellrenderer.c
|
||||
--- src/ui/gtk/gtk2/pbarcellrenderer.c 2005-01-25 01:24:15.291080696 -0500
|
||||
+++ src/ui/gtk/gtk2/pbarcellrenderer.c 2005-01-25 01:37:07.614669664 -0500
|
||||
@@ -51,6 +51,9 @@
|
||||
* Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
+/* If we're using GTK 2.6, this is obsolete - Tim Hentenaar */
|
||||
+#if GTK_MAJOR_VERSION == 2 && GTK_MINOR_VERSION < 6
|
||||
+
|
||||
#include "gtk/gui.h"
|
||||
|
||||
RCSID("$Id: 0.95-gtk2.6.patch,v 1.1 2005/01/30 20:46:05 squinky86 Exp $");
|
||||
@@ -426,5 +429,5 @@
|
||||
G_FREE_NULL(cellprogress->priv);
|
||||
(*G_OBJECT_CLASS(parent_class)->finalize)(object);
|
||||
}
|
||||
-
|
||||
+#endif /* GTK < 2.6 */
|
||||
/* vi: set ts=4: */
|
||||
diff -ur gtk-gnutella-0.95-old/src/ui/gtk/gtk2/pbarcellrenderer.h gtk-gnutella-0.95/src/ui/gtk/gtk2/pbarcellrenderer.h
|
||||
--- src/ui/gtk/gtk2/pbarcellrenderer.h 2005-01-25 01:24:15.291080696 -0500
|
||||
+++ src/ui/gtk/gtk2/pbarcellrenderer.h 2005-01-25 01:35:55.844580376 -0500
|
||||
@@ -49,6 +49,9 @@
|
||||
#ifndef _gtk2_pbarcellrenderer_h_
|
||||
#define _gtk2_pbarcellrenderer_h_
|
||||
|
||||
+/* If we're using GTK 2.6, this is obsolete - Tim Hentenaar */
|
||||
+#if GTK_MAJOR_VERSION == 2 && GTK_MINOR_VERSION < 6
|
||||
+
|
||||
#include <gtk/gtkcellrenderer.h>
|
||||
#include "gtk/gui.h"
|
||||
|
||||
@@ -76,5 +79,5 @@
|
||||
GtkCellRenderer* gtk_cell_renderer_progress_new(void);
|
||||
|
||||
G_END_DECLS
|
||||
-
|
||||
+#endif /* GTK < 2.6 */
|
||||
#endif /* _gtk2_pbarcellrenderer_h_ */
|
|
@ -1,24 +0,0 @@
|
|||
--- Configure.orig Wed Jun 9 01:49:22 2004
|
||||
+++ Configure Sat Jun 12 16:48:17 2004
|
||||
@@ -3874,8 +3874,8 @@
|
||||
$rm -f t.c
|
||||
|
||||
: see if ucnv_open_2_6 exists
|
||||
-set ucnv_open_2_6 d_ucnv_open_2_6
|
||||
-eval $inlibc
|
||||
+: set ucnv_open_2_6 d_ucnv_open_2_6
|
||||
+: eval $inlibc
|
||||
|
||||
: check whether we have a working ICU library
|
||||
echo " "
|
||||
@@ -3883,8 +3883,8 @@
|
||||
case " $libs " in
|
||||
*" -licuuc "*)
|
||||
has_icu=y
|
||||
- case "$i_uni_putil$d_ucnv_open_2_6" in
|
||||
- "$define$define")
|
||||
+ case "$i_uni_putil" in
|
||||
+ "$define")
|
||||
echo "Your ICU library is workable." >&4
|
||||
val="$define"
|
||||
;;
|
Loading…
Reference in a new issue