- Fix build with gcc4
PR: 113769 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
parent
2e9f7aa3c2
commit
3db3e6026f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=193864
4 changed files with 73 additions and 114 deletions
|
@ -15,29 +15,26 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
|
|||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= An OpenGL based space-ship "shoot-em-up" game
|
||||
|
||||
LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut \
|
||||
png.5:${PORTSDIR}/graphics/png
|
||||
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
USE_GNOME= gnometarget
|
||||
USE_SDL= sdl mixer
|
||||
USE_GL= glut
|
||||
USE_GMAKE= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GL= yes
|
||||
USE_SDL= sdl mixer
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
|
||||
MAN6= glaxium.6
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Broken with gcc 4.2
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -i '' -e 's|/usr/X11R6|${X11BASE}|g; \
|
||||
s|\$datadir/games/glaxium|\$datadir/glaxium|g' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -i '' -e 's|%%X11BASE%%|${X11BASE}|g' \
|
||||
${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g; \
|
||||
s|/games/glaxium|/glaxium|g' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|gcc -g -o|$$(CC) -o|g ; \
|
||||
s|/games/glaxium|/glaxium|g' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|Scratcher:: Scratcher|Scratcher|g' \
|
||||
${WRKSRC}/scratcher.hpp
|
||||
@${REINPLACE_CMD} -e 's|TankFire::TankFire|TankFire|g' \
|
||||
${WRKSRC}/tank.hpp
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
--- Makefile.in.orig
|
||||
+++ Makefile.in
|
||||
@@ -15,11 +15,11 @@
|
||||
|
||||
GLAXIUM_INSTALLDIR=$(bindir)
|
||||
DATA_DIRS=samples textures
|
||||
-GLAXIUM_HOME=$(datadir)/games/glaxium
|
||||
+GLAXIUM_HOME=$(datadir)/glaxium
|
||||
MAN_DIR=$(mandir)
|
||||
|
||||
glaxium : $(OBJ)
|
||||
- gcc -g -o glaxium $(OBJ) $(LIB)
|
||||
+ $(CC) -g -o glaxium $(OBJ) $(LIB)
|
||||
|
||||
|
||||
|
|
@ -1,22 +0,0 @@
|
|||
--- configure.in.orig
|
||||
+++ configure.in
|
||||
@@ -10,8 +10,8 @@
|
||||
dnl Check for SDL
|
||||
AM_PATH_SDL(1.1.5, , AC_MSG_ERROR([*** SDL version $SDL_VERSION not found!]))
|
||||
|
||||
-LIBS="$LIBS -L/usr/X11R6/lib $SDL_LIBS"
|
||||
-CPPFLAGS="$CPPFLAGS -I/usr/X11R6/include $SDL_CFLAGS"
|
||||
+LIBS="$LIBS -L%%X11BASE%%/lib $SDL_LIBS"
|
||||
+CPPFLAGS="$CPPFLAGS -I%%X11BASE%%/include $SDL_CFLAGS"
|
||||
|
||||
AC_CHECK_HEADER(SDL.h, , echo "No SDL.h header... cannot do anything !";exit 12 )
|
||||
|
||||
@@ -41,7 +41,7 @@
|
||||
AC_EGREP_HEADER(PFNGLBINDPROGRAMNVPROC, GL/glext.h, ,echo "Glaxium won't compile: get a newer version of your openGL header GL/glext.h at <http://oss.sgi.com/projects/ogl-sample/registry/>";exit 12)
|
||||
|
||||
dnl Expand DATADIR
|
||||
-FC_EXPAND_DIR(DATADIR, "$datadir/games/glaxium")
|
||||
+FC_EXPAND_DIR(DATADIR, "$datadir/glaxium")
|
||||
AC_DEFINE_UNQUOTED(DATADIR, "$DATADIR")
|
||||
|
||||
AC_OUTPUT(Makefile)
|
|
@ -1,61 +1,61 @@
|
|||
bin/glaxium
|
||||
share/glaxium/samples/detection.wav
|
||||
share/glaxium/samples/explode1.wav
|
||||
share/glaxium/samples/explode2.wav
|
||||
share/glaxium/samples/gameover.wav
|
||||
share/glaxium/samples/glax.xm
|
||||
share/glaxium/samples/glax3.xm
|
||||
share/glaxium/samples/glups.wav
|
||||
share/glaxium/samples/powerup.wav
|
||||
share/glaxium/samples/tachefire.wav
|
||||
share/glaxium/samples/tir.wav
|
||||
share/glaxium/samples/welcome.wav
|
||||
share/glaxium/textures/bandit1.png
|
||||
share/glaxium/textures/bandit2.png
|
||||
share/glaxium/textures/board.png
|
||||
share/glaxium/textures/bord.png
|
||||
share/glaxium/textures/border.png
|
||||
share/glaxium/textures/border2.png
|
||||
share/glaxium/textures/camouflage.png
|
||||
share/glaxium/textures/capsule_bomb.png
|
||||
share/glaxium/textures/capsule_invul.png
|
||||
share/glaxium/textures/capsule_power.png
|
||||
share/glaxium/textures/capsule_shield.png
|
||||
share/glaxium/textures/chain.png
|
||||
share/glaxium/textures/chars.png
|
||||
share/glaxium/textures/cube.png
|
||||
share/glaxium/textures/deadtache.png
|
||||
share/glaxium/textures/effect1.png
|
||||
share/glaxium/textures/fighter2.png
|
||||
share/glaxium/textures/floor.png
|
||||
share/glaxium/textures/floor1.png
|
||||
share/glaxium/textures/floor2.png
|
||||
share/glaxium/textures/floor3.png
|
||||
share/glaxium/textures/floor4.png
|
||||
share/glaxium/textures/floormap.png
|
||||
share/glaxium/textures/floormap1.png
|
||||
share/glaxium/textures/floormap2.png
|
||||
share/glaxium/textures/floormap3.png
|
||||
share/glaxium/textures/floormap4.png
|
||||
share/glaxium/textures/fumee1.png
|
||||
share/glaxium/textures/fumee2.png
|
||||
share/glaxium/textures/fumee3.png
|
||||
share/glaxium/textures/galaxy.png
|
||||
share/glaxium/textures/gameover.png
|
||||
share/glaxium/textures/glax2.png
|
||||
share/glaxium/textures/iflicla.png
|
||||
share/glaxium/textures/mark.png
|
||||
share/glaxium/textures/missile.png
|
||||
share/glaxium/textures/myship.png
|
||||
share/glaxium/textures/piege.png
|
||||
share/glaxium/textures/ship1.png
|
||||
share/glaxium/textures/space0.png
|
||||
share/glaxium/textures/space1.png
|
||||
share/glaxium/textures/space2.png
|
||||
share/glaxium/textures/space3.png
|
||||
share/glaxium/textures/sphere.png
|
||||
share/glaxium/textures/tache.png
|
||||
share/glaxium/textures/thunder.png
|
||||
@dirrm share/glaxium/textures
|
||||
@dirrm share/glaxium/samples
|
||||
@dirrm share/glaxium
|
||||
%%DATADIR%%/samples/detection.wav
|
||||
%%DATADIR%%/samples/explode1.wav
|
||||
%%DATADIR%%/samples/explode2.wav
|
||||
%%DATADIR%%/samples/gameover.wav
|
||||
%%DATADIR%%/samples/glax.xm
|
||||
%%DATADIR%%/samples/glax3.xm
|
||||
%%DATADIR%%/samples/glups.wav
|
||||
%%DATADIR%%/samples/powerup.wav
|
||||
%%DATADIR%%/samples/tachefire.wav
|
||||
%%DATADIR%%/samples/tir.wav
|
||||
%%DATADIR%%/samples/welcome.wav
|
||||
%%DATADIR%%/textures/bandit1.png
|
||||
%%DATADIR%%/textures/bandit2.png
|
||||
%%DATADIR%%/textures/board.png
|
||||
%%DATADIR%%/textures/bord.png
|
||||
%%DATADIR%%/textures/border.png
|
||||
%%DATADIR%%/textures/border2.png
|
||||
%%DATADIR%%/textures/camouflage.png
|
||||
%%DATADIR%%/textures/capsule_bomb.png
|
||||
%%DATADIR%%/textures/capsule_invul.png
|
||||
%%DATADIR%%/textures/capsule_power.png
|
||||
%%DATADIR%%/textures/capsule_shield.png
|
||||
%%DATADIR%%/textures/chain.png
|
||||
%%DATADIR%%/textures/chars.png
|
||||
%%DATADIR%%/textures/cube.png
|
||||
%%DATADIR%%/textures/deadtache.png
|
||||
%%DATADIR%%/textures/effect1.png
|
||||
%%DATADIR%%/textures/fighter2.png
|
||||
%%DATADIR%%/textures/floor.png
|
||||
%%DATADIR%%/textures/floor1.png
|
||||
%%DATADIR%%/textures/floor2.png
|
||||
%%DATADIR%%/textures/floor3.png
|
||||
%%DATADIR%%/textures/floor4.png
|
||||
%%DATADIR%%/textures/floormap.png
|
||||
%%DATADIR%%/textures/floormap1.png
|
||||
%%DATADIR%%/textures/floormap2.png
|
||||
%%DATADIR%%/textures/floormap3.png
|
||||
%%DATADIR%%/textures/floormap4.png
|
||||
%%DATADIR%%/textures/fumee1.png
|
||||
%%DATADIR%%/textures/fumee2.png
|
||||
%%DATADIR%%/textures/fumee3.png
|
||||
%%DATADIR%%/textures/galaxy.png
|
||||
%%DATADIR%%/textures/gameover.png
|
||||
%%DATADIR%%/textures/glax2.png
|
||||
%%DATADIR%%/textures/iflicla.png
|
||||
%%DATADIR%%/textures/mark.png
|
||||
%%DATADIR%%/textures/missile.png
|
||||
%%DATADIR%%/textures/myship.png
|
||||
%%DATADIR%%/textures/piege.png
|
||||
%%DATADIR%%/textures/ship1.png
|
||||
%%DATADIR%%/textures/space0.png
|
||||
%%DATADIR%%/textures/space1.png
|
||||
%%DATADIR%%/textures/space2.png
|
||||
%%DATADIR%%/textures/space3.png
|
||||
%%DATADIR%%/textures/sphere.png
|
||||
%%DATADIR%%/textures/tache.png
|
||||
%%DATADIR%%/textures/thunder.png
|
||||
@dirrm %%DATADIR%%/textures
|
||||
@dirrm %%DATADIR%%/samples
|
||||
@dirrm %%DATADIR%%
|
||||
|
|
Loading…
Reference in a new issue