Fix build on Alpha.

This commit is contained in:
Steve Price 1999-05-31 04:58:10 +00:00
parent a53d0ce8e7
commit 3dbe12fad1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19136
4 changed files with 30 additions and 10 deletions

View file

@ -1,10 +1,11 @@
--- configure.orig Mon Oct 5 17:26:04 1998
+++ configure Sat Oct 24 00:42:30 1998
@@ -1415,6 +1415,7 @@
--- configure.orig Mon Oct 5 04:26:04 1998
+++ configure Sun May 30 19:01:51 1999
@@ -1415,6 +1415,8 @@
case "$host" in
mips-sgi-irix5.* | mips-sgi-irix6.*) TARGET=MIPS; TARGETDIR=mips;;
i*86-pc-linux*) TARGET=X86; TARGETDIR=x86;;
+i*86-unknown-freebsd*) TARGET=X86; TARGETDIR=x86;;
+alpha-unknown-freebsd*) TARGET=ALPHA; TARGETDIR=alpha;;
sparc-sun-4*) TARGET=SPARC; TARGETDIR=sparc;;
sparc-sun-*) TARGET=SPARC; TARGETDIR=sparc;;
alpha*-*-linux* | alpha*-*-osf*) TARGET=ALPHA; TARGETDIR=alpha;;

View file

@ -1,5 +1,5 @@
--- src/Makefile.in.orig Tue Feb 2 21:19:24 1999
+++ src/Makefile.in Tue Feb 2 21:19:34 1999
--- src/Makefile.in.orig Mon Oct 5 04:26:33 1998
+++ src/Makefile.in Sun May 30 21:48:55 1999
@@ -164,7 +164,7 @@
SOURCES = $(libffi_la_SOURCES) $(ffitest_SOURCES)
OBJECTS = $(libffi_la_OBJECTS) $(ffitest_OBJECTS)
@ -9,3 +9,12 @@
.SUFFIXES:
.SUFFIXES: .S .c .lo .o .s
@@ -296,7 +296,7 @@
done
debug.o debug.lo: debug.c ../include/ffi.h ../fficonfig.h \
../include/ffi_common.h
-ffi.o ffi.lo: x86/ffi.c ../include/ffi.h ../fficonfig.h \
+ffi.o ffi.lo: @TARGETDIR@/ffi.c ../include/ffi.h ../fficonfig.h \
../include/ffi_common.h
ffitest.o ffitest.lo: ffitest.c ../include/ffi.h ../fficonfig.h
prep_cif.o prep_cif.lo: prep_cif.c ../include/ffi.h ../fficonfig.h \

View file

@ -1,10 +1,11 @@
--- configure.orig Mon Oct 5 17:26:04 1998
+++ configure Sat Oct 24 00:42:30 1998
@@ -1415,6 +1415,7 @@
--- configure.orig Mon Oct 5 04:26:04 1998
+++ configure Sun May 30 19:01:51 1999
@@ -1415,6 +1415,8 @@
case "$host" in
mips-sgi-irix5.* | mips-sgi-irix6.*) TARGET=MIPS; TARGETDIR=mips;;
i*86-pc-linux*) TARGET=X86; TARGETDIR=x86;;
+i*86-unknown-freebsd*) TARGET=X86; TARGETDIR=x86;;
+alpha-unknown-freebsd*) TARGET=ALPHA; TARGETDIR=alpha;;
sparc-sun-4*) TARGET=SPARC; TARGETDIR=sparc;;
sparc-sun-*) TARGET=SPARC; TARGETDIR=sparc;;
alpha*-*-linux* | alpha*-*-osf*) TARGET=ALPHA; TARGETDIR=alpha;;

View file

@ -1,5 +1,5 @@
--- src/Makefile.in.orig Tue Feb 2 21:19:24 1999
+++ src/Makefile.in Tue Feb 2 21:19:34 1999
--- src/Makefile.in.orig Mon Oct 5 04:26:33 1998
+++ src/Makefile.in Sun May 30 21:48:55 1999
@@ -164,7 +164,7 @@
SOURCES = $(libffi_la_SOURCES) $(ffitest_SOURCES)
OBJECTS = $(libffi_la_OBJECTS) $(ffitest_OBJECTS)
@ -9,3 +9,12 @@
.SUFFIXES:
.SUFFIXES: .S .c .lo .o .s
@@ -296,7 +296,7 @@
done
debug.o debug.lo: debug.c ../include/ffi.h ../fficonfig.h \
../include/ffi_common.h
-ffi.o ffi.lo: x86/ffi.c ../include/ffi.h ../fficonfig.h \
+ffi.o ffi.lo: @TARGETDIR@/ffi.c ../include/ffi.h ../fficonfig.h \
../include/ffi_common.h
ffitest.o ffitest.lo: ffitest.c ../include/ffi.h ../fficonfig.h
prep_cif.o prep_cif.lo: prep_cif.c ../include/ffi.h ../fficonfig.h \