Upgrade to 0.129.0 which is required for gitlab-ce 11.5.

Approved by:	mentors (implicit)
This commit is contained in:
Matthias Fechner 2018-11-23 15:01:58 +00:00
parent a89bf01ebf
commit 3dc94ad8c6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=485670
6 changed files with 66 additions and 51 deletions

View file

@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= gitaly
DISTVERSION= 0.125.1
PORTREVISION= 1
DISTVERSION= 0.129.0
PORTREVISION= 0
CATEGORIES= devel
MAINTAINER= mfechner@FreeBSD.org
@ -14,20 +14,20 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# define dependencies that are required for build and run under MY_DEPENDS
MY_DEPENDS= git>=2.17:devel/git \
rubygem-i18n>=0:devel/rubygem-i18n \
rubygem-bundler>=1.16.5:sysutils/rubygem-bundler \
rubygem-rugged>=0.27.4:devel/rubygem-rugged \
rubygem-github-linguist53>=5.3.3:textproc/rubygem-github-linguist53 \
rubygem-bundler>0:sysutils/rubygem-bundler \
rubygem-github-linguist>=6.1:textproc/rubygem-github-linguist \
rubygem-gitlab-markup>=1.6.4:textproc/rubygem-gitlab-markup \
rubygem-gitaly-proto>=0.107.0:net/rubygem-gitaly-proto \
rubygem-gitaly-proto>=0.123.0:net/rubygem-gitaly-proto \
rubygem-activesupport50>=5.0.2:devel/rubygem-activesupport50 \
rubygem-rdoc>=6.0:devel/rubygem-rdoc \
rubygem-gitlab-gollum-lib>=4.2:www/rubygem-gitlab-gollum-lib \
rubygem-gitlab-gollum-rugged_adapter>=0.4.4:www/rubygem-gitlab-gollum-rugged_adapter \
rubygem-grpc>=1.11.0:net/rubygem-grpc \
rubygem-grpc>=1.15.0:net/rubygem-grpc \
rubygem-sentry-raven>=2.7.2:devel/rubygem-sentry-raven \
rubygem-faraday>=0.12:www/rubygem-faraday \
rubygem-licensee8>=8.9.0:devel/rubygem-licensee8 \
rubygem-google-protobuf351>=3.5.1:devel/rubygem-google-protobuf351
rubygem-google-protobuf>=3.6:devel/rubygem-google-protobuf
BUILD_DEPENDS= go>=1.9:lang/go \
gem:devel/ruby-gems \
@ -42,7 +42,7 @@ USE_RUBY= yes
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitaly/tags
GL_COMMIT= 076f3b0710ac07af5530ff20618e3fc27a5aead7
GL_COMMIT= 1a4581d04d67d2821e5df6866af8ba6bbef40960
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config.toml.example
@ -57,8 +57,4 @@ do-install:
cd ${WRKSRC} && ${COPYTREE_SHARE} config.toml.sample ${STAGEDIR}${DATADIR}) && \
cd ${WRKSRC}/ruby && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/ruby
post-install:
${STRIP_CMD} ${STAGEDIR}${DATADIR}/bin/gitaly
${STRIP_CMD} ${STAGEDIR}${DATADIR}/bin/gitaly-ssh
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1540328037
SHA256 (gitlab-org-gitaly-076f3b0710ac07af5530ff20618e3fc27a5aead7_GL0.tar.gz) = 7d4f62b68b5e8b587024a3db5833285068bb25d77b3f40c440bbeb3a9d9418f0
SIZE (gitlab-org-gitaly-076f3b0710ac07af5530ff20618e3fc27a5aead7_GL0.tar.gz) = 3603356
TIMESTAMP = 1542968937
SHA256 (gitlab-org-gitaly-1a4581d04d67d2821e5df6866af8ba6bbef40960_GL0.tar.gz) = e07cd0e36368f2ae8dfdb77a523ce89ba132261429cfdb814fcca1d443eef6ad
SIZE (gitlab-org-gitaly-1a4581d04d67d2821e5df6866af8ba6bbef40960_GL0.tar.gz) = 4183911

View file

@ -1,20 +0,0 @@
--- Makefile.orig 2018-07-01 11:16:07 UTC
+++ Makefile
@@ -11,7 +11,7 @@ INSTALL_DEST_DIR := $(DESTDIR)$(PREFIX)/
COVERAGE_DIR := $(TARGET_DIR)/cover
ASSEMBLY_ROOT := $(TARGET_DIR)/assembly
export GITALY_TEST_RUBY_DIR := $(BUILD_DIR)/ruby
-BUNDLE_FLAGS ?= --deployment
+BUNDLE_FLAGS ?= --local
BUILDTIME = $(shell date -u +%Y%m%d.%H%M%S)
VERSION_PREFIXED = $(shell git describe)
@@ -57,7 +57,7 @@ build: .ruby-bundle $(TARGET_SETUP)
.ruby-bundle: ruby/Gemfile.lock ruby/Gemfile
cd ruby && bundle config # for debugging
- cd ruby && bundle install $(BUNDLE_FLAGS)
+ cd ruby && rm Gemfile.lock && bundle install $(BUNDLE_FLAGS)
cd ruby && bundle show gitaly-proto # sanity check
touch $@

View file

@ -0,0 +1,20 @@
--- _support/makegen.go.orig 2018-11-23 11:12:56 UTC
+++ _support/makegen.go
@@ -225,7 +225,7 @@ var templateText = `
# These variables may be overriden at runtime by top-level make
PREFIX ?= /usr/local
INSTALL_DEST_DIR := $(DESTDIR)$(PREFIX)/bin/
-BUNDLE_FLAGS ?= --deployment
+BUNDLE_FLAGS ?= --local
ASSEMBLY_ROOT ?= {{ .BuildDir }}/assembly
unexport GOROOT
@@ -245,7 +245,7 @@ build: ../.ruby-bundle
# _build. Hence the '../' in front.
../.ruby-bundle: {{ .SourceDir }}/ruby/Gemfile.lock {{ .SourceDir }}/ruby/Gemfile
cd {{ .SourceDir }}/ruby && bundle config # for debugging
- cd {{ .SourceDir }}/ruby && bundle install $(BUNDLE_FLAGS)
+ cd {{ .SourceDir }}/ruby && rm Gemfile.lock && bundle install $(BUNDLE_FLAGS)
cd {{ .SourceDir }}/ruby && bundle show gitaly-proto # sanity check
touch $@

View file

@ -1,32 +1,28 @@
--- ruby/Gemfile.orig 2018-09-07 08:03:54 UTC
--- ruby/Gemfile.orig 2018-11-23 10:31:05 UTC
+++ ruby/Gemfile
@@ -1,16 +1,17 @@
source 'https://rubygems.org'
gem 'rugged', '~> 0.27.4'
-gem 'github-linguist', '~> 6.1', require: 'linguist'
+gem 'github-linguist', '~> 5.3', require: 'linguist'
@@ -8,12 +8,13 @@ gem 'github-linguist', '~> 6.1', require
gem 'gitlab-markup', '~> 1.6.4'
-gem 'gitaly-proto', '~> 0.116.0', require: 'gitaly'
+gem 'gitaly-proto', '~> 0.118.1', require: 'gitaly'
gem 'gitaly-proto', '~> 0.123.0', require: 'gitaly'
gem 'activesupport', '~> 5.0.2'
-gem 'rdoc', '~> 4.2'
+gem 'rdoc', '~> 6.0'
gem 'gitlab-gollum-lib', '~> 4.2', require: false
gem 'gitlab-gollum-rugged_adapter', '~> 0.4.4', require: false
gem 'grpc', '~> 1.11.0'
gem 'grpc', '~> 1.15.0'
gem 'sentry-raven', '~> 2.7.2', require: false
gem 'faraday', '~> 0.12'
+gem 'i18n'
# Detects the open source license the repository includes
# This version needs to be in sync with GitLab CE/EE
@@ -18,8 +19,3 @@ gem 'licensee', '~> 8.9.0'
@@ -21,10 +22,3 @@ gem 'licensee', '~> 8.9.0'
gem 'google-protobuf', '~> 3.6'
# Locked until https://github.com/google/protobuf/issues/4210 is closed
gem 'google-protobuf', '= 3.5.1'
-
-group :development, :test do
- gem 'gitlab-styles', '~> 2.0.0', require: false
- gem 'rubocop', '~> 0.50', require: false
- gem 'rspec', require: false
- gem 'rspec-parameterized', require: false
- gem 'timecop', require: false
- gem 'factory_bot', require: false
-end

View file

@ -2,6 +2,8 @@
%%DATADIR%%/ruby/README.md
@(,,555) %%DATADIR%%/ruby/bin/gitaly-ruby
@(,,555) %%DATADIR%%/ruby/bin/ruby-cd
%%DATADIR%%/ruby/.rubocop.yml
%%DATADIR%%/ruby/.rubocop_todo.yml
%%DATADIR%%/ruby/lib/gitaly_server.rb
%%DATADIR%%/ruby/lib/gitaly_server/blob_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/client.rb
@ -14,6 +16,7 @@
%%DATADIR%%/ruby/lib/gitaly_server/ref_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/remote_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/repository_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/rugged_interceptor.rb
%%DATADIR%%/ruby/lib/gitaly_server/sentry.rb
%%DATADIR%%/ruby/lib/gitaly_server/sentry_interceptor.rb
%%DATADIR%%/ruby/lib/gitaly_server/utils.rb
@ -24,6 +27,7 @@
%%DATADIR%%/ruby/lib/gitlab/git/blob.rb
%%DATADIR%%/ruby/lib/gitlab/git/branch.rb
%%DATADIR%%/ruby/lib/gitlab/git/commit.rb
%%DATADIR%%/ruby/lib/gitlab/git/commit_patches.rb
%%DATADIR%%/ruby/lib/gitlab/git/commit_stats.rb
%%DATADIR%%/ruby/lib/gitlab/git/committer_with_hooks.rb
%%DATADIR%%/ruby/lib/gitlab/git/conflict/file.rb
@ -47,6 +51,7 @@
%%DATADIR%%/ruby/lib/gitlab/git/repository.rb
%%DATADIR%%/ruby/lib/gitlab/git/repository_mirroring.rb
%%DATADIR%%/ruby/lib/gitlab/git/rev_list.rb
%%DATADIR%%/ruby/lib/gitlab/git/submodule.rb
%%DATADIR%%/ruby/lib/gitlab/git/tag.rb
%%DATADIR%%/ruby/lib/gitlab/git/user.rb
%%DATADIR%%/ruby/lib/gitlab/git/wiki.rb
@ -58,22 +63,40 @@
%%DATADIR%%/ruby/lib/gitlab/rails_logger.rb
%%DATADIR%%/ruby/lib/gitlab/utils/strong_memoize.rb
%%DATADIR%%/ruby/lib/gitlab/version_info.rb
%%DATADIR%%/ruby/spec/factories/gitaly/commit.rb
%%DATADIR%%/ruby/spec/factories/gitaly/commit_author.rb
%%DATADIR%%/ruby/spec/factories/sequences.rb
%%DATADIR%%/ruby/spec/gitaly/ref_service_spec.rb
%%DATADIR%%/ruby/spec/gitaly/repository_service_spec.rb
%%DATADIR%%/ruby/spec/integration_helper.rb
%%DATADIR%%/ruby/spec/lib/gitaly_server/exception_sanitizer_interceptor_spec.rb
%%DATADIR%%/ruby/spec/lib/gitaly_server/rugged_interceptor_spec.rb
%%DATADIR%%/ruby/spec/lib/gitaly_server/utils_spec.rb
%%DATADIR%%/ruby/spec/lib/gitaly_server/sentry/url_sanitizer_spec.rb
%%DATADIR%%/ruby/spec/lib/gitaly_server/sentry_interceptor_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/config_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/blob_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/branch_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/commit_patches_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/commit_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/diff_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/gitlab_projects_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/hook_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/index_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/lfs_changes_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/popen_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/raw_diff_change_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/remote_repository_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/repository_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/rev_list_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/submodule_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/user_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/wiki_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/version_info_spec.rb
%%DATADIR%%/ruby/spec/spec_helper.rb
%%DATADIR%%/ruby/spec/support/generate-seed-repo-rb
%%DATADIR%%/ruby/spec/support/helpers/gitlab_shell_helper.rb
%%DATADIR%%/ruby/spec/support/helpers/integration_helper.rb
%%DATADIR%%/ruby/spec/support/helpers/seed_repo.rb
%%DATADIR%%/ruby/spec/support/sentry.rb
%%DATADIR%%/ruby/spec/test_repo_helper.rb
@(,,555) %%DATADIR%%/bin/gitaly