- Update to 3.0.2
PR: 148566 Submitted by: Ports Fury
This commit is contained in:
parent
7b2d17f983
commit
3e2084c8c4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=257784
6 changed files with 73 additions and 190 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= miro
|
||||
PORTVERSION= 2.5.4
|
||||
PORTREVISION= 5
|
||||
PORTVERSION= 3.0.2
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= ftp://ftp.osuosl.org/pub/pculture.org/miro/src/ \
|
||||
http://ftp.osuosl.org/pub/pculture.org/miro/src/
|
||||
|
@ -17,26 +16,22 @@ COMMENT= A video player to get internet TV broadcasts
|
|||
|
||||
BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex \
|
||||
update-mime-database:${PORTSDIR}/misc/shared-mime-info
|
||||
LIB_DEPENDS= boost_python.4:${PORTSDIR}/devel/boost-python-libs \
|
||||
xine.1:${PORTSDIR}/multimedia/libxine
|
||||
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb \
|
||||
${PYTHON_SITELIBDIR}/pysqlite2/_sqlite.so:${PORTSDIR}/databases/py-pysqlite23 \
|
||||
${PYTHON_SITELIBDIR}/dbus/glib.py:${PORTSDIR}/devel/py-dbus \
|
||||
${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify \
|
||||
convert:${PORTSDIR}/graphics/ImageMagick
|
||||
${PYTHON_SITELIBDIR}/libtorrent.so:${PORTSDIR}/net-p2p/libtorrent-rasterbar-15-python \
|
||||
${PYTHON_SITELIBDIR}/webkit/webkit.so:${PORTSDIR}/www/py-webkitgtk
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/platform/gtk-x11
|
||||
INSTALL_WRKSRC= ${WRKSRC}/platform/gtk-x11
|
||||
|
||||
CONFLICTS= Miro-[0-9]*
|
||||
|
||||
USE_GCC= 4.4+
|
||||
USE_GNOME= gtk20 pygnomeextras
|
||||
USE_GECKO= libxul seamonkey
|
||||
USE_OPENSSL= yes
|
||||
USE_PYTHON= yes
|
||||
WANT_GSTREAMER= yes
|
||||
USE_GNOME= gconf2 gtk20
|
||||
USE_GSTREAMER= python
|
||||
USE_GETTEXT= yes
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
MAKE_ENV= CPPFLAGS="${CPPFLAGS}"
|
||||
INSTALLS_ICONS= yes
|
||||
|
@ -49,32 +44,12 @@ CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_GSTREAMER)
|
||||
USE_GSTREAMER+= python
|
||||
.endif
|
||||
|
||||
.if defined(GECKO) && ${GECKO:Mlibxul}!=""
|
||||
CPPFLAGS+= -D_WCHAR_T_DECLARED
|
||||
XPCOM_LIB= ${GECKO}
|
||||
GTKMOZEMBED_LIB=${GECKO}
|
||||
XULRUNNER_19= True
|
||||
.else
|
||||
XPCOM_LIB= ${GECKO}-xpcom
|
||||
GTKMOZEMBED_LIB=${GECKO}-gtkmozembed
|
||||
XULRUNNER_19= False
|
||||
.endif
|
||||
|
||||
.SILENT:
|
||||
|
||||
post-patch:
|
||||
.for file in setup.py plat/resources.py
|
||||
${REINPLACE_CMD} -e 's|%%XPCOM_RUNTIME_PATH%%|${LOCALBASE}/lib/${GECKO}|g ; \
|
||||
s|%%XPCOM_LIB%%|${XPCOM_LIB}|g ; \
|
||||
s|%%GTKMOZEMBED_LIB%%|${GTKMOZEMBED_LIB}|g ; \
|
||||
s|%%XULRUNNER_19%%|${XULRUNNER_19}|g ; \
|
||||
s|%%LOCALBASE%%|${LOCALBASE}|g ; \
|
||||
s|%%CC%%|${CC}|g ; \
|
||||
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g ; \
|
||||
${REINPLACE_CMD} -e \
|
||||
's|%%LOCALBASE%%|${LOCALBASE}|g ; \
|
||||
s|%%PREFIX%%|${PREFIX}|g ; \
|
||||
s|%%MANPREFIX%%|${MANPREFIX}|g' \
|
||||
${BUILD_WRKSRC}/${file}
|
||||
|
@ -87,10 +62,6 @@ post-patch:
|
|||
${REINPLACE_CMD} -e 's|^PREFIX=.*|PREFIX=${PREFIX}|g' \
|
||||
${BUILD_WRKSRC}/${file}
|
||||
.endfor
|
||||
.for file in plat/renderers/xinerenderer.py
|
||||
${REINPLACE_CMD} -e 's|lib/miro|libexec/miro|g' \
|
||||
${BUILD_WRKSRC}/${file}
|
||||
.endfor
|
||||
|
||||
.if defined(MAINTAINER_MODE)
|
||||
regression-test: install
|
||||
|
|
|
@ -1,3 +1,6 @@
|
|||
MD5 (miro-2.5.4.tar.gz) = d0ae2bf0463201c6b6dc7367f1fa8b3c
|
||||
SHA256 (miro-2.5.4.tar.gz) = 43f18abfc8cc7cdbb84fb5de2136397080e4c153881498b18970c81a671b0f67
|
||||
SIZE (miro-2.5.4.tar.gz) = 10032329
|
||||
MD5 (miro-3.0.2.tar.gz) = 385ac3f7478bfd88c87b8a47d356bd4f
|
||||
SHA256 (miro-3.0.2.tar.gz) = adf62bf628f5423f914a552356ebcc7fc41f8b80577a0f470954c0ba0e56235d
|
||||
SIZE (miro-3.0.2.tar.gz) = 9695827
|
||||
MD5 (libtorrent-rasterbar-0.14.10.tar.gz) = 99e9f4fa9c9f1f5097a4748c7260ef53
|
||||
SHA256 (libtorrent-rasterbar-0.14.10.tar.gz) = 524a19effb6b7e410a20e385e0d0421bfefc1d3f87cb7f78b77f391f12351957
|
||||
SIZE (libtorrent-rasterbar-0.14.10.tar.gz) = 1997446
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
--- platform/gtk-x11/plat/options.py.orig 2009-07-25 12:41:11.000000000 +0900
|
||||
+++ platform/gtk-x11/plat/options.py 2009-07-30 15:45:34.000000000 +0900
|
||||
@@ -46,12 +46,12 @@
|
||||
self.help = help
|
||||
|
||||
USE_RENDERER = GTKPref(key="useRenderer",
|
||||
- default=u"gstreamer",
|
||||
+ default=u"xine",
|
||||
alias="renderer",
|
||||
help="Which renderer to use. (gstreamer, xine)" )
|
||||
|
||||
USE_XINE_XV_HACK = GTKPref(key="UseXineXVHack",
|
||||
- default=True,
|
||||
+ default=False,
|
||||
alias="xine-xvhack",
|
||||
help="Whether or not to use the Xine xv hack. (true, false)" )
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- platform/gtk-x11/xine/xine.pyx.orig 2010-05-08 21:58:50.000000000 +0200
|
||||
+++ platform/gtk-x11/xine/xine.pyx 2010-05-08 21:59:10.000000000 +0200
|
||||
@@ -89,7 +89,7 @@
|
||||
cdef _Xine* xine
|
||||
cdef object eosCallback
|
||||
|
||||
- def __new__(self):
|
||||
+ def __cinit__(self):
|
||||
self.xine = xineCreate(on_xine_event, <void*>self)
|
||||
self.eosCallback = None
|
||||
def __dealloc__(self):
|
|
@ -1,35 +1,6 @@
|
|||
--- platform/gtk-x11/setup.py.orig 2009-12-03 01:40:42.000000000 +0900
|
||||
+++ platform/gtk-x11/setup.py 2009-12-21 06:10:08.000000000 +0900
|
||||
@@ -70,7 +70,7 @@
|
||||
# Examples:
|
||||
# XPCOM_RUNTIME_PATH = "/usr/lib/firefox"
|
||||
# XPCOM_RUNTIME_PATH = "/usr/lib/xulrunner-1.9.0.1"
|
||||
-XPCOM_RUNTIME_PATH = None
|
||||
+XPCOM_RUNTIME_PATH = "%%XPCOM_RUNTIME_PATH%%"
|
||||
|
||||
# Location of xulrunner/firefox components for gtkmozembed.set_comp_path.
|
||||
# See documentation for set_comp_path here:
|
||||
@@ -112,14 +112,15 @@
|
||||
# XPCOM_LIB = "firefox-xpcom"
|
||||
# GTKMOZEMBED_LIB = "firefox-gtkmozembed"
|
||||
# XULRUNNER_19 = False
|
||||
-XPCOM_LIB = None
|
||||
-GTKMOZEMBED_LIB = None
|
||||
-XULRUNNER_19 = None
|
||||
+XPCOM_LIB = "%%XPCOM_LIB%%"
|
||||
+GTKMOZEMBED_LIB = "%%GTKMOZEMBED_LIB%%"
|
||||
+XULRUNNER_19 = %%XULRUNNER_19%%
|
||||
|
||||
# The name of the boost python library. Used for building extensions.
|
||||
# If this is set to None, setup.py will divine the right lib to use.
|
||||
# It should probably be either "boost_python" or "boost_python-mt".
|
||||
-BOOST_LIB = None
|
||||
+BOOST_LIB = 'boost_python'
|
||||
+BOOST_LIB_PATH = '%%LOCALBASE%%/lib'
|
||||
|
||||
|
||||
###############################################################################
|
||||
@@ -285,6 +286,9 @@
|
||||
--- platform/gtk-x11/setup.py.orig 2010-05-23 05:39:24.000000000 +0900
|
||||
+++ platform/gtk-x11/setup.py 2010-06-14 18:47:40.000000000 +0900
|
||||
@@ -198,6 +198,9 @@
|
||||
options_dict['library_dirs'].append(rest)
|
||||
elif prefix == '-l':
|
||||
options_dict['libraries'].append(rest)
|
||||
|
@ -39,56 +10,16 @@
|
|||
else:
|
||||
options_dict['extra_compile_args'].append(comp)
|
||||
|
||||
@@ -315,7 +319,7 @@
|
||||
print "Using %s" % BOOST_LIB
|
||||
|
||||
def compile_xine_extractor():
|
||||
- rv = os.system("gcc %s -o %s `pkg-config --libs --cflags gdk-pixbuf-2.0 glib-2.0 libxine`" %
|
||||
+ rv = os.system("%%CC%% %s -o %s `pkg-config --libs --cflags gdk-pixbuf-2.0 glib-2.0 libxine` %%PTHREAD_LIBS%%" %
|
||||
(os.path.join(platform_dir, "xine/xine_extractor.c"), os.path.join(platform_dir, "xine/xine_extractor")))
|
||||
if rv != 0:
|
||||
raise RuntimeError("xine_extractor compilation failed. Possibly missing libxine, gdk-pixbuf-2.0, or glib-2.0.")
|
||||
@@ -353,7 +357,7 @@
|
||||
@@ -241,7 +244,7 @@
|
||||
exit;
|
||||
fi
|
||||
|
||||
- %(runtimelib)s$GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON ./miro.real --sync "$@"
|
||||
+ %(runtimelib)s$GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON %%PREFIX%%/bin/miro.real --sync "$@"
|
||||
- $GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON ./miro.real --sync "$@"
|
||||
+ $GDB -ex 'set breakpoint pending on' -ex 'run' --args $PYTHON %%PREFIX%%/bin/miro.real --sync "$@"
|
||||
else
|
||||
%(runtimelib)smiro.real "$@"
|
||||
miro.real "$@"
|
||||
fi
|
||||
@@ -366,6 +370,7 @@
|
||||
Extension("miro.fasttypes",
|
||||
sources = [os.path.join(portable_dir, 'fasttypes.cpp')],
|
||||
libraries = [BOOST_LIB],
|
||||
+ library_dirs = [BOOST_LIB_PATH],
|
||||
)
|
||||
|
||||
|
||||
@@ -402,12 +407,12 @@
|
||||
"-DHAVE___INCLUDE_LIBTORRENT_ASIO_SSL_STREAM_HPP=1",
|
||||
"-DHAVE___INCLUDE_LIBTORRENT_ASIO_IP_TCP_HPP=1",
|
||||
"-DHAVE_PTHREAD=1", "-DTORRENT_USE_OPENSSL=1", "-DHAVE_SSL=1",
|
||||
- "-DNDEBUG=1", "-O2"]
|
||||
+ "-DNDEBUG=1"]
|
||||
|
||||
if is_x64():
|
||||
extra_compile_args.append("-DAMD64")
|
||||
|
||||
- libraries = ['z', 'pthread', 'ssl']
|
||||
+ libraries = ['z', 'ssl']
|
||||
|
||||
# get mt or non-mt versions of the boost libraries
|
||||
libraries += [mt_or_not("boost_python"),
|
||||
@@ -432,6 +437,7 @@
|
||||
return Extension("miro.libtorrent",
|
||||
include_dirs=include_dirs,
|
||||
libraries=libraries,
|
||||
+ library_dirs=[BOOST_LIB_PATH],
|
||||
extra_compile_args=extra_compile_args,
|
||||
sources=sources)
|
||||
|
||||
@@ -558,7 +564,7 @@
|
||||
@@ -253,7 +256,7 @@
|
||||
xlib_ext = \
|
||||
Extension("miro.plat.xlibhelper",
|
||||
[ os.path.join(platform_package_dir,'xlibhelper.pyx') ],
|
||||
|
@ -97,7 +28,7 @@
|
|||
libraries = ['X11'],
|
||||
)
|
||||
|
||||
@@ -644,36 +650,36 @@
|
||||
@@ -274,34 +277,34 @@
|
||||
# filter out app.config.template (which is handled specially)
|
||||
files = [f for f in listfiles(resource_dir) \
|
||||
if os.path.basename(f) != 'app.config.template']
|
||||
|
@ -139,12 +70,9 @@
|
|||
- ('/usr/share/man/man1',
|
||||
+ ('%%MANPREFIX%%/man/man1',
|
||||
[os.path.join(platform_dir, 'miro.real.1.gz')]),
|
||||
- ('/usr/lib/miro/',
|
||||
+ ('%%PREFIX%%/libexec/miro',
|
||||
[os.path.join(platform_dir, 'xine/xine_extractor')]),
|
||||
]
|
||||
|
||||
@@ -697,7 +703,7 @@
|
||||
@@ -324,7 +327,7 @@
|
||||
|
||||
def install_app_config(self):
|
||||
source = os.path.join(resource_dir, 'app.config.template')
|
||||
|
@ -153,7 +81,7 @@
|
|||
|
||||
config_file = util.read_simple_config_file(source)
|
||||
print "Trying to figure out the git revision...."
|
||||
@@ -739,7 +745,7 @@
|
||||
@@ -366,7 +369,7 @@
|
||||
lang = os.path.basename(source)[:-3]
|
||||
if 'LINGUAS' in os.environ and lang not in os.environ['LINGUAS']:
|
||||
continue
|
||||
|
@ -162,7 +90,7 @@
|
|||
if self.root:
|
||||
dest = change_root(self.root, dest)
|
||||
self.mkpath(os.path.dirname(dest))
|
||||
@@ -768,7 +774,7 @@
|
||||
@@ -395,7 +398,7 @@
|
||||
|
||||
#### install_theme installs a specified theme .zip
|
||||
class install_theme(Command):
|
||||
|
@ -171,7 +99,7 @@
|
|||
user_options = [("theme=", None, 'ZIP file containing the theme')]
|
||||
|
||||
def initialize_options(self):
|
||||
@@ -796,7 +802,7 @@
|
||||
@@ -423,7 +426,7 @@
|
||||
raise DistutilsOptionError, "invalid theme file"
|
||||
self.zipfile = zf
|
||||
self.theme_name = themeName
|
||||
|
|
|
@ -42,12 +42,18 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/databasehelper.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/databasehelper.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/databasehelper.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/databaselog.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/databaselog.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/databaselog.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/databasesanity.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/databasesanity.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/databasesanity.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/databaseupgrade.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/databaseupgrade.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/databaseupgrade.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/datastructures.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/datastructures.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/datastructures.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/dbupgradeprogress.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/dbupgradeprogress.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/dbupgradeprogress.pyo
|
||||
|
@ -93,7 +99,6 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/eventloop.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/eventloop.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/eventloop.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/fasttypes.so
|
||||
%%PYTHON_SITELIBDIR%%/miro/feed.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/feed.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/feed.pyo
|
||||
|
@ -278,6 +283,9 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemcontextmenu.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemcontextmenu.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemcontextmenu.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemedit.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemedit.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemedit.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemlist.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemlist.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/frontends/widgets/itemlist.pyo
|
||||
|
@ -380,13 +388,12 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/iconcache.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/iconcache.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/iconcache.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/iso_639.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/iso_639.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/iso_639.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/item.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/item.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/item.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/libtorrent.so
|
||||
%%PYTHON_SITELIBDIR%%/miro/menubar.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/menubar.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/menubar.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/messagehandler.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/messagehandler.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/messagehandler.pyo
|
||||
|
@ -399,9 +406,6 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/moviedata.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/moviedata.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/moviedata.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/olddatabaseupgrade.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/olddatabaseupgrade.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/olddatabaseupgrade.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/opml.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/opml.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/opml.pyo
|
||||
|
@ -420,9 +424,9 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/application.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/application.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/application.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/httpobserver.so
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/mozprompt.so
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/pluginsdir.so
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/mediakeys.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/mediakeys.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/mediakeys.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/prefpanelset.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/prefpanelset.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/prefpanelset.pyo
|
||||
|
@ -432,16 +436,15 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/timer.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/timer.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/timer.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/webkitbrowser.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/webkitbrowser.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/webkitbrowser.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/widgetset.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/widgetset.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/widgetset.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets/windowcreator.so
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/idletime.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/idletime.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/idletime.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/mozsetup.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/mozsetup.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/mozsetup.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/onetime.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/onetime.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/onetime.pyo
|
||||
|
@ -457,9 +460,6 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/plat/renderers/gstreamerrenderer.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/renderers/gstreamerrenderer.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/renderers/gstreamerrenderer.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/renderers/xinerenderer.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/renderers/xinerenderer.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/renderers/xinerenderer.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/resources.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/resources.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/plat/resources.pyo
|
||||
|
@ -500,7 +500,6 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/singleclick.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/singleclick.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/singleclick.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/sorts.so
|
||||
%%PYTHON_SITELIBDIR%%/miro/startup.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/startup.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/startup.pyo
|
||||
|
@ -516,18 +515,15 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/test/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/bmachinetest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/bmachinetest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/bmachinetest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/databasesanitytest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/databasesanitytest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/databasesanitytest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/databasetest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/databasetest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/databasetest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/fasttypestest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/fasttypestest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/fasttypestest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/datastructurestest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/datastructurestest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/datastructurestest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/feedparsertest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/feedparsertest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/feedparsertest.pyo
|
||||
|
@ -558,9 +554,6 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/test/messagetest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/messagetest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/messagetest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/olddatabaseupgradetest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/olddatabaseupgradetest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/olddatabaseupgradetest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/parseurltest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/parseurltest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/parseurltest.pyo
|
||||
|
@ -576,6 +569,9 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/test/signalstest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/signalstest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/signalstest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/sparkletest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/sparkletest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/sparkletest.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/storedatabasetest.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/storedatabasetest.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/test/storedatabasetest.pyo
|
||||
|
@ -609,13 +605,12 @@ bin/miro.real
|
|||
%%PYTHON_SITELIBDIR%%/miro/xhtmltools.py
|
||||
%%PYTHON_SITELIBDIR%%/miro/xhtmltools.pyc
|
||||
%%PYTHON_SITELIBDIR%%/miro/xhtmltools.pyo
|
||||
%%PYTHON_SITELIBDIR%%/miro/xine.so
|
||||
libexec/miro/xine_extractor
|
||||
share/applications/miro.desktop
|
||||
share/icons/hicolor/128x128/apps/miro.png
|
||||
share/icons/hicolor/24x24/apps/miro.png
|
||||
share/icons/hicolor/48x48/apps/miro.png
|
||||
share/icons/hicolor/72x72/apps/miro.png
|
||||
share/locale/af/LC_MESSAGES/miro.mo
|
||||
share/locale/ar/LC_MESSAGES/miro.mo
|
||||
share/locale/be/LC_MESSAGES/miro.mo
|
||||
share/locale/bg/LC_MESSAGES/miro.mo
|
||||
|
@ -667,6 +662,7 @@ share/locale/mk/LC_MESSAGES/miro.mo
|
|||
share/locale/ml/LC_MESSAGES/miro.mo
|
||||
share/locale/mr/LC_MESSAGES/miro.mo
|
||||
share/locale/ms/LC_MESSAGES/miro.mo
|
||||
share/locale/mt/LC_MESSAGES/miro.mo
|
||||
share/locale/nb/LC_MESSAGES/miro.mo
|
||||
share/locale/nds/LC_MESSAGES/miro.mo
|
||||
share/locale/ne/LC_MESSAGES/miro.mo
|
||||
|
@ -703,9 +699,6 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/images/broken-image.gif
|
||||
%%DATADIR%%/resources/images/cancel-button.png
|
||||
%%DATADIR%%/resources/images/channelguide-icon-tablist.png
|
||||
%%DATADIR%%/resources/images/display_center.png
|
||||
%%DATADIR%%/resources/images/display_left.png
|
||||
%%DATADIR%%/resources/images/display_right.png
|
||||
%%DATADIR%%/resources/images/download-arrow.png
|
||||
%%DATADIR%%/resources/images/feedicon.png
|
||||
%%DATADIR%%/resources/images/folder-icon-tablist.png
|
||||
|
@ -733,7 +726,18 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/images/icon-site.png
|
||||
%%DATADIR%%/resources/images/icon-streaming.png
|
||||
%%DATADIR%%/resources/images/icon-streaming_large.png
|
||||
%%DATADIR%%/resources/images/icon-updating.png
|
||||
%%DATADIR%%/resources/images/icon-updating-0.png
|
||||
%%DATADIR%%/resources/images/icon-updating-1.png
|
||||
%%DATADIR%%/resources/images/icon-updating-10.png
|
||||
%%DATADIR%%/resources/images/icon-updating-11.png
|
||||
%%DATADIR%%/resources/images/icon-updating-2.png
|
||||
%%DATADIR%%/resources/images/icon-updating-3.png
|
||||
%%DATADIR%%/resources/images/icon-updating-4.png
|
||||
%%DATADIR%%/resources/images/icon-updating-5.png
|
||||
%%DATADIR%%/resources/images/icon-updating-6.png
|
||||
%%DATADIR%%/resources/images/icon-updating-7.png
|
||||
%%DATADIR%%/resources/images/icon-updating-8.png
|
||||
%%DATADIR%%/resources/images/icon-updating-9.png
|
||||
%%DATADIR%%/resources/images/icon-video.png
|
||||
%%DATADIR%%/resources/images/icon-video_large.png
|
||||
%%DATADIR%%/resources/images/list-view-button-icon.png
|
||||
|
@ -757,6 +761,7 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/images/navstop_disabled.png
|
||||
%%DATADIR%%/resources/images/normal-view-button-icon.png
|
||||
%%DATADIR%%/resources/images/pause-button.png
|
||||
%%DATADIR%%/resources/images/pause-item-button.png
|
||||
%%DATADIR%%/resources/images/pause.png
|
||||
%%DATADIR%%/resources/images/pause_active.png
|
||||
%%DATADIR%%/resources/images/play-button.png
|
||||
|
@ -786,7 +791,6 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/images/search_icon_bliptv.png
|
||||
%%DATADIR%%/resources/images/search_icon_blogdigger.png
|
||||
%%DATADIR%%/resources/images/search_icon_dailymotion.png
|
||||
%%DATADIR%%/resources/images/search_icon_everyzing.png
|
||||
%%DATADIR%%/resources/images/search_icon_google.png
|
||||
%%DATADIR%%/resources/images/search_icon_mefeedia.png
|
||||
%%DATADIR%%/resources/images/search_icon_metavid.png
|
||||
|
@ -825,6 +829,7 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/images/status-icon-newly-downloaded.png
|
||||
%%DATADIR%%/resources/images/stop.png
|
||||
%%DATADIR%%/resources/images/stop_active.png
|
||||
%%DATADIR%%/resources/images/subtitles_down.png
|
||||
%%DATADIR%%/resources/images/thumb-default-audio.png
|
||||
%%DATADIR%%/resources/images/thumb-default-folder.png
|
||||
%%DATADIR%%/resources/images/thumb-default-video.png
|
||||
|
@ -842,7 +847,6 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/searchengines/bliptv.xml
|
||||
%%DATADIR%%/resources/searchengines/blogdigger.xml
|
||||
%%DATADIR%%/resources/searchengines/dailymotion.xml
|
||||
%%DATADIR%%/resources/searchengines/everyzing.xml.disabled
|
||||
%%DATADIR%%/resources/searchengines/google.xml
|
||||
%%DATADIR%%/resources/searchengines/metavid.xml
|
||||
%%DATADIR%%/resources/searchengines/mininova.xml
|
||||
|
@ -851,6 +855,7 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/searchengines/yahoosearch.xml
|
||||
%%DATADIR%%/resources/searchengines/youtube.xml
|
||||
%%DATADIR%%/resources/searchengines/youtubeuser.xml
|
||||
%%DATADIR%%/resources/testdata/database.duplicate-id-test
|
||||
%%DATADIR%%/resources/testdata/dean.jpg
|
||||
%%DATADIR%%/resources/testdata/democracy-now-unicode-bug.xml
|
||||
%%DATADIR%%/resources/testdata/hide-result
|
||||
|
@ -861,6 +866,7 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/testdata/olddatabase-0.8.1
|
||||
%%DATADIR%%/resources/testdata/olddatabase-0.8.2
|
||||
%%DATADIR%%/resources/testdata/olddatabase-0.8.2-2
|
||||
%%DATADIR%%/resources/testdata/olddatabase.bug.12305
|
||||
%%DATADIR%%/resources/testdata/olddatabase.bug.2003
|
||||
%%DATADIR%%/resources/testdata/olddatabase.bug.2515
|
||||
%%DATADIR%%/resources/testdata/olddatabase.bug.2685
|
||||
|
@ -892,6 +898,8 @@ share/mime/packages/miro.xml
|
|||
%%DATADIR%%/resources/testdata/stripperdata/test7.in
|
||||
%%DATADIR%%/resources/testdata/stripperdata/test8.expected
|
||||
%%DATADIR%%/resources/testdata/stripperdata/test8.in
|
||||
%%DATADIR%%/resources/testdata/stripperdata/test9.expected
|
||||
%%DATADIR%%/resources/testdata/stripperdata/test9.in
|
||||
%%DATADIR%%/resources/testdata/stripperdata/testburma.expected
|
||||
%%DATADIR%%/resources/testdata/stripperdata/testburma.in
|
||||
%%DATADIR%%/resources/testdata/translation-result
|
||||
|
@ -923,8 +931,9 @@ share/pixmaps/miro.xpm
|
|||
@dirrmtry share/locale/ckb
|
||||
@dirrmtry share/locale/csb/LC_MESSAGES
|
||||
@dirrmtry share/locale/csb
|
||||
@dirrmtry share/locale/zu/LC_MESSAGES
|
||||
@dirrmtry share/locale/zu
|
||||
@dirrmtry share/applications
|
||||
@dirrm libexec/miro
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/miro/test
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/miro/plat/renderers
|
||||
@dirrm %%PYTHON_SITELIBDIR%%/miro/plat/frontends/widgets
|
||||
|
|
Loading…
Reference in a new issue