Add development version of graphics/processing
Processing is an open source programming language and environment for people who want to program images, animation, and interactions. It is used by students, artists, designers, researchers, and hobbyists for learning, prototyping, and production. It is created to teach fundamentals of computer programming within a visual context and to serve as a software sketchbook and professional production tool. Processing is an alternative to proprietary software tools in the same domain. WWW: http://processing.org/
This commit is contained in:
parent
e4d0664b0c
commit
3e6e2542f3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=215512
6 changed files with 1909 additions and 0 deletions
|
@ -617,6 +617,7 @@
|
|||
SUBDIR += preview
|
||||
SUBDIR += price
|
||||
SUBDIR += processing
|
||||
SUBDIR += processing-devel
|
||||
SUBDIR += proj
|
||||
SUBDIR += pstoedit
|
||||
SUBDIR += pstoepsi
|
||||
|
|
36
graphics/processing-devel/Makefile
Normal file
36
graphics/processing-devel/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
# New ports collection makefile for: processing
|
||||
# Date created: 20 June 2008
|
||||
# Whom: Edwin Groothuis <edwin@mavetju.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= processing-devel
|
||||
PORTVERSION= 0142
|
||||
CATEGORIES= graphics cad java
|
||||
MASTER_SITES= http://processing.org./download/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= edwin@mavetju.org
|
||||
COMMENT= Open source programming language and environment for people who want to program images, animation, and interactions
|
||||
|
||||
RUN_DEPENDS= jikes:${PORTSDIR}/java/jikes
|
||||
|
||||
USE_JAVA= 1.5+
|
||||
NO_BUILD= yes
|
||||
|
||||
post-extract:
|
||||
# Go from 116 Mb to 28 Mb
|
||||
${RM} -rf ${WRKSRC}/jikes
|
||||
${RM} -rf ${WRKSRC}/java
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/processing
|
||||
${RM} ${WRKSRC}/processing.*
|
||||
|
||||
do-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/processing ${PREFIX}/bin
|
||||
${MKDIR} ${PREFIX}/libexec/processing
|
||||
${CP} -Rp ${WRKSRC}/* ${PREFIX}/libexec/processing
|
||||
|
||||
.include <bsd.port.mk>
|
3
graphics/processing-devel/distinfo
Normal file
3
graphics/processing-devel/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (processing-0135.tgz) = d2948f5897e4fd604d6f7a81653ef452
|
||||
SHA256 (processing-0135.tgz) = ab443628a425fbb8565f545368650a1f425d2ca501de617f67c9fc1f41d25299
|
||||
SIZE (processing-0135.tgz) = 47961415
|
28
graphics/processing-devel/files/patch-processing
Normal file
28
graphics/processing-devel/files/patch-processing
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- processing.orig 2008-06-20 16:07:46.000000000 +1000
|
||||
+++ processing 2008-06-20 16:10:07.000000000 +1000
|
||||
@@ -1,6 +1,6 @@
|
||||
#!/bin/sh
|
||||
|
||||
-APPDIR=$(dirname "$0")
|
||||
+APPDIR=%%PREFIX%%/libexec/processing
|
||||
|
||||
# as of 0109, now using all relative paths and doing a cd to the
|
||||
# processing folder on run, because there are too many dependencies
|
||||
@@ -17,14 +17,14 @@
|
||||
#PATH=`pwd`/`dirname $0`:`pwd`/java/bin:${PATH}
|
||||
#PATH=$APPDIR:$APPDIR/java/bin:${PATH}
|
||||
#echo $PATH
|
||||
-PATH=.:java/bin:${PATH}
|
||||
-export PATH
|
||||
+#PATH=.:java/bin:${PATH}
|
||||
+#export PATH
|
||||
|
||||
# test to see if jikes is operable. i'm a crappy bash scripter
|
||||
# so if someone knows a more elegant way to do this, let me know.
|
||||
#
|
||||
#echo $APPDIR/jikes
|
||||
-"$APPDIR/jikes" -version 1> /dev/null 2> /dev/null
|
||||
+jikes -version 1> /dev/null 2> /dev/null
|
||||
# if stmt modified as per bug #373
|
||||
if [ $? -eq 0 ]
|
||||
then
|
10
graphics/processing-devel/pkg-descr
Normal file
10
graphics/processing-devel/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
Processing is an open source programming language and environment
|
||||
for people who want to program images, animation, and interactions.
|
||||
It is used by students, artists, designers, researchers, and hobbyists
|
||||
for learning, prototyping, and production. It is created to teach
|
||||
fundamentals of computer programming within a visual context and
|
||||
to serve as a software sketchbook and professional production tool.
|
||||
Processing is an alternative to proprietary software tools in the
|
||||
same domain.
|
||||
|
||||
WWW: http://processing.org/
|
1831
graphics/processing-devel/pkg-plist
Normal file
1831
graphics/processing-devel/pkg-plist
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue