update sysutils/liburcu to 0.9.3
PR: 216141 Submitted by: Mahdi Mokhtari <mokhi64@gmail.com> Reviewed by: matthew Approved by: matthew (mentor), maintainer timeout (freebsd@dns-lab.com, 2 weeks) Differential Revision: https://reviews.freebsd.org/D9199
This commit is contained in:
parent
9ad196a4cb
commit
3ea0bbeb63
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433104
5 changed files with 133 additions and 22 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= liburcu
|
||||
PORTVERSION= 0.7.17
|
||||
PORTVERSION= 0.9.3
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://lttng.org/files/urcu/
|
||||
DISTNAME= userspace-rcu-${PORTVERSION}
|
||||
|
@ -12,8 +12,6 @@ COMMENT= Userspace read-copy-update (RCU) data synchronization library
|
|||
|
||||
LICENSE= LGPL21
|
||||
|
||||
PORTDOCS= ChangeLog README cds-api.txt rcu-api.txt uatomic-api.txt
|
||||
|
||||
BROKEN_aarch64= Fails to build: Cannot build: unrecognized architecture detected
|
||||
BROKEN_armv6= Fails to build: address argument to atomic builtin must be a pointer
|
||||
BROKEN_mips= Fails to build: undefined reference to `__sync_bool_compare_and_swap_4
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1481228008
|
||||
SHA256 (userspace-rcu-0.7.17.tar.bz2) = 19ceae968fa29a3bb425a2743832f2965c3b28639e845cf01edfe2e75b31781c
|
||||
SIZE (userspace-rcu-0.7.17.tar.bz2) = 392424
|
||||
TIMESTAMP = 1483800399
|
||||
SHA256 (userspace-rcu-0.9.3.tar.bz2) = 1bce32e6a6c967fef6d37adaadf33df19878d69673f9ef9d3f2470e0c6ed4006
|
||||
SIZE (userspace-rcu-0.9.3.tar.bz2) = 472624
|
||||
|
|
|
@ -0,0 +1,14 @@
|
|||
--- doc/examples/Makefile.examples.template.orig 2017-01-07 14:57:52 UTC
|
||||
+++ doc/examples/Makefile.examples.template
|
||||
@@ -11,9 +11,9 @@
|
||||
#
|
||||
# This makefile is purposefully kept simple to support GNU and BSD make.
|
||||
|
||||
-ifdef AM_CC
|
||||
+.if defined(AM_CC)
|
||||
CC = $(AM_CC)
|
||||
-endif
|
||||
+.endif
|
||||
CFLAGS = -g -O2 -Wall
|
||||
|
||||
all: $(BINARY)
|
11
sysutils/liburcu/files/patch-urcu_syscall-compat.h
Normal file
11
sysutils/liburcu/files/patch-urcu_syscall-compat.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- urcu/syscall-compat.h.orig 2016-11-30 21:05:22 UTC
|
||||
+++ urcu/syscall-compat.h
|
||||
@@ -32,7 +32,7 @@
|
||||
#elif defined(__linux__) || defined(__GLIBC__)
|
||||
#include <syscall.h>
|
||||
|
||||
-#elif defined(__CYGWIN__) || defined(__APPLE__)
|
||||
+#elif defined(__CYGWIN__) || defined(__APPLE__) || defined(__FreeBSD__)
|
||||
/* Don't include anything on Cygwin or MacOSX. */
|
||||
|
||||
#else
|
|
@ -10,28 +10,32 @@ include/urcu/arch/generic.h
|
|||
include/urcu/cds.h
|
||||
include/urcu/compiler.h
|
||||
include/urcu/config.h
|
||||
include/urcu/debug.h
|
||||
include/urcu/futex.h
|
||||
include/urcu/hlist.h
|
||||
include/urcu/lfstack.h
|
||||
include/urcu/list.h
|
||||
include/urcu/map/urcu-bp.h
|
||||
include/urcu/map/urcu-mp.h
|
||||
include/urcu/map/urcu-qsbr.h
|
||||
include/urcu/map/urcu.h
|
||||
include/urcu/rand-compat.h
|
||||
include/urcu/rcuhlist.h
|
||||
include/urcu/rculfhash.h
|
||||
include/urcu/rculfqueue.h
|
||||
include/urcu/rculfstack.h
|
||||
include/urcu/rculist.h
|
||||
include/urcu/ref.h
|
||||
include/urcu/static/bkp-wfqueue.h
|
||||
include/urcu/static/lfstack.h
|
||||
include/urcu/static/rculfqueue.h
|
||||
include/urcu/static/rculfstack.h
|
||||
include/urcu/static/urcu-bp.h
|
||||
include/urcu/static/urcu-pointer.h
|
||||
include/urcu/static/urcu-qsbr.h
|
||||
include/urcu/static/urcu.h
|
||||
include/urcu/static/wfcqueue.h
|
||||
include/urcu/static/wfqueue.h
|
||||
include/urcu/static/wfstack.h
|
||||
include/urcu/syscall-compat.h
|
||||
include/urcu/system.h
|
||||
include/urcu/tls-compat.h
|
||||
include/urcu/uatomic.h
|
||||
|
@ -39,39 +43,123 @@ include/urcu/uatomic/generic.h
|
|||
include/urcu/uatomic_arch.h
|
||||
include/urcu/urcu-futex.h
|
||||
include/urcu/urcu_ref.h
|
||||
include/urcu/wfcqueue.h
|
||||
include/urcu/wfqueue.h
|
||||
include/urcu/wfstack.h
|
||||
lib/liburcu-bp.a
|
||||
lib/liburcu-bp.so
|
||||
lib/liburcu-bp.so.1
|
||||
lib/liburcu-bp.so.1.0.0
|
||||
lib/liburcu-bp.so.4
|
||||
lib/liburcu-bp.so.4.1.0
|
||||
lib/liburcu-cds.a
|
||||
lib/liburcu-cds.so
|
||||
lib/liburcu-cds.so.1
|
||||
lib/liburcu-cds.so.1.0.0
|
||||
lib/liburcu-cds.so.4
|
||||
lib/liburcu-cds.so.4.1.0
|
||||
lib/liburcu-common.a
|
||||
lib/liburcu-common.so
|
||||
lib/liburcu-common.so.1
|
||||
lib/liburcu-common.so.1.0.0
|
||||
lib/liburcu-common.so.4
|
||||
lib/liburcu-common.so.4.1.0
|
||||
lib/liburcu-mb.a
|
||||
lib/liburcu-mb.so
|
||||
lib/liburcu-mb.so.1
|
||||
lib/liburcu-mb.so.1.0.0
|
||||
lib/liburcu-mb.so.4
|
||||
lib/liburcu-mb.so.4.1.0
|
||||
lib/liburcu-qsbr.a
|
||||
lib/liburcu-qsbr.so
|
||||
lib/liburcu-qsbr.so.1
|
||||
lib/liburcu-qsbr.so.1.0.0
|
||||
lib/liburcu-qsbr.so.4
|
||||
lib/liburcu-qsbr.so.4.1.0
|
||||
lib/liburcu-signal.a
|
||||
lib/liburcu-signal.so
|
||||
lib/liburcu-signal.so.1
|
||||
lib/liburcu-signal.so.1.0.0
|
||||
lib/liburcu-signal.so.4
|
||||
lib/liburcu-signal.so.4.1.0
|
||||
lib/liburcu.a
|
||||
lib/liburcu.so
|
||||
lib/liburcu.so.1
|
||||
lib/liburcu.so.1.0.0
|
||||
lib/liburcu.so.4
|
||||
lib/liburcu.so.4.1.0
|
||||
libdata/pkgconfig/liburcu-bp.pc
|
||||
libdata/pkgconfig/liburcu-cds.pc
|
||||
libdata/pkgconfig/liburcu-mb.pc
|
||||
libdata/pkgconfig/liburcu-qsbr.pc
|
||||
libdata/pkgconfig/liburcu-signal.pc
|
||||
libdata/pkgconfig/liburcu.pc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/cds-api.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/Makefile.examples.template
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/Makefile.cds_hlist_add_head_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/Makefile.cds_hlist_del_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/Makefile.cds_hlist_for_each_entry_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/Makefile.cds_hlist_for_each_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/cds_hlist_add_head_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/cds_hlist_del_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/cds_hlist_for_each_entry_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/hlist/cds_hlist_for_each_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/lfstack/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/lfstack/Makefile.cds_lfs_pop_all_blocking
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/lfstack/Makefile.cds_lfs_pop_blocking
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/lfstack/Makefile.cds_lfs_push
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/lfstack/cds_lfs_pop_all_blocking.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/lfstack/cds_lfs_pop_blocking.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/lfstack/cds_lfs_push.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/Makefile.cds_list_add_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/Makefile.cds_list_add_tail_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/Makefile.cds_list_del_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/Makefile.cds_list_for_each_entry_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/Makefile.cds_list_for_each_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/Makefile.cds_list_replace_rcu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/cds_list_add_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/cds_list_add_tail_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/cds_list_del_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/cds_list_for_each_entry_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/cds_list_for_each_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/list/cds_list_replace_rcu.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/Makefile.cds_lfht_add
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/Makefile.cds_lfht_add_replace
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/Makefile.cds_lfht_add_unique
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/Makefile.cds_lfht_del
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/Makefile.cds_lfht_destroy
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/Makefile.cds_lfht_for_each_entry_duplicate
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/Makefile.cds_lfht_lookup
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/cds_lfht_add.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/cds_lfht_add_replace.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/cds_lfht_add_unique.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/cds_lfht_del.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/cds_lfht_destroy.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/cds_lfht_for_each_entry_duplicate.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/cds_lfht_lookup.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfhash/jhash.h
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfqueue/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfqueue/Makefile.cds_lfq_dequeue
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfqueue/Makefile.cds_lfq_enqueue
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfqueue/cds_lfq_dequeue.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/rculfqueue/cds_lfq_enqueue.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/Makefile.bp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/Makefile.mb
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/Makefile.membarrier
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/Makefile.qsbr
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/Makefile.signal
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/bp.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/mb.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/membarrier.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/qsbr.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/urcu-flavors/signal.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfcqueue/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfcqueue/Makefile.cds_wfcq_dequeue
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfcqueue/Makefile.cds_wfcq_enqueue
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfcqueue/Makefile.cds_wfcq_splice
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfcqueue/cds_wfcq_dequeue.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfcqueue/cds_wfcq_enqueue.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfcqueue/cds_wfcq_splice.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfstack/Makefile
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfstack/Makefile.cds_wfs_pop
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfstack/Makefile.cds_wfs_pop_all_blocking
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfstack/Makefile.cds_wfs_push
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfstack/cds_wfs_pop.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfstack/cds_wfs_pop_all_blocking.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/wfstack/cds_wfs_push.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rcu-api.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/solaris-build.md
|
||||
%%PORTDOCS%%%%DOCSDIR%%/uatomic-api.md
|
||||
|
|
Loading…
Reference in a new issue