Add avis 1.2.0, elvin Publish/Subscribe Message Bus server based on the

Elvin protocol.

PR:		ports/120111
Submitted by:	Benjamin Close <benjsc at FreeBSD.org>
This commit is contained in:
Vanilla I. Shu 2008-01-29 14:43:28 +00:00
parent 680946be82
commit 3ebbb6fe4e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=206385
9 changed files with 160 additions and 0 deletions

View file

@ -4,6 +4,7 @@
COMMENT = Java language support
SUBDIR += avalon-logkit
SUBDIR += avis
SUBDIR += berkeley-db
SUBDIR += bluej
SUBDIR += bouncycastle

74
java/avis/Makefile Normal file
View file

@ -0,0 +1,74 @@
# New ports collection makefile for: avis
# Date created: 13 November, 2007
# Whom: Benjamin Close <benjsc@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= avis
PORTVERSION= 1.2.0
CATEGORIES= java net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= avis
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= benjsc@FreeBSD.org
COMMENT= Elvin Publish/Subscribe Message Bus server based on the Elvin protocol
USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.5+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.if !defined(WITHOUT_COMPILE)
BUILD_DEPENDS+= ${ANT_CMD}:${PORTSDIR}/devel/apache-ant
ANT_CMD?= ${LOCALBASE}/bin/ant
ANT= ${SETENV} JAVA_HOME=${JAVA_HOME} ${ANT_CMD}
ANT_TARGETS= jar-server
JAVA_BUILD= yes
.endif
.if !defined(NOPORTDOCS)
PORTDOCS= README.txt\
LICENSE.txt\
history.txt
.endif
.include <bsd.port.pre.mk>
pre-fetch:
@${ECHO_MSG} ""
@${ECHO_MSG} "You may use the following build options:"
@${ECHO_MSG} ""
@${ECHO_MSG} " WITHOUT_COMPILE=yes Install the pre-compiled .jar file"
@${ECHO_MSG} " NOPORTDOCS=yes Don't install the port documentation"
@${ECHO_MSG} ""
do-build:
.if !defined(WITHOUT_COMPILE)
@cd ${WRKSRC}/server && ${ANT} ${ANT_TARGETS}
.endif
do-install:
@${ECHO_CMD} -n ">> Installing avisd..."
@${MKDIR} ${PREFIX}/libexec/avis/
@${INSTALL_SCRIPT} ${WRKSRC}/server/bin/avisd ${PREFIX}/sbin/avisd
@${INSTALL_DATA} ${WRKSRC}/server/lib/avis-router.jar ${PREFIX}/libexec/avis/avis-router.jar
@${ECHO_CMD} " [DONE]"
@${INSTALL_DATA} ${WRKSRC}/server/etc/avisd.config ${PREFIX}/etc/avisd.conf.sample
.if !defined(NOPORTDOCS)
@${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/server/doc && ${FIND} . \
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
.endif
.if !exists(${WRKDIR}/avisd.sh)
@${MKDIR} ${WRKDIR}
@${CP} ${FILESDIR}/avisd.sh ${WRKDIR}/avisd.sh
.endif
@${ECHO_CMD} ">> Installing ${PREFIX}/etc/rc.d/avisd.sh startup script."
@${INSTALL_SCRIPT} -m 555 ${WRKDIR}/avisd.sh ${PREFIX}/etc/rc.d/avisd.sh
.include <bsd.port.post.mk>

3
java/avis/distinfo Normal file
View file

@ -0,0 +1,3 @@
MD5 (avis-src-1.2.0.zip) = 0b7661ad6fa01a4600e1e91100202de6
SHA256 (avis-src-1.2.0.zip) = 55e17ee7d5bfc9f349217d3e955767c1bb1d3abfe24fbb2e790ff50178ff4cc0
SIZE (avis-src-1.2.0.zip) = 1606335

34
java/avis/files/avisd.sh Normal file
View file

@ -0,0 +1,34 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: avisd
# REQUIRE: LOGIN
# KEYWORD: shutdown
# Add the following line to /etc/rc.conf to enable `avisd':
#
#avisd_enable="YES"
#
# See avisd(1) for avisd_flags
#
. "/etc/rc.subr"
name="avisd"
rcvar=`set_rcvar`
logfile="/var/log/avis.log"
command="/usr/local/sbin/avisd"
pidfile="/var/run/$name.pid"
command_args="-c /usr/local/etc/$name.conf -daemon -pidfile $pidfile -logfile $logfile"
command_interpreter=/bin/sh
required_files="/usr/local/etc/$name.conf"
# read configuration and set defaults
load_rc_config "$name"
: ${avisd_enable="NO"}
: ${avisd_flags=""}
run_rc_command "$1"

View file

@ -0,0 +1,11 @@
--- server/bin/avisd 2008-01-19 19:22:26.000000000 +1030
+++ server/bin/avisd.new 2008-01-29 16:40:15.038606540 +1030
@@ -51,7 +51,7 @@
command="java $java_options -jar $avisd_jar $avis_opts"
-if [ $daemon == 1 ]; then
+if [ $daemon -eq 1 ]; then
if [ -z $logfile ]; then
logfile=/dev/null

View file

@ -0,0 +1,11 @@
--- server/build.xml-orig 2008-01-29 17:22:51.909302396 +1030
+++ server/build.xml 2008-01-29 17:22:36.780316170 +1030
@@ -22,7 +22,7 @@
<property name="server" value="${basedir}" />
- <property name="common" value="${server}/../common" />
+ <property name="common" value="${server}/../common/java" />
<property name="client" value="${server}/../client" />
<property name="avis-root" value="${server}/../.." />

View file

@ -0,0 +1,17 @@
--- server/src/main/org/avis/federation/Link.java-orig 2008-01-21 18:05:26.000000000 +1030
+++ server/src/main/org/avis/federation/Link.java 2008-01-29 17:16:37.334636622 +1030
@@ -302,7 +285,7 @@
private void handleAck (Ack ack)
{
- if (ack.request instanceof FedSubReplace)
+ if (ack.request.getClass () == FedSubReplace.class)
subscribed = true;
}
@@ -409,3 +392,5 @@
return newRouting;
}
}
+
+

5
java/avis/pkg-descr Normal file
View file

@ -0,0 +1,5 @@
Avis is a multicast event bus server. Providing the ability to publish and
subscribe to events. The protocol is compatible with the commercial Elvin
implmentation developed by Mantara Software.
WWW: http://avis.sourceforge.net/

4
java/avis/pkg-plist Normal file
View file

@ -0,0 +1,4 @@
sbin/avisd
etc/avisd.conf.sample
libexec/avis/avis-router.jar
@dirrm libexec/avis