- Don't build on ia64, arora core dumps on startup [1]

- Update maintainer email address
- Add LICENSE
- Mark MAKE_JOBS_SAFE
- substitute a patch file with REINPLACE_CMD

PR:		ports/166837
Submitted by:	Shane Bell <decept0@gmail.com>
Reported by:	Anton Shterenlikht [1]
Approved by:	crees (mentor)
This commit is contained in:
Guido Falsi 2012-04-17 17:54:30 +00:00
parent aa23a3e83b
commit 3eebc9be40
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=294963
2 changed files with 11 additions and 14 deletions

View file

@ -9,18 +9,25 @@ PORTVERSION= 0.11.0
CATEGORIES= www
MASTER_SITES= GOOGLE_CODE
MAINTAINER= decept0@gmail.com
MAINTAINER= shanjobe@gmail.com
COMMENT= Simple Qt4 based browser
LICENSE= GPLv3
USE_QT_VER= 4
QT_COMPONENTS= network webkit qmake_build moc_build uic_build rcc_build \
imageformats gui script sql
HAS_CONFIGURE= yes
QMAKE_ARGS+= -unix -recursive PREFIX=${PREFIX}
MAKE_JOBS_UNSAFE= yes
MAN1= arora.1 arora-cacheinfo.1 arora-placesimport.1 htmlToXBel.1
.include <bsd.port.pre.mk>
.if ${ARCH} == ia64
BROKEN= core dump on application startup
.endif
.if defined(WITHOUT_NLS)
PLIST_SUB+= NLS="@comment "
.else
@ -50,6 +57,7 @@ post-configure:
@${REINPLACE_CMD} -e \
's|^CC .*|CC=${CC}|; s|^CXX .*|CXX=${CXX}|; s|^LINK .*|LINK=${CXX}|' \
${WRKSRC}/src/Makefile
@${REINPLACE_CMD} 's|raster||' ${WRKSRC}/src/main.cpp
post-install:
${INSTALL_MAN} ${WRKSRC}/src/data/arora.1 \
@ -58,4 +66,4 @@ post-install:
${WRKSRC}/tools/placesimport/data/arora-placesimport.1 \
${PREFIX}/man/man1
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,11 +0,0 @@
--- ./src/main.cpp.orig 2010-09-27 06:42:17.000000000 +0400
+++ ./src/main.cpp 2010-11-07 17:02:53.153956800 +0300
@@ -28,7 +28,7 @@
Q_INIT_RESOURCE(htmls);
Q_INIT_RESOURCE(data);
#ifdef Q_WS_X11
- QApplication::setGraphicsSystem(QString::fromLatin1("raster"));
+ // QApplication::setGraphicsSystem(QString::fromLatin1("raster"));
#endif
BrowserApplication application(argc, argv);
if (!application.isRunning())