New port: comms/freedv
FreeDV is a Digital Voice mode for HF radio. FreeDV allows any SSB radio to be used for low bit rate digital voice. Speech is compressed down to 700-1600 bit/s then modulated onto a 1.25 kHz wide signal comprised of 16 QPSK carriers which is sent to the Mic input of a SSB radio. The signal is received by an SSB radio, then demodulated and decoded by FreeDV. FreeDV 700(B) rivals SSB in it's low SNR performance. At high SNRs FreeDV 1600 sounds like FM, with no annoying analog HF radio noise. WWW: http://freedv.org/tiki-index.php
This commit is contained in:
parent
bf21fdb9e2
commit
3f54000051
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=403766
6 changed files with 72 additions and 0 deletions
|
@ -45,6 +45,7 @@
|
|||
SUBDIR += fllog
|
||||
SUBDIR += flrig
|
||||
SUBDIR += flwrap
|
||||
SUBDIR += freedv
|
||||
SUBDIR += gammu
|
||||
SUBDIR += ge-x2212
|
||||
SUBDIR += geoid
|
||||
|
|
30
comms/freedv/Makefile
Normal file
30
comms/freedv/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= freedv
|
||||
PORTVERSION= 1.1
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= http://files.freedv.org/freedv/ \
|
||||
LOCAL/shurd
|
||||
|
||||
MAINTAINER= hamradio@FreeBSD.org
|
||||
COMMENT= Narrow band digital voice
|
||||
|
||||
LIB_DEPENDS= libcodec2.so:${PORTSDIR}/audio/codec2 \
|
||||
libportaudio.so:${PORTSDIR}/audio/portaudio \
|
||||
libhamlib.so:${PORTSDIR}/comms/hamlib \
|
||||
libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
|
||||
libsox.so:${PORTSDIR}/audio/sox \
|
||||
libsndfile.so:${PORTSDIR}/audio/libsndfile \
|
||||
libspeexdsp.so:${PORTSDIR}/audio/speex
|
||||
|
||||
USE_WX= 3.0+
|
||||
USES= cmake:outsource compiler:c++11-lib tar:xz
|
||||
CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
|
||||
-DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
|
||||
-DUSE_STATIC_CODEC2=FALSE \
|
||||
-DUSE_STATIC_PORTAUDIO=FALSE \
|
||||
-DUSE_STATIC_SOX=FALSE \
|
||||
-DUSE_STATIC_SPEEXDSP=FALSE
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
comms/freedv/distinfo
Normal file
2
comms/freedv/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (freedv-1.1.tar.xz) = 3439930d73ebc9f58d39f4dff45356c3ee0e338a984e98ef8eb839eccaa44703
|
||||
SIZE (freedv-1.1.tar.xz) = 424420
|
24
comms/freedv/files/patch-CMakeLists.txt
Normal file
24
comms/freedv/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- CMakeLists.txt.orig 2015-09-24 19:30:57 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -72,7 +72,7 @@ endif()
|
||||
|
||||
|
||||
# Set default build flags.
|
||||
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
|
||||
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++11")
|
||||
|
||||
#
|
||||
# Setup cmake options
|
||||
@@ -339,6 +339,12 @@ if(NOT USE_STATIC_SOX)
|
||||
if(LIBSOX_LIBRARY AND LIBSOX_INCLUDE_DIR)
|
||||
list(APPEND FREEDV_LINK_LIBS ${LIBSOX_LIBRARY})
|
||||
include_directories(${LIBSOX_INCLUDE_DIR})
|
||||
+ message(STATUS "Looking for static sox...")
|
||||
+ find_library(STATIC_LIBSOX_LIBRARY libsox.a)
|
||||
+ message(STATUS " static sox library: ${STATIC_LIBSOX_LIBRARY}")
|
||||
+ if(STATIC_LIBSOX_LIBRARY)
|
||||
+ list(APPEND FREEDV_LINK_LIBS ${STATIC_LIBSOX_LIBRARY})
|
||||
+ endif(STATIC_LIBSOX_LIBRARY)
|
||||
else(LIBSOX_LIBRARY AND LIBSOX_INCLUDE_DIR)
|
||||
message(FATAL_ERROR "sox library not found.
|
||||
On Linux systems try installing:
|
9
comms/freedv/pkg-descr
Normal file
9
comms/freedv/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
FreeDV is a Digital Voice mode for HF radio. FreeDV allows any SSB radio
|
||||
to be used for low bit rate digital voice. Speech is compressed down to
|
||||
700-1600 bit/s then modulated onto a 1.25 kHz wide signal comprised of
|
||||
16 QPSK carriers which is sent to the Mic input of a SSB radio. The signal
|
||||
is received by an SSB radio, then demodulated and decoded by FreeDV. FreeDV
|
||||
700(B) rivals SSB in it's low SNR performance. At high SNRs FreeDV 1600
|
||||
sounds like FM, with no annoying analog HF radio noise.
|
||||
|
||||
WWW: http://freedv.org/tiki-index.php
|
6
comms/freedv/pkg-plist
Normal file
6
comms/freedv/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
bin/freedv
|
||||
share/applications/freedv.desktop
|
||||
share/icons/hicolor/128x128/apps/freedv.png
|
||||
share/icons/hicolor/256x256/apps/freedv.png
|
||||
share/icons/hicolor/48x48/apps/freedv.png
|
||||
share/icons/hicolor/64x64/apps/freedv.png
|
Loading…
Reference in a new issue