New port: biology/rampler: Standalone module for sampling genomic sequences
This commit is contained in:
parent
14a3d5e688
commit
3f71b2e05d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=562039
5 changed files with 66 additions and 0 deletions
|
@ -148,6 +148,7 @@
|
|||
SUBDIR += pyfasta
|
||||
SUBDIR += python-nexus
|
||||
SUBDIR += rainbow
|
||||
SUBDIR += rampler
|
||||
SUBDIR += recombine
|
||||
SUBDIR += ruby-bio
|
||||
SUBDIR += rubygem-bio
|
||||
|
|
26
biology/rampler/Makefile
Normal file
26
biology/rampler/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= rampler
|
||||
DISTVERSION= 2.0.0
|
||||
CATEGORIES= biology
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Standalone module for sampling genomic sequences
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= bioparser>0:biology/bioparser \
|
||||
${LOCALBASE}/include/biosoup/nucleic_acid.hpp:biology/biosoup
|
||||
|
||||
USES= cmake localbase
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= rvaser
|
||||
|
||||
LDFLAGS+= -lz
|
||||
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
|
||||
.include <bsd.port.mk>
|
3
biology/rampler/distinfo
Normal file
3
biology/rampler/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1611049494
|
||||
SHA256 (rvaser-rampler-2.0.0_GH0.tar.gz) = 3a589b1ce1c2a0ac55a105cdd185b5698b4a5f6c9e015e59edee56fd64261eb8
|
||||
SIZE (rvaser-rampler-2.0.0_GH0.tar.gz) = 5190
|
31
biology/rampler/files/patch-CMakeLists.txt
Normal file
31
biology/rampler/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,31 @@
|
|||
--- CMakeLists.txt.orig 2021-01-19 09:45:19 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -13,19 +13,20 @@ set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${PROJECT_BINARY_DI
|
||||
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/lib)
|
||||
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR}/bin)
|
||||
|
||||
-if (NOT TARGET bioparser)
|
||||
- add_subdirectory(vendor/bioparser EXCLUDE_FROM_ALL)
|
||||
-endif ()
|
||||
-if (NOT TARGET biosoup)
|
||||
- add_subdirectory(vendor/bioparser/vendor/biosoup EXCLUDE_FROM_ALL)
|
||||
-endif ()
|
||||
+#if (NOT TARGET bioparser)
|
||||
+# add_subdirectory(vendor/bioparser EXCLUDE_FROM_ALL)
|
||||
+#endif ()
|
||||
+#if (NOT TARGET biosoup)
|
||||
+# add_subdirectory(vendor/bioparser/vendor/biosoup EXCLUDE_FROM_ALL)
|
||||
+#endif ()
|
||||
|
||||
add_executable(${PROJECT_NAME}
|
||||
src/main.cpp
|
||||
src/sampler.cpp)
|
||||
target_link_libraries(${PROJECT_NAME}
|
||||
- bioparser
|
||||
- biosoup)
|
||||
+ #bioparser
|
||||
+ #biosoup
|
||||
+)
|
||||
target_compile_definitions(${PROJECT_NAME} PRIVATE
|
||||
RAMPLER_VERSION="v${PROJECT_VERSION}")
|
||||
|
5
biology/rampler/pkg-descr
Normal file
5
biology/rampler/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
Rampler is a standalone module for sampling genomic sequences. It supports two
|
||||
modes, random subsampling of sequencing data to a desired depth (given the
|
||||
reference length) and file splitting to desired size in bytes.
|
||||
|
||||
WWW: https://github.com/rvaser/rampler
|
Loading…
Reference in a new issue