. Update to 2.1.0.

. Quieten seach and replace.
. Remove a warning message that is no longer relevant.
This commit is contained in:
Greg Lewis 2005-05-18 16:43:39 +00:00
parent 4dae3c2d51
commit 3fab73f163
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=135557
4 changed files with 58 additions and 28 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= afterstep
PORTVERSION= 2.00.05
PORTVERSION= 2.1.0
CATEGORIES= x11-wm afterstep
MASTER_SITES= ftp://ftp.afterstep.org/stable/ \
${MASTER_SITE_SOURCEFORGE}
@ -42,7 +42,7 @@ CONFIGURE_ARGS+=--enable-i18n \
MAKE_ENV= INCS_PRIVATE="${CPPFLAGS}" LIBS_PRIVATE="${LDFLAGS}"
MAN1= ASDatabase.1x ASDatabaseEntry.1x AfterStep.1x Align.1x \
Animate.1x AnimateTypes.1x Audio.1x AudioEvents.1x \
Animate.1x AnimateTypes.1x Arrange.1x Audio.1x AudioEvents.1x \
AutoExec.1x Base.1x Bevel.1x ColorScheme.1x Feel.1x \
FeelWindowBox.1x Functions.1x Gravity.1x Look.1x \
MyBackground.1x MyFrame.1x MyStyle.1x Pager.1x \
@ -73,27 +73,20 @@ post-extract:
post-patch:
.for file in afterstep/database
${PERL} -pi -e 's,linux-penguin,monitor-bsd,' \
@${PERL} -pi -e 's,linux-penguin,monitor-bsd,' \
${WRKSRC}/${file}
.endfor
.for file in libAfterBase/Makefile.in libAfterImage/Makefile.in
${PERL} -pi.orig -e 's,^install\.,noinstall.,g ; \
@${PERL} -pi.orig -e 's,^install\.,noinstall.,g ; \
s,^install:,install:#,g' ${WRKSRC}/${file}
.endfor
.for file in libAfterBase/configure libAfterImage/configure
${PERL} -pi.orig -e 's,="-O3",="$$CFLAGS",g' \
@${PERL} -pi.orig -e 's,="-O3",="$$CFLAGS",g' \
${WRKSRC}/${file}
.endfor
.for file in libAfterStep/afterstep-config.in
${PERL} -pi -e 's,ft_version,libafterstep_version,g' \
@${PERL} -pi -e 's,ft_version,libafterstep_version,g' \
${WRKSRC}/${file}
.endfor
post-install:
.if defined(WITH_DIFFERENT_LOOKNFEELS)
@${ECHO_MSG} ""
@${ECHO_MSG} "===> The WinList module is broken with different-looknfeels. Don't use it."
@${ECHO_MSG} ""
.endif
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
MD5 (AfterStep-2.00.05.tar.bz2) = 7b3753f9b272bf96bb081221fdc3b33b
SIZE (AfterStep-2.00.05.tar.bz2) = 4997596
MD5 (AfterStep-2.1.0.tar.bz2) = b2dba216770c322aadf3953bae1502d7
SIZE (AfterStep-2.1.0.tar.bz2) = 5004033

View file

@ -1,8 +1,28 @@
$FreeBSD$
--- src/Arrange/Arrange.c.orig Wed May 4 14:15:17 2005
+++ src/Arrange/Arrange.c Wed May 4 14:16:39 2005
@@ -457,11 +457,12 @@
--- src/Arrange/Arrange.c.orig Wed May 18 10:38:10 2005
+++ src/Arrange/Arrange.c Wed May 18 10:39:48 2005
@@ -488,15 +488,14 @@
{
int buf_size = 256;
char buf[buf_size];
-
- ASWindowData *wd = fetch_window_by_id( ((client_item *) data)->cl );
- if(!wd)
- return True;
-
/* used by SendNumCommand */
send_signed_data_type vals[2] ;
send_signed_data_type units[2] ;
+ ASWindowData *wd = fetch_window_by_id( ((client_item *) data)->cl );
+ if(!wd)
+ return True;
+
if(! window_is_suitable( wd ))
return True; /* Next window please */
@@ -550,6 +549,7 @@
void
tile_windows()
{
@ -10,20 +30,24 @@ $FreeBSD$
int n_windows = 0;
iterate_asbidirlist( ArrangeState.clients_order,
count_managed_windows, &n_windows, NULL, False);
@@ -561,7 +561,7 @@
if(ArrangeState.count == 0)
ArrangeState.count = n_windows; /*Put all elements in one group*/
- int n_groups = ArrangeState.clients_order->count / ArrangeState.count;
+ n_groups = ArrangeState.clients_order->count / ArrangeState.count;
if(ArrangeState.clients_order->count % ArrangeState.count)
n_groups++;
@@ -505,12 +506,11 @@
Bool
cascade_window(void *data, void *aux_data)
- int n_groups = n_windows / ArrangeState.count;
+ n_groups = n_windows / ArrangeState.count;
/* If not all windows fit in n_groups groups, an
* extra group for remaining windows is needed.*/
if(n_windows % ArrangeState.count)
@@ -614,13 +614,12 @@
{
int buf_size = 256;
char buf[buf_size];
+ send_signed_data_type vals[2] ;
+ send_signed_data_type units[2] ;
ASWindowData *wd = fetch_window_by_id( ((client_item *) data)->cl );
if(wd == NULL)
if(!wd)
return True;
-
- send_signed_data_type vals[2] ;

View file

@ -192,6 +192,10 @@ lib/libAfterStep.a
%%DATADIR%%/desktop/bars/ostx
%%DATADIR%%/desktop/bars/ostxs
%%DATADIR%%/desktop/bars/ostxu
%%DATADIR%%/desktop/bars/postcard_maybe
%%DATADIR%%/desktop/bars/postcard_msg
%%DATADIR%%/desktop/bars/postcard_no
%%DATADIR%%/desktop/bars/postcard_yes
%%DATADIR%%/desktop/bars/red
%%DATADIR%%/desktop/bars/south
%%DATADIR%%/desktop/bars/southeast
@ -872,6 +876,7 @@ lib/libAfterStep.a
%%DATADIR%%/doc/html/Align.html
%%DATADIR%%/doc/html/Animate.html
%%DATADIR%%/doc/html/AnimateTypes.html
%%DATADIR%%/doc/html/Arrange.html
%%DATADIR%%/doc/html/Audio.html
%%DATADIR%%/doc/html/AudioEvents.html
%%DATADIR%%/doc/html/AutoExec.html
@ -1077,6 +1082,14 @@ lib/libAfterStep.a
%%DATADIR%%/doc/html/data/desktop/bars/ostxs.png
%%DATADIR%%/doc/html/data/desktop/bars/ostxu.html
%%DATADIR%%/doc/html/data/desktop/bars/ostxu.png
%%DATADIR%%/doc/html/data/desktop/bars/postcard_maybe.html
%%DATADIR%%/doc/html/data/desktop/bars/postcard_maybe.png
%%DATADIR%%/doc/html/data/desktop/bars/postcard_msg.html
%%DATADIR%%/doc/html/data/desktop/bars/postcard_msg.png
%%DATADIR%%/doc/html/data/desktop/bars/postcard_no.html
%%DATADIR%%/doc/html/data/desktop/bars/postcard_no.png
%%DATADIR%%/doc/html/data/desktop/bars/postcard_yes.html
%%DATADIR%%/doc/html/data/desktop/bars/postcard_yes.png
%%DATADIR%%/doc/html/data/desktop/bars/red.html
%%DATADIR%%/doc/html/data/desktop/bars/red.png
%%DATADIR%%/doc/html/data/desktop/bars/south.html
@ -3043,6 +3056,6 @@ share/xsessions/AfterStep.desktop
@dirrm %%DATADIR%%/backgrounds/Mirrored_Tiles
@dirrm %%DATADIR%%/backgrounds/Gradient_Textures
@dirrm %%DATADIR%%/backgrounds
@dirrm share/afterstep
@dirrm %%DATADIR%%
@dirrm include/libAfterStep
@dirrm include/libAfterConf