Stage, and pull the patches into a sed command.
This commit is contained in:
parent
ae8a2ea5c2
commit
3facf74bef
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=363321
4 changed files with 7 additions and 75 deletions
|
@ -11,10 +11,12 @@ MAINTAINER= ports@FreeBSD.org
|
|||
COMMENT= Checkout and build ports and all depending ports
|
||||
|
||||
USES= shebangfix perl5
|
||||
SHEBANG_FILES= portcheckout.pl
|
||||
MAN1= portcheckout.1
|
||||
MANCOMPRESSED= maybe
|
||||
PLIST_FILES= bin/portcheckout
|
||||
SHEBANG_FILES= ${PORTNAME}.pl
|
||||
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's/cvs checkout/& -P/g; \
|
||||
s/\(exec\) \(pod2text\)/\1 "\2"/;' \
|
||||
${WRKSRC}/${PORTNAME}.pl
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
--- portcheckout.pl-- Tue Oct 24 13:04:07 2000
|
||||
+++ portcheckout.pl Tue Oct 24 13:04:35 2000
|
||||
@@ -94,14 +94,14 @@
|
||||
PORTSDIR="/tmp/ports"; export PORTSDIR
|
||||
|
||||
# checkout FreeBSD ports system Makefiles
|
||||
- cvs checkout ports/Mk
|
||||
+ cvs checkout -P ports/Mk
|
||||
|
||||
##################################################
|
||||
# checkout port: de-dict-1.1
|
||||
- cvs checkout ports/german/dict
|
||||
+ cvs checkout -P ports/german/dict
|
||||
|
||||
# de-dict-1.1 depend on port: agrep-2.04
|
||||
- cvs checkout ports/textproc/agrep
|
||||
+ cvs checkout -P ports/textproc/agrep
|
||||
|
||||
##################################################
|
||||
# Compile and install de-dict-1.1
|
||||
@@ -328,7 +328,7 @@
|
||||
#print qq{DISTDIR="/usr/ports/distfiles"; export DISTDIR\n};
|
||||
|
||||
print "\n# checkout FreeBSD ports system Makefiles\n";
|
||||
-print "cvs checkout $release ports/Mk\n\n";
|
||||
+print "cvs checkout -P $release ports/Mk\n\n";
|
||||
|
||||
|
||||
# list of dependings ports
|
||||
@@ -338,7 +338,7 @@
|
||||
|
||||
print "#" x 50, "\n";
|
||||
print "# checkout port: $distributionname\n";
|
||||
- print "cvs checkout $release ", $obj->{$distributionname}{portpath}, "\n\n";
|
||||
+ print "cvs checkout -P $release ", $obj->{$distributionname}{portpath}, "\n\n";
|
||||
|
||||
$ports_depends{$distributionname} = 1;
|
||||
foreach my $depends (
|
||||
@@ -355,7 +355,7 @@
|
||||
$ports_depends{$depends} = 1;
|
||||
|
||||
print "# $distributionname depend on port: $depends\n";
|
||||
- print "cvs checkout $release ", $obj->{$depends}{portpath}, "\n\n";
|
||||
+ print "cvs checkout -P $release ", $obj->{$depends}{portpath}, "\n\n";
|
||||
}
|
||||
}
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
--- portcheckout.pl.old Thu Jul 31 02:23:39 2003
|
||||
+++ portcheckout.pl Thu Jul 31 02:24:54 2003
|
||||
@@ -328,7 +328,8 @@
|
||||
#print qq{DISTDIR="/usr/ports/distfiles"; export DISTDIR\n};
|
||||
|
||||
print "\n# checkout FreeBSD ports system Makefiles\n";
|
||||
-print "cvs checkout -P $release ports/Mk\n\n";
|
||||
+print "cvs checkout -P $release ports/Mk\n";
|
||||
+print "cvs checkout -P $release ports/Templates\n\n";
|
||||
|
||||
|
||||
# list of dependings ports
|
|
@ -1,11 +0,0 @@
|
|||
--- portcheckout.pl 2011/12/12 09:40:17 1.1
|
||||
+++ portcheckout.pl 2011/12/12 09:40:29
|
||||
@@ -182,7 +182,7 @@
|
||||
# print manual page to stdout
|
||||
sub help {
|
||||
$ENV{'PAGER'} = 'cat';
|
||||
- exec pod2text, $0;
|
||||
+ exec "pod2text", $0;
|
||||
exit 2;
|
||||
}
|
||||
|
Loading…
Reference in a new issue