Update to version 2.0.9

PR:		ports/67963
Submitted by:	maintainer
This commit is contained in:
Kirill Ponomarev 2004-06-20 07:13:50 +00:00
parent bf3fff33fe
commit 3fd24b3e84
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111838
7 changed files with 150 additions and 80 deletions

View file

@ -6,53 +6,49 @@
#
PORTNAME= ftgl
PORTVERSION= 2.07
PORTREVISION= 1
PORTVERSION= 2.09
CATEGORIES= graphics
MASTER_SITES= http://homepages.paradise.net.nz/henryj/code/
DISTNAME= ${PORTNAME:U}
DISTNAME= ${PORTNAME}-${PORTVERSION:C/([[:digit:]])$/.\1/}
MAINTAINER= tiamat@comset.net
COMMENT= An OpenGL FreeType fonts rendering library
BUILD_DEPENDS= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_GMAKE= yes
USE_GL= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}/unix
WRKSRC= ${WRKDIR}/${PORTNAME:U}
CONFIGURE_WRKSRC= ${WRKSRC}/unix
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-gl-inc=${X11BASE}/include --with-gl-lib=${X11BASE}/lib
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALLS_SHLIB= yes
MAKE_ENV= MKDIR="${MKDIR}"
do-install:
${INSTALL_DATA} ${INSTALL_WRKSRC}/src/.libs/lib${PORTNAME}.a ${PREFIX}/lib
${INSTALL_DATA} ${INSTALL_WRKSRC}/${PORTNAME}.pc ${PREFIX}/libdata/pkgconfig
@${MKDIR} ${PREFIX}/include/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/${PORTNAME}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
${PERL} -pi -e 's|%%CC%%|${CC}|g; \
s|%%CXX%%|${CXX}|g; \
s|%%RM%%|${RM}|g; \
s|%%CFLAGS%%|${CFLAGS}|g; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g; \
s|%%PREFIX%%|${PREFIX}|g; \
s|%%X11BASE%%|${X11BASE}|g; \
s|%%LOCALBASE%%|${LOCALBASE}|g' \
<${FILESDIR}/makefile.ex >${EXAMPLESDIR}/makefile
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/FTGL.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/FTGL_1_3.gif ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/images
${INSTALL_DATA} ${WRKSRC}/docs/images/* ${DOCSDIR}/images
.ifdef (NOPORTDOCS)
DO_INSTALL_DOCS=\#
.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%PORTDOCS%%|${DO_INSTALL_DOCS}|' \
${BUILD_WRKSRC}/Makefile
post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
@${SED} -e 's|%%CC%%|${CC}|g; \
s|%%CXX%%|${CXX}|g; \
s|%%RM%%|${RM}|g; \
s|%%CFLAGS%%|${CFLAGS}|g; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g; \
s|%%PREFIX%%|${PREFIX}|g; \
s|%%X11BASE%%|${X11BASE}|g; \
s|%%LOCALBASE%%|${LOCALBASE}|g' \
<${FILESDIR}/makefile.ex >${EXAMPLESDIR}/makefile
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
MD5 (FTGL.tar.gz) = 62d363867d4906a428640e661c97f74f
SIZE (FTGL.tar.gz) = 569505
MD5 (ftgl-2.0.9.tar.gz) = 2268267277c0655688879d0657b82650
SIZE (ftgl-2.0.9.tar.gz) = 561543

View file

@ -1,11 +1,13 @@
# Make sure, that you have graphics/libglut installed
# in order to build example program
#
# $FreeBSD$
CC= %%CC%%
CXX= %%CXX%%
RM= %%RM%%
CFLAGS= %%CFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/ftgl
CXXFLAGS= %%CXXFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/ftgl
CFLAGS= %%CFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/FTGL
CXXFLAGS= %%CXXFLAGS%% -I. -I%%X11BASE%%/include -I%%PREFIX%%/include/FTGL
LDFLAGS= -L%%X11BASE%%/lib -L%%PREFIX%%/lib -lglut -lftgl
FREETYPE_CFLAGS!=%%LOCALBASE%%/bin/freetype-config --cflags

View file

@ -1,11 +0,0 @@
--- src/FTFace.cpp.orig Fri Jan 16 13:23:11 2004
+++ src/FTFace.cpp Fri Jan 16 13:23:23 2004
@@ -62,7 +62,7 @@
{
FT_Open_Args open;
- open.flags = (FT_Open_Flags)1; // FT_OPEN_MEMORY;
+ open.flags = /*(FT_Open_Flags)*/1; // FT_OPEN_MEMORY;
open.memory_base = (FT_Byte *)pBufferBytes;
open.memory_size = bufferSizeInBytes;

View file

@ -0,0 +1,22 @@
--- unix/Makefile.orig Mon Jan 13 00:27:04 2003
+++ unix/Makefile Thu Jun 17 17:20:29 2004
@@ -1,7 +1,7 @@
top_builddir=.
-include $(top_builddir)/Make.conf
-SUBDIRS = src demo docs
+SUBDIRS = src demo %%PORTDOCS%%docs
AUTOGEN = Make.conf config.log config.status libtool autom4te.cache ftgl.pc
AUTOGEN_MAINT = aclocal.m4 acinclude.m4 config.guess config.sub configure ltmain.sh install-sh
@@ -16,8 +16,8 @@
./configure
install-local: ftgl.pc
- $(INSTALL) -d -m 0755 $(libdir)/pkgconfig
- $(INSTALL) -m 0644 ftgl.pc $(libdir)/pkgconfig/
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+ $(INSTALL) -m 0644 ftgl.pc ${PREFIX}/libdata/pkgconfig/
maint-clean-local:
$(RM) $(AUTOGEN_MAINT)

View file

@ -0,0 +1,13 @@
--- unix/src/Makefile.orig Tue Jun 15 11:39:46 2004
+++ unix/src/Makefile Tue Jun 15 11:40:03 2004
@@ -75,8 +75,8 @@
install-local: libftgl.la
$(INSTALL) -d -m 0755 $(libdir)
$(LIBTOOL) --mode=install $(INSTALL) -m 0644 $(TARGET) $(libdir)
- $(INSTALL) -d -m 0755 $(includedir)/FTGL
- $(INSTALL) -m 0644 $(HEADER_FILES) $(includedir)/FTGL
+ $(INSTALL) -d -m 0755 $(includedir)/FTGL
+ $(INSTALL) -m 0644 $(HEADER_FILES) $(includedir)/FTGL
clean-local:

View file

@ -1,32 +1,32 @@
include/ftgl/FTBBox.h
include/ftgl/FTBitmapGlyph.h
include/ftgl/FTCharToGlyphIndexMap.h
include/ftgl/FTCharmap.h
include/ftgl/FTContour.h
include/ftgl/FTExtrdGlyph.h
include/ftgl/FTFace.h
include/ftgl/FTFont.h
include/ftgl/FTGL.h
include/ftgl/FTGLBitmapFont.h
include/ftgl/FTGLExtrdFont.h
include/ftgl/FTGLOutlineFont.h
include/ftgl/FTGLPixmapFont.h
include/ftgl/FTGLPolygonFont.h
include/ftgl/FTGLTextureFont.h
include/ftgl/FTGlyph.h
include/ftgl/FTGlyphContainer.h
include/ftgl/FTLibrary.h
include/ftgl/FTList.h
include/ftgl/FTOutlineGlyph.h
include/ftgl/FTPixmapGlyph.h
include/ftgl/FTPoint.h
include/ftgl/FTPolyGlyph.h
include/ftgl/FTSize.h
include/ftgl/FTTextureGlyph.h
include/ftgl/FTVector.h
include/ftgl/FTVectoriser.h
@dirrm include/ftgl
include/FTGL/FTBBox.h
include/FTGL/FTBitmapGlyph.h
include/FTGL/FTCharToGlyphIndexMap.h
include/FTGL/FTCharmap.h
include/FTGL/FTContour.h
include/FTGL/FTExtrdGlyph.h
include/FTGL/FTFace.h
include/FTGL/FTFont.h
include/FTGL/FTGL.h
include/FTGL/FTGLBitmapFont.h
include/FTGL/FTGLExtrdFont.h
include/FTGL/FTGLOutlineFont.h
include/FTGL/FTGLPixmapFont.h
include/FTGL/FTGLPolygonFont.h
include/FTGL/FTGLTextureFont.h
include/FTGL/FTGlyph.h
include/FTGL/FTGlyphContainer.h
include/FTGL/FTLibrary.h
include/FTGL/FTList.h
include/FTGL/FTOutlineGlyph.h
include/FTGL/FTPixmapGlyph.h
include/FTGL/FTPoint.h
include/FTGL/FTPolyGlyph.h
include/FTGL/FTSize.h
include/FTGL/FTTextureGlyph.h
include/FTGL/FTVector.h
include/FTGL/FTVectoriser.h
lib/libftgl.a
lib/libftgl.la
libdata/pkgconfig/ftgl.pc
%%EXAMPLESDIR%%/makefile
%%EXAMPLESDIR%%/tb.c
@ -35,11 +35,59 @@ libdata/pkgconfig/ftgl.pc
%%EXAMPLESDIR%%/tb.h
%%EXAMPLESDIR%%/trackball.h
%%EXAMPLESDIR%%/README.txt
@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/images/ftgldemo.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/metrics.png
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
%%PORTDOCS%%%%DOCSDIR%%/FTGL_1_3.gif
%%PORTDOCS%%%%DOCSDIR%%/FTGL.html
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/html/FTBitmapGlyph_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTBitmapGlyph_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTCharmap_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTCharmap_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTContour_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTContour_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTExtrdGlyph_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTExtrdGlyph_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTFace_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTFace_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTFont_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTFont_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLBitmapFont_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLBitmapFont_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLExtrdFont_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLExtrdFont_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLOutlineFont_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLOutlineFont_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPixmapFont_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPixmapFont_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPolygonFont_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLPolygonFont_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLTextureFont_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGLTextureFont_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyphContainer_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyphContainer_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyph_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTGlyph_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTLibrary_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTLibrary_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTOutlineGlyph_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTOutlineGlyph_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTPixmapGlyph_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTPixmapGlyph_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTPoint_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTPoint_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTPolyGlyph_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTPolyGlyph_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTSize_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTSize_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTTextureGlyph_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTTextureGlyph_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTVectoriser_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/html/FTVectoriser_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/html/files.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_func.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_vars.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@unexec rmdir %D/libdata/pkgconfig 2>/dev/null || true
@dirrm include/FTGL
@dirrm %%EXAMPLESDIR%%