irc/anope: Update to 2.0.5

Modernize port options
Fix building with MySQL
Add new REDIS option

Changelog:	a9bf251886/docs/Changes

MFH:		2017Q2
This commit is contained in:
Mark Felder 2017-06-09 13:55:01 +00:00
parent 507bd26160
commit 40338eb384
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=442989
4 changed files with 55 additions and 105 deletions

View file

@ -2,8 +2,8 @@
# $FreeBSD$ # $FreeBSD$
PORTNAME= anope PORTNAME= anope
PORTVERSION= 2.0.2 PORTVERSION= 2.0.5
PORTREVISION= 2 PORTREVISION= 0
CATEGORIES= irc CATEGORIES= irc
MAINTAINER= feld@FreeBSD.org MAINTAINER= feld@FreeBSD.org
@ -13,7 +13,7 @@ LICENSE= GPLv2
USES= cmake:outsource shebangfix USES= cmake:outsource shebangfix
CMAKE_ARGS+= -DINSTDIR:STRING="${LOCALBASE}/anope" CMAKE_ARGS+= -DINSTDIR:STRING="${LOCALBASE}/anope"
CPPFLAGS+= "-I${LOCALBASE}/include" CXXFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib" LDFLAGS+= "-L${LOCALBASE}/lib"
SHEBANG_FILES= ${WRKSRC}/src/tools/*.sh SHEBANG_FILES= ${WRKSRC}/src/tools/*.sh
@ -23,84 +23,35 @@ USE_RC_SUBR= anope
SUB_FILES= pkg-message SUB_FILES= pkg-message
OPTIONS_DEFINE= GNUTLS LDAP MYSQL NLS OPENSSL PCRE POSIX SASL SQLITE STATS TRE OPTIONS_DEFINE= GNUTLS LDAP MYSQL NLS OPENSSL PCRE POSIX REDIS SASL SQLITE STATS TRE
OPTIONS_DEFAULT= MYSQL OPENSSL POSIX OPTIONS_DEFAULT= MYSQL OPENSSL POSIX
OPTIONS_SUB= yes
POSIX_DESC= POSIX Regex Module POSIX_DESC= POSIX Regex Module
STATS_DESC= Channel Statistics Module STATS_DESC= Channel Statistics Module
TRE_DESC= Tre Regex Module TRE_DESC= Tre Regex Module
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
LDAP_VARS_ON= USE_OPENLDAP=yes
MYSQL_USES= mysql
NLS_USES= gettext NLS_USES= gettext
OPENSSL_USES= ssl
REDIS_RUN_DEPENDS= redis:databases/redis
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SQLITE_USES= sqlite
TRE_LIB_DEPENDS= libtre.so:textproc/libtre
.include <bsd.port.options.mk> .include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNUTLS}
PLIST_SUB+= GNUTLS=""
LIB_DEPENDS+= libgnutls.so:security/gnutls
.else
PLIST_SUB+= GNUTLS="@comment "
.endif
.if ${PORT_OPTIONS:MLDAP}
PLIST_SUB+= LDAP=""
USE_OPENLDAP= yes
.else
PLIST_SUB+= LDAP="@comment "
.endif
.if ${PORT_OPTIONS:MMYSQL}
PLIST_SUB+= MYSQL=""
USE_MYSQL= yes
.else
PLIST_SUB+= MYSQL="@comment "
.endif
.if ${PORT_OPTIONS:MOPENSSL}
PLIST_SUB+= OPENSSL=""
USES+= ssl
.else
PLIST_SUB+= OPENSSL="@comment "
.endif
.if ${PORT_OPTIONS:MPCRE}
PLIST_SUB+= PCRE=""
LIB_DEPENDS+= libpcre.so:devel/pcre
.else
PLIST_SUB+= PCRE="@comment "
.endif
.if ${PORT_OPTIONS:MPOSIX}
PLIST_SUB+= POSIX=""
.else
PLIST_SUB+= POSIX="@comment "
.endif
.if ${PORT_OPTIONS:MSASL}
PLIST_SUB+= SASL=""
LIB_DEPENDS+= libsasl2.so:security/cyrus-sasl2
.else
PLIST_SUB+= SASL="@comment "
.endif
.if ${PORT_OPTIONS:MSQLITE}
PLIST_SUB+= SQLITE=""
USES+= sqlite
.else
PLIST_SUB+= SQLITE="@comment "
.endif
.if ${PORT_OPTIONS:MSTATS}
PLIST_SUB+= STATS=""
.else
PLIST_SUB+= STATS="@comment "
.endif
.if ${PORT_OPTIONS:MTRE}
PLIST_SUB+= TRE=""
LIB_DEPENDS+= libtre.so:textproc/libtre
.else
PLIST_SUB+= TRE="@comment "
.endif
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
# XXX Add here other arch which needs -fPIC :-) # XXX Add here other arch which needs -fPIC :-)

View file

@ -1,2 +1,3 @@
SHA256 (anope-anope-2.0.2_GH0.tar.gz) = 15e041bf3ebe0c86002e41162e98beb9276a910ef43628c46b58ae0a230401e2 TIMESTAMP = 1497014744
SIZE (anope-anope-2.0.2_GH0.tar.gz) = 1764564 SHA256 (anope-anope-2.0.5_GH0.tar.gz) = acfaa189b05a08108838dcdd6dc6c445cc437861911a7c922599eb7b862f3109
SIZE (anope-anope-2.0.5_GH0.tar.gz) = 1779920

View file

@ -1,27 +1,24 @@
--- CMakeLists.txt.orig 2015-03-22 19:34:50 UTC --- CMakeLists.txt.orig 2017-06-09 13:48:41 UTC
+++ CMakeLists.txt +++ CMakeLists.txt
@@ -485,17 +485,17 @@ get_target_property(SERVICES_BINARY ${PR @@ -489,16 +489,16 @@ get_target_property(SERVICES_BINARY ${PR
get_filename_component(SERVICES_BINARY ${SERVICES_BINARY} NAME) get_filename_component(SERVICES_BINARY ${SERVICES_BINARY} NAME)
# At install time, create the following additional directories # At install time, create the following additional directories
-install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/backups\")") -install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/backups\")")
-install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${LOGS_DIR}\")") -install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${LOGS_DIR}\")")
+#install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/backups\")") +#install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/backups\")")
+#install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${LOGS_DIR}\")") +#install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${LOGS_DIR}\")")
if(WIN32) if(WIN32)
install(CODE "file(MAKE_DIRECTORY \"\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/runtime\")") install(CODE "file(MAKE_DIRECTORY \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/${DB_DIR}/runtime\")")
endif(WIN32) endif(WIN32)
# On non-Windows platforms, if RUNGROUP is set, change the permissions of the below directories, as well as the group of the data directory # On non-Windows platforms, if RUNGROUP is set, change the permissions of the below directories, as well as the group of the data directory
-if(NOT WIN32 AND RUNGROUP) if(NOT WIN32 AND RUNGROUP)
- install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\${CMAKE_INSTALL_PREFIX}/\${DB_DIR}/backups\")") - install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${DB_DIR}/backups\")")
- install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\${CMAKE_INSTALL_PREFIX}/\${LOGS_DIR}\")") - install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${LOGS_DIR}\")")
- install(CODE "execute_process(COMMAND ${CHGRP} -R ${RUNGROUP} \"\${CMAKE_INSTALL_PREFIX}\")") - install(CODE "execute_process(COMMAND ${CHGRP} -R ${RUNGROUP} \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}\")")
-endif(NOT WIN32 AND RUNGROUP) +# install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${DB_DIR}/backups\")")
+#if(NOT WIN32 AND RUNGROUP) +# install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}/\${LOGS_DIR}\")")
+# install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\${CMAKE_INSTALL_PREFIX}/\${DB_DIR}/backups\")") +# install(CODE "execute_process(COMMAND ${CHGRP} -R ${RUNGROUP} \"\$ENV{DESTDIR}\${CMAKE_INSTALL_PREFIX}\")")
+# install(CODE "execute_process(COMMAND ${CHMOD} 2775 \"\${CMAKE_INSTALL_PREFIX}/\${LOGS_DIR}\")") endif(NOT WIN32 AND RUNGROUP)
+# install(CODE "execute_process(COMMAND ${CHGRP} -R ${RUNGROUP} \"\${CMAKE_INSTALL_PREFIX}\")")
+#endif(NOT WIN32 AND RUNGROUP)
# On Windows platforms, install extra files # On Windows platforms, install extra files
if(WIN32) if(WIN32)
install(FILES ${Anope_SOURCE_DIR}/src/win32/anope.bat

View file

@ -202,21 +202,22 @@ anope/lib/modules/os_sxline.so
anope/lib/modules/os_update.so anope/lib/modules/os_update.so
anope/lib/modules/plexus.so anope/lib/modules/plexus.so
anope/lib/modules/ratbox.so anope/lib/modules/ratbox.so
anope/lib/modules/unreal4.so
anope/lib/modules/unreal.so anope/lib/modules/unreal.so
anope/lib/modules/webcpanel.so anope/lib/modules/webcpanel.so
anope/locale/ca_ES/LC_MESSAGES/anope.mo %%NLS%%anope/locale/ca_ES/LC_MESSAGES/anope.mo
anope/locale/de_DE/LC_MESSAGES/anope.mo %%NLS%%anope/locale/de_DE/LC_MESSAGES/anope.mo
anope/locale/el_GR/LC_MESSAGES/anope.mo %%NLS%%anope/locale/el_GR/LC_MESSAGES/anope.mo
anope/locale/en_US/LC_MESSAGES/anope.mo %%NLS%%anope/locale/en_US/LC_MESSAGES/anope.mo
anope/locale/es_ES/LC_MESSAGES/anope.mo %%NLS%%anope/locale/es_ES/LC_MESSAGES/anope.mo
anope/locale/fr_FR/LC_MESSAGES/anope.mo %%NLS%%anope/locale/fr_FR/LC_MESSAGES/anope.mo
anope/locale/hu_HU/LC_MESSAGES/anope.mo %%NLS%%anope/locale/hu_HU/LC_MESSAGES/anope.mo
anope/locale/it_IT/LC_MESSAGES/anope.mo %%NLS%%anope/locale/it_IT/LC_MESSAGES/anope.mo
anope/locale/nl_NL/LC_MESSAGES/anope.mo %%NLS%%anope/locale/nl_NL/LC_MESSAGES/anope.mo
anope/locale/pl_PL/LC_MESSAGES/anope.mo %%NLS%%anope/locale/pl_PL/LC_MESSAGES/anope.mo
anope/locale/pt_PT/LC_MESSAGES/anope.mo %%NLS%%anope/locale/pt_PT/LC_MESSAGES/anope.mo
anope/locale/ru_RU/LC_MESSAGES/anope.mo %%NLS%%anope/locale/ru_RU/LC_MESSAGES/anope.mo
anope/locale/tr_TR/LC_MESSAGES/anope.mo %%NLS%%anope/locale/tr_TR/LC_MESSAGES/anope.mo
@dir(nobody,,) anope/data/backups @dir(nobody,,) anope/data/backups
@dir(nobody,,) anope/data @dir(nobody,,) anope/data
@dir(nobody,,) anope/logs @dir(nobody,,) anope/logs