Use hack to unsetenv SunOS 3.2 TTY compatibility

as this broke the build on 7.x which still have it.

Submitted by:	pluknet@ (via private mail)
This commit is contained in:
Baptiste Daroussin 2012-07-24 11:33:20 +00:00
parent a80c248464
commit 404ade345a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=301452
2 changed files with 14 additions and 7 deletions

View file

@ -33,10 +33,4 @@ CMAKE_ARGS+= -DNLS_ENABLED=false
PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800000
BROKEN= does not compile on FreeBSD 7.X
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -0,0 +1,13 @@
--- src/util.c.orig 2012-07-24 13:34:08.000000000 +0400
+++ src/util.c 2012-07-24 13:34:29.000000000 +0400
@@ -48,6 +48,10 @@
#include <libintl.h>
#endif
+#ifdef TIOCGSIZE
+#undef TIOCGSIZE
+#endif
+
/*
* Return the longest of the two parameters
* @a: first element to compare