Add compiz-fusion-plugins-main, the main set of plugins for Compiz.
PR: ports/115705 Submitted by: Robert Noland <rnoland@2hip.net>
This commit is contained in:
parent
fcabad1176
commit
408b9025b1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=198130
11 changed files with 321 additions and 0 deletions
|
@ -28,6 +28,7 @@
|
|||
SUBDIR += boxtools
|
||||
SUBDIR += clementine
|
||||
SUBDIR += compiz
|
||||
SUBDIR += compiz-fusion-plugins-main
|
||||
SUBDIR += ctwm
|
||||
SUBDIR += devilspie
|
||||
SUBDIR += dwm
|
||||
|
|
37
x11-wm/compiz-fusion-plugins-main/Makefile
Normal file
37
x11-wm/compiz-fusion-plugins-main/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# New ports collection makefile for: compiz-fusion-plugins-main
|
||||
# Date created: 2007-08-15
|
||||
# Whom: Robert Noland <rnoland@2hip.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= compiz-fusion-plugins-main
|
||||
PORTVERSION= 0.5.2
|
||||
#PORTREVISION= 0
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
|
||||
|
||||
MAINTAINER= rnoland@2hip.net
|
||||
COMMENT= Plugins for Compiz Composite Window Manager
|
||||
|
||||
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
|
||||
pangocairo-1.0:${PORTSDIR}/x11-toolkits/pango
|
||||
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz \
|
||||
${LOCALBASE}/libdata/pkgconfig/bcop.pc:${PORTSDIR}/devel/compiz-bcop
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GL= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack
|
||||
USE_XORG= glproto
|
||||
USE_GETTEXT= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
3
x11-wm/compiz-fusion-plugins-main/distinfo
Normal file
3
x11-wm/compiz-fusion-plugins-main/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (compiz-fusion-plugins-main-0.5.2.tar.bz2) = cb5703d8e59697dd6c7b075c483e81cc
|
||||
SHA256 (compiz-fusion-plugins-main-0.5.2.tar.bz2) = 72f32fe4ee5ad0a04899b10a598573d08bff728802832e04da48d5e9ad2ceaf8
|
||||
SIZE (compiz-fusion-plugins-main-0.5.2.tar.bz2) = 606991
|
|
@ -0,0 +1,28 @@
|
|||
--- src/text/text.c.orig 2007-08-12 15:51:59.000000000 -0400
|
||||
+++ src/text/text.c 2007-08-17 22:31:24.000000000 -0400
|
||||
@@ -75,7 +75,11 @@
|
||||
return NULL;
|
||||
}
|
||||
|
||||
- retval = strndup (val, nitems);
|
||||
+ if ((retval = (char *) malloc(nitems + 1)) != NULL) {
|
||||
+ bzero (retval, nitems + 1);
|
||||
+ strncpy (retval, val, nitems);
|
||||
+ }
|
||||
+
|
||||
XFree (val);
|
||||
|
||||
return retval;
|
||||
@@ -92,7 +96,11 @@
|
||||
text.nitems = 0;
|
||||
if (XGetTextProperty (d->display, id, &text, atom))
|
||||
{
|
||||
- retval = strndup ((char *)text.value,text.nitems);
|
||||
+ if ((retval = (char *) malloc(text.nitems + 1)) != NULL) {
|
||||
+ bzero (retval, text.nitems + 1);
|
||||
+ strncpy (retval, (char *)text.value, text.nitems);
|
||||
+ }
|
||||
+
|
||||
if (text.value)
|
||||
XFree (text.value);
|
||||
}
|
3
x11-wm/compiz-fusion-plugins-main/pkg-descr
Normal file
3
x11-wm/compiz-fusion-plugins-main/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
This is the main set of plugins for Compiz.
|
||||
|
||||
WWW: http://forums.compiz-fusion.org/
|
89
x11-wm/compiz-fusion-plugins-main/pkg-plist
Normal file
89
x11-wm/compiz-fusion-plugins-main/pkg-plist
Normal file
|
@ -0,0 +1,89 @@
|
|||
@comment $FreeBSD$
|
||||
include/compiz/text.h
|
||||
lib/compiz/libanimation.so
|
||||
lib/compiz/libanimation.la
|
||||
lib/compiz/libanimation.a
|
||||
lib/compiz/libcolorfilter.so
|
||||
lib/compiz/libcolorfilter.la
|
||||
lib/compiz/libcolorfilter.a
|
||||
lib/compiz/libexpo.so
|
||||
lib/compiz/libexpo.la
|
||||
lib/compiz/libexpo.a
|
||||
lib/compiz/libezoom.so
|
||||
lib/compiz/libezoom.la
|
||||
lib/compiz/libezoom.a
|
||||
lib/compiz/libimgjpeg.so
|
||||
lib/compiz/libimgjpeg.la
|
||||
lib/compiz/libimgjpeg.a
|
||||
lib/compiz/libneg.so
|
||||
lib/compiz/libneg.la
|
||||
lib/compiz/libneg.a
|
||||
lib/compiz/libopacify.so
|
||||
lib/compiz/libopacify.la
|
||||
lib/compiz/libopacify.a
|
||||
lib/compiz/libput.so
|
||||
lib/compiz/libput.la
|
||||
lib/compiz/libput.a
|
||||
lib/compiz/libresizeinfo.so
|
||||
lib/compiz/libresizeinfo.la
|
||||
lib/compiz/libresizeinfo.a
|
||||
lib/compiz/libring.so
|
||||
lib/compiz/libring.la
|
||||
lib/compiz/libring.a
|
||||
lib/compiz/libscaleaddon.so
|
||||
lib/compiz/libscaleaddon.la
|
||||
lib/compiz/libscaleaddon.a
|
||||
lib/compiz/libsnap.so
|
||||
lib/compiz/libsnap.la
|
||||
lib/compiz/libsnap.a
|
||||
lib/compiz/libtext.so
|
||||
lib/compiz/libtext.la
|
||||
lib/compiz/libtext.a
|
||||
lib/compiz/libthumbnail.so
|
||||
lib/compiz/libthumbnail.la
|
||||
lib/compiz/libthumbnail.a
|
||||
lib/compiz/libwall.so
|
||||
lib/compiz/libwall.la
|
||||
lib/compiz/libwall.a
|
||||
lib/compiz/libwinrules.so
|
||||
lib/compiz/libwinrules.la
|
||||
lib/compiz/libwinrules.a
|
||||
lib/compiz/libworkarounds.so
|
||||
lib/compiz/libworkarounds.la
|
||||
lib/compiz/libworkarounds.a
|
||||
lib/compiz/libvpswitch.so
|
||||
lib/compiz/libvpswitch.la
|
||||
lib/compiz/libvpswitch.a
|
||||
lib/compiz/libshift.so
|
||||
lib/compiz/libshift.la
|
||||
lib/compiz/libshift.a
|
||||
libdata/pkgconfig/compiz-text.pc
|
||||
share/locale/de/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/el/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/fr/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/it/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/ja/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/pt_PT/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/pl_PL/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/compiz/animation.xml
|
||||
share/compiz/colorfilter.xml
|
||||
share/compiz/expo.xml
|
||||
share/compiz/ezoom.xml
|
||||
share/compiz/imgjpeg.xml
|
||||
share/compiz/neg.xml
|
||||
share/compiz/opacify.xml
|
||||
share/compiz/put.xml
|
||||
share/compiz/resizeinfo.xml
|
||||
share/compiz/ring.xml
|
||||
share/compiz/snap.xml
|
||||
share/compiz/text.xml
|
||||
share/compiz/thumbnail.xml
|
||||
share/compiz/wall.xml
|
||||
share/compiz/winrules.xml
|
||||
share/compiz/workarounds.xml
|
||||
share/compiz/scaleaddon.xml
|
||||
share/compiz/vpswitch.xml
|
||||
share/compiz/shift.xml
|
||||
@dirrmtry share/locale/pl_PL/LC_MESSAGES
|
||||
@dirrmtry share/locale/pl_PL
|
37
x11-wm/compiz-plugins-main/Makefile
Normal file
37
x11-wm/compiz-plugins-main/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
# New ports collection makefile for: compiz-fusion-plugins-main
|
||||
# Date created: 2007-08-15
|
||||
# Whom: Robert Noland <rnoland@2hip.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= compiz-fusion-plugins-main
|
||||
PORTVERSION= 0.5.2
|
||||
#PORTREVISION= 0
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
|
||||
|
||||
MAINTAINER= rnoland@2hip.net
|
||||
COMMENT= Plugins for Compiz Composite Window Manager
|
||||
|
||||
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
|
||||
pangocairo-1.0:${PORTSDIR}/x11-toolkits/pango
|
||||
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz \
|
||||
${LOCALBASE}/libdata/pkgconfig/bcop.pc:${PORTSDIR}/devel/compiz-bcop
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GL= yes
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= gnomehack
|
||||
USE_XORG= glproto
|
||||
USE_GETTEXT= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
|
||||
.include <bsd.port.mk>
|
3
x11-wm/compiz-plugins-main/distinfo
Normal file
3
x11-wm/compiz-plugins-main/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (compiz-fusion-plugins-main-0.5.2.tar.bz2) = cb5703d8e59697dd6c7b075c483e81cc
|
||||
SHA256 (compiz-fusion-plugins-main-0.5.2.tar.bz2) = 72f32fe4ee5ad0a04899b10a598573d08bff728802832e04da48d5e9ad2ceaf8
|
||||
SIZE (compiz-fusion-plugins-main-0.5.2.tar.bz2) = 606991
|
28
x11-wm/compiz-plugins-main/files/patch-src-text-text.c
Normal file
28
x11-wm/compiz-plugins-main/files/patch-src-text-text.c
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- src/text/text.c.orig 2007-08-12 15:51:59.000000000 -0400
|
||||
+++ src/text/text.c 2007-08-17 22:31:24.000000000 -0400
|
||||
@@ -75,7 +75,11 @@
|
||||
return NULL;
|
||||
}
|
||||
|
||||
- retval = strndup (val, nitems);
|
||||
+ if ((retval = (char *) malloc(nitems + 1)) != NULL) {
|
||||
+ bzero (retval, nitems + 1);
|
||||
+ strncpy (retval, val, nitems);
|
||||
+ }
|
||||
+
|
||||
XFree (val);
|
||||
|
||||
return retval;
|
||||
@@ -92,7 +96,11 @@
|
||||
text.nitems = 0;
|
||||
if (XGetTextProperty (d->display, id, &text, atom))
|
||||
{
|
||||
- retval = strndup ((char *)text.value,text.nitems);
|
||||
+ if ((retval = (char *) malloc(text.nitems + 1)) != NULL) {
|
||||
+ bzero (retval, text.nitems + 1);
|
||||
+ strncpy (retval, (char *)text.value, text.nitems);
|
||||
+ }
|
||||
+
|
||||
if (text.value)
|
||||
XFree (text.value);
|
||||
}
|
3
x11-wm/compiz-plugins-main/pkg-descr
Normal file
3
x11-wm/compiz-plugins-main/pkg-descr
Normal file
|
@ -0,0 +1,3 @@
|
|||
This is the main set of plugins for Compiz.
|
||||
|
||||
WWW: http://forums.compiz-fusion.org/
|
89
x11-wm/compiz-plugins-main/pkg-plist
Normal file
89
x11-wm/compiz-plugins-main/pkg-plist
Normal file
|
@ -0,0 +1,89 @@
|
|||
@comment $FreeBSD$
|
||||
include/compiz/text.h
|
||||
lib/compiz/libanimation.so
|
||||
lib/compiz/libanimation.la
|
||||
lib/compiz/libanimation.a
|
||||
lib/compiz/libcolorfilter.so
|
||||
lib/compiz/libcolorfilter.la
|
||||
lib/compiz/libcolorfilter.a
|
||||
lib/compiz/libexpo.so
|
||||
lib/compiz/libexpo.la
|
||||
lib/compiz/libexpo.a
|
||||
lib/compiz/libezoom.so
|
||||
lib/compiz/libezoom.la
|
||||
lib/compiz/libezoom.a
|
||||
lib/compiz/libimgjpeg.so
|
||||
lib/compiz/libimgjpeg.la
|
||||
lib/compiz/libimgjpeg.a
|
||||
lib/compiz/libneg.so
|
||||
lib/compiz/libneg.la
|
||||
lib/compiz/libneg.a
|
||||
lib/compiz/libopacify.so
|
||||
lib/compiz/libopacify.la
|
||||
lib/compiz/libopacify.a
|
||||
lib/compiz/libput.so
|
||||
lib/compiz/libput.la
|
||||
lib/compiz/libput.a
|
||||
lib/compiz/libresizeinfo.so
|
||||
lib/compiz/libresizeinfo.la
|
||||
lib/compiz/libresizeinfo.a
|
||||
lib/compiz/libring.so
|
||||
lib/compiz/libring.la
|
||||
lib/compiz/libring.a
|
||||
lib/compiz/libscaleaddon.so
|
||||
lib/compiz/libscaleaddon.la
|
||||
lib/compiz/libscaleaddon.a
|
||||
lib/compiz/libsnap.so
|
||||
lib/compiz/libsnap.la
|
||||
lib/compiz/libsnap.a
|
||||
lib/compiz/libtext.so
|
||||
lib/compiz/libtext.la
|
||||
lib/compiz/libtext.a
|
||||
lib/compiz/libthumbnail.so
|
||||
lib/compiz/libthumbnail.la
|
||||
lib/compiz/libthumbnail.a
|
||||
lib/compiz/libwall.so
|
||||
lib/compiz/libwall.la
|
||||
lib/compiz/libwall.a
|
||||
lib/compiz/libwinrules.so
|
||||
lib/compiz/libwinrules.la
|
||||
lib/compiz/libwinrules.a
|
||||
lib/compiz/libworkarounds.so
|
||||
lib/compiz/libworkarounds.la
|
||||
lib/compiz/libworkarounds.a
|
||||
lib/compiz/libvpswitch.so
|
||||
lib/compiz/libvpswitch.la
|
||||
lib/compiz/libvpswitch.a
|
||||
lib/compiz/libshift.so
|
||||
lib/compiz/libshift.la
|
||||
lib/compiz/libshift.a
|
||||
libdata/pkgconfig/compiz-text.pc
|
||||
share/locale/de/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/el/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/fr/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/it/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/ja/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/pt_PT/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/locale/pl_PL/LC_MESSAGES/compiz-fusion-plugins-main.mo
|
||||
share/compiz/animation.xml
|
||||
share/compiz/colorfilter.xml
|
||||
share/compiz/expo.xml
|
||||
share/compiz/ezoom.xml
|
||||
share/compiz/imgjpeg.xml
|
||||
share/compiz/neg.xml
|
||||
share/compiz/opacify.xml
|
||||
share/compiz/put.xml
|
||||
share/compiz/resizeinfo.xml
|
||||
share/compiz/ring.xml
|
||||
share/compiz/snap.xml
|
||||
share/compiz/text.xml
|
||||
share/compiz/thumbnail.xml
|
||||
share/compiz/wall.xml
|
||||
share/compiz/winrules.xml
|
||||
share/compiz/workarounds.xml
|
||||
share/compiz/scaleaddon.xml
|
||||
share/compiz/vpswitch.xml
|
||||
share/compiz/shift.xml
|
||||
@dirrmtry share/locale/pl_PL/LC_MESSAGES
|
||||
@dirrmtry share/locale/pl_PL
|
Loading…
Reference in a new issue