- Mark BROKEN for ia64.

Reported by:	pointyhat
This commit is contained in:
Alejandro Pulver 2006-12-13 16:14:54 +00:00
parent 73021e6e14
commit 409d90ad8a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179669
2 changed files with 4 additions and 13 deletions

View file

@ -29,6 +29,10 @@ OPTIONS= DEBUG "Enable debugging information" off \
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
BROKEN= does not build
.endif
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+=--enable-ipv6
.if ${OSVERSION} < 500000

View file

@ -1,13 +0,0 @@
--- ./gc.c.orig Thu Apr 13 05:18:48 2006
+++ ./gc.c Thu Oct 19 13:56:46 2006
@@ -34,6 +34,10 @@
#include <windows.h>
#endif
+#ifdef __ia64__
+#include <ucontext.h>
+#endif
+
int rb_io_fptr_finalize(struct OpenFile*);
#if !defined(setjmp) && defined(HAVE__SETJMP)