Update to version 20030527.
PR: 52862 Submitted by: Ports Fury
This commit is contained in:
parent
f7d0f452ef
commit
40aca5887c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82455
7 changed files with 80 additions and 166 deletions
|
@ -6,17 +6,36 @@
|
|||
#
|
||||
|
||||
PORTNAME= xmorph
|
||||
PORTVERSION= 2001.02.22
|
||||
PORTVERSION= 2003.05.27
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.colorado-research.com/~gourlay/software/Graphics/Xmorph/pub/
|
||||
DISTNAME= ${PORTNAME}-2001feb22
|
||||
MASTER_SITES= ${MASTER_SITE_DEBIAN}
|
||||
MASTER_SITE_SUBDIR= pool/main/x/xmorph
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//g}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= A digital image warping program
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= xmorph.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${HAVE_GNOME:Mgtk20}!=""
|
||||
USE_GNOME+= gtk20
|
||||
CONFIGURE_ARGS+= --with-gtk2
|
||||
MAN1+= gtkmorph.1
|
||||
PLIST_SUB+= GTK2=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-gtkmorph
|
||||
PLIST_SUB+= GTK2="@comment "
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (xmorph-2001feb22.tar.gz) = 0f73bf5d85d4e3bd0d5c220f5429b739
|
||||
MD5 (xmorph_20030527.tar.gz) = 8bd5ac56a1f228f59578f2618ddfa682
|
||||
|
|
|
@ -1,150 +0,0 @@
|
|||
--- Makefile.orig Sat Apr 29 08:26:30 2000
|
||||
+++ Makefile Sat Aug 5 04:52:50 2000
|
||||
@@ -121,7 +121,6 @@
|
||||
#CC=gcc
|
||||
#CC=/bin/cc
|
||||
#CC=cc
|
||||
-CC=cc
|
||||
|
||||
|
||||
|
||||
@@ -142,7 +141,7 @@
|
||||
#
|
||||
|
||||
#INCLUDE=-I/usr/local/include -I/usr/openwin/include
|
||||
-INCLUDE=-I/usr/local/include
|
||||
+INCLUDE=-I${X11BASE}/include
|
||||
|
||||
|
||||
|
||||
@@ -179,7 +178,7 @@
|
||||
#DEBUG=-O -g -Wall -DVERBOSE -DDEBUG
|
||||
#DEBUG=-O
|
||||
#DEBUG=-g3 -O -fullwarn -DVERBOSE -DDEBUG
|
||||
-DEBUG=-g3 -O -fullwarn
|
||||
+#DEBUG=-g3 -O -fullwarn
|
||||
|
||||
|
||||
|
||||
@@ -268,7 +267,10 @@
|
||||
#XLIBS=-L/usr/X11R6/lib -lXaw -lXmu -lXext -lXt -lX11
|
||||
|
||||
# SGI IRIX:
|
||||
-XLIBS= -lXaw -lXmu -lXext -lXt -lcvt -lX11
|
||||
+#XLIBS= -lXaw -lXmu -lXext -lXt -lcvt -lX11
|
||||
+
|
||||
+# FreeBSD:
|
||||
+XLIBS=-L${X11BASE}/lib -lXaw -lXmu -lXext -lXt -lX11
|
||||
|
||||
|
||||
|
||||
@@ -313,10 +315,10 @@
|
||||
#
|
||||
# -lmalloc_cv has more robust memory checking
|
||||
|
||||
-#NON_GUI_LIBS = -lm
|
||||
+NON_GUI_LIBS = -lm
|
||||
#NON_GUI_LIBS = -lm -ldl
|
||||
#NON_GUI_LIBS = -lm /usr/lib/debug/malloc.o
|
||||
-NON_GUI_LIBS = -lm -lmalloc
|
||||
+#NON_GUI_LIBS = -lm -lmalloc
|
||||
|
||||
|
||||
|
||||
@@ -344,7 +346,7 @@
|
||||
|
||||
# SHLIB_EXT: filename extension for shared libraries
|
||||
# --------------------------------------------------
|
||||
-SHLIB_EXT=so
|
||||
+SHLIB_EXT=so.1
|
||||
|
||||
|
||||
|
||||
@@ -353,7 +355,7 @@
|
||||
## -----------------------
|
||||
#
|
||||
|
||||
-LDFLAGS=-L/usr/local/lib
|
||||
+LDFLAGS=
|
||||
|
||||
|
||||
|
||||
@@ -378,14 +380,14 @@
|
||||
|
||||
#CFLAGS=$(DEBUG) $(DEFINES) $(INCLUDE) -DSUNOS
|
||||
|
||||
-CFLAGS=$(DEBUG) $(DEFINES) $(INCLUDE)
|
||||
+CFLAGS+=$(DEBUG) $(DEFINES) $(INCLUDE)
|
||||
|
||||
|
||||
|
||||
|
||||
## INSTALL_BASE: Directory base to install files
|
||||
## ---------------------------------------------
|
||||
-INSTALL_BASE=/usr/local
|
||||
+INSTALL_BASE=${PREFIX}
|
||||
|
||||
|
||||
|
||||
@@ -450,15 +452,19 @@
|
||||
xmorph.o
|
||||
|
||||
#all: morph.$(SHLIB_EXT)
|
||||
-all: xmorph morph xmorph.man xmorph.info
|
||||
+#all: xmorph morph xmorph.man xmorph.info
|
||||
+all: libmorph.a libmorph.so xmorph
|
||||
|
||||
libmorph.a: $(LIB_OBJS)
|
||||
ar cr $@ $(LIB_OBJS)
|
||||
|
||||
libmorph.$(SHLIB_EXT): $(LIB_OBJS)
|
||||
- ld $(SHLIB_FLAG) $(LDFLAGS) $(LIB_OBJS) -o $@
|
||||
+ $(CC) $(SHLIB_FLAG) -Wl,-soname,$@ $(LDFLAGS) $(LIB_OBJS) -o $@
|
||||
+
|
||||
+libmorph.so: libmorph.$(SHLIB_EXT)
|
||||
+ ln -sf libmorph.$(SHLIB_EXT) libmorph.so
|
||||
|
||||
-xmorph: main-x.o libmorph.a $(GUI_OBJS)
|
||||
+xmorph: main-x.o libmorph.so $(GUI_OBJS)
|
||||
@echo ""
|
||||
@echo ""
|
||||
@echo ""
|
||||
@@ -471,14 +477,17 @@
|
||||
@echo ""
|
||||
@echo ""
|
||||
@echo ""
|
||||
- $(CC) $(CFLAGS) -o $@ main-x.o $(GUI_OBJS) libmorph.a $(LIBS)
|
||||
+ $(CC) $(CFLAGS) -o $@ main-x.o $(GUI_OBJS) -L. -lmorph $(LIBS)
|
||||
|
||||
-morph: main-cl.o libmorph.a
|
||||
- $(CC) $(CFLAGS) -o $@ main-cl.o libmorph.a $(NON_GUI_LIBS)
|
||||
+morph: main-cl.o libmorph.so
|
||||
+ $(CC) $(CFLAGS) -o $@ main-cl.o -L. -lmorph $(NON_GUI_LIBS)
|
||||
|
||||
.c$(OBJ): $(SRCS) Makefile
|
||||
$(CC) $(CFLAGS) $(CPPFLAGS) -c $<
|
||||
|
||||
+$(LIB_OBJS): $(LIB_OBJS:.o=.c) Makefile
|
||||
+ $(CC) $(CFLAGS) $(CPPFLAGS) -fpic -DPIC -c $<
|
||||
+
|
||||
main-x.o: main.c
|
||||
$(CC) $(CFLAGS) $(CPPFLAGS) -c -DX_GUI main.c -o $@
|
||||
|
||||
@@ -498,11 +507,12 @@
|
||||
|
||||
|
||||
|
||||
-install: xmorph xmorph.man libmorph.a libmorph.$(SHLIB_EXT)
|
||||
- cp xmorph $(INSTALL_BASE)/bin
|
||||
- cp xmorph.1 $(INSTALL_BASE)/man/man1
|
||||
- cp libmorph.a $(INSTALL_BASE)/lib
|
||||
- cp libmorph.$(SHLIB_EXT) $(INSTALL_BASE)/lib
|
||||
+install: xmorph xmorph.man libmorph.a libmorph.so
|
||||
+ ${BSD_INSTALL_PROGRAM} xmorph $(INSTALL_BASE)/bin
|
||||
+ ${BSD_INSTALL_MAN} xmorph.1 $(INSTALL_BASE)/man/man1
|
||||
+ ${BSD_INSTALL_DATA} libmorph.a $(INSTALL_BASE)/lib
|
||||
+ ${BSD_INSTALL_DATA} libmorph.$(SHLIB_EXT) $(INSTALL_BASE)/lib
|
||||
+ ln -sf libmorph.$(SHLIB_EXT) $(INSTALL_BASE)/lib/libmorph.so
|
||||
|
||||
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- my_malloc.c.orig Wed Apr 26 05:12:54 2000
|
||||
+++ my_malloc.c Sat Aug 5 04:07:53 2000
|
||||
@@ -32,7 +32,7 @@
|
||||
// Thanks to Geoff Lawler.
|
||||
*/
|
||||
|
||||
-#if defined(apollo) || defined(__CYGWIN32__)
|
||||
+#if defined(apollo) || defined(__CYGWIN32__) || defined(__STDC__)
|
||||
#else
|
||||
#include <malloc.h>
|
||||
#endif
|
10
graphics/xmorph/files/patch-configure
Normal file
10
graphics/xmorph/files/patch-configure
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- configure.orig Wed May 28 01:35:34 2003
|
||||
+++ configure Thu May 29 10:06:07 2003
|
||||
@@ -7652,6 +7652,7 @@
|
||||
|
||||
# This can be used to rebuild libtool when needed
|
||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
|
||||
|
||||
# Always use our own libtool.
|
||||
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
14
graphics/xmorph/files/patch-libmorph_my__malloc.c
Normal file
14
graphics/xmorph/files/patch-libmorph_my__malloc.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- libmorph/my_malloc.c.orig Sat Jun 7 16:35:29 2003
|
||||
+++ libmorph/my_malloc.c Sat Jun 7 16:35:43 2003
|
||||
@@ -34,7 +34,7 @@
|
||||
|
||||
#if defined(apollo) || defined(__CYGWIN32__)
|
||||
#else
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
#endif
|
||||
|
||||
|
|
@ -1,4 +1,36 @@
|
|||
@comment $FreeBSD$
|
||||
%%GTK2%%bin/gtkmorph
|
||||
bin/morph
|
||||
bin/xmorph
|
||||
include/xmorph/RgbaImage.h
|
||||
include/xmorph/mesh.h
|
||||
include/xmorph/my_malloc.h
|
||||
include/xmorph/relax.h
|
||||
include/xmorph/spl-array.h
|
||||
include/xmorph/spline.h
|
||||
include/xmorph/tga.h
|
||||
include/xmorph/warp.h
|
||||
info/xmorph.info
|
||||
lib/libmorph.a
|
||||
lib/libmorph.so
|
||||
lib/libmorph.so.1
|
||||
share/locale/it/LC_MESSAGES/xmorph.mo
|
||||
share/xmorph/example/README
|
||||
share/xmorph/example/gtkmorph.session
|
||||
share/xmorph/example/image1.png
|
||||
share/xmorph/example/image1.png.mesh
|
||||
share/xmorph/example/image2.png
|
||||
share/xmorph/example/image2.png.mesh
|
||||
%%GTK2%%share/xmorph/mpeg.param
|
||||
share/xmorph/pixmaps/cursor_left.xpm
|
||||
share/xmorph/pixmaps/eraser.xpm
|
||||
share/xmorph/pixmaps/example.xpm
|
||||
share/xmorph/pixmaps/hand01.xpm
|
||||
share/xmorph/pixmaps/howmany.xpm
|
||||
share/xmorph/pixmaps/pencil.xpm
|
||||
share/xmorph/pixmaps/pencil_y.xpm
|
||||
share/xmorph/pixmaps/transform.xpm
|
||||
@dirrm share/xmorph/pixmaps
|
||||
@dirrm share/xmorph/example
|
||||
@dirrm share/xmorph
|
||||
@dirrm include/xmorph
|
||||
|
|
Loading…
Reference in a new issue