Add TCL binding for PostgreSQL client. This used to be part of PostgreSQL

client up to version 7.x, but is not found in 8.x.
This commit is contained in:
Mikhail Teterin 2007-06-18 20:45:59 +00:00
parent 29f53c2564
commit 40bd9f0101
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=193833
6 changed files with 139 additions and 0 deletions

View file

@ -338,6 +338,7 @@
SUBDIR += pgpool
SUBDIR += pgpool-II
SUBDIR += pgpoolAdmin
SUBDIR += pgtcl
SUBDIR += pgtop
SUBDIR += pgworksheet
SUBDIR += php-sqlite3

44
databases/pgtcl/Makefile Normal file
View file

@ -0,0 +1,44 @@
# New ports collection makefile for: pgtcl
# Date created: February 13, 2007
# Whom: Mikhail Teterin
#
# $FreeBSD$
#
PORTNAME= pgtcl
PORTVERSION= 1.6.0
CATEGORIES= databases tcl84
DISTNAME= ${PORTNAME}${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:src
MASTER_SITES= http://pgfoundry.org/frs/download.php/1229/:src
MAINTAINER= mi@aldan.algebra.com
COMMENT= TCL extension for accessing a PostgreSQL server
USE_TCL= yes
USE_PGSQL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} --with-tclinclude=${TCL_INCLUDEDIR}
LIBDIR= ${PREFIX}/lib/${PORTNAME}
PLIST_SUB+= PORTVERSION=${PORTVERSION}
.if !defined(NOPORTDOCS)
EXTRACT_ONLY= ${_DISTFILES:M*tar.gz}
DISTFILES+= pgtcldocs-20070115.zip:doc
MASTER_SITES+= http://pgfoundry.org/frs/download.php/1228/:doc
BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
.endif
post-configure:
${REINPLACE_CMD} -e 's,tclstub,tcl,g' \
-e 's,-DUSE_TCL_STUBS=1,-UUSE_TCL_STUBS,g' \
${WRKSRC}/Makefile
do-install:
${MKDIR} ${LIBDIR}
${INSTALL_DATA} ${WRKSRC}/pkgIndex.tcl \
${WRKSRC}/libpgtcl${PORTVERSION}.so ${LIBDIR}
.if !defined(NOPORTDOCS)
${UNZIP_CMD} -j ${DISTDIR}/${_DISTFILES:M*.zip} -d ${DOCSDIR}
.endif
.include <bsd.port.mk>

6
databases/pgtcl/distinfo Normal file
View file

@ -0,0 +1,6 @@
MD5 (pgtcl1.6.0.tar.gz) = 25eda4bb40fb3d4ec9b205a1fdc1bbbc
SHA256 (pgtcl1.6.0.tar.gz) = 3e508e14cb5ca59fd2cb82158145a393ce330090d860e85718dedee542467b43
SIZE (pgtcl1.6.0.tar.gz) = 178146
MD5 (pgtcldocs-20070115.zip) = 8ce98e93b238c3329d0fe43810442c44
SHA256 (pgtcldocs-20070115.zip) = c5bcab2f0169041bcf8a10ff80bb39500ef3d068d960cf8d10c1e48b2c1c49de
SIZE (pgtcldocs-20070115.zip) = 128754

View file

@ -0,0 +1,13 @@
size_t is the right type to use, but Tcl's core is not prepared for it.
-mi
--- pgtclCmds.c Mon Jan 15 21:41:07 2007
+++ pgtclCmds.c Mon Jun 18 16:28:31 2007
@@ -3644,5 +3644,5 @@
{
unsigned char *from_binary;
- size_t from_len;
+ int from_len;
unsigned char *to_string;
size_t to_len;

View file

@ -0,0 +1,5 @@
A TCL extension for accessing PostgreSQL databases. This used
to come bunlded with PostgreSQL itself, but was split into a
separate project in more recent version (8+).
WWW: http://pgtcl.projects.postgresql.org/

70
databases/pgtcl/pkg-plist Normal file
View file

@ -0,0 +1,70 @@
lib/pgtcl/libpgtcl%%PORTVERSION%%.so
lib/pgtcl/pkgIndex.tcl
@dirrm lib/pgtcl
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/ln-legalnotice.html
%%PORTDOCS%%%%DOCSDIR%%/pg-blocking.html
%%PORTDOCS%%%%DOCSDIR%%/pg-cancelrequest.html
%%PORTDOCS%%%%DOCSDIR%%/pg-conndefaults.html
%%PORTDOCS%%%%DOCSDIR%%/pg-connect.html
%%PORTDOCS%%%%DOCSDIR%%/pg-disconnect.html
%%PORTDOCS%%%%DOCSDIR%%/pg-escape-bytea.html
%%PORTDOCS%%%%DOCSDIR%%/pg-escape-string.html
%%PORTDOCS%%%%DOCSDIR%%/pg-exec-params.html
%%PORTDOCS%%%%DOCSDIR%%/pg-exec-prepared.html
%%PORTDOCS%%%%DOCSDIR%%/pg-exec.html
%%PORTDOCS%%%%DOCSDIR%%/pg-execute.html
%%PORTDOCS%%%%DOCSDIR%%/pg-getresult.html
%%PORTDOCS%%%%DOCSDIR%%/pg-isbusy.html
%%PORTDOCS%%%%DOCSDIR%%/pg-listen.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-close.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-creat.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-export.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-import.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-lseek.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-open.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-read.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-tell.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-unlink.html
%%PORTDOCS%%%%DOCSDIR%%/pg-lo-write.html
%%PORTDOCS%%%%DOCSDIR%%/pg-notice-handler.html
%%PORTDOCS%%%%DOCSDIR%%/pg-on-connection-loss.html
%%PORTDOCS%%%%DOCSDIR%%/pg-parameter-status.html
%%PORTDOCS%%%%DOCSDIR%%/pg-quote.html
%%PORTDOCS%%%%DOCSDIR%%/pg-result-callback.html
%%PORTDOCS%%%%DOCSDIR%%/pg-result.html
%%PORTDOCS%%%%DOCSDIR%%/pg-select.html
%%PORTDOCS%%%%DOCSDIR%%/pg-sendquery-params.html
%%PORTDOCS%%%%DOCSDIR%%/pg-sendquery.html
%%PORTDOCS%%%%DOCSDIR%%/pg-sendquery-prepared.html
%%PORTDOCS%%%%DOCSDIR%%/pg-transaction-status.html
%%PORTDOCS%%%%DOCSDIR%%/pg-unescape-bytea.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-async.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-asyncevent.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-cnq-execute.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-copy.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-dblist.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-picstore-esc.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-picstore-lo.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-picstore-pq.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-picview-esc.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-picview-lo.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-make.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-picview-pq.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-example-results.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-examples.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-load-static.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-loading-load.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-loading.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-make-macos.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-make-win.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-overview.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-preface.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-ref-async.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-ref-connstatus.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-ref-largeobj.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-ref-notif.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-ref-query.html
%%PORTDOCS%%%%DOCSDIR%%/pgtcl-ref.html
%%PORTDOCS%%%%DOCSDIR%%/stylesheet.css
%%PORTDOCS%%@dirrm %%DOCSDIR%%