Update to asun-2.1.3

This commit is contained in:
Stefan Bethke 1999-03-22 21:34:23 +00:00
parent d578b7947c
commit 40be034042
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17354
13 changed files with 273 additions and 42 deletions

View file

@ -3,11 +3,11 @@
# Date created: 07 Sep 1998
# Whom: stb@freebsd.org
#
# $Id: Makefile,v 1.3 1998/11/29 23:46:01 asami Exp $
# $Id: Makefile,v 1.4 1999/02/25 01:57:43 asami Exp $
#
DISTNAME= netatalk-1.4b2+asun2.1.0
PKGNAME= netatalk-1.4b2+asun-2.1.0
DISTNAME= netatalk-1.4b2+asun2.1.3
PKGNAME= netatalk-1.4b2+asun-2.1.3
CATEGORIES= net print
MASTER_SITES= ftp://ftp.u.washington.edu/public/asun/
@ -15,6 +15,36 @@ MAINTAINER= stb@freebsd.org
LIB_DEPENDS= wrap.7:${PORTSDIR}/security/tcp_wrapper
MAKE_ARGS= INSTALL="${INSTALL} ${COPY}"
.include <bsd.port.pre.mk>
.if defined(USE_SENDFILE) && ${OSVERSION} >= 310000
MAKE_ARGS+= -DUSE_SENDFILE
.endif
.if defined(USE_CNID)
## Support for fixed DirIDs; probably broken.
BUILD_DEPENDS= ${PREFIX}/lib/libdb.a:${PORTSDIR}/databases/db
MAKE_ARGS+= -DUSE_CNID
.endif
pre-build:
## sendfile(2) support seems to be broken in this version, but go ahead an try
## to fix it!
.if defined(USE_SENDFILE) && ${OSVERSION} < 310000
@echo "*** sendfile(2) support is available only with FreeBSD 3.1-RELEASE"
@echo " or newer. This port probably won't compile."
.endif
.if ${OSVERSION} >= 310000
.if defined(USE_SENDFILE)
@echo "*** sendfile(2) support is experimental and will likely cause"
@echo " undesired behaviour!"
.else
# @echo "*** Use -DUSE_SENDFILE to enable the experimental sendfile(2) support."
.endif
.endif
MAN1= aecho.1 getzones.1 megatron.1 nbp.1 pap.1 psorder.1
MAN3= atalk_aton.3 nbp_name.3
MAN4= atalk.4

View file

@ -1 +1 @@
MD5 (netatalk-1.4b2+asun2.1.0.tar.gz) = 0dac5276cbad4e966cb76a7e0399d3fd
MD5 (netatalk-1.4b2+asun2.1.3.tar.gz) = b417c5977f36f4125d0932076df54db5

View file

@ -1,8 +1,7 @@
--- Makefile.orig Mon Sep 28 21:48:41 1998
+++ Makefile Tue Nov 24 14:19:18 1998
--- Makefile.orig Sun Feb 7 12:15:46 1999
+++ Makefile Mon Mar 8 09:42:21 1999
@@ -1,15 +1,15 @@
-# Root of installation. Subdirectories will be ${DESTDIR}/etc,
+TARGETS= atalk
# Root of installation. Subdirectories will be ${DESTDIR}/etc,
# ${DESTDIR}/bin, and ${DESTDIR}/lib.
-DESTDIR=/usr/local/atalk
+DESTDIR=${PREFIX}
@ -20,7 +19,15 @@
# for configuration files (AppleVolumes.system, etc.)
ETCDIR=$(DESTDIR)/etc
# for include files
@@ -29,16 +29,16 @@
@@ -27,22 +27,27 @@
#MANDIR=/usr/man
# Location of the Berkeley v2 db library and include files.
-#DB2DIR=/usr/local/BerkeleyDB
+.if defined(USE_CNID)
+DB2DIR=${PREFIX}
+.endif
# Location of the DES library and include files. Comment this out if you
# don't want Randnum Exchange and 2-Way Randnum Exchange as allowable UAMs
# for afpd. We expect libdes.a in $DESDIR/lib and des.h in $DESDIR/include.
@ -36,17 +43,28 @@
# Location of PAM support library and include files. Comment this out
# if you don't want to enable PAM support
-PAMDIR=/usr
-
+## FreeBSD's PAM modules currently only support auth; session and account
+## are also required.
+#.if exists(/usr/lib/libpam.a)
+#PAMDIR=/usr
+#.endif
# Location of the AFS and Kerberos libraries and include files. Uncomment
@@ -74,7 +74,8 @@
# and edit these if you want to include AFS or Kerberos support in afpd
@@ -77,12 +82,13 @@
ETCDIR="${ETCDIR}" LIBDIR="${LIBDIR}" INCDIR="${INCDIR}" \
DESTDIR="${DESTDIR}" MANDIR="${MANDIR}" \
TCPWRAPDIR="${TCPWRAPDIR}" PAMDIR="${PAMDIR}" \
TCPWRAPDIR="${TCPWRAPDIR}" PAMDIR="${PAMDIR}" DB2DIR="${DB2DIR}" \
- AFSDIR="${AFSDIR}" KRBDIR="${KRBDIR}" DESDIR="${DESDIR}" $@
+ AFSDIR="${AFSDIR}" KRBDIR="${KRBDIR}" DESDIR="${DESDIR}" \
+ OPTOPTS="${CFLAGS}" $@
FRC:
SYS=sunos ultrix solaris
-VERSION=`date +%y%m%d`
+VERSION="netatalk-1.4b2+asun-2.1.3"
DISTDIR=../netatalk-${VERSION}
sysclean : FRC

View file

@ -1,14 +1,33 @@
--- sys/freebsd/Makefile.orig Fri Sep 18 05:19:27 1998
+++ sys/freebsd/Makefile Tue Nov 24 14:12:32 1998
@@ -1,6 +1,6 @@
--- sys/freebsd/Makefile.orig Thu Feb 4 08:38:12 1999
+++ sys/freebsd/Makefile Mon Mar 8 09:24:52 1999
@@ -1,9 +1,14 @@
# FreeBSD specific defines, passed to subdirectories.
-#DEFS= -DBSD4_4 -DSENDFILE_FLAVOR_BSD
DEFS= -DBSD4_4
-OPTOPTS= -O2
+.if defined(USE_SENDFILE)
+DEFS+= -DSENDFILE_FLAVOR_BSD
+.endif
+.if defined(USE_CNID)
+DEFS+= -DUSE_CNID
+.endif
+#OPTOPTS= -O2
CC= gcc
INSTALL= install
-INSTALL= install
+#INSTALL= install
AFPLIBS= -lcrypt -lrpcsvc
@@ -23,7 +23,8 @@
ADDLIBS=
@@ -11,7 +16,7 @@
oops:
@echo "Read README again. Don't type 'make' here."
- @exit 1
+ @exit 64
all: ${ALL}
@@ -28,7 +33,8 @@
FRC:
install :
@ -18,7 +37,7 @@
for i in ${ALL}; \
do (cd $$i; ${MAKE} ${MFLAGS} CC="${CC}" \
ADDLIBS="${ADDLIBS}" DEFS="${DEFS}" OPTOPTS="${OPTOPTS}" \
@@ -32,17 +33,21 @@
@@ -37,17 +43,21 @@
AFSDIR="${AFSDIR}" KRBDIR="${KRBDIR}" AFPLIBS="${AFPLIBS}" \
INSTALL="${INSTALL}" $@); \
done

View file

@ -0,0 +1,13 @@
--- etc/afpd/nls/Makefile.orig Sat Dec 12 12:01:06 1998
+++ etc/afpd/nls/Makefile Mon Mar 1 03:48:48 1999
@@ -13,8 +13,8 @@
${CC} ${CFLAGS} ${LDFLAGS} makecode.o -o makecode
install:
- -mkdir ${RESDIR}/nls
- ${INSTALL} -m 644 maccode.* ${RESDIR}/nls
+ -mkdir ${RESDIR}/nls/netatalk
+ ${INSTALL} -m 644 maccode.* ${RESDIR}/nls/netatalk
clean:
rm -f *.o

View file

@ -0,0 +1,20 @@
--- etc/afpd/Makefile.orig Sat Feb 6 21:02:31 1999
+++ etc/afpd/Makefile Tue Mar 2 00:17:37 1999
@@ -56,7 +56,7 @@
fi; \
fi; \
if [ x"${PAMDIR}" != x ]; then \
- PAMLIBS="-lpam -ldl"; \
+ PAMLIBS="-lpam"; \
if [ "${PAMDIR}" != "/usr" ]; then \
PAMLIBDIRS="-L${PAMDIR}/lib"; \
PAMINCPATH="-I${PAMDIR}/include"; \
@@ -107,7 +107,7 @@
-D_NAME_AFPDPWFILE=\"~/.passwd\" \
-D_PATH_AFPDCONF=\"${ETCDIR}/afpd.conf\" \
-D_PATH_AFPDUAMPATH=\"${ETCDIR}/uams/\" \
- -D_PATH_AFPDNLSPATH=\"${RESDIR}/nls/\" \
+ -D_PATH_AFPDNLSPATH=\"${RESDIR}/nls/netatalk/\" \
${CPPFLAGS} -c afp_options.c
config.o: config.c

View file

@ -0,0 +1,34 @@
--- etc/afpd/volume.c.orig Tue Mar 2 01:40:57 1999
+++ etc/afpd/volume.c Tue Mar 2 01:40:21 1999
@@ -159,13 +159,29 @@
{
struct vol *volume;
int vlen;
+ char p[PATH_MAX];
- if ( name == NULL || *name == '\0' ) {
+ if ( name != NULL && name[0] != '\0') {
+ strncpy( p, name, 27+1 );
+ } else {
if (( name = strrchr( path, '/' )) == NULL ) {
return -1; /* Obviously not a fully qualified path */
}
- name++;
+
+ strncpy( p, path, PATH_MAX );
+ name = p + (name - path);
+ /* Find last non-empty component */
+ while ( name != NULL && ( name[1] == '\0' || name[1] == '/' )) {
+ name[0] = '\0';
+ name = strrchr( p, '/' );
+ }
+ if ( name == NULL ) {
+ strcpy( p, "(root)" );
+ } else {
+ memmove( p, name + 1, strlen( name )+1 );
+ }
}
+ name = p;
for ( volume = volumes; volume; volume = volume->v_next ) {
if ( strcasecmp( volume->v_name, name ) == 0 ) {

View file

@ -0,0 +1,14 @@
--- include/atalk/adouble.h.orig Sun Feb 7 12:15:38 1999
+++ include/atalk/adouble.h Mon Mar 8 09:19:34 1999
@@ -86,7 +86,11 @@
/* version info */
#define AD_VERSION1 0x00010000
#define AD_VERSION2 0x00020000
+#if defined(USE_CNID)
+#define AD_VERSION AD_VERSION2
+#else
#define AD_VERSION AD_VERSION1
+#endif
/* sizes of relevant entry bits */
#define AD_HEADER_LEN 26 /* everything up to the first entry header */

View file

@ -0,0 +1,21 @@
--- libatalk/Makefile.orig Mon Mar 8 09:20:40 1999
+++ libatalk/Makefile Mon Mar 8 09:22:00 1999
@@ -1,8 +1,15 @@
-ALL= asp dsi atp nbp adouble util compat # cnid
+ALL= asp dsi atp nbp adouble util compat
LIBS= asp/asplib atp/atplib nbp/nbplib adouble/adoublelib \
- dsi/dsilib util/utillib compat/compatlib # cnid/cnidlib
+ dsi/dsilib util/utillib compat/compatlib
PLIBS= asp/asplib_p atp/atplib_p nbp/nbplib_p adouble/adoublelib_p \
- dsi/dsilib_p util/utillib_p compat/compatlib_p # cnid/cnidlib_p
+ dsi/dsilib_p util/utillib_p compat/compatlib_p
+
+.if defined(USE_CNID)
+ALL+= cnid
+LIBS+= cnid/cnidlib
+PLIBS+= cnid/cnidlib_p
+.endif
+
TAGSFILE=tags
CC=cc
INSTALL=install

View file

@ -1,8 +1,8 @@
--- man/man8/afpd.8.orig Tue May 20 19:35:43 1997
+++ man/man8/afpd.8 Tue Nov 24 03:49:13 1998
--- man/man8/afpd.8.orig Mon Mar 1 02:20:38 1999
+++ man/man8/afpd.8 Mon Mar 1 04:05:53 1999
@@ -1,108 +1,59 @@
-.TH AFPD 8 "25 Jan 1994" "netatalk 1.3"
+.TH AFPD 8 "07 Sep 1998" "netatalk 1.4b2/asun 2.1.0"
+.TH AFPD 8 "23 Feb 1999" "netatalk 1.4b2/asun 2.1.3"
+
.SH NAME
afpd \- AppleTalk Filing Protocol daemon
@ -190,7 +190,7 @@
.TP
.B \-G
.TP
@@ -144,50 +103,191 @@
@@ -144,50 +103,246 @@
.B \-C
.TP
.B \-A
@ -253,14 +253,18 @@
+authentication (using the \fBTwoWayRandNum\fR method).
+.TP
+\fB\-\fR[\fBno\fR]\fBafskrb\fR
+Allow (do not allow) logins using AFS Kerberos. Whether this option is
+available depends on both the server and the client (using the \fBAFS
+Kerberos\fR method).
+Allow (do not allow) logins using AFS Kerberos (using the \fBAFS Kerberos\fR
+method). Whether this option is available depends on both how \fBnetatalk\fR
+was compiled and the client.
+.TP
+\fB\-\fR[\fBno\fR]\fBkrbiv\fR
+Allow (do not allow) logins using Kerberos IV. Whether this option is
+available depends on both the server and the client (using the
+\fBKerberos\ IV\fR method).
+Allow (do not allow) logins using Kerberos IV (using the
+\fBKerberos\ IV\fR method). Whether this option is
+available depends on both how \fBnetatalk\fR was compiled and the client.
+.TP
+\fB\-authall\fR
+Allow \fBNoUserAuthent\fR, \fBCleartxt\fR, \fBAFS Kerberos\fR, and
+\fBKerberos\ IV\fR authentication methods (default).
+.TP
+\fB\-\fR[\fBno\fR]\fBsetpassword\fR
+Allow (do not allow) the user to change her or his password.
@ -268,9 +272,6 @@
+\fB\-\fR[\fBno\fR]\fBsavepassword\fR
+Allow (do not allow) the client to save the password locally.
+.TP
+\fB\-authall\fR
+Allow all available authentication methods.
+.TP
+\fB\-defaultvol\fR \fIfile\fR
+Specifies an alternate location of the default volume specification file
+instead of the default \fB:ETCDIR:/AppleVolumes.default\fR.
@ -286,6 +287,10 @@
+\fB\-\fR[\fBno\fR]\fBuservol\fR
+Read (do not read) the user's volume specification file.
+.TP
+\fB\-nlspath\fR \fIpath\fR
+When using a code page for file name translation (see below), prefix the file
+name with \fIpath\fR. Default is ``:RESDIR:/nls/netatalk''.
+.TP
+\fB\-guestname\fR \fIusername\fR
+User \fIusername\fR as the user id for guest access.
+.TP
@ -324,11 +329,61 @@
+.RS
+.sp
+.I pathname
+[\fIvolumename\fR]
+[\fIvolumename\fR] [\fBcasefold=\fIcasefold\fR] [\fBcodepage=\fIfile\fR]
+[\fBoptions=\fIoptions\fR] [\fBdbpath=\fIpath to ID database\fR]
+[\fBaccess=\fIuser,@group,...\fR] [\fBpassword=\fIpassword\fR]
+.sp
+.RE
+If \fIvolumename\fR is unspecified, the last component of
+\fIpathname\fR is used. No two volumes may have the same name.
+.RE
+.sp
+The optional \fBcasefold\fR parameter specifies how the caseness of file
+names should be handled:
+.TP
+\fBtolower\fR
+converts filenames for all files created from the client to lowercase;
+existing mixed-case filenames are ignored.
+.TP
+\fBtoupper\fR
+converts filenames for all files created from the client to uppercase;
+existing mixed-case filenames are ignored.
+.TP
+\fBxlatelower\fR
+make filenames appear in lowercase on the client, and in uppercase in the
+file system.
+.TP
+\fBxlateupper\fR
+make filenames appear in uppercase on the client, and in lowercase in the
+file system.
+.LP
+The optional \fBcodepage\fR parameter determines the code page file to be
+used for filename translation. By default, no translation takes place. By
+default (see \fB-nlspath\fR, above), the code page filename is prefixed with
+\fB:RESDIR:/nls/netatalk\fR, which contains a number of code pages
+suitable for use with \fBnetatalk\fR.
+.LP
+The optional \fBoptions\fR parameter may take one or more of:
+.TP
+\fBprodos\fR
+Mark volume as ProDOS compatible.
+.TP
+\fBcrlf\fR
+Convert line endings of all files of type ``TEXT'' between CR (Mac) and LF
+(Unix).
+.TP
+\fBnoadouble\fR
+Don't create ``.AppleDouble'' directory unless the client stores a resource
+fork.
+.LP
+The optional \fBaccess\fR parameter lists users and groups which are to be
+allowed access to the volume. Group names must be prefixed with ``@.''
+.LP
+The optional \fBdbpath\fR sets the path to the File ID database for this
+volume. By default, the database is stored in the volume's root directory.
+.LP
+The optional \fBpassword\fR sets a volume password which the client needs to
+supply before being able to access the volumes.
+.LP
+An extension mapping is formatted as follows:
+.RS
@ -414,7 +469,7 @@
.LP
If a user renames a folder that has an application as its progeny, the
.B APPL
@@ -195,16 +295,16 @@
@@ -195,16 +350,16 @@
that double-clicking on one of the application's documents will no
longer launch the application. The
.B APPL
@ -435,7 +490,7 @@
.LP
It is not possible to move directories between devices.
.LP
@@ -221,7 +321,7 @@
@@ -221,7 +376,7 @@
so that his home directory is no longer offered, he will no longer be able
to edit his
.B $HOME/AppleVolumes
@ -444,7 +499,7 @@
.LP
Unix files beginning with `.' are not accessible from the mac.
.LP
@@ -252,8 +352,11 @@
@@ -252,8 +407,11 @@
synchronization locks use the
.BR flock (2)
interface. This interface is not usually ``NFS-aware''.
@ -456,7 +511,7 @@
.B :ETCDIR:/AppleVolumes.default
list of default volumes to mount
.TP 20
@@ -262,6 +365,14 @@
@@ -262,6 +420,14 @@
.TP 20
.B $HOME/AppleVolumes
user's list of volumes to mount

View file

@ -6,6 +6,6 @@
is typically started at boot time, out of
-.B /etc/rc.
+.B :ETCDIR:/rc.d/netatalk.sh .
It first reads from it's configuration file,
It first reads from its configuration file,
.BR :ETCDIR:/atalkd.conf .
If there is no configuration file,

View file

@ -1,6 +1,6 @@
--- config/afpd.conf.orig Sat May 2 05:01:11 1998
+++ config/afpd.conf Tue Nov 24 04:05:13 1998
@@ -1,33 +1,59 @@
--- config/afpd.conf.orig Thu Dec 17 19:39:06 1998
+++ config/afpd.conf Mon Mar 1 23:51:24 1999
@@ -1,35 +1,63 @@
#
-# Format of lines in this file:
+# CONFIGURATION FOR AFPD
@ -28,6 +28,8 @@
-# address (binds a server to a specific address)
-# port (has to be specified if more than one tcp server
-# is to be served)
-# tickleval (sets the tickle interval in seconds)
-# uampath, nlspath
-#
-# Order of precedence:
-# options in afpd.conf > command-line options > built-in options
@ -54,7 +56,7 @@
+# -[no]randnum
+# -[no]rand2num [Don't] Allow Random Number or Two-Way Random Number
+# exchange for transmitting the password (see below)
+# -authall Allow all of the above
+# -authall Allow cleartxt and guest
+#
+# Password Options:
+# -[no]savepassword [Don't] Allow clients to save password locally
@ -72,6 +74,10 @@
+# (same as -u on command line)
+# -[no]uservol [Don't] Read the user's volume file
+#
+# -nlspath Prepend this path to each code page filename
+# in volume options (see afpd.8, default
+# :RESDIR:/nls/netatalk).
+#
+# Miscellaneous:
+# -guestname "user" Specifies the user name for the guest login
+# (default "nobody", same as -g on command line)
@ -87,7 +93,7 @@
# Some examples:
#
# The simplest case is to not have an afpd.conf.
@@ -45,4 +71,3 @@
@@ -47,4 +75,3 @@
# "Guest Volume" -nocleartxt -loginmesg "Welcome guest!"
# "User Volume" -noguest -port 12000
# "special" -notcp -defaultvol <path> -systemvol <path>

View file

@ -22,6 +22,7 @@ include/atalk/aep.h
include/atalk/afp.h
include/atalk/asp.h
include/atalk/atp.h
include/atalk/cnid.h
include/atalk/compat.h
include/atalk/ddp.h
include/atalk/dsi.h