Update to 3.5.0
This commit is contained in:
parent
8b8e0eed1c
commit
40db6c5435
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=390649
5 changed files with 24 additions and 24 deletions
|
@ -1,7 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= sdcc
|
||||
PORTVERSION= 3.4.0
|
||||
PORTVERSION= 3.5.0
|
||||
DISTVERSIONPREFIX= src-
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= SF
|
||||
|
@ -15,7 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/adjacency_list.hpp:${PORTSDIR}/d
|
|||
|
||||
CONFLICTS_INSTALL= sdcc-[0-9]* sdcc-devel-[0-9]*
|
||||
GNU_CONFIGURE= yes
|
||||
USES= gmake tar:bzip2
|
||||
USES= gmake readline:port tar:bzip2
|
||||
|
||||
OPTIONS_DEFINE= DEVLIB DOCS UCSIM
|
||||
OPTIONS_MULTI= TARGETS
|
||||
|
@ -25,11 +25,10 @@ DEVLIB_DESC= Device libraries
|
|||
HC08_DESC= Freescale 68HC08/S08
|
||||
MCS51_DESC= Intel MCS51, Maxim DS80C390/DS80C400
|
||||
PIC_DESC= Microchip PIC
|
||||
UCSIM_DESC= The ucSim simulator
|
||||
STM8_DESC= STMicroelectronics STM8
|
||||
UCSIM_DESC= The ucSim simulator
|
||||
Z80_DESC= Zilog Z80/Z180/GBZ80, Rabbit 2000/3000, Toshiba TLCS-90
|
||||
|
||||
CPPFLAGS+= -idirafter ${LOCALBASE}/include
|
||||
CONFIGURE_ARGS= --disable-avr --disable-install-libbfd --disable-werror \
|
||||
--disable-st7 docdir=${DOCSDIR} sdcc_cv_c_fms_extensions=no
|
||||
CONFIGURE_ENV= ARCH=""
|
||||
|
@ -46,8 +45,8 @@ MCS51_CONFIGURE_OFF= --disable-51 --disable-mcs51-port \
|
|||
PIC_BUILD_DEPENDS= gputils>=1.2.0:${PORTSDIR}/devel/gputils
|
||||
PIC_RUN_DEPENDS= gpasm:${PORTSDIR}/devel/gputils
|
||||
PIC_CONFIGURE_OFF= --disable-pic14-port --disable-pic16-port
|
||||
UCSIM_CONFIGURE_OFF= --disable-ucsim
|
||||
STM8_CONFIGURE_OFF= --disable-stm8 --disable-stm8-port
|
||||
UCSIM_CONFIGURE_OFF= --disable-ucsim
|
||||
Z80_CONFIGURE_OFF= --disable-z80 --disable-z80-port \
|
||||
--disable-z180-port --disable-gbz80-port \
|
||||
--disable-r2k-port --disable-r3ka-port \
|
||||
|
@ -56,7 +55,7 @@ Z80_CONFIGURE_OFF= --disable-z80 --disable-z80-port \
|
|||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${ARCH} == "amd64"
|
||||
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
|
||||
CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (sdcc-src-3.4.0.tar.bz2) = cf6af862b94d5f259f11afa0a1b86304f3047b3723a9df96f20dba869deb5bf9
|
||||
SIZE (sdcc-src-3.4.0.tar.bz2) = 10249599
|
||||
SHA256 (sdcc-src-3.5.0.tar.bz2) = f82978d1614244b22e093402c0a4de1f688a07c807b2980126c964eb3df85fa9
|
||||
SIZE (sdcc-src-3.5.0.tar.bz2) = 10504517
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- device/lib/Makefile.in.orig
|
||||
--- device/lib/Makefile.in.orig 2015-04-15 16:44:20 UTC
|
||||
+++ device/lib/Makefile.in
|
||||
@@ -501,27 +501,6 @@
|
||||
@@ -513,27 +513,6 @@ clean_intermediate-pic14:
|
||||
# ---------------------------------------------------
|
||||
install: all installdirs
|
||||
[ ! -d "$(BUILDDIR)" ] || $(CP_U) -r $(BUILDDIR)/* $(sdcc_libdir)
|
||||
|
@ -28,7 +28,7 @@
|
|||
|
||||
# Deleting all the installed files
|
||||
# --------------------------------
|
||||
@@ -541,13 +520,7 @@
|
||||
@@ -553,13 +532,7 @@ installcheck:
|
||||
# Creating installation directories
|
||||
# ---------------------------------
|
||||
installdirs:
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
--- device/non-free/lib/Makefile.in.orig
|
||||
--- device/non-free/lib/Makefile.in.orig 2015-03-26 13:21:24 UTC
|
||||
+++ device/non-free/lib/Makefile.in
|
||||
@@ -397,17 +397,6 @@
|
||||
# ---------------------------------------------------
|
||||
@@ -353,17 +353,6 @@ clean_intermediate-pic14:
|
||||
install: all installdirs
|
||||
ifneq ($(TARGETS), )
|
||||
[ ! -d "$(BUILDDIR)" ] || $(CP_U) -r $(BUILDDIR)/* $(sdcc_libdir)
|
||||
- $(CP_U) -r $(srcdir)/pic14 $(srcdir)/pic16 $(sdcc_libdir)/src
|
||||
- $(CP_U) -r $(foreach p, $(ENABLED_PORTS), $(srcdir)/$(p)) $(sdcc_libdir)/src
|
||||
-
|
||||
- for src in pic14 pic16; do \
|
||||
- for src in $(ENABLED_PORTS); do \
|
||||
- find $(sdcc_libdir)/src/$$src -depth \
|
||||
- \( -name '*.rel' -o -name '*.dump*' -o -name '*.sym' -o -name '*.o' -o -name '*.lib' -o \
|
||||
- -name '*.lst' -o -name '*.asm' -o -name '.svn' -o -name 'autom4te.cache' -o \
|
||||
|
@ -15,18 +15,18 @@
|
|||
- -name 'bootstrap.sh' \) \
|
||||
- -exec rm -rf {} + ; \
|
||||
- done
|
||||
endif
|
||||
|
||||
# Deleting all the installed files
|
||||
# --------------------------------
|
||||
@@ -427,10 +416,7 @@
|
||||
# Creating installation directories
|
||||
@@ -385,10 +374,7 @@ installcheck:
|
||||
# ---------------------------------
|
||||
installdirs:
|
||||
- for libdir in pic16 pic14; do \
|
||||
ifneq ($(TARGETS), )
|
||||
- for libdir in $(ENABLED_PORTS); do \
|
||||
- mkdir -p $(sdcc_libdir)/$$libdir; \
|
||||
- done
|
||||
- mkdir -p $(sdcc_libdir)/src
|
||||
+ mkdir -p $(sdcc_libdir)
|
||||
endif
|
||||
|
||||
# Creating dependencies
|
||||
# ---------------------
|
||||
|
|
|
@ -18,9 +18,10 @@ bin/sdcclib
|
|||
%%UCSIM%%%%MCS51%%bin/sdcdbsrc.el
|
||||
bin/sdcpp
|
||||
bin/sdld
|
||||
bin/sdld6808
|
||||
bin/sdldgb
|
||||
bin/sdldz80
|
||||
%%HC08%%bin/sdld6808
|
||||
%%Z80%%bin/sdldgb
|
||||
%%STM8%%bin/sdldstm8
|
||||
%%Z80%%bin/sdldz80
|
||||
bin/sdnm
|
||||
bin/sdobjcopy
|
||||
bin/sdranlib
|
||||
|
|
Loading…
Reference in a new issue