Remove expired port:
2016-06-01 lang/ruby20: Upstream support ended
This commit is contained in:
parent
0ec45745a0
commit
4136263df7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416235
18 changed files with 1 additions and 17698 deletions
1
MOVED
1
MOVED
|
@ -8336,3 +8336,4 @@ security/py-clamav|security/py-pyclamd|2016-05-30|Has expired: Not updated since
|
|||
graphics/ruby-gdal||2016-05-31|Has expired: disabled by upstream (https://trac.osgeo.org/gdal/changeset/28756)
|
||||
net/omcmd||2016-06-01|Has expired: Unfetchable and depends on expired net/isc-dhcp41-server
|
||||
net/isc-dhcp41-server|net/isc-dhcp43-server|2016-06-01|Has expired: isc-dhcp 4.1 is now End of Life
|
||||
lang/ruby20||2016-06-01|Has expired: Upstream support ended
|
||||
|
|
|
@ -290,7 +290,6 @@
|
|||
SUBDIR += rexx-wrapper
|
||||
SUBDIR += rhino
|
||||
SUBDIR += rubinius
|
||||
SUBDIR += ruby20
|
||||
SUBDIR += ruby21
|
||||
SUBDIR += ruby22
|
||||
SUBDIR += ruby23
|
||||
|
|
|
@ -1,247 +0,0 @@
|
|||
# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ruby
|
||||
PORTVERSION= ${RUBY_PORTVERSION}
|
||||
PORTREVISION= ${RUBY_PORTREVISION}
|
||||
PORTEPOCH= ${RUBY_PORTEPOCH}
|
||||
CATEGORIES= lang ruby ipv6
|
||||
MASTER_SITES= RUBY/${MASTER_SITE_SUBDIR_RUBY}
|
||||
DISTNAME= ${RUBY_DISTNAME}
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= ruby@FreeBSD.org
|
||||
COMMENT?= Object-oriented interpreted scripting language
|
||||
|
||||
LICENSE= BSD2CLAUSE RUBY
|
||||
LICENSE_COMB= dual
|
||||
LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/BSDL
|
||||
LICENSE_FILE_RUBY= ${WRKSRC}/COPYING
|
||||
|
||||
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
|
||||
BUILD_DEPENDS= libffi>=0:devel/libffi
|
||||
LIB_DEPENDS= libyaml.so:textproc/libyaml
|
||||
RUN_DEPENDS= libffi>=0:devel/libffi
|
||||
|
||||
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
|
||||
--disable-rpath \
|
||||
--enable-pthread \
|
||||
--enable-shared \
|
||||
--with-ruby-version=minor \
|
||||
--with-sitedir="${PREFIX}/lib/ruby/site_ruby" \
|
||||
--with-vendordir="${PREFIX}/lib/ruby/vendor_ruby"
|
||||
CONFIGURE_ENV= LC_ALL=C debugflags=
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
GNU_CONFIGURE= yes
|
||||
# Keep this, else ruby will fail to load libraries dependent of libpthread.
|
||||
LIBS+= -lpthread -L${LOCALBASE}/lib
|
||||
MAKE_ENV= LC_ALL=C
|
||||
USE_LDCONFIG= yes
|
||||
USE_OPENSSL= yes
|
||||
USES= autoreconf cpe execinfo tar:xz
|
||||
WRKSRC= ${RUBY_WRKSRC}
|
||||
|
||||
RUBY_VER= 2.0
|
||||
USE_RUBY= yes
|
||||
RUBY_NO_BUILD_DEPENDS= yes
|
||||
RUBY_NO_RUN_DEPENDS= yes
|
||||
|
||||
NOT_FOR_ARCHS= ia64
|
||||
NOT_FOR_ARCHS_REASON_ia64= does not build
|
||||
|
||||
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES RDOC
|
||||
OPTIONS_DEFAULT= RDOC LIBEDIT
|
||||
OPTIONS_SINGLE= EDIT
|
||||
OPTIONS_SINGLE_EDIT= LIBEDIT READLINE
|
||||
OPTIONS_SUB= yes
|
||||
CAPIDOCS_DESC= Build and install C API documents
|
||||
RDOC_DESC= Build and install Rdoc indexes
|
||||
EDIT_DESC= Which line editing lib to use
|
||||
LIBEDIT_DESC= Use libedit
|
||||
READLINE_DESC= Use libreadline
|
||||
CAPIDOCS_BUILD_DEPENDS= doxygen>0:devel/doxygen \
|
||||
dot:graphics/graphviz
|
||||
CAPIDOCS_CONFIGURE_ENABLE= install-capi
|
||||
LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LOCALBASE}
|
||||
LIBEDIT_USES= libedit
|
||||
RDOC_CONFIGURE_ENABLE= install-rdoc
|
||||
READLINE_BUILD_DEPENDS= readline>=0:devel/readline
|
||||
READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${LOCALBASE}
|
||||
READLINE_RUN_DEPENDS= readline>=0:devel/readline
|
||||
|
||||
CPE_VENDOR= ruby-lang
|
||||
CPE_VERSION= ${RUBY_RELVERSION}
|
||||
CPE_UPDATE= p${RUBY_PATCHLEVEL}
|
||||
|
||||
DEPRECATED= Upstream support ended
|
||||
EXPIRATION_DATE= 2016-06-01
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# PORTEPOCH/PORTREVISION hack
|
||||
|
||||
.if ${PORTEPOCH} != 0
|
||||
_SUF2= ,${PORTEPOCH}
|
||||
.endif
|
||||
|
||||
.if ${PORTREVISION} != 0
|
||||
_SUF1= _${PORTREVISION}
|
||||
.endif
|
||||
|
||||
.if ${OPSYS} == "FreeBSD"
|
||||
.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == "amd64" || ${ARCH} == "i386")
|
||||
CONFIGURE_ARGS+= --enable-dtrace
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-dtrace
|
||||
.endif
|
||||
.endif
|
||||
|
||||
.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
|
||||
CONFIGURE_ARGS+= --with-setjmp-type=_setjmp
|
||||
CONFIGURE_ENV+= ac_cv_func__setjmp=yes
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MCAPIDOCS}
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
.endif
|
||||
|
||||
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
|
||||
MLINKS= ${RUBY_NAME}.1 ruby.1
|
||||
PLIST_SUB+= IF_DEFAULT=""
|
||||
.else
|
||||
PKGNAMESUFFIX= ${RUBY_VER:C/\.//}
|
||||
PLIST_SUB+= IF_DEFAULT="@comment "
|
||||
.endif
|
||||
|
||||
INSTALLED_SCRIPTS= irb erb rdoc ri ruby testrb
|
||||
|
||||
EXTSAMPLES= bigdecimal/sample/*.rb \
|
||||
curses/hello.rb \
|
||||
curses/rain.rb \
|
||||
curses/view.rb \
|
||||
curses/view2.rb
|
||||
|
||||
EXTDOCS= readline/README* \
|
||||
ripper/README \
|
||||
stringio/README \
|
||||
syslog/syslog.txt
|
||||
|
||||
# Macros to change variables in rbconfig.rb
|
||||
RB_SET_CONF_VAR=${SH} -c '${REINPLACE_CMD} -E -e "s,(CONFIG\[\"$$0\"\][[:space:]]*=[[:space:]]*)(\(?)(.*)(\)?),\1\2$$1\4," ${WRKSRC}/rbconfig.rb' --
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -E \
|
||||
-e 's,-l$$pthread_lib,-lpthread,g' \
|
||||
-e '/^RUBY_LIB_PATH/s,\.\$$\{TEENY\},,' \
|
||||
-e '/^RUBY_SITE_LIB_PATH2/s,\.\$$\{TEENY\},,' \
|
||||
-e '/^RUBY_VENDOR_LIB_PATH2/s,\.\$$\{TEENY\},,' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
#
|
||||
# Eliminate all leftovers
|
||||
#
|
||||
@${FIND} ${WRKSRC}/ -name "*.orig" -delete
|
||||
|
||||
#
|
||||
# Remove modules we don't want
|
||||
#
|
||||
.for d in win32ole
|
||||
@${RM} -rf ${BUILD_WRKSRC}/ext/${d}
|
||||
.endfor
|
||||
# We get rake from ports.
|
||||
.for d in bin/rake doc/rake lib/rake test/rake man/rake.1 lib/rake.rb
|
||||
@${RM} -rf ${BUILD_WRKSRC}/${d}
|
||||
.endfor
|
||||
# We get the gem executable from ports.
|
||||
@${RM} ${BUILD_WRKSRC}/bin/gem
|
||||
|
||||
#
|
||||
# Prepare modules we are wanting to build via external ports
|
||||
#
|
||||
.for d in gdbm tk
|
||||
@${MV} ${BUILD_WRKSRC}/ext/${d} ${WRKDIR}/
|
||||
.endfor
|
||||
|
||||
post-build:
|
||||
#
|
||||
# Hack to allow modules to be installed into separate PREFIX and/or under user
|
||||
# privilegies
|
||||
#
|
||||
@${RB_SET_CONF_VAR} "prefix" "ENV['PREFIX'] || \3"
|
||||
@${RB_SET_CONF_VAR} "INSTALL" "'/usr/bin/install -c'"
|
||||
@${RB_SET_CONF_VAR} "INSTALL_PROGRAM" "ENV['RB_USER_INSTALL'] ? '${INSTALL} ${COPY} ${STRIP} -m ${BINMODE}' : '${INSTALL_PROGRAM}'"
|
||||
@${RB_SET_CONF_VAR} "INSTALL_SCRIPT" "ENV['RB_USER_INSTALL'] ? '${INSTALL} ${COPY} -m ${BINMODE}' : '${INSTALL_SCRIPT}'"
|
||||
@${RB_SET_CONF_VAR} "INSTALL_DATA" "ENV['RB_USER_INSTALL'] ? '${INSTALL} ${COPY} -m ${SHAREMODE}' : '${INSTALL_DATA}'"
|
||||
|
||||
post-build-CAPIDOCS-on:
|
||||
@${FIND} ${WRKSRC}/doc -type d -empty -delete
|
||||
|
||||
pre-install:
|
||||
${MKDIR} ${STAGEDIR}${RUBY_SITEARCHLIBDIR}
|
||||
${MKDIR} ${STAGEDIR}${RUBY_VENDORARCHLIBDIR}
|
||||
|
||||
pre-install-DOCS-on:
|
||||
${MKDIR} ${STAGEDIR}${RUBY_DOCDIR}
|
||||
|
||||
pre-install-EXAMPLES-on:
|
||||
${MKDIR} ${STAGEDIR}${RUBY_EXAMPLESDIR}
|
||||
|
||||
pre-install-RDOC-on:
|
||||
${MKDIR} ${STAGEDIR}${RUBY_RIDIR}
|
||||
${MKDIR} ${STAGEDIR}${RUBY_SITERIDIR}
|
||||
|
||||
post-install:
|
||||
#
|
||||
# Link just installed "ruby" to "ruby20", etc.
|
||||
#
|
||||
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
|
||||
. for FILE in ${INSTALLED_SCRIPTS}
|
||||
${LN} -fs ${FILE}${RUBY_SUFFIX} ${STAGEDIR}${PREFIX}/bin/${FILE}
|
||||
. endfor
|
||||
.endif
|
||||
|
||||
post-install-DEBUG-off:
|
||||
#
|
||||
# XXX: hack to strip ruby binary. Ruby uses its own install script that seems
|
||||
# bogus to hack.
|
||||
#
|
||||
.if defined(STRIP) && ${STRIP} == -s
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${RUBY_NAME}
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libruby${RUBY_SHLIBVER}.so.${RUBY_SHLIBVER}
|
||||
${FIND} ${STAGEDIR}${RUBY_ARCHLIBDIR} -type f -name '*\.so' -exec ${STRIP_CMD} {} \;
|
||||
.endif
|
||||
|
||||
post-install-DOCS-on:
|
||||
# Create all dirs required (":u" isn't avaiable in STABLE yet :-()
|
||||
${MKDIR} ${EXTDOCS:C,^([^/]+)/.*,\1,:S,^,${STAGEDIR}${RUBY_DOCDIR}/,}
|
||||
.for FILE in ${EXTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/ext/${FILE} \
|
||||
${STAGEDIR}${RUBY_DOCDIR}/${FILE:C,^([^/]+)/.*,\1,}/
|
||||
.endfor
|
||||
@(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${RUBY_DOCDIR}/)
|
||||
${INSTALL_DATA} ${WRKSRC}/COPYING* \
|
||||
${WRKSRC}/ChangeLog \
|
||||
${WRKSRC}/LEGAL \
|
||||
${WRKSRC}/README* \
|
||||
${STAGEDIR}${RUBY_DOCDIR}/
|
||||
|
||||
post-install-EXAMPLES-on:
|
||||
# Create all dirs required (":u" isn't avaiable in STABLE yet :-()
|
||||
${MKDIR} ${EXTSAMPLES:C,^([^/]+)/.*,\1,:S,^,${STAGEDIR}${RUBY_EXAMPLESDIR}/,}
|
||||
.for FILE in ${EXTSAMPLES}
|
||||
${INSTALL_DATA} ${WRKSRC}/ext/${FILE} \
|
||||
${STAGEDIR}${RUBY_EXAMPLESDIR}/${FILE:C,^([^/]+)/.*,\1,}/
|
||||
.endfor
|
||||
@(cd ${WRKSRC}/sample/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${RUBY_EXAMPLESDIR}/)
|
||||
|
||||
regression-test test:
|
||||
@(cd ${WRKSRC}; ${MAKE} test)
|
||||
|
||||
validate:
|
||||
@${MKDIR} ${WRKSRC}/rubyspec
|
||||
${RM} -rf ${WRKSRC}/rubyspec/*
|
||||
(cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/rubyspec.git)
|
||||
(cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/mspec.git)
|
||||
(cd ${WRKSRC}/rubyspec/rubyspec && ${SETENV} PATH=${WRKSRC}/rubyspec/mspec/bin:${PATH} mspec -t ${PREFIX}/bin/ruby${RUBY_SUFFIX} .)
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (ruby/ruby-2.0.0-p648.tar.xz) = 22fe97739110ba9171b13fc4dcd1a92e767f16769de3593ee41ef1283d218402
|
||||
SIZE (ruby/ruby-2.0.0-p648.tar.xz) = 8303584
|
|
@ -1,20 +0,0 @@
|
|||
--- Makefile.in.orig 2014-09-26 18:04:18 UTC
|
||||
+++ Makefile.in
|
||||
@@ -342,7 +342,7 @@
|
||||
|
||||
.d.h:
|
||||
@$(ECHO) translating probes $<
|
||||
- $(Q) $(DTRACE) -o $@.tmp -h -C $(INCFLAGS) -s $<
|
||||
+ $(Q) $(DTRACE) -xnolibs -o $@.tmp -h -C $(INCFLAGS) -s $<
|
||||
$(Q) sed -e 's/RUBY_/RUBY_DTRACE_/g' -e 's/PROBES_H_TMP/PROBES_H/g' -e 's/(char \*/(const char */g' -e 's/, char \*/, const char */g' $@.tmp > $@
|
||||
$(Q) $(RM) $@.tmp
|
||||
|
||||
@@ -362,7 +362,7 @@
|
||||
fi; \
|
||||
touch "$$stamp"
|
||||
$(RM) $@
|
||||
- $(Q) $(DTRACE) -G -C $(INCFLAGS) -s $(srcdir)/probes.d -o $@ $(DTRACE_DEPENDENT_OBJS)
|
||||
+ $(Q) $(DTRACE) -xnolibs -G -C $(INCFLAGS) -s $(srcdir)/probes.d -o $@ $(DTRACE_DEPENDENT_OBJS)
|
||||
|
||||
# DTrace static library hacks described here:
|
||||
# http://mail.opensolaris.org/pipermail/dtrace-discuss/2005-August/000207.html
|
|
@ -1,77 +0,0 @@
|
|||
--- configure.in.orig 2014-09-26 17:17:06 UTC
|
||||
+++ configure.in
|
||||
@@ -515,7 +515,7 @@
|
||||
[AC_CACHE_CHECK(whether dtrace USDT is available, rb_cv_dtrace_available,
|
||||
[
|
||||
echo "provider conftest{ probe fire(); };" > conftest_provider.d
|
||||
- if $DTRACE -h -o conftest_provider.h -s conftest_provider.d >/dev/null 2>/dev/null; then
|
||||
+ if $DTRACE -xnolibs -h -o conftest_provider.h -s conftest_provider.d >/dev/null 2>/dev/null; then
|
||||
# DTrace is available on the system
|
||||
rb_cv_dtrace_available=yes
|
||||
else
|
||||
@@ -532,13 +532,13 @@
|
||||
[
|
||||
if {
|
||||
echo "provider conftest{ probe fire(); };" > conftest_provider.d &&
|
||||
- dtrace -h -o conftest_provider.h -s conftest_provider.d >/dev/null 2>/dev/null &&
|
||||
+ dtrace -xnolibs -h -o conftest_provider.h -s conftest_provider.d >/dev/null 2>/dev/null &&
|
||||
cat >conftest.c <<_CONF &&
|
||||
@%:@include "conftest_provider.h"
|
||||
int main(void){ CONFTEST_FIRE(); return 0; }
|
||||
_CONF
|
||||
$CC $CFLAGS -c -o conftest.o conftest.c &&
|
||||
- $DTRACE -G -s conftest_provider.d conftest.o 2>/dev/null
|
||||
+ $DTRACE -xnolibs -G -s conftest_provider.d conftest.o 2>/dev/null
|
||||
}; then
|
||||
rb_cv_prog_dtrace_g=yes
|
||||
else
|
||||
@@ -1428,11 +1428,11 @@
|
||||
AC_CHECK_DECLS([sys_nerr], [], [], [$ac_includes_default
|
||||
@%:@include <errno.h>])
|
||||
|
||||
-AC_CHECK_LIB(crypt, crypt)
|
||||
-AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
|
||||
-AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
|
||||
-AC_CHECK_LIB(socket, socketpair) # SunOS/Solaris
|
||||
-AC_CHECK_LIB(rt, clock_gettime) # GNU/Linux
|
||||
+AC_SEARCH_LIBS(crypt, crypt)
|
||||
+AC_SEARCH_LIBS(dlopen, dl) # Dynamic linking for SunOS/Solaris and SYSV
|
||||
+AC_SEARCH_LIBS(shl_load, dld) # Dynamic linking for HP-UX
|
||||
+AC_SEARCH_LIBS(socketpair, socket) # SunOS/Solaris
|
||||
+AC_SEARCH_LIBS(clock_gettime, rt) # GNU/Linux
|
||||
|
||||
AS_CASE(["$target_cpu"],
|
||||
[alpha*|sh4|sh4el|sh4eb], [AS_CASE(["$target_os"::"$GCC"],
|
||||
@@ -2123,7 +2123,7 @@
|
||||
fi
|
||||
|
||||
if test x"$enable_pthread" = xyes; then
|
||||
- for pthread_lib in thr pthread pthreads c c_r root; do
|
||||
+ for pthread_lib in pthread thr pthreads c c_r root; do
|
||||
AC_CHECK_LIB($pthread_lib, pthread_kill,
|
||||
rb_with_pthread=yes, rb_with_pthread=no)
|
||||
if test "$rb_with_pthread" = "yes"; then break; fi
|
||||
@@ -2137,6 +2137,7 @@
|
||||
[c], [],
|
||||
[root], [],
|
||||
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
|
||||
+ [pthread], [MAINLIBS="-pthread $MAINLIBS"],
|
||||
[AS_CASE(["$target_os"],
|
||||
[openbsd*], [LIBS="-pthread $LIBS"],
|
||||
[LIBS="-l$pthread_lib $LIBS"])])
|
||||
@@ -2368,7 +2369,6 @@
|
||||
: ${LDSHARED='$(CC) -shared'}
|
||||
if test "$rb_cv_binary_elf" = yes; then
|
||||
LDFLAGS="$LDFLAGS -rdynamic"
|
||||
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
|
||||
else
|
||||
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
|
||||
fi
|
||||
@@ -2755,6 +2755,7 @@
|
||||
[freebsd*|dragonfly*], [
|
||||
SOLIBS='$(LIBS)'
|
||||
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'
|
||||
+ LIBRUBY_DLDFLAGS='-Wl,-soname,$(LIBRUBY_SO)'
|
||||
if test "$rb_cv_binary_elf" != "yes" ; then
|
||||
LIBRUBY_SO="$LIBRUBY_SO.\$(TEENY)"
|
||||
LIBRUBY_ALIASES=''
|
|
@ -1,11 +0,0 @@
|
|||
--- cont.c.orig 2013-10-09 15:37:54 UTC
|
||||
+++ cont.c
|
||||
@@ -44,6 +44,8 @@
|
||||
/* At least, Linux/ia64's getcontext(3) doesn't save register window.
|
||||
*/
|
||||
# define FIBER_USE_NATIVE 0
|
||||
+# elif defined(__FreeBSD__)
|
||||
+# define FIBER_USE_NATIVE 0
|
||||
# elif defined(__GNU__)
|
||||
/* GNU/Hurd doesn't fully support getcontext, setcontext, makecontext
|
||||
* and swapcontext functions. Disabling their usage till support is
|
|
@ -1,15 +0,0 @@
|
|||
--- ext/openssl/extconf.rb.orig 2015-04-01 22:28:09 UTC
|
||||
+++ ext/openssl/extconf.rb
|
||||
@@ -100,9 +100,9 @@ have_func("OBJ_NAME_do_all_sorted")
|
||||
have_func("SSL_SESSION_get_id")
|
||||
have_func("SSL_SESSION_cmp")
|
||||
have_func("OPENSSL_cleanse")
|
||||
-have_func("SSLv2_method")
|
||||
-have_func("SSLv2_server_method")
|
||||
-have_func("SSLv2_client_method")
|
||||
+have_func("SSLv23_method")
|
||||
+have_func("SSLv23_server_method")
|
||||
+have_func("SSLv23_client_method")
|
||||
have_func("TLSv1_1_method")
|
||||
have_func("TLSv1_1_server_method")
|
||||
have_func("TLSv1_1_client_method")
|
|
@ -1,19 +0,0 @@
|
|||
--- ext/readline/extconf.rb.orig 2014-05-01 11:59:37.000000000 +0000
|
||||
+++ ext/readline/extconf.rb 2015-10-23 04:05:44.000000000 +0000
|
||||
@@ -37,6 +37,7 @@
|
||||
case enable_libedit
|
||||
when true
|
||||
# --enable-libedit
|
||||
+ dir_config("libedit")
|
||||
unless (readline.have_header("editline/readline.h") ||
|
||||
readline.have_header("readline/readline.h")) &&
|
||||
have_library("edit", "readline")
|
||||
@@ -62,7 +63,7 @@ else
|
||||
end
|
||||
|
||||
readline.have_func("rl_getc")
|
||||
-readline.have_func("rl_getc_function")
|
||||
+#readline.have_func("rl_getc_function")
|
||||
readline.have_func("rl_filename_completion_function")
|
||||
readline.have_func("rl_username_completion_function")
|
||||
readline.have_func("rl_completion_matches")
|
|
@ -1,11 +0,0 @@
|
|||
--- include/ruby/ruby.h.orig 2015-09-20 20:42:37 UTC
|
||||
+++ include/ruby/ruby.h
|
||||
@@ -238,7 +238,7 @@ typedef char ruby_check_sizeof_voidp[SIZ
|
||||
#define FIXNUM_MAX (LONG_MAX>>1)
|
||||
#define FIXNUM_MIN RSHIFT((long)LONG_MIN,1)
|
||||
|
||||
-#define INT2FIX(i) ((VALUE)(((SIGNED_VALUE)(i))<<1 | FIXNUM_FLAG))
|
||||
+#define INT2FIX(i) (((VALUE)(i))<<1 | FIXNUM_FLAG)
|
||||
#define LONG2FIX(i) INT2FIX(i)
|
||||
#define rb_fix_new(v) INT2FIX(v)
|
||||
VALUE rb_int2inum(SIGNED_VALUE);
|
|
@ -1,13 +0,0 @@
|
|||
--- lib/rdoc/single_class.rb 2012-11-27 04:28:14 UTC
|
||||
+++ lib/rdoc/single_class.rb
|
||||
@@ -10,6 +10,10 @@ def ancestors
|
||||
superclass ? super + [superclass] : super
|
||||
end
|
||||
|
||||
+ def aref_prefix # :nodoc:
|
||||
+ 'sclass'
|
||||
+ end
|
||||
+
|
||||
##
|
||||
# The definition of this singleton class, <tt>class << MyClassName</tt>
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- ./lib/rdoc/ruby_lex.rb.orig 2012-12-18 07:31:36 UTC
|
||||
+++ ./lib/rdoc/ruby_lex.rb
|
||||
@@ -1028,6 +1028,8 @@
|
||||
end
|
||||
|
||||
if output_heredoc then
|
||||
+ raise Error, "Missing terminating #{quoted} for string" unless l
|
||||
+
|
||||
doc << l.chomp
|
||||
else
|
||||
doc << '"'
|
|
@ -1,11 +0,0 @@
|
|||
--- lib/mkmf.rb.orig 2013-06-26 14:03:38 UTC
|
||||
+++ lib/mkmf.rb
|
||||
@@ -226,7 +226,7 @@
|
||||
end
|
||||
$extmk ||= false
|
||||
if not $extmk and File.exist?(($hdrdir = RbConfig::CONFIG["rubyhdrdir"]) + "/ruby/ruby.h")
|
||||
- $topdir = $hdrdir
|
||||
+ $topdir = $hdrdir + "/" + "#{CONFIG['arch']}/ruby/"
|
||||
$top_srcdir = $hdrdir
|
||||
$arch_hdrdir = RbConfig::CONFIG["rubyarchhdrdir"]
|
||||
elsif File.exist?(($hdrdir = ($top_srcdir ||= topdir) + "/include") + "/ruby.h")
|
|
@ -1,12 +0,0 @@
|
|||
--- tool/mkconfig.rb.orig 2013-05-27 03:20:04 UTC
|
||||
+++ tool/mkconfig.rb
|
||||
@@ -173,7 +173,8 @@
|
||||
end
|
||||
vars["prefix"] = ""
|
||||
vars["exec_prefix"] = ""
|
||||
-prefix = vars.expand(vars["rubyarchdir"])
|
||||
+major, minor, *rest = RUBY_VERSION.split('.')
|
||||
+prefix = "/lib/ruby/#{major}.#{minor}/#{arch}"
|
||||
print " TOPDIR = File.dirname(__FILE__).chomp!(#{prefix.dump})\n"
|
||||
print " DESTDIR = ", (drive ? "TOPDIR && TOPDIR[/\\A[a-z]:/i] || " : ""), "'' unless defined? DESTDIR\n"
|
||||
print <<'ARCH' if universal
|
|
@ -1,82 +0,0 @@
|
|||
--- tool/rbinstall.rb.orig 2013-02-07 08:02:31 UTC
|
||||
+++ tool/rbinstall.rb
|
||||
@@ -307,6 +307,7 @@
|
||||
libdir = CONFIG["libdir", true]
|
||||
rubyhdrdir = CONFIG["rubyhdrdir", true]
|
||||
archhdrdir = CONFIG["rubyarchhdrdir"] || (rubyhdrdir + "/" + CONFIG['arch'])
|
||||
+libdatadir = CONFIG["prefix", true] + "/" + "libdata"
|
||||
rubylibdir = CONFIG["rubylibdir", true]
|
||||
archlibdir = CONFIG["rubyarchdir", true]
|
||||
sitelibdir = CONFIG["sitelibdir"]
|
||||
@@ -362,7 +363,7 @@
|
||||
install?(:local, :arch, :data) do
|
||||
pc = CONFIG["ruby_pc"]
|
||||
if pc and File.file?(pc) and File.size?(pc)
|
||||
- prepare "pkgconfig data", pkgconfigdir = File.join(libdir, "pkgconfig")
|
||||
+ prepare "pkgconfig data", pkgconfigdir = File.join(libdatadir, "pkgconfig")
|
||||
install pc, pkgconfigdir, :mode => $data_mode
|
||||
end
|
||||
end
|
||||
@@ -684,62 +685,6 @@
|
||||
end
|
||||
# :startdoc:
|
||||
|
||||
-install?(:ext, :comm, :gem) do
|
||||
- $:.unshift(File.join(srcdir, "lib"))
|
||||
- require("rubygems.rb")
|
||||
- gem_dir = Gem.default_dir
|
||||
- # Gem.ensure_gem_subdirectories makes subdirectories group-writable.
|
||||
- directories = Gem::REPOSITORY_SUBDIRECTORIES
|
||||
- prepare "default gems", gem_dir, directories
|
||||
-
|
||||
- spec_dir = File.join(gem_dir, directories.grep(/^spec/)[0])
|
||||
- default_spec_dir = "#{spec_dir}/default"
|
||||
- makedirs(default_spec_dir)
|
||||
-
|
||||
- gems = {}
|
||||
- File.foreach(File.join(srcdir, "defs/default_gems")) do |line|
|
||||
- line.chomp!
|
||||
- line.sub!(/\s*#.*/, '')
|
||||
- next if line.empty?
|
||||
- words = []
|
||||
- line.scan(/\G\s*([^\[\]\s]+|\[([^\[\]]*)\])/) do
|
||||
- words << ($2 ? $2.split : $1)
|
||||
- end
|
||||
- name, base_dir, src, execs = *words
|
||||
- next unless name and base_dir and src
|
||||
-
|
||||
- src = File.join(srcdir, src)
|
||||
- base_dir = File.join(srcdir, base_dir)
|
||||
- specgen = RbInstall::Specs::Generator.new(name, base_dir, src, execs || [])
|
||||
- gems[name] ||= specgen
|
||||
- end
|
||||
-
|
||||
- Dir.glob(srcdir+"/{lib,ext}/**/*.gemspec").each do |src|
|
||||
- specgen = RbInstall::Specs::Reader.new(src)
|
||||
- gems[specgen.gemspec.name] ||= specgen
|
||||
- end
|
||||
-
|
||||
- gems.sort.each do |name, specgen|
|
||||
- gemspec = specgen.gemspec
|
||||
- base_dir = specgen.src.sub(/\A#{Regexp.escape(srcdir)}\//, "")
|
||||
- full_name = "#{gemspec.name}-#{gemspec.version}"
|
||||
-
|
||||
- puts "#{" "*30}#{gemspec.name} #{gemspec.version}"
|
||||
- gemspec_path = File.join(default_spec_dir, "#{full_name}.gemspec")
|
||||
- open_for_install(gemspec_path, $data_mode) do
|
||||
- specgen.spec_source
|
||||
- end
|
||||
-
|
||||
- unless gemspec.executables.empty? then
|
||||
- bin_dir = File.join(gem_dir, 'gems', full_name, 'bin')
|
||||
- makedirs(bin_dir)
|
||||
-
|
||||
- execs = gemspec.executables.map {|exec| File.join(srcdir, 'bin', exec)}
|
||||
- install(execs, bin_dir, :mode => $prog_mode)
|
||||
- end
|
||||
- end
|
||||
-end
|
||||
-
|
||||
parse_args()
|
||||
|
||||
include FileUtils
|
|
@ -1,19 +0,0 @@
|
|||
Ruby is the interpreted scripting language for quick and
|
||||
easy object-oriented programming. It has many features to
|
||||
process text files and to do system management tasks (as in
|
||||
Perl). It is simple, straight-forward, and extensible.
|
||||
|
||||
Features of Ruby are shown below.
|
||||
|
||||
+ Simple Syntax
|
||||
+ *Normal* Object-Oriented features(ex. class, method calls)
|
||||
+ *Advanced* Object-Oriented features(ex. Mix-in, Singleton-method)
|
||||
+ Operator Overloading
|
||||
+ Exception Handling
|
||||
+ Iterators and Closures
|
||||
+ Garbage Collection
|
||||
+ Dynamic Loading of Object files(on some architecture)
|
||||
+ Highly Portable(works on many UNIX machines, and on DOS,
|
||||
Windows, Mac, BeOS etc.)
|
||||
|
||||
WWW: http://www.ruby-lang.org/en/
|
|
@ -1,14 +0,0 @@
|
|||
====
|
||||
Some of the standard commands are provided as separate ports for ease
|
||||
of upgrading:
|
||||
|
||||
devel/ruby-gems: gem - RubyGems package manager
|
||||
devel/rubygem-rake: rake - Ruby Make
|
||||
|
||||
And some of the standard libraries are provided as separate ports
|
||||
since they require extra dependencies:
|
||||
|
||||
databases/ruby-gdbm: GDBM module
|
||||
|
||||
Install them as occasion demands.
|
||||
====
|
17133
lang/ruby20/pkg-plist
17133
lang/ruby20/pkg-plist
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue