Adding xkbctrl version 1.0.
Display and manipulate XKB keyboard controls from the commandline. PR: 16006 Submitted by: Yoshiro MIHIRA <sanpei@sanpei.org>
This commit is contained in:
parent
d5b4e10d76
commit
413d8b01b6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=25220
8 changed files with 100 additions and 0 deletions
|
@ -59,6 +59,7 @@
|
|||
SUBDIR += xfedor
|
||||
SUBDIR += xfishtank
|
||||
SUBDIR += xgrab
|
||||
SUBDIR += xkbctrl
|
||||
SUBDIR += xkeycaps
|
||||
SUBDIR += xkeywrap
|
||||
SUBDIR += xloadimage
|
||||
|
|
32
x11/xkbctrl/Makefile
Normal file
32
x11/xkbctrl/Makefile
Normal file
|
@ -0,0 +1,32 @@
|
|||
# New ports collection makefile for: xkbctrl
|
||||
# Version required: 1.0
|
||||
# Date created: 9 January 2000
|
||||
# Whom: Yoshiro MIHIRA <sanpei@sanpei.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= xkbctrl
|
||||
PKGNAME= xkbctrl-1.0
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ftp://core.ring.gr.jp/pub/X/opengroup/unsupported/test/Xkb/programs/ \
|
||||
ftp://ring.nacsis.ac.jp/pub/X/opengroup/unsupported/test/Xkb/programs/
|
||||
DISTFILES= Imakefile xkbctrl.c
|
||||
|
||||
MAINTAINER= sanpei@sanpei.org
|
||||
|
||||
DIST_SUBDIR= xkbctrl
|
||||
USE_IMAKE= yes
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
do-extract:
|
||||
@${RM} -rf ${WRKDIR}
|
||||
@${MKDIR} ${WRKDIR}
|
||||
@for file in ${DISTFILES}; do \
|
||||
${CP} ${DISTDIR}/${DIST_SUBDIR}/$${file} ${WRKSRC}; \
|
||||
done
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
2
x11/xkbctrl/distinfo
Normal file
2
x11/xkbctrl/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (xkbctrl/Imakefile) = 12125739f5bbbaaa43bcecd161fe580d
|
||||
MD5 (xkbctrl/xkbctrl.c) = 7db64f67827adf216ed7fe8b29a66101
|
40
x11/xkbctrl/files/patch-aa
Normal file
40
x11/xkbctrl/files/patch-aa
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- Imakefile.org Sun Jan 9 22:48:52 2000
|
||||
+++ Imakefile Sun Jan 9 22:49:13 2000
|
||||
@@ -7,35 +7,9 @@
|
||||
DEPLIBS = $(DEPXKBFILELIB) $(DEPXONLYLIB)
|
||||
XTLOCLIBS = $(XTOOLLIB) $(XONLYLIB)
|
||||
XTDEPLIBS = $(DEPXTOOLLIB) $(DEPXONLYLIB)
|
||||
- SRCS = xkbver.c xkbev.c xkbshow.c xkblock.c xkbctrl.c xkbsetmasks.c \
|
||||
- xkbwatch.c xkbdebug.c xkbleds.c xkbrefresh.c xkbcompat.c xkbget.c \
|
||||
- xkbtest.c xkbcfgtest.c xkbwrbynames.c xkbextdev.c xkblist.c \
|
||||
- xkbmaptest.c testmaprules.c xkbsetgeom.c
|
||||
+ SRCS = xkbctrl.c
|
||||
|
||||
-all: xkbver xkbev xkbshow xkblock xkbctrl xkbsetmasks xkbwatch \
|
||||
- xkbdebug xkbleds xkbrefresh xkbcompat xkbget xkbtest \
|
||||
- xkbcfgtest xkbwrbynames xkbextdev xkblist \
|
||||
- xkbmaptest testmaprules xkbsetgeom
|
||||
+all:: xkbctrl
|
||||
|
||||
-NormalProgramTarget(xkbver,xkbver.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbev,xkbev.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbshow,xkbshow.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkblock,xkblock.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
NormalProgramTarget(xkbctrl,xkbctrl.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbsetmasks,xkbsetmasks.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbwatch,xkbwatch.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbdebug,xkbdebug.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbleds,xkbleds.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbrefresh,xkbrefresh.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbcompat,xkbcompat.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbget,xkbget.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbtest,xkbtest.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbcfgtest,xkbcfgtest.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbwrbynames,xkbwrbynames.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbextdev,xkbextdev.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkblist,xkblist.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbmaptest,xkbmaptest.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(testmaprules,testmaprules.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-NormalProgramTarget(xkbsetgeom,xkbsetgeom.o,$(DEPLIBS),$(LOCLIBS),NullParameter)
|
||||
-
|
||||
DependTarget()
|
11
x11/xkbctrl/files/patch-ab
Normal file
11
x11/xkbctrl/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- xkbctrl.c.org Sun Jan 9 22:51:02 2000
|
||||
+++ xkbctrl.c Sun Jan 9 22:51:21 2000
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
-#include <values.h>
|
||||
+#include <limits.h>
|
||||
#include <ctype.h>
|
||||
#include <X11/Xos.h>
|
||||
#include <X11/Xlib.h>
|
1
x11/xkbctrl/pkg-comment
Normal file
1
x11/xkbctrl/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Display and manipulate XKB keyboard controls from the commandline
|
12
x11/xkbctrl/pkg-descr
Normal file
12
x11/xkbctrl/pkg-descr
Normal file
|
@ -0,0 +1,12 @@
|
|||
Display and manipulate XKB keyboard controls from the commandline
|
||||
|
||||
You can set keyboard delay and repeat rates with XKB/X enviroment:
|
||||
|
||||
% xkbctrl +repeat 200 20
|
||||
|
||||
command help:
|
||||
|
||||
% xkbctrl -help
|
||||
|
||||
MIHIRA Yoshiro
|
||||
<sanpei@sanpei.org>
|
1
x11/xkbctrl/pkg-plist
Normal file
1
x11/xkbctrl/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/xkbctrl
|
Loading…
Reference in a new issue