Update to 1.6.17; IPv6 support has been removed from eggdrop.
PR: ports/71423 Submitted by: Ulrich Spoerlein <q at uni dot de> (maintainer)
This commit is contained in:
parent
40a3dd9700
commit
4169ea8ee8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118830
13 changed files with 118 additions and 107 deletions
|
@ -6,19 +6,19 @@
|
|||
#
|
||||
|
||||
PORTNAME= eggdrop
|
||||
PORTVERSION= 1.6.15
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= irc tcl84 ipv6
|
||||
PORTVERSION= 1.6.17
|
||||
CATEGORIES= irc tcl84
|
||||
MASTER_SITES= ftp://ftp.eggheads.org/pub/eggdrop/source/1.6/
|
||||
DISTNAME= ${PORTNAME:S/-//}${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}${PORTVERSION}
|
||||
|
||||
PATCHFILES= eggdrop1.6.15-ssl.fixed.diff.gz
|
||||
PATCHFILES= ${PORTNAME}${PORTVERSION}-ssl.diff.gz
|
||||
PATCH_SITES= http://www.egghelp.org/files/patches/
|
||||
PATCH_WRKSRC= ${WRKDIR}
|
||||
|
||||
MAINTAINER= q@uni.de
|
||||
COMMENT= The most popular open source Internet Relay Chat bot
|
||||
|
||||
USE_BZIP2= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
|
||||
.if !defined(WITHOUT_TCL)
|
||||
|
@ -36,22 +36,12 @@ CONFIGURE_ARGS+= --without-ssl
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 400014 && defined(WITH_IPV6)
|
||||
CONFIGURE_ARGS+= --enable-ipv6
|
||||
PLIST_SUB+= IPV6="@comment "
|
||||
.else
|
||||
PLIST_SUB+= IPV6=""
|
||||
.endif
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= eggdrop.1
|
||||
|
||||
pre-everything::
|
||||
.if ${OSVERSION} >= 400014 && !defined(WITH_IPV6)
|
||||
@${ECHO_MSG} 'Define WITH_IPV6 to enable IPv6 support'
|
||||
.endif
|
||||
.if !defined(WITH_SSL)
|
||||
@${ECHO_MSG} 'Define WITH_SSL to enable SSL support'
|
||||
.endif
|
||||
|
@ -60,8 +50,8 @@ post-configure:
|
|||
@(cd ${WRKSRC}; ${MAKE} config)
|
||||
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${WRKSRC}/eggdrop.conf \
|
||||
> ${WRKSRC}/eggdrop.conf.sample
|
||||
# Workaround broken relative path in SSL-patch
|
||||
@(cd ${WRKSRC}/src && ${LN} -s ../config.h)
|
||||
# Workaround broken relative path in SSL-patch
|
||||
@(cd ${WRKSRC}/src && ${LN} -fs ../config.h)
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/eggdrop ${PREFIX}/bin
|
||||
|
@ -71,23 +61,24 @@ do-install:
|
|||
${DATADIR}/language ${DATADIR}/text ${PREFIX}/lib/eggdrop
|
||||
@${INSTALL_DATA} ${WRKSRC}/language/core.*.lang ${DATADIR}/language
|
||||
@cd ${WRKSRC} && ${INSTALL_DATA} assoc.so blowfish.so channels.so \
|
||||
compress.so console.so ctcp.so filesys.so irc.so notes.so seen.so \
|
||||
server.so share.so transfer.so uptime.so wire.so ${PREFIX}/lib/eggdrop
|
||||
.if !defined(WITH_IPV6)
|
||||
@cd ${WRKSRC} && ${INSTALL_DATA} dns.so ${PREFIX}/lib/eggdrop
|
||||
.endif
|
||||
compress.so console.so ctcp.so dns.so filesys.so irc.so notes.so \
|
||||
seen.so server.so share.so transfer.so uptime.so wire.so \
|
||||
${PREFIX}/lib/eggdrop
|
||||
.for f in assoc.mod/help/assoc.help channels.mod/help/chaninfo.help \
|
||||
channels.mod/help/channels.help console.mod/help/console.help \
|
||||
compress.mod/help/compress.help ctcp.mod/help/ctcp.help \
|
||||
filesys.mod/help/filesys.help irc.mod/help/irc.help \
|
||||
notes.mod/help/notes.help seen.mod/help/seen.help \
|
||||
server.mod/help/server.help share.mod/help/share.help
|
||||
server.mod/help/server.help share.mod/help/share.help \
|
||||
transfer.mod/help/transfer.help uptime.mod/help/uptime.help \
|
||||
wire.mod/help/wire.help
|
||||
@${INSTALL_DATA} ${WRKSRC}/src/mod/$f ${DATADIR}/help
|
||||
.endfor
|
||||
.for f in channels.mod/help/set/channels.help compress.mod/help/set/compress.help \
|
||||
console.mod/help/set/console.help ctcp.mod/help/set/ctcp.help \
|
||||
filesys.mod/help/set/filesys.help irc.mod/help/set/irc.help \
|
||||
notes.mod/help/set/notes.help server.mod/help/set/server.help \
|
||||
transfer.mod/help/set/transfer.help
|
||||
share.mod/help/set/share.help transfer.mod/help/set/transfer.help
|
||||
@${INSTALL_DATA} ${WRKSRC}/src/mod/$f ${DATADIR}/help/set
|
||||
.endfor
|
||||
.for f in irc.mod/help/msg/irc.help notes.mod/help/msg/notes.help \
|
||||
|
@ -107,14 +98,15 @@ do-install:
|
|||
@cd ${WRKSRC}/text && ${INSTALL_DATA} banner motd ${DATADIR}/text
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}/settings ${DOCSDIR}/html
|
||||
@cd ${WRKSRC}/doc && ${INSTALL_DATA} BOTNET tcl-commands.doc tricks \
|
||||
BUG-REPORT first_script.txt KNOWN-PROBLEMS MODULES PARTYLINE \
|
||||
text-substitutions.doc UPDATES1.5 UPDATES1.6 ${DOCSDIR}
|
||||
@cd ${WRKSRC}/doc && ${INSTALL_DATA} ABOUT AUTHORS BANS BOTNET BUG-REPORT \
|
||||
COMPILE-GUIDE CONTENTS FIRST-SCRIPT KNOWN-PROBLEMS MODULES \
|
||||
PARTYLINE PATCH-HOWTO TEXT-SUBSTITUTIONS TRICKS UPDATES1.6 USERS \
|
||||
WEIRD-MESSAGES tcl-commands.doc ${DOCSDIR}
|
||||
@cd ${WRKSRC}/doc/html && ${INSTALL_DATA} *.html ${DOCSDIR}/html
|
||||
@cd ${WRKSRC}/doc/settings && ${INSTALL_DATA} * ${DOCSDIR}/settings
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${PKGMESSAGE}
|
||||
@${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${PKGMESSAGE} | fmt
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
MD5 (eggdrop1.6.15.tar.gz) = f1f0c3e8b914d626c06a567560f737dd
|
||||
SIZE (eggdrop1.6.15.tar.gz) = 961868
|
||||
MD5 (eggdrop1.6.15-ssl.fixed.diff.gz) = ac2a146dc1ec2c4e28bf8e77178fae74
|
||||
SIZE (eggdrop1.6.15-ssl.fixed.diff.gz) = 20318
|
||||
MD5 (eggdrop1.6.17.tar.bz2) = 68e181201483dee398f9904e8652e6ca
|
||||
SIZE (eggdrop1.6.17.tar.bz2) = 805376
|
||||
MD5 (eggdrop1.6.17-ssl.diff.gz) = cb3520ca39cc1ef833993af5ac308d7b
|
||||
SIZE (eggdrop1.6.17-ssl.diff.gz) = 9839
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
--- eggdrop1.6.15/src/main.c.orig Mon May 5 06:05:32 2003
|
||||
+++ eggdrop1.6.15/src/main.c Mon Jun 2 11:16:57 2003
|
||||
@@ -70,7 +70,7 @@
|
||||
#define _POSIX_SOURCE 1
|
||||
--- eggdrop1.6.17/src/main.c.orig Mon May 5 06:05:32 2003
|
||||
+++ eggdrop1.6.17/src/main.c Mon Jun 2 11:16:57 2003
|
||||
@@ -73,6 +73,6 @@
|
||||
#endif
|
||||
|
||||
-extern char origbotname[], userfile[], botnetnick[];
|
||||
|
@ -9,16 +8,16 @@
|
|||
extern int dcc_total, conmask, cache_hit, cache_miss, max_logs, quick_logs;
|
||||
extern struct dcc_t *dcc;
|
||||
extern struct userrec *userlist;
|
||||
@@ -101,7 +101,7 @@
|
||||
* stats? */
|
||||
int term_z = 0; /* Foreground: use the terminal as a party
|
||||
* line? */
|
||||
-char configfile[121] = "eggdrop.conf"; /* Name of the config file */
|
||||
+char configfile[121] = __PREFIX__ "/etc/eggdrop.conf"; /* Name of the config file */
|
||||
char helpdir[121] = "help/"; /* Directory of help files (if used) */
|
||||
char textdir[121] = "text/"; /* Directory for text files that get dumped */
|
||||
int keep_all_logs = 0; /* Never erase logfiles, no matter how old
|
||||
@@ -735,6 +735,8 @@
|
||||
@@ -102,7 +102,7 @@
|
||||
int term_z = 0; /* Foreground: use the terminal as a partyline? */
|
||||
int use_stderr = 1; /* Send stuff to stderr instead of logfiles? */
|
||||
|
||||
-char configfile[121] = "eggdrop.conf"; /* Default config file name */
|
||||
+char configfile[121] = __PREFIX__ "/etc/eggdrop.conf"; /* Default config file name */
|
||||
char pid_file[120]; /* Name of the pid file */
|
||||
char helpdir[121] = "help/"; /* Directory of help files */
|
||||
char textdir[121] = "text/"; /* Directory for text files */
|
||||
@@ -732,6 +732,8 @@
|
||||
}
|
||||
#endif
|
||||
|
||||
|
@ -27,7 +26,7 @@
|
|||
/* Initialise context list */
|
||||
for (i = 0; i < 16; i++)
|
||||
Context;
|
||||
@@ -834,7 +836,7 @@
|
||||
@@ -831,7 +833,7 @@
|
||||
cache_miss = 0;
|
||||
cache_hit = 0;
|
||||
if (!pid_file[0])
|
||||
|
|
|
@ -1,20 +1,10 @@
|
|||
--- eggdrop1.6.15/src/Makefile.in.orig Mon Feb 9 22:42:35 2004
|
||||
+++ eggdrop1.6.15/src/Makefile.in Mon Feb 9 22:43:23 2004
|
||||
@@ -17,7 +17,7 @@
|
||||
--- eggdrop1.6.17/src/Makefile.in.orig Mon Feb 9 22:42:35 2004
|
||||
+++ eggdrop1.6.17/src/Makefile.in Mon Feb 9 22:43:23 2004
|
||||
@@ -19,6 +19,6 @@
|
||||
STRIP = @STRIP@
|
||||
#CFLAGS = @CFLAGS@ -I.. -I$(top_srcdir) @DEFS@ $(CFLGS)
|
||||
CFLAGS = @CFLAGS@ -I$(XSSL_INCLUDE) -I.. -I$(top_srcdir) @DEFS@ $(CFLGS)
|
||||
CFLAGS = @CFLAGS@ -I.. -I$(top_srcdir) @DEFS@ $(CFLGS)
|
||||
-CPPFLAGS = @CPPFLAGS@
|
||||
+CPPFLAGS = @CPPFLAGS@ '-D__PREFIX__="@prefix@"'
|
||||
|
||||
eggdrop_objs = bg.o botcmd.o botmsg.o botnet.o chanprog.o cmds.o dcc.o \
|
||||
dccutil.o dns.o flags.o language.o match.o main.o mem.o misc.o misc_file.o \
|
||||
@@ -39,7 +39,7 @@
|
||||
@echo ""
|
||||
@touch mod/mod.xlibs
|
||||
# $(LD) -o ../$(EGGEXEC) $(eggdrop_objs) $(MODOBJS) $(XLIBS) md5/md5c.o compat/*.o `cat mod/mod.xlibs`
|
||||
- $(LD) -o ../$(EGGEXEC) $(eggdrop_objs) $(XSSL_LIBS) $(MODOBJS) $(XLIBS) md5/md5c.o compat/*.o `cat mod/mod.xlibs`
|
||||
+ $(LD) -o ../$(EGGEXEC) $(eggdrop_objs) $(XSSL_LIBS) $(MODOBJS) $(XLDFLAGS) $(XLIBS) md5/md5c.o compat/*.o `cat mod/mod.xlibs`
|
||||
$(STRIP) ../$(EGGEXEC)
|
||||
@echo "Successful compile: $(EGGEXEC)"
|
||||
@echo ""
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- eggdrop1.6.15/src/mod/filesys.mod/filesys.c.orig Mon Jun 2 11:25:01 2003
|
||||
+++ eggdrop1.6.15/src/mod/filesys.mod/filesys.c Mon Jun 2 11:25:46 2003
|
||||
@@ -452,7 +452,7 @@
|
||||
--- eggdrop1.6.17/src/mod/filesys.mod/filesys.c.orig Mon Jun 2 11:25:01 2003
|
||||
+++ eggdrop1.6.17/src/mod/filesys.mod/filesys.c Mon Jun 2 11:25:46 2003
|
||||
@@ -461,7 +461,7 @@
|
||||
if (at_limit(nick)) {
|
||||
char xxx[1024];
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- eggdrop1.6.15/src/mod/ctcp.mod/ctcp.c.orig Mon Jun 2 11:27:58 2003
|
||||
+++ eggdrop1.6.15/src/mod/ctcp.mod/ctcp.c Mon Jun 2 11:29:29 2003
|
||||
@@ -160,8 +160,8 @@
|
||||
--- eggdrop1.6.17/src/mod/ctcp.mod/ctcp.c.orig Mon Jun 2 11:27:58 2003
|
||||
+++ eggdrop1.6.17/src/mod/ctcp.mod/ctcp.c Mon Jun 2 11:29:29 2003
|
||||
@@ -161,8 +161,8 @@
|
||||
/* Do me a favour and don't change this back to a CTCP reply,
|
||||
* CTCP replies are NOTICE's this has to be a PRIVMSG
|
||||
* -poptix 5/1/1997 */
|
||||
|
|
|
@ -1,11 +1,8 @@
|
|||
--- eggdrop1.6.15/src/modules.c.orig Mon Jun 2 11:31:15 2003
|
||||
+++ eggdrop1.6.15/src/modules.c Mon Jun 2 11:31:44 2003
|
||||
@@ -101,7 +101,7 @@
|
||||
--- eggdrop1.6.17/src/modules.c.orig Mon Jun 2 11:31:15 2003
|
||||
+++ eggdrop1.6.17/src/modules.c Mon Jun 2 11:31:44 2003
|
||||
@@ -120,4 +120,4 @@
|
||||
#ifndef STATIC
|
||||
|
||||
/* Directory to look for modules */
|
||||
-char moddir[121] = "modules/";
|
||||
+char moddir[121] = __PREFIX__ "/lib/eggdrop/";
|
||||
|
||||
#else
|
||||
#endif
|
||||
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- eggdrop1.6.15/src/mod/share.mod/share.c.orig Mon May 5 00:05:33 2003
|
||||
+++ eggdrop1.6.15/src/mod/share.mod/share.c Tue Nov 18 16:51:41 2003
|
||||
@@ -1113,7 +1113,7 @@
|
||||
--- eggdrop1.6.17/src/mod/share.mod/share.c.orig Mon May 5 00:05:33 2003
|
||||
+++ eggdrop1.6.17/src/mod/share.mod/share.c Tue Nov 18 16:51:41 2003
|
||||
@@ -1120,7 +1120,7 @@
|
||||
int i, sock;
|
||||
FILE *f;
|
||||
|
||||
- egg_snprintf(s, sizeof s, ".share.%s.%lu.users", botnetnick, now);
|
||||
- egg_snprintf(s, sizeof s, ".share.%s.%li.users", botnetnick, now);
|
||||
+ egg_snprintf(s, sizeof s, "%.100s/.share.%.32s.%lu.users", tempdir, botnetnick, now);
|
||||
if (!(b_status(idx) & STAT_SHARE)) {
|
||||
dprintf(idx, "s e You didn't ask; you just started sending.\n");
|
||||
dprintf(idx, "s e Ask before sending the userfile.\n");
|
||||
@@ -1883,8 +1883,8 @@
|
||||
@@ -1889,8 +1889,8 @@
|
||||
struct chanuserrec *ch;
|
||||
struct chanset_t *cst;
|
||||
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- eggdrop1.6.15/src/mod/Makefile.in.orig Mon Jun 2 11:36:50 2003
|
||||
+++ eggdrop1.6.15/src/mod/Makefile.in Mon Jun 2 11:39:02 2003
|
||||
@@ -87,7 +87,7 @@
|
||||
echo "Configuring module $${modname} ..."; \
|
||||
--- eggdrop1.6.17/src/mod/Makefile.in.orig Mon Jun 2 11:36:50 2003
|
||||
+++ eggdrop1.6.17/src/mod/Makefile.in Mon Jun 2 11:39:02 2003
|
||||
@@ -86,7 +86,7 @@
|
||||
echo ""; \
|
||||
echo "Configuring module '$${modname}'."; \
|
||||
if test ! -d $$i; then mkdir $$i; fi; \
|
||||
- (cd $$i && $(MOD_UPDIR)$(srcdir)/$$i/configure $(egg_ac_parameters) $(ENABLEIPV6) --cache-file=../../../config.cache --srcdir=$(MOD_UPDIR)$(top_srcdir)/src/mod/$$i); \
|
||||
+ (cd $$i && $(MOD_UPDIR)$(srcdir)/$$i/configure "$(egg_ac_parameters)" $(ENABLEIPV6) --cache-file=../../../config.cache --srcdir=$(MOD_UPDIR)$(top_srcdir)/src/mod/$$i); \
|
||||
- (cd $$i && $(MOD_UPDIR)$(srcdir)/$$i/configure $(egg_ac_parameters) --cache-file=../../../config.cache --srcdir=$(MOD_UPDIR)$(top_srcdir)/src/mod/$$i); \
|
||||
+ (cd $$i && $(MOD_UPDIR)$(srcdir)/$$i/configure $(egg_ac_parameters) --cache-file=../../../config.cache --srcdir=$(MOD_UPDIR)$(top_srcdir)/src/mod/$$i); \
|
||||
fi; \
|
||||
done; \
|
||||
echo ""
|
||||
|
|
|
@ -1,11 +1,9 @@
|
|||
--- eggdrop1.6.15/src/eggdrop.h.orig Mon Jun 2 11:39:45 2003
|
||||
+++ eggdrop1.6.15/src/eggdrop.h Mon Jun 2 11:40:17 2003
|
||||
@@ -85,7 +85,7 @@
|
||||
|
||||
|
||||
--- eggdrop1.6.17/src/eggdrop.h.orig Mon Jun 2 11:39:45 2003
|
||||
+++ eggdrop1.6.17/src/eggdrop.h Mon Jun 2 11:40:17 2003
|
||||
@@ -77,7 +77,7 @@
|
||||
/* Language stuff */
|
||||
-#define LANGDIR "./language" /* language file directory */
|
||||
+#define LANGDIR __PREFIX__ "/share/eggdrop/language" /* language file directory */
|
||||
#define BASELANG "english" /* language which always gets loaded before
|
||||
+#define LANGDIR __PREFIX__ "/share/eggdrop/language" /* language file directory */
|
||||
#define BASELANG "english" /* language which always gets loaded before
|
||||
all other languages. You do not want to
|
||||
change this. */
|
||||
|
|
|
@ -1,12 +1,10 @@
|
|||
--- eggdrop1.6.15/eggdrop.conf.orig Mon May 5 00:05:32 2003
|
||||
+++ eggdrop1.6.15/eggdrop.conf Wed Mar 3 21:17:14 2004
|
||||
@@ -1,4 +1,4 @@
|
||||
--- eggdrop1.6.17/eggdrop.conf.orig Mon May 5 00:05:32 2003
|
||||
+++ eggdrop1.6.17/eggdrop.conf Wed Mar 3 21:17:14 2004
|
||||
@@ -1,2 +1,2 @@
|
||||
-#! /path/to/executable/eggdrop
|
||||
+#!%%PREFIX%%/bin/eggdrop
|
||||
# ^- This should contain a fully qualified path to your Eggdrop executable.
|
||||
#
|
||||
# $Id: eggdrop.conf,v 1.26 2003/04/17 04:38:33 wcc Exp $
|
||||
@@ -422,7 +422,7 @@
|
||||
@@ -420,7 +420,7 @@
|
||||
# If you run the bot from the compilation directory, you will want to set
|
||||
# this to "". If you use 'make install' (like all good kiddies do ;), this
|
||||
# is a fine default. Otherwise, use your head :)
|
||||
|
@ -15,9 +13,9 @@
|
|||
|
||||
|
||||
#### DNS MODULE ####
|
||||
@@ -814,6 +814,11 @@
|
||||
@@ -812,6 +812,11 @@
|
||||
you.need.to.change.this:6667
|
||||
another.example.com:7000
|
||||
another.example.com:7000:password
|
||||
}
|
||||
+
|
||||
+# Set this option, if you want a SSL connection to the IRC Server(s) specified
|
||||
|
|
18
irc/eggdrop/files/patch-src::md5::md5c.c
Normal file
18
irc/eggdrop/files/patch-src::md5::md5c.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- eggdrop1.6.17/src/md5/md5c.c.orig Fri Sep 3 14:08:28 2004
|
||||
+++ eggdrop1.6.17/src/md5/md5c.c Fri Sep 3 14:04:51 2004
|
||||
@@ -25,6 +25,7 @@
|
||||
|
||||
#include "compat/compat.h"
|
||||
|
||||
+#ifdef EGG_SSL_EXT
|
||||
typedef unsigned long MD5_u32plus;
|
||||
|
||||
typedef struct {
|
||||
@@ -33,6 +34,7 @@
|
||||
unsigned char buffer[64];
|
||||
MD5_u32plus block[16];
|
||||
} MD5_CTX;
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* The basic MD5 functions.
|
|
@ -6,7 +6,7 @@ lib/eggdrop/channels.so
|
|||
lib/eggdrop/compress.so
|
||||
lib/eggdrop/console.so
|
||||
lib/eggdrop/ctcp.so
|
||||
%%IPV6%%lib/eggdrop/dns.so
|
||||
lib/eggdrop/dns.so
|
||||
lib/eggdrop/filesys.so
|
||||
lib/eggdrop/irc.so
|
||||
lib/eggdrop/notes.so
|
||||
|
@ -21,14 +21,19 @@ lib/eggdrop/wire.so
|
|||
%%DATADIR%%/help/channels.help
|
||||
%%DATADIR%%/help/cmds1.help
|
||||
%%DATADIR%%/help/cmds2.help
|
||||
%%DATADIR%%/help/compress.help
|
||||
%%DATADIR%%/help/console.help
|
||||
%%DATADIR%%/help/core.help
|
||||
%%DATADIR%%/help/ctcp.help
|
||||
%%DATADIR%%/help/filesys.help
|
||||
%%DATADIR%%/help/irc.help
|
||||
%%DATADIR%%/help/notes.help
|
||||
%%DATADIR%%/help/seen.help
|
||||
%%DATADIR%%/help/server.help
|
||||
%%DATADIR%%/help/share.help
|
||||
%%DATADIR%%/help/transfer.help
|
||||
%%DATADIR%%/help/uptime.help
|
||||
%%DATADIR%%/help/wire.help
|
||||
%%DATADIR%%/help/msg/irc.help
|
||||
%%DATADIR%%/help/msg/notes.help
|
||||
%%DATADIR%%/help/msg/seen.help
|
||||
|
@ -41,33 +46,41 @@ lib/eggdrop/wire.so
|
|||
%%DATADIR%%/help/set/irc.help
|
||||
%%DATADIR%%/help/set/notes.help
|
||||
%%DATADIR%%/help/set/server.help
|
||||
%%DATADIR%%/help/set/share.help
|
||||
%%DATADIR%%/help/set/transfer.help
|
||||
%%DATADIR%%/language/core.danish.lang
|
||||
%%DATADIR%%/language/core.english.lang
|
||||
%%DATADIR%%/language/core.finnish.lang
|
||||
%%DATADIR%%/language/core.french.lang
|
||||
%%DATADIR%%/language/core.german.lang
|
||||
%%DATADIR%%/language/assoc.danish.lang
|
||||
%%DATADIR%%/language/assoc.english.lang
|
||||
%%DATADIR%%/language/assoc.finnish.lang
|
||||
%%DATADIR%%/language/assoc.french.lang
|
||||
%%DATADIR%%/language/assoc.german.lang
|
||||
%%DATADIR%%/language/console.danish.lang
|
||||
%%DATADIR%%/language/console.english.lang
|
||||
%%DATADIR%%/language/console.finnish.lang
|
||||
%%DATADIR%%/language/console.french.lang
|
||||
%%DATADIR%%/language/console.german.lang
|
||||
%%DATADIR%%/language/filesys.danish.lang
|
||||
%%DATADIR%%/language/filesys.english.lang
|
||||
%%DATADIR%%/language/filesys.finnish.lang
|
||||
%%DATADIR%%/language/filesys.french.lang
|
||||
%%DATADIR%%/language/filesys.german.lang
|
||||
%%DATADIR%%/language/notes.danish.lang
|
||||
%%DATADIR%%/language/notes.english.lang
|
||||
%%DATADIR%%/language/notes.finnish.lang
|
||||
%%DATADIR%%/language/notes.french.lang
|
||||
%%DATADIR%%/language/notes.german.lang
|
||||
%%DATADIR%%/language/transfer.danish.lang
|
||||
%%DATADIR%%/language/transfer.english.lang
|
||||
%%DATADIR%%/language/transfer.finnish.lang
|
||||
%%DATADIR%%/language/transfer.french.lang
|
||||
%%DATADIR%%/language/transfer.german.lang
|
||||
%%DATADIR%%/language/wire.danish.lang
|
||||
%%DATADIR%%/language/wire.english.lang
|
||||
%%DATADIR%%/language/wire.finnish.lang
|
||||
%%DATADIR%%/language/wire.french.lang
|
||||
%%DATADIR%%/language/wire.german.lang
|
||||
%%DATADIR%%/scripts/CONTENTS
|
||||
|
@ -86,17 +99,24 @@ lib/eggdrop/wire.so
|
|||
%%DATADIR%%/scripts/weed
|
||||
%%DATADIR%%/text/banner
|
||||
%%DATADIR%%/text/motd
|
||||
%%PORTDOCS%%%%DOCSDIR%%/ABOUT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BANS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BOTNET
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tcl-commands.doc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tricks
|
||||
%%PORTDOCS%%%%DOCSDIR%%/BUG-REPORT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/first_script.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COMPILE-GUIDE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CONTENTS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/FIRST-SCRIPT
|
||||
%%PORTDOCS%%%%DOCSDIR%%/KNOWN-PROBLEMS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/MODULES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/PARTYLINE
|
||||
%%PORTDOCS%%%%DOCSDIR%%/text-substitutions.doc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/UPDATES1.5
|
||||
%%PORTDOCS%%%%DOCSDIR%%/PATCH-HOWTO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TEXT-SUBSTITUTIONS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TRICKS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/UPDATES1.6
|
||||
%%PORTDOCS%%%%DOCSDIR%%/USERS
|
||||
%%PORTDOCS%%%%DOCSDIR%%/WEIRD-MESSAGES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tcl-commands.doc
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/about.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/app-problems.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/app-textsub.html
|
||||
|
@ -111,7 +131,6 @@ lib/eggdrop/wire.so
|
|||
%%PORTDOCS%%%%DOCSDIR%%/html/features.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/install.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/ipv6.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/mod-assoc.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/mod-blowfish.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/html/mod-channels.html
|
||||
|
|
Loading…
Reference in a new issue