audio/zrythm: Fix license; Fix link to fftw3*_threads libraries: they weren't linked to due to a bug in meson.build

Reported by:	upstream
This commit is contained in:
Yuri Victorovich 2020-09-15 18:26:42 +00:00
parent 5110e246e8
commit 41eb79d3c9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548738
3 changed files with 7 additions and 14 deletions

View file

@ -3,15 +3,17 @@
PORTNAME= zrythm
DISTVERSIONPREFIX= v
DISTVERSION= 0.8.911
PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
COMMENT= Modern music production system, also known as DAW
LICENSE= GPLv3
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= fftw3>0:math/fftw3 \
fftw3-float>0:math/fftw3-float \
help2man:misc/help2man \
kf5-breeze-icons>0:x11-themes/kf5-breeze-icons
LIB_DEPENDS= libaudec.so:audio/libaudec \
@ -48,6 +50,8 @@ USE_XORG= x11
GLIB_SCHEMAS= org.zrythm.Zrythm.gschema.xml
INSTALLS_ICONS= yes
LDFLAGS+= ${LOCALBASE}/lib/libfftw3_threads.so ${LOCALBASE}/lib/libfftw3f_threads.so # these libs are required but aren't returned by pkg-config for fftw3
BINARY_ALIAS= git=false python3=${PYTHON_CMD}
post-patch: # https://git.zrythm.org/zrythm/zrythm/issues/299

View file

@ -1,3 +1,5 @@
Workaround for the bug in meson.build: fftw3_threads and fftw3f_threads libraries aren't returned by pkg-config
--- meson.build.orig 2020-06-06 18:03:44 UTC
+++ meson.build
@@ -638,8 +638,8 @@ zrythm_deps = [

View file

@ -1,13 +0,0 @@
--- src/main.c.orig 2020-05-26 06:54:40 UTC
+++ src/main.c
@@ -505,8 +505,8 @@ main (int argc,
/* init fftw */
g_message ("Making fftw planner thread safe...");
- fftw_make_planner_thread_safe ();
- fftwf_make_planner_thread_safe ();
+ //fftw_make_planner_thread_safe ();
+ //fftwf_make_planner_thread_safe ();
/* init audio decoder */
g_message ("Initing audio decoder...");