- Fixed packaging error by adding USE_GMAKE and patching Makefiles

that invoke make directly, instead of using ${MAKE}

Reported by:	QAT
This commit is contained in:
Greg Larkin 2009-06-25 19:05:27 +00:00
parent edc31aa94f
commit 41f07c02df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=236626
3 changed files with 66 additions and 0 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= lmbench
PORTVERSION= 3.0.a9
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= benchmarks
MASTER_SITES= SF http://thegaul.org/src/
@ -29,6 +30,8 @@ MAN8= bw_file_rd.8 bw_mem.8 bw_mem_rd.8 bw_mmap_rd.8 \
lat_unix_connect.8 line.8 lmbench.8 lmdd.8 mhz.8 \
par_mem.8 par_ops.8 stream.8 tlb.8
USE_GMAKE= yes
# the bindir for the PLIST is:
# (note that ./os needs to be run inside the work dir, running it
# outside will give a different result.)

View file

@ -0,0 +1,43 @@
--- ./results/Makefile.orig 2009-06-25 14:38:27.000000000 -0400
+++ ./results/Makefile 2009-06-25 14:38:52.000000000 -0400
@@ -121,10 +121,10 @@
echo .ps 12 >> summary.roff
echo .po .35i >> summary.roff
echo .sp .5i >> summary.roff
- make LIST="$(LIST)" summary >> summary.roff
+ ${MAKE} LIST="$(LIST)" summary >> summary.roff
echo .bp >> summary.roff
echo .sp .5i >> summary.roff
- make LIST="$(LIST)" percent >> summary.roff
+ ${MAKE} LIST="$(LIST)" percent >> summary.roff
list:
@echo $(LIST)
@@ -185,11 +185,11 @@
# XXX - this has to be made incremental, doing everything over from
# scratch makes you want a Ghz machine.
html: dirs
- -make clean
+ -${MAKE} clean
#$(SCRIPTS)bghtml $(BG)
$(SCRIPTS)html-list $(LIST)
$(MK) LIST="$(LIST)" summary > HTML/summary.out 2> HTML/summary.errs
- #make LIST="$(LIST)" percent > HTML/percent.out 2> HTML/percent.errs
+ #${MAKE} LIST="$(LIST)" percent > HTML/percent.out 2> HTML/percent.errs
$(MK) LIST="$(LIST)" SIZE= PRINT="$(PS)" \
GMEM="$(GMEM) -cut -gthk1" GCTX="$(GCTX) -cut -gthk1" print
$(MK) LIST="$(LIST)" SIZE= NOOP=-noop PRINT="$(PS)" \
@@ -207,11 +207,11 @@
rm HTML/*.pbm HTML/___tmp*
htmltest: dirs
- -make clean
+ -${MAKE} clean
#$(SCRIPTS)bghtml $(BG)
$(SCRIPTS)html-list $(LIST)
$(MK) LIST="$(LIST)" summary > HTML/summary.out 2> HTML/summary.errs
- #make LIST="$(LIST)" percent > HTML/percent.out 2> HTML/percent.errs
+ #${MAKE} LIST="$(LIST)" percent > HTML/percent.out 2> HTML/percent.errs
$(MK) LIST="$(LIST)" SIZE= PRINT="$(PS)" \
GMEM="$(GMEM) -cut -gthk1" GCTX="$(GCTX) -cut -gthk1" print

View file

@ -0,0 +1,20 @@
--- ./src/Makefile.orig 2009-06-25 14:38:24.000000000 -0400
+++ ./src/Makefile 2009-06-25 14:38:41.000000000 -0400
@@ -146,7 +146,7 @@
cp $(EXES) $(BASE)/bin
cp $(INCS) $(BASE)/include
cp $O/lmbench.a $(BASE)/lib/libmbench.a
- cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install
+ cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" ${MAKE} CC="${CC}" OS="${OS}" BASE="$(BASE)" install
# No special handling for all these
@@ -239,7 +239,7 @@
$(COMPILE) -c getopt.c -o $O/getopt.o
$(UTILS) :
- -cd ../scripts; make get
+ -cd ../scripts; ${MAKE} get
# Do not remove the next line, $(MAKE) depend needs it
# MAKEDEPEND follows