Update to version 2.05b.

PR:		41176
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
David E. O'Brien 2002-08-04 06:57:11 +00:00
parent c13284aa47
commit 421df473ba
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=63947
18 changed files with 114 additions and 174 deletions

View file

@ -7,7 +7,7 @@
#
PORTNAME= bash
PORTVERSION= 2.05a
PORTVERSION= 2.05b
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/bash/
@ -18,6 +18,8 @@ DISTFILES= bash-${PORTVERSION}.tar.gz bash-doc-${PORTVERSION}.tar.gz
MAINTAINER= obrien@FreeBSD.org
.include <bsd.port.pre.mk>
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
CONFIGURE_ENV= LDFLAGS=-static
@ -28,15 +30,17 @@ post-install:
(${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells
${RM} /etc/shells.bak
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/bash
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} \
${WRKDIR}/doc/article.ps \
${WRKDIR}/doc/bashref.ps \
${PREFIX}/share/doc/bash
${DOCSDIR}
${INSTALL_MAN} \
${WRKDIR}/doc/article.txt \
${PREFIX}/share/doc/bash
${GZIP_CMD} ${PREFIX}/share/doc/bash/*.ps
${DOCSDIR}
${BZIP2_CMD} ${DOCSDIR}/*.ps
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>
CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}

View file

@ -1,2 +1,2 @@
MD5 (bash-2.05a.tar.gz) = eeabc3f624861c4a8a687f7701db3d06
MD5 (bash-doc-2.05a.tar.gz) = c86e07eb43c3a1a9b2c830b6bff1331d
MD5 (bash-2.05b.tar.gz) = 5238251b4926d778dfe162f6ce729733
MD5 (bash-doc-2.05b.tar.gz) = 511b2d07f0f401f686e8edc551a8e47f

View file

@ -1,24 +0,0 @@
$FreeBSD$
--- Makefile.in.orig Mon Nov 12 17:42:45 2001
+++ Makefile.in Wed Nov 21 00:08:16 2001
@@ -59,6 +59,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_DATA = @INSTALL_DATA@
INSTALLMODE= -m 0755
INSTALLMODE2 = -m 0555
@@ -627,8 +628,8 @@
@${SHELL} $(SUPPORT_SRC)mkdirs $(DESTDIR)$(infodir)
install: .made installdirs
- $(INSTALL_PROGRAM) $(INSTALLMODE) $(Program) $(DESTDIR)$(bindir)/$(Program)
- $(INSTALL_PROGRAM) $(INSTALLMODE2) bashbug $(DESTDIR)$(bindir)/bashbug
+ $(INSTALL_PROGRAM) $(Program) $(DESTDIR)$(bindir)/$(Program)
+ $(INSTALL_SCRIPT) bashbug $(DESTDIR)$(bindir)/bashbug
-( cd $(DOCDIR) ; $(MAKE) $(MFLAGS) \
man1dir=$(man1dir) man1ext=$(man1ext) \
man3dir=$(man3dir) man3ext=$(man3ext) \

View file

@ -1,14 +1,14 @@
$FreeBSD$
--- configure.orig Mon Nov 19 18:27:10 2001
+++ configure Mon Nov 19 18:27:17 2001
@@ -1108,7 +1108,7 @@
--- configure.orig Tue Jul 16 22:31:47 2002
+++ configure Wed Jul 24 23:54:26 2002
@@ -1132,7 +1132,7 @@
mips-irix6*) opt_bash_malloc=no ;; # needs 8-byte alignment
m68k-sysv) opt_bash_malloc=no ;; # fixes file descriptor leak in closedir
sparc-linux*) opt_bash_malloc=no ;; # sparc running linux; requires ELF
-#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
-#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better; I disagree
+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better; I disagree
*-openbsd*) opt_bash_malloc=no ;; # they claim it needs eight-bit alignment
*-aix*) opt_bash_malloc=no ;; # AIX machines
*-nextstep*) opt_bash_malloc=no ;; # NeXT machines running NeXTstep

View file

@ -1,6 +1,6 @@
--- bashline.c.orig Mon Nov 5 09:58:59 2001
+++ bashline.c Sun Mar 24 19:15:04 2002
@@ -1724,10 +1724,6 @@
--- bashline.c.orig Wed May 8 04:52:42 2002
+++ bashline.c Wed Jul 24 05:54:07 2002
@@ -1873,10 +1873,6 @@
}
}
@ -11,7 +11,7 @@
/* If FIGNORE is set, then don't match files with the given suffixes when
completing filenames. If only one of the possibilities has an acceptable
suffix, delete the others, else just return and let the completer
@@ -1752,10 +1748,15 @@
@@ -1901,10 +1897,15 @@
{
char **newnames;
int idx, nidx;
@ -29,7 +29,7 @@
/* If there is only one completion, see if it is acceptable. If it is
not, free it up. In any case, short-circuit and return. This is a
@@ -1763,13 +1764,12 @@
@@ -1912,13 +1913,12 @@
if there is only one completion; it is the completion itself. */
if (names[1] == (char *)0)
{
@ -49,23 +49,23 @@
return;
}
@@ -1778,10 +1778,11 @@
@@ -1927,10 +1927,11 @@
for (nidx = 1; names[nidx]; nidx++)
;
newnames = alloc_array (nidx + 1);
newnames = strvec_create (nidx + 1);
-#ifdef NO_FORCE_FIGNORE
- oldnames = alloc_array (nidx - 1);
- oldnames = strvec_create (nidx - 1);
- oidx = 0;
-#endif
+ if (no_force_fignore)
+ {
+ oldnames = alloc_array (nidx - 1);
+ oldnames = strvec_create (nidx - 1);
+ oidx = 0;
+ }
newnames[0] = names[0];
for (idx = nidx = 1; names[idx]; idx++)
@@ -1789,11 +1790,10 @@
@@ -1938,11 +1939,10 @@
if ((*name_func) (names[idx]))
newnames[nidx++] = names[idx];
else
@ -81,7 +81,7 @@
}
newnames[nidx] = (char *)NULL;
@@ -1801,21 +1801,23 @@
@@ -1950,21 +1950,23 @@
/* If none are acceptable then let the completer handle it. */
if (nidx == 1)
{

View file

@ -1,14 +1,14 @@
--- lib/readline/terminal.c.orig Tue Feb 6 12:39:22 2001
+++ lib/readline/terminal.c Wed Apr 11 09:43:44 2001
@@ -297,7 +297,11 @@
--- lib/readline/terminal.c.orig Tue Mar 5 02:23:09 2002
+++ lib/readline/terminal.c Wed Jul 24 05:57:59 2002
@@ -313,7 +313,11 @@
{ "ei", &_rl_term_ei },
{ "ic", &_rl_term_ic },
{ "im", &_rl_term_im },
{ "kd", &_rl_term_kd },
{ "kh", &_rl_term_kh }, /* home */
+#ifdef __FreeBSD__
+ { "@7", &_rl_term_kH }, /* end */
+ { "@7", &_rl_term_kH }, /* home down ?? */
+#else
{ "kH", &_rl_term_kH }, /* end */
{ "kH", &_rl_term_kH }, /* home down ?? */
+#endif
{ "kl", &_rl_term_kl },
{ "kr", &_rl_term_kr },
{ "ku", &_rl_term_ku },
{ "kI", &_rl_term_kI }, /* insert */
{ "kd", &_rl_term_kd },
{ "ke", &_rl_term_ke }, /* end keypad mode */

View file

@ -7,7 +7,7 @@
#
PORTNAME= bash
PORTVERSION= 2.05a
PORTVERSION= 2.05b
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/bash/
@ -18,6 +18,8 @@ DISTFILES= bash-${PORTVERSION}.tar.gz bash-doc-${PORTVERSION}.tar.gz
MAINTAINER= obrien@FreeBSD.org
.include <bsd.port.pre.mk>
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
CONFIGURE_ENV= LDFLAGS=-static
@ -28,15 +30,17 @@ post-install:
(${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells
${RM} /etc/shells.bak
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/bash
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} \
${WRKDIR}/doc/article.ps \
${WRKDIR}/doc/bashref.ps \
${PREFIX}/share/doc/bash
${DOCSDIR}
${INSTALL_MAN} \
${WRKDIR}/doc/article.txt \
${PREFIX}/share/doc/bash
${GZIP_CMD} ${PREFIX}/share/doc/bash/*.ps
${DOCSDIR}
${BZIP2_CMD} ${DOCSDIR}/*.ps
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>
CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}

View file

@ -1,2 +1,2 @@
MD5 (bash-2.05a.tar.gz) = eeabc3f624861c4a8a687f7701db3d06
MD5 (bash-doc-2.05a.tar.gz) = c86e07eb43c3a1a9b2c830b6bff1331d
MD5 (bash-2.05b.tar.gz) = 5238251b4926d778dfe162f6ce729733
MD5 (bash-doc-2.05b.tar.gz) = 511b2d07f0f401f686e8edc551a8e47f

View file

@ -1,24 +0,0 @@
$FreeBSD$
--- Makefile.in.orig Mon Nov 12 17:42:45 2001
+++ Makefile.in Wed Nov 21 00:08:16 2001
@@ -59,6 +59,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_DATA = @INSTALL_DATA@
INSTALLMODE= -m 0755
INSTALLMODE2 = -m 0555
@@ -627,8 +628,8 @@
@${SHELL} $(SUPPORT_SRC)mkdirs $(DESTDIR)$(infodir)
install: .made installdirs
- $(INSTALL_PROGRAM) $(INSTALLMODE) $(Program) $(DESTDIR)$(bindir)/$(Program)
- $(INSTALL_PROGRAM) $(INSTALLMODE2) bashbug $(DESTDIR)$(bindir)/bashbug
+ $(INSTALL_PROGRAM) $(Program) $(DESTDIR)$(bindir)/$(Program)
+ $(INSTALL_SCRIPT) bashbug $(DESTDIR)$(bindir)/bashbug
-( cd $(DOCDIR) ; $(MAKE) $(MFLAGS) \
man1dir=$(man1dir) man1ext=$(man1ext) \
man3dir=$(man3dir) man3ext=$(man3ext) \

View file

@ -1,14 +1,14 @@
$FreeBSD$
--- configure.orig Mon Nov 19 18:27:10 2001
+++ configure Mon Nov 19 18:27:17 2001
@@ -1108,7 +1108,7 @@
--- configure.orig Tue Jul 16 22:31:47 2002
+++ configure Wed Jul 24 23:54:26 2002
@@ -1132,7 +1132,7 @@
mips-irix6*) opt_bash_malloc=no ;; # needs 8-byte alignment
m68k-sysv) opt_bash_malloc=no ;; # fixes file descriptor leak in closedir
sparc-linux*) opt_bash_malloc=no ;; # sparc running linux; requires ELF
-#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
-#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better; I disagree
+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better; I disagree
*-openbsd*) opt_bash_malloc=no ;; # they claim it needs eight-bit alignment
*-aix*) opt_bash_malloc=no ;; # AIX machines
*-nextstep*) opt_bash_malloc=no ;; # NeXT machines running NeXTstep

View file

@ -1,6 +1,6 @@
--- bashline.c.orig Mon Nov 5 09:58:59 2001
+++ bashline.c Sun Mar 24 19:15:04 2002
@@ -1724,10 +1724,6 @@
--- bashline.c.orig Wed May 8 04:52:42 2002
+++ bashline.c Wed Jul 24 05:54:07 2002
@@ -1873,10 +1873,6 @@
}
}
@ -11,7 +11,7 @@
/* If FIGNORE is set, then don't match files with the given suffixes when
completing filenames. If only one of the possibilities has an acceptable
suffix, delete the others, else just return and let the completer
@@ -1752,10 +1748,15 @@
@@ -1901,10 +1897,15 @@
{
char **newnames;
int idx, nidx;
@ -29,7 +29,7 @@
/* If there is only one completion, see if it is acceptable. If it is
not, free it up. In any case, short-circuit and return. This is a
@@ -1763,13 +1764,12 @@
@@ -1912,13 +1913,12 @@
if there is only one completion; it is the completion itself. */
if (names[1] == (char *)0)
{
@ -49,23 +49,23 @@
return;
}
@@ -1778,10 +1778,11 @@
@@ -1927,10 +1927,11 @@
for (nidx = 1; names[nidx]; nidx++)
;
newnames = alloc_array (nidx + 1);
newnames = strvec_create (nidx + 1);
-#ifdef NO_FORCE_FIGNORE
- oldnames = alloc_array (nidx - 1);
- oldnames = strvec_create (nidx - 1);
- oidx = 0;
-#endif
+ if (no_force_fignore)
+ {
+ oldnames = alloc_array (nidx - 1);
+ oldnames = strvec_create (nidx - 1);
+ oidx = 0;
+ }
newnames[0] = names[0];
for (idx = nidx = 1; names[idx]; idx++)
@@ -1789,11 +1790,10 @@
@@ -1938,11 +1939,10 @@
if ((*name_func) (names[idx]))
newnames[nidx++] = names[idx];
else
@ -81,7 +81,7 @@
}
newnames[nidx] = (char *)NULL;
@@ -1801,21 +1801,23 @@
@@ -1950,21 +1950,23 @@
/* If none are acceptable then let the completer handle it. */
if (nidx == 1)
{

View file

@ -1,14 +1,14 @@
--- lib/readline/terminal.c.orig Tue Feb 6 12:39:22 2001
+++ lib/readline/terminal.c Wed Apr 11 09:43:44 2001
@@ -297,7 +297,11 @@
--- lib/readline/terminal.c.orig Tue Mar 5 02:23:09 2002
+++ lib/readline/terminal.c Wed Jul 24 05:57:59 2002
@@ -313,7 +313,11 @@
{ "ei", &_rl_term_ei },
{ "ic", &_rl_term_ic },
{ "im", &_rl_term_im },
{ "kd", &_rl_term_kd },
{ "kh", &_rl_term_kh }, /* home */
+#ifdef __FreeBSD__
+ { "@7", &_rl_term_kH }, /* end */
+ { "@7", &_rl_term_kH }, /* home down ?? */
+#else
{ "kH", &_rl_term_kH }, /* end */
{ "kH", &_rl_term_kH }, /* home down ?? */
+#endif
{ "kl", &_rl_term_kl },
{ "kr", &_rl_term_kr },
{ "ku", &_rl_term_ku },
{ "kI", &_rl_term_kI }, /* insert */
{ "kd", &_rl_term_kd },
{ "ke", &_rl_term_ke }, /* end keypad mode */

View file

@ -7,7 +7,7 @@
#
PORTNAME= bash
PORTVERSION= 2.05a
PORTVERSION= 2.05b
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/bash/
@ -18,6 +18,8 @@ DISTFILES= bash-${PORTVERSION}.tar.gz bash-doc-${PORTVERSION}.tar.gz
MAINTAINER= obrien@FreeBSD.org
.include <bsd.port.pre.mk>
GNU_CONFIGURE= Yes
CONFIGURE_ARGS= --with-installed-readline
CONFIGURE_ENV= LDFLAGS=-static
@ -28,15 +30,17 @@ post-install:
(${GREP} -v ${PREFIX}/bin/bash /etc/shells.bak; ${ECHO_CMD} ${PREFIX}/bin/bash) >/etc/shells
${RM} /etc/shells.bak
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/bash
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} \
${WRKDIR}/doc/article.ps \
${WRKDIR}/doc/bashref.ps \
${PREFIX}/share/doc/bash
${DOCSDIR}
${INSTALL_MAN} \
${WRKDIR}/doc/article.txt \
${PREFIX}/share/doc/bash
${GZIP_CMD} ${PREFIX}/share/doc/bash/*.ps
${DOCSDIR}
${BZIP2_CMD} ${DOCSDIR}/*.ps
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>
CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}

View file

@ -1,2 +1,2 @@
MD5 (bash-2.05a.tar.gz) = eeabc3f624861c4a8a687f7701db3d06
MD5 (bash-doc-2.05a.tar.gz) = c86e07eb43c3a1a9b2c830b6bff1331d
MD5 (bash-2.05b.tar.gz) = 5238251b4926d778dfe162f6ce729733
MD5 (bash-doc-2.05b.tar.gz) = 511b2d07f0f401f686e8edc551a8e47f

View file

@ -1,24 +0,0 @@
$FreeBSD$
--- Makefile.in.orig Mon Nov 12 17:42:45 2001
+++ Makefile.in Wed Nov 21 00:08:16 2001
@@ -59,6 +59,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_DATA = @INSTALL_DATA@
INSTALLMODE= -m 0755
INSTALLMODE2 = -m 0555
@@ -627,8 +628,8 @@
@${SHELL} $(SUPPORT_SRC)mkdirs $(DESTDIR)$(infodir)
install: .made installdirs
- $(INSTALL_PROGRAM) $(INSTALLMODE) $(Program) $(DESTDIR)$(bindir)/$(Program)
- $(INSTALL_PROGRAM) $(INSTALLMODE2) bashbug $(DESTDIR)$(bindir)/bashbug
+ $(INSTALL_PROGRAM) $(Program) $(DESTDIR)$(bindir)/$(Program)
+ $(INSTALL_SCRIPT) bashbug $(DESTDIR)$(bindir)/bashbug
-( cd $(DOCDIR) ; $(MAKE) $(MFLAGS) \
man1dir=$(man1dir) man1ext=$(man1ext) \
man3dir=$(man3dir) man3ext=$(man3ext) \

View file

@ -1,14 +1,14 @@
$FreeBSD$
--- configure.orig Mon Nov 19 18:27:10 2001
+++ configure Mon Nov 19 18:27:17 2001
@@ -1108,7 +1108,7 @@
--- configure.orig Tue Jul 16 22:31:47 2002
+++ configure Wed Jul 24 23:54:26 2002
@@ -1132,7 +1132,7 @@
mips-irix6*) opt_bash_malloc=no ;; # needs 8-byte alignment
m68k-sysv) opt_bash_malloc=no ;; # fixes file descriptor leak in closedir
sparc-linux*) opt_bash_malloc=no ;; # sparc running linux; requires ELF
-#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better
-#*-freebsd*) opt_bash_malloc=no ;; # they claim it's better; I disagree
+*-freebsd*) opt_bash_malloc=no ;; # they claim it's better; I disagree
*-openbsd*) opt_bash_malloc=no ;; # they claim it needs eight-bit alignment
*-aix*) opt_bash_malloc=no ;; # AIX machines
*-nextstep*) opt_bash_malloc=no ;; # NeXT machines running NeXTstep

View file

@ -1,6 +1,6 @@
--- bashline.c.orig Mon Nov 5 09:58:59 2001
+++ bashline.c Sun Mar 24 19:15:04 2002
@@ -1724,10 +1724,6 @@
--- bashline.c.orig Wed May 8 04:52:42 2002
+++ bashline.c Wed Jul 24 05:54:07 2002
@@ -1873,10 +1873,6 @@
}
}
@ -11,7 +11,7 @@
/* If FIGNORE is set, then don't match files with the given suffixes when
completing filenames. If only one of the possibilities has an acceptable
suffix, delete the others, else just return and let the completer
@@ -1752,10 +1748,15 @@
@@ -1901,10 +1897,15 @@
{
char **newnames;
int idx, nidx;
@ -29,7 +29,7 @@
/* If there is only one completion, see if it is acceptable. If it is
not, free it up. In any case, short-circuit and return. This is a
@@ -1763,13 +1764,12 @@
@@ -1912,13 +1913,12 @@
if there is only one completion; it is the completion itself. */
if (names[1] == (char *)0)
{
@ -49,23 +49,23 @@
return;
}
@@ -1778,10 +1778,11 @@
@@ -1927,10 +1927,11 @@
for (nidx = 1; names[nidx]; nidx++)
;
newnames = alloc_array (nidx + 1);
newnames = strvec_create (nidx + 1);
-#ifdef NO_FORCE_FIGNORE
- oldnames = alloc_array (nidx - 1);
- oldnames = strvec_create (nidx - 1);
- oidx = 0;
-#endif
+ if (no_force_fignore)
+ {
+ oldnames = alloc_array (nidx - 1);
+ oldnames = strvec_create (nidx - 1);
+ oidx = 0;
+ }
newnames[0] = names[0];
for (idx = nidx = 1; names[idx]; idx++)
@@ -1789,11 +1790,10 @@
@@ -1938,11 +1939,10 @@
if ((*name_func) (names[idx]))
newnames[nidx++] = names[idx];
else
@ -81,7 +81,7 @@
}
newnames[nidx] = (char *)NULL;
@@ -1801,21 +1801,23 @@
@@ -1950,21 +1950,23 @@
/* If none are acceptable then let the completer handle it. */
if (nidx == 1)
{

View file

@ -1,14 +1,14 @@
--- lib/readline/terminal.c.orig Tue Feb 6 12:39:22 2001
+++ lib/readline/terminal.c Wed Apr 11 09:43:44 2001
@@ -297,7 +297,11 @@
--- lib/readline/terminal.c.orig Tue Mar 5 02:23:09 2002
+++ lib/readline/terminal.c Wed Jul 24 05:57:59 2002
@@ -313,7 +313,11 @@
{ "ei", &_rl_term_ei },
{ "ic", &_rl_term_ic },
{ "im", &_rl_term_im },
{ "kd", &_rl_term_kd },
{ "kh", &_rl_term_kh }, /* home */
+#ifdef __FreeBSD__
+ { "@7", &_rl_term_kH }, /* end */
+ { "@7", &_rl_term_kH }, /* home down ?? */
+#else
{ "kH", &_rl_term_kH }, /* end */
{ "kH", &_rl_term_kH }, /* home down ?? */
+#endif
{ "kl", &_rl_term_kl },
{ "kr", &_rl_term_kr },
{ "ku", &_rl_term_ku },
{ "kI", &_rl_term_kI }, /* insert */
{ "kd", &_rl_term_kd },
{ "ke", &_rl_term_ke }, /* end keypad mode */