emulators/virtualbox-ose: Fix build with ports provided SSL library on 11.x

Due to a compiler/linker command line ordering issue, VirtualBox 6
fails to compile on 11.x when a ports provided SSL library is
used.

Fix the order of -L options passed to the linker where the ssl
library is used.

Thanks to  Chad Jacob Milios <milios@ccsys.com> for suggesting the
correct fix.

PR:		254295
Submitted by:	russo@bogodyn.org
MFH:		2021Q2
This commit is contained in:
Guido Falsi 2021-04-11 16:55:35 +02:00
parent 132212e166
commit 423f3dfd75

View file

@ -0,0 +1,13 @@
--- src/VBox/RDP/client-1.8.4/Makefile.kmk.orig 2021-01-07 15:41:47 UTC
+++ src/VBox/RDP/client-1.8.4/Makefile.kmk
@@ -117,8 +117,8 @@ rdesktop-vrdp_SOURCES.solaris = \
rdesktop-vrdp_SOURCES.freebsd = \
rdpsnd_oss.c
rdesktop-vrdp_LIBPATH = \
- /usr/lib \
- $(VBOX_LIBPATH_X11)
+ $(VBOX_LIBPATH_X11)/lib \
+ /usr/lib
rdesktop-vrdp_LIBS = \
X11 \
$(LIB_RUNTIME)