Update to ezm3-1.2.
This commit is contained in:
parent
d6b9ce0421
commit
42ad4ecb32
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=115298
4 changed files with 12 additions and 51 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= ezm3
|
||||
PORTVERSION= 1.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.2
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ${MASTER_SITE_FREEBSD_ORG}
|
||||
MASTER_SITE_SUBDIR=development/CVSup/ezm3
|
||||
|
@ -59,8 +58,8 @@ BOOTSTRAP= ezm3-${PORTVERSION}-${TARGET}-boot.tar.bz2
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
.if ${ARCH} == "sparc64" && ${OSVERSION} >= 502107
|
||||
@${REINPLACE_CMD} -E -e 's|(^.*time_t.*=.*)int32_t;|\1int64_t;|' \
|
||||
.if ${ARCH} == "sparc64" && ${OSVERSION} < 502107
|
||||
@${REINPLACE_CMD} -E -e 's|(^.*time_t.*=.*)int64_t;|\1int32_t;|' \
|
||||
${WRKSRC}/libs/m3core/src/unix/freebsd-4.sparc64/Utypes.i3
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
MD5 (ezm3/ezm3-1.1a-FBSD_ALPHA-boot.tar.bz2) = a8bc5b827f6f24cec2a5a482543b46a8
|
||||
SIZE (ezm3/ezm3-1.1a-FBSD_ALPHA-boot.tar.bz2) = 2379484
|
||||
MD5 (ezm3/ezm3-1.1-FBSD_SPARC64-boot.tar.bz2) = 1dce08c7b56b48f1597fe3dff6ac2ef7
|
||||
SIZE (ezm3/ezm3-1.1-FBSD_SPARC64-boot.tar.bz2) = 1460393
|
||||
MD5 (ezm3/ezm3-1.1-FreeBSD4-boot.tar.bz2) = e04522a09a2ed8b11c36b9b0dcebf2e1
|
||||
SIZE (ezm3/ezm3-1.1-FreeBSD4-boot.tar.bz2) = 1365809
|
||||
MD5 (ezm3/ezm3-1.1-src.tar.bz2) = 0cb8d2af3784142144c01ffac4c0ffff
|
||||
SIZE (ezm3/ezm3-1.1-src.tar.bz2) = 10705295
|
||||
MD5 (ezm3/ezm3-1.2-FBSD_ALPHA-boot.tar.bz2) = 4e92f46afad748f0363ee6efb9680237
|
||||
SIZE (ezm3/ezm3-1.2-FBSD_ALPHA-boot.tar.bz2) = 1437778
|
||||
MD5 (ezm3/ezm3-1.2-FBSD_SPARC64-boot.tar.bz2) = 4de19b84603e22a7a0fb0caf3db85975
|
||||
SIZE (ezm3/ezm3-1.2-FBSD_SPARC64-boot.tar.bz2) = 1461363
|
||||
MD5 (ezm3/ezm3-1.2-FreeBSD4-boot.tar.bz2) = bf7b23c5f8859f33f460eb0d230b13c5
|
||||
SIZE (ezm3/ezm3-1.2-FreeBSD4-boot.tar.bz2) = 1366495
|
||||
MD5 (ezm3/ezm3-1.2-src.tar.bz2) = 41ac38cc9a57d7498b2ce7705792e2d8
|
||||
SIZE (ezm3/ezm3-1.2-src.tar.bz2) = 10727649
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
--- language/modula3/m3compiler/m3ship/src/Main.m3.orig Mon Jun 7 10:11:49 1999
|
||||
+++ language/modula3/m3compiler/m3ship/src/Main.m3 Sat Sep 8 14:46:14 2001
|
||||
@@ -303,9 +303,10 @@
|
||||
m3_template := Env.Get("M3_TEMPLATE_DIR");
|
||||
path : TEXT;
|
||||
subpath : TEXT;
|
||||
- nextsep : INTEGER := 0;
|
||||
- prevsep : INTEGER := 0;
|
||||
+ nextsep : INTEGER;
|
||||
+ prevsep : INTEGER := -1;
|
||||
sep : CHAR;
|
||||
+ filename : TEXT;
|
||||
BEGIN
|
||||
IF m3_template # NIL THEN
|
||||
template_dir := m3_template;
|
||||
@@ -322,13 +323,17 @@
|
||||
REPEAT
|
||||
nextsep := Text.FindChar(path, sep, prevsep + 1);
|
||||
IF nextsep # -1 THEN
|
||||
- subpath := Text.Sub(path, prevsep, nextsep - prevsep - 1);
|
||||
+ subpath := Text.Sub(path, prevsep + 1, nextsep - prevsep - 1);
|
||||
ELSE
|
||||
- subpath := Text.Sub(path, prevsep);
|
||||
+ subpath := Text.Sub(path, prevsep + 1);
|
||||
END;
|
||||
- IF M3File.IsReadable(subpath & template) THEN
|
||||
- template_dir := subpath;
|
||||
- RETURN;
|
||||
+ IF Text.Length(subpath) > 0 THEN
|
||||
+ filename := subpath & SL & template;
|
||||
+ IF M3File.IsReadable(filename) AND
|
||||
+ NOT M3File.IsDirectory(filename) THEN
|
||||
+ template_dir := subpath;
|
||||
+ RETURN;
|
||||
+ END;
|
||||
END;
|
||||
prevsep := nextsep;
|
||||
UNTIL prevsep = -1;
|
|
@ -4,7 +4,7 @@ bug in the ezm3 port.
|
|||
|
||||
--- language/modula3/m3compiler/m3cc/gcc/gcc/Makefile.in.orig Fri Apr 18 14:31:46 2003
|
||||
+++ language/modula3/m3compiler/m3cc/gcc/gcc/Makefile.in Fri Apr 18 14:32:11 2003
|
||||
@@ -690,8 +690,8 @@
|
||||
@@ -691,8 +691,8 @@
|
||||
-e 's|%% *|../|g' \
|
||||
-e 's|%||g'
|
||||
SUBDIR_FLAGS_TO_PASS = $(ORDINARY_FLAGS_TO_PASS) \
|
||||
|
|
Loading…
Reference in a new issue