- Split the library part of multimedia/rtmpdump into multimedia/librtmp.

- Update ports depending on librtmp.
- Add instruction to avoid a build error in multimedia/rtmpdump under a
  specific condition.
This commit is contained in:
Hiroki Sato 2013-10-31 02:03:01 +00:00
parent b80cc120d0
commit 42bc4e4802
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=332194
16 changed files with 92 additions and 21 deletions

View file

@ -5,6 +5,18 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20131031:
AFFECTS: users of multimedia/rtmpdump
AUTHOR: hrs@FreeBSD.org
The library part of multimedia/rtmpdump is split into multimedia/librtmp.
multimedia/rtmpdump now depends on the library port.
A build error can occur if you built and installed old rtmpdump by
using stock OpenSSL, and then install security/openssl and try to build
multimedia/rtmpdump without deinstalling the installed one. Please
make sure if the old rtmpdump is removed before building the new version.
20131028:
AFFECTS: users of comms/dcf77pi
AUTHOR: rene@FreeBSD.org

View file

@ -103,7 +103,7 @@ PROXY_CONFIGURE_OFF= --disable-proxy
PROXY_CONFIGURE_ON= --enable-proxy
RTMP_CONFIGURE_OFF= --without-librtmp
RTMP_CONFIGURE_ON= --with-librtmp=${LOCALBASE}
RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/rtmpdump
RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/librtmp
SPNEGO_CONFIGURE_OFF= --without-spnego
SPNEGO_CONFIGURE_ON= --with-spnego=${LOCALBASE}/lib
SPNEGO_CPPFLAGS= -I${LOCALBASE}/include/fbopenssl

View file

@ -178,6 +178,7 @@
SUBDIR += libquicktime-lame
SUBDIR += libquvi
SUBDIR += libquvi-scripts
SUBDIR += librtmp
SUBDIR += libsmacker
SUBDIR += libtheora
SUBDIR += libtuner

View file

@ -143,7 +143,7 @@ PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE= libpulse
# rtmp
RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/rtmpdump
RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/librtmp
RTMP_CONFIGURE_ENABLE= librtmp
# schroedinger

View file

@ -274,7 +274,7 @@ CONFIGURE_ARGS+= --disable-libopenjpeg
# rtmp
.if ${PORT_OPTIONS:MRTMP}
LIB_DEPENDS+= librtmp.so:${PORTSDIR}/multimedia/rtmpdump
LIB_DEPENDS+= librtmp.so:${PORTSDIR}/multimedia/librtmp
CONFIGURE_ARGS+= --enable-librtmp
. if ${OPENSSLBASE} != "/usr"
FFMPEG_CFLAGS+= -I${OPENSSLINC}

View file

@ -101,7 +101,7 @@ OPUS_CONFIGURE_ENABLE= libopus
PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE= libpulse
RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/rtmpdump
RTMP_LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/librtmp
RTMP_CONFIGURE_ENABLE= librtmp
SCHROEDINGER_LIB_DEPENDS= libschroedinger-1.0.so:${PORTSDIR}/multimedia/schroedinger

View file

@ -0,0 +1,21 @@
# $FreeBSD$
PORTNAME= librtmp
PORTVERSION= 2.4.20130923
CATEGORIES= multimedia net
MASTER_SITES= LOCAL/hrs
DISTNAME= rtmpdump-${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= RTMP stream library
LICENSE= GPLv2
USES= pkgconfig
USE_LDCONFIG= yes
USE_OPENSSL= yes
CFLAGS+= ${PTHREAD_CFLAGS} -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
WRKSRC= ${WRKDIR}/${DISTNAME}/librtmp
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (rtmpdump-2.4.20130923.tar.gz) = 220259e3ac6b9f17d4f8643ec019fbf88780b5033bf7781fe69f1f86eff759f6
SIZE (rtmpdump-2.4.20130923.tar.gz) = 143065

View file

@ -0,0 +1,3 @@
librtmp is the library part of rtmpdump.
WWW: http://rtmpdump.mplayerhq.hu/

View file

@ -0,0 +1,11 @@
@comment $FreeBSD$
include/librtmp/amf.h
include/librtmp/http.h
include/librtmp/log.h
include/librtmp/rtmp.h
@dirrm include/librtmp
lib/librtmp.a
lib/librtmp.so
lib/librtmp.so.0
libdata/pkgconfig/librtmp.pc
man/man3/librtmp.3.gz

View file

@ -2,21 +2,22 @@
PORTNAME= rtmpdump
PORTVERSION= 2.4.20130923
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= multimedia net
MASTER_SITES= LOCAL/hrs
MAINTAINER= hrs@FreeBSD.org
COMMENT= A tool to download RTMP streams
COMMENT= RTMP streams download utility
LICENSE= GPLv2
LIB_DEPENDS= librtmp.so:${PORTSDIR}/multimedia/librtmp
USES= pkgconfig
USE_LDCONFIG= yes
USE_OPENSSL= yes
MAKE_ENV= THREADLIB="${PTHREAD_LIBS}"
CFLAGS+= ${PTHREAD_CFLAGS} -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
LDFLAGS+= -L${LOCALBASE}/lib -L${OPENSSLLIB}
PORTDOCS= ChangeLog README
OPTIONS_DEFINE= DOCS

View file

@ -1,5 +1,5 @@
--- Makefile.orig 2013-10-07 03:52:05.000000000 +0900
+++ Makefile 2013-10-20 14:37:46.000000000 +0900
+++ Makefile 2013-10-30 15:30:57.000000000 +0900
@@ -1,9 +1,9 @@
VERSION=v2.4
@ -25,7 +25,14 @@
bindir=$(prefix)/bin
sbindir=$(prefix)/sbin
@@ -41,7 +42,7 @@
@@ -35,13 +36,13 @@
LIBS_posix=
LIBS_darwin=
LIBS_mingw=-lws2_32 -lwinmm -lgdi32
-LIB_RTMP=-Llibrtmp -lrtmp
+LIB_RTMP=-lrtmp
LIBS=$(LIB_RTMP) $(CRYPTO_LIB) $(LIBS_$(SYS)) $(XLIBS)
THREADLIB_posix=-lpthread
THREADLIB_darwin=-lpthread
THREADLIB_mingw=
@ -34,3 +41,26 @@
SLIBS=$(THREADLIB) $(LIBS)
LIBRTMP=librtmp/librtmp.a
@@ -54,9 +55,7 @@
PROGS=rtmpdump rtmpgw rtmpsrv rtmpsuck
-all: $(LIBRTMP) $(PROGS)
-
-$(PROGS): $(LIBRTMP)
+all: $(PROGS)
install: $(PROGS)
-mkdir -p $(BINDIR) $(SBINDIR) $(MANDIR)/man1 $(MANDIR)/man8
@@ -64,11 +63,9 @@
cp rtmpgw$(EXT) rtmpsrv$(EXT) rtmpsuck$(EXT) $(SBINDIR)
cp rtmpdump.1 $(MANDIR)/man1
cp rtmpgw.8 $(MANDIR)/man8
- @cd librtmp; $(MAKE) install
clean:
rm -f *.o rtmpdump$(EXT) rtmpgw$(EXT) rtmpsrv$(EXT) rtmpsuck$(EXT)
- @cd librtmp; $(MAKE) clean
FORCE:

View file

@ -3,15 +3,5 @@ bin/rtmpdump
sbin/rtmpgw
sbin/rtmpsrv
sbin/rtmpsuck
include/librtmp/amf.h
include/librtmp/http.h
include/librtmp/log.h
include/librtmp/rtmp.h
@dirrm include/librtmp
lib/librtmp.a
lib/librtmp.so
lib/librtmp.so.0
libdata/pkgconfig/librtmp.pc
man/man1/rtmpdump.1.gz
man/man3/librtmp.3.gz
man/man8/rtmpgw.8.gz

View file

@ -175,7 +175,7 @@ CONFIGURE_ARGS+= --disable-pulse
.if ${PORT_OPTIONS:MRTMP}
CONFIGURE_ARGS+= --enable-rtmp
LIB_DEPENDS+= rtmp:${PORTSDIR}/multimedia/rtmpdump
LIB_DEPENDS+= rtmp:${PORTSDIR}/multimedia/librtmp
.else
CONFIGURE_ARGS+= --disable-rtmp
.endif